ADOdb Library for PHP

ADOdb Library for PHP Manual

V4.91 2 Aug 2006 (c) 2000-2006 John Lim (jlim#natsoft.com)

Thanks to Gyõrvári 'Scr34m' Gábor (scr34m#frontember.hu) for html splitting and conversion to chm.

This software is dual licensed using BSD-Style and LGPL. Where there is any discrepancy, the BSD-Style license will take precedence. This means you can use it in proprietary and commercial products.

Useful ADOdb links: Download Other Docs

This document covers the core ADOdb functions. ADOdb has many other modules which are documented elsewhere:

- Data Dictionary
- Database-backed Sessions
- Database Performance Monitoring.

Table of Contents

  • Introduction
  • Unique Features of ADOdb
  • How People are using ADOdb
  • Feature Requests and Bug Reports
  • Installation Guide
  • Minimal Install
  • Code Initialization and Connecting to Databases
    • Data Source Names
    • Connection Examples
  • High Speed ADOdb - tuning tips
  • Hacking and Modifying ADOdb Safely
  • PHP5 Features
    • foreach iterators
    • exceptions
  • Supported Databases
  • Tutorials
    • Select Statement
    • Advanced Select with Field Objects
    • Inserting
    • Debugging
    • MySQL and Menus
    • Connecting to Multiple Databases at once
    • Generating Update and Insert SQL
    • Implementing Scrolling with Next and Previous
    • Exporting in CSV or Tab-Delimited Format
    • Recordset Filters
    • Smart Transactions
  • Using Custom Error Handlers and PEAR_Error
  • Data Source Names
  • Caching of Recordsets
  • Pivot Tables
  • Class Reference
    • Variables:
      • $ADODB_ANSI_PADDING_OFF
      • $ADODB_COUNTRECS
      • $ADODB_CACHE_DIR
      • $ADODB_FETCH_MODE
      • $ADODB_FORCE_TYPE
      • $ADODB_LANG
    • Constants:
      • ADODB_ASSOC_CASE
    • ADOConnection
      • Connection
      • Connect
      • PConnect
      • NConnect
      • IsConnected
      • Executing SQL
      • Execute
      • CacheExecute
      • ExecuteCursor (oci8 only)
      • SelectLimit
      • CacheSelectLimit
      • CacheFlush
      • Prepare
      • PrepareSP
      • InParameter
      • OutParameter
      • Param
      • GetOne
      • CacheGetOne
      • GetAssoc
      • CacheGetAssoc
      • GetRow
      • CacheGetRow
      • GetAll
      • CacheGetAll
      • GetCol
      • CacheGetCol
      • Replace
      • AutoExecute
      • Generates SQL
      • GetUpdateSQL
      • GetInsertSQL
      • Blob/Clob Handling
      • UpdateBlob
      • UpdateClob
      • UpdateBlobFile
      • BlobEncode
      • BlobDecode
      • Paging/Scrolling
      • PageExecute
      • CachePageExecute
      • CleanUp
      • Close
      • CacheFlush
      • Transactions
      • StartTrans
      • CompleteTrans
      • FailTrans
      • HasFailedTrans
      • SetTransactionMode
      • BeginTrans
      • CommitTrans
      • RollbackTrans
      • SetFetchMode
      • String Manipulation
      • Concat
      • IfNull
      • length
      • substr
      • random
      • qstr
      • quote
      • Date Handling
      • DBDate
      • BindDate
      • DBTimeStamp
      • BindTimeStamp
      • UnixDate
      • UnixTimeStamp
      • OffsetDate
      • SQLDate
      • Row Management
      • Affected_Rows
      • Insert_ID
      • RowLock
      • Sequences
      • GenID
      • CreateSequence
      • DropSequence
      • Error Handling
      • ErrorMsg
      • ErrorNo
      • MetaError
      • MetaErrMsg
      • IgnoreErrors
      • Data Dictionary
      • MetaDatabases
      • MetaTables
      • MetaColumns
      • MetaColumnNames
      • MetaPrimaryKeys and MetaForeignKeys
      • ServerInfo
      • Statistics and Query Rewriting
      • LogSQL
      • fnExecute and fnCacheExecute
      • Deprecated
      • Bind
      • BlankRecordSet
      • Parameter
    • ADORecordSet
      • Returns one row
      • FetchRow
      • FetchInto
      • FetchObject
      • FetchNextObject
      • FetchObj
      • FetchNextObj
      • Returns all rows
      • GetArray
      • GetRows
      • GetAssoc
      • Scrolling
      • Move
      • MoveNext
      • MoveFirst
      • MoveLast
      • AbsolutePosition
      • CurrentRow
      • AtFirstPage
      • AtLastPage
      • AbsolutePage
      • Menu generation
      • GetMenu
      • GetMenu2
      • Dates
      • UserDate
      • UserTimeStamp
      • Recordset info
      • RecordCount
      • PO_RecordSet
      • NextRecordSet
      • Field info
      • FieldCount
      • FetchField
      • MetaType
      • Cleanup
      • Close
      • Deprecated
      • GetRowAssoc
      • Fields
    • rs2html
  • Database Driver Guide
  • ToDo
  • Change Log

Sponsored by phpLens


Introduction

PHP's database access functions are not standardised. This creates a need for a database class library to hide the differences between the different database API's (encapsulate the differences) so we can easily switch databases. PHP 4.0.5 or later is now required (because we use array-based str_replace).

We currently support MySQL, Oracle, Microsoft SQL Server, Sybase, Sybase SQL Anywhere, Informix, PostgreSQL, FrontBase, Interbase (Firebird and Borland variants), Foxpro, Access, ADO and ODBC. We have had successful reports of connecting to Progress, SQLite and DB2 via ODBC. We hope more people will contribute drivers to support other databases.

PHP4 supports session variables. You can store your session information using ADOdb for true portability and scalability. See adodb-session.php for more information.

Also read http://php.weblogs.com/portable_sql (also available as tips_portable_sql.htm in the release) for tips on writing portable SQL.

Prev | Home | Next
ADOdb Library for PHP | Up | Unique Features


Unique Features of ADOdb

  • Easy for Windows programmers to adapt to because many of the conventions are similar to Microsoft's ADO.
  • Unlike other PHP database classes which focus only on select statements, we provide support code to handle inserts and updates which can be adapted to multiple databases quickly. Methods are provided for date handling, string concatenation and string quoting characters for differing databases.
  • A metatype system is built in so that we can figure out that types such as CHAR, TEXT and STRING are equivalent in different databases.
  • Easy to port because all the database dependant code are stored in stub functions. You do not need to port the core logic of the classes.
  • PHP4 session support. See adodb-session.php.
  • Portable table and index creation with the datadict classes.
  • Database performance monitoring and SQL tuning with the performance monitoring classes.
  • Object-Relational Mapping using ADOdb_Active_Record classes.
Prev | Home | Next
Introduction | Up | How People are using ADOdb


How People are using ADOdb

Here are some examples of how people are using ADOdb (for a much longer list, visit http://php.weblogs.com/adodb-cool-applications):

  • PhpLens is a commercial data grid component that allows both cool Web designers and serious unshaved programmers to develop and maintain databases on the Web easily. Developed by the author of ADOdb.
  • PHAkt: PHP Extension for DreamWeaver Ultradev allows you to script PHP in the popular Web page editor. Database handling provided by ADOdb.
  • Analysis Console for Intrusion Databases (ACID): PHP-based analysis engine to search and process a database of security incidents generated by security-related software such as IDSes and firewalls (e.g. Snort, ipchains). By Roman Danyliw.
  • PostNuke is a very popular free content management system and weblog system. It offers full CSS support, HTML 4.01 transitional compliance throughout, an advanced blocks system, and is fully multi-lingual enabled.
  • EasyPublish CMS is another free content management system for managing information and integrated modules on your internet, intranet- and extranet-sites. From Norway.
  • NOLA is a full featured accounting, inventory, and job tracking application. It is licensed under the GPL, and developed by Noguska.
Prev | Home | Next
Unique Features of ADOdb | Up | Feature Requests and Bug Reports


Feature Requests and Bug Reports

Feature requests and bug reports can be emailed to jlim#natsoft.com.my or posted to the ADOdb Help forums at http://phplens.com/lens/lensforum/topics.php?id=4.

Prev | Home | Next
Unique Features of ADOdb | Up | Installation Guide


Installation Guide

Make sure you are running PHP 4.0.5 or later. Unpack all the files into a directory accessible by your webserver.

To test, try modifying some of the tutorial examples. Make sure you customize the connection settings correctly. You can debug using $db->debug = true as shown below:

 <?php
include('adodb/adodb.inc.php');
$db =
  ADONewConnection($database);
$db->debug
  = true;
$db->Connect($server,
  $user, $password,
  $database);
$rs =
  $db->Execute('select
  * from some_small_table');
print "<pre>";
print_r($rs->GetRows());
print "</pre>";
?>

Minimum Install

For developers who want to release a minimal install of ADOdb, you will need:

  • adodb.inc.php
  • adodb-lib.inc.php
  • adodb-time.inc.php
  • drivers/adodb-$database.inc.php
  • license.txt (for legal reasons)
  • adodb-php4.inc.php
  • adodb-iterator.inc.php (php5 functionality)
Optional:
  • adodb-error.inc.php and lang/adodb-$lang.inc.php (if you use MetaError())
  • adodb-csvlib.inc.php (if you use cached recordsets - CacheExecute(), etc)
  • adodb-exceptions.inc.php and adodb-errorhandler.inc.php (if you use adodb error handler or php5 exceptions).
  • adodb-active-record.inc.php if you use Active Records.
Prev | Home | Next
Feature Requests and Bug Reports | Up | Code Initialization


Code Initialization, High Speed ADOdb, Hacking ADOdb, PHP5 Features

Prev Code Initialization, High Speed ADOdb, Hacking ADOdb, PHP5 Features Next

Code Initialization and Connecting to Databases

When running ADOdb, at least two files are loaded. First is adodb/adodb.inc.php, which contains all functions used by all database classes. The code specific to a particular database is in the adodb/driver/adodb-????.inc.php file.

For example, to connect to a mysql database:

include('/path/to/set/here/adodb.inc.php');
$conn = &ADONewConnection('mysql');

Whenever you need to connect to a database, you create a Connection object using the ADONewConnection($driver) function. NewADOConnection($driver) is an alternative name for the same function.

At this point, you are not connected to the database (no longer true if you pass in a dsn). You will first need to decide whether to use persistent or non-persistent connections. The advantage of persistent connections is that they are faster, as the database connection is never closed (even when you call Close()). Non-persistent connections take up much fewer resources though, reducing the risk of your database and your web-server becoming overloaded.

For persistent connections, use $conn->PConnect(), or $conn->Connect() for non-persistent connections. Some database drivers also support NConnect(), which forces the creation of a new connection.

Connection Gotcha: If you create two connections, but both use the same userid and password, PHP will share the same connection. This can cause problems if the connections are meant to different databases. The solution is to always use different userid's for different databases, or use NConnect().

Data Source Name (DSN) Support

Since ADOdb 4.51, you can connect to a database by passing a dsn to NewADOConnection (or ADONewConnection, which is the same function). The dsn format is:

    $driver://$username:$password@hostname/$database?options[=value]

NewADOConnection() calls Connect() or PConnect() internally for you. If the connection fails, false is returned.

    # non-persistent connection
    $dsn = 'mysql://root:pwd@localhost/mydb';
    $db = NewADOConnection($dsn);
    if (!$db) die("Connection failed");

    # no need to call connect/pconnect!
    $arr = $db->GetArray("select * from table");

    # persistent connection
    $dsn2 = 'mysql://root:pwd@localhost/mydb?persist';

If you have special characters such as /:? in your dsn, then you need to rawurlencode them first:

    $pwd = rawurlencode($pwd);
    $dsn = "mysql://root:$pwd@localhost/mydb";
    $dsn2 = rawurlencode("sybase_ase")."://user:pass@host/path?query";

Legal options are:

For all drivers | 'persist', 'persistent', 'debug', 'fetchmode'
Interbase/Firebird | 'dialect', 'charset', 'buffers', 'role'
M'soft ADO | 'charpage'
MySQL | 'clientflags'
MySQLi | 'port', 'socket', 'clientflags'
Oci8 | 'nls_date_format', 'charset'

For all drivers, when the options persist or persistent are set, a persistent connection is forced. The debug option enables debugging. The fetchmode calls SetFetchMode(). If no value is defined for an option, then the value is set to 1.

ADOdb DSN's are compatible with version 1.0 of PEAR DB's DSN format.

Examples of Connecting to Databases

MySQL and Most Other Database Drivers

MySQL connections are very straightforward, and the parameters are identical to mysql_connect:

    $conn = &ADONewConnection('mysql');
    $conn->PConnect('localhost','userid','password','database');

    # or dsn
    $dsn = 'mysql://user:pwd@localhost/mydb';
    $conn = ADONewConnection($dsn);  # no need for Connect()

    # or persistent dsn
    $dsn = 'mysql://user:pwd@localhost/mydb?persist';
    $conn = ADONewConnection($dsn);  # no need for PConnect()

    # a more complex example:
    $pwd = urlencode($pwd);
    $flags =  MYSQL_CLIENT_COMPRESS;
    $dsn = "mysql://user:$pwd@localhost/mydb?persist&clientflags=$flags";
    $conn = ADONewConnection($dsn);  # no need for PConnect()

For most drivers, you can use the standard function: Connect($server, $user, $password, $database), or a DSN since ADOdb 4.51. Exceptions to this are listed below.

PDO

PDO, which only works with PHP5, accepts a driver specific connection string:

    $conn =& NewADConnection('pdo');
    $conn->Connect('mysql:host=localhost',$user,$pwd,$mydb);
    $conn->Connect('mysql:host=localhost;dbname=mydb',$user,$pwd);
    $conn->Connect("mysql:host=localhost;dbname=mydb;username=$user;password=$pwd");

The DSN mechanism is also supported:

    $conn =& NewADConnection("pdo_mysql://user:pwd@localhost/mydb?persist"); # persist is optional

PostgreSQL

PostgreSQL 7 and 8 accepts connections using:

a. the standard connection string:

    $conn = &ADONewConnection('postgres');
    $conn->PConnect('host=localhost port=5432 dbname=mary');

b. the classical 4 parameters:

    $conn->PConnect('localhost','userid','password','database');

c. dsn:

    $dsn = 'postgres://user:pwd@localhost/mydb?persist';  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

LDAP

Here is an example of querying a LDAP server. Thanks to Josh Eldridge for the driver and this example:

require('/path/to/adodb.inc.php');

/* Make sure to set this BEFORE calling Connect() */
$LDAP_CONNECT_OPTIONS = Array(
    Array ("OPTION_NAME"=>LDAP_OPT_DEREF, "OPTION_VALUE"=>2),
    Array ("OPTION_NAME"=>LDAP_OPT_SIZELIMIT,"OPTION_VALUE"=>100),
    Array ("OPTION_NAME"=>LDAP_OPT_TIMELIMIT,"OPTION_VALUE"=>30),
    Array ("OPTION_NAME"=>LDAP_OPT_PROTOCOL_VERSION,"OPTION_VALUE"=>3),
    Array ("OPTION_NAME"=>LDAP_OPT_ERROR_NUMBER,"OPTION_VALUE"=>13),
    Array ("OPTION_NAME"=>LDAP_OPT_REFERRALS,"OPTION_VALUE"=>FALSE),
    Array ("OPTION_NAME"=>LDAP_OPT_RESTART,"OPTION_VALUE"=>FALSE)
);
$host = 'ldap.baylor.edu';
$ldapbase = 'ou=People,o=Baylor University,c=US';

$ldap = NewADOConnection( 'ldap' );
$ldap->Connect( $host, $user_name='', $password='', $ldapbase );

echo "<pre>";

print_r( $ldap->ServerInfo() );
$ldap->SetFetchMode(ADODB_FETCH_ASSOC);
$userName = 'eldridge';
$filter="(|(CN=$userName*)(sn=$userName*)(givenname=$userName*)(uid=$userName*))";

$rs = $ldap->Execute( $filter );
if ($rs)
    while ($arr = $rs->FetchRow()) {
         print_r($arr);
    }

$rs = $ldap->Execute( $filter );
if ($rs)
    while (!$rs->EOF) {
         print_r($rs->fields);
        $rs->MoveNext();
    }

print_r( $ldap->GetArray( $filter ) );
print_r( $ldap->GetRow( $filter ) );

$ldap->Close();
echo "</pre>";

Using DSN:

$dsn = "ldap://ldap.baylor.edu/ou=People,o=Baylor University,c=US";
$db = NewADOConnection($dsn);

Interbase/Firebird

You define the database in the $host parameter:
    $conn = &ADONewConnection('ibase');
    $conn->PConnect('localhost:c:\ibase\employee.gdb','sysdba','masterkey');

Or dsn:

    $dsn = 'firebird://user:pwd@localhost/mydb?persist&dialect=3';  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

SQLite

Sqlite will create the database file if it does not exist.
    $conn = &ADONewConnection('sqlite');
    $conn->PConnect('c:\path\to\sqlite.db'); # sqlite will create if does not exist

Or dsn:

    $path = urlencode('c:\path\to\sqlite.db');
    $dsn = "sqlite://$path/?persist";  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

Oracle (oci8)

With oci8, you can connect in multiple ways. Note that oci8 works fine with newer versions of the Oracle, eg. 9i and 10g.

a. PHP and Oracle reside on the same machine, use default SID.

    $conn->Connect(false, 'scott', 'tiger');

b. TNS Name defined in tnsnames.ora (or ONAMES or HOSTNAMES), eg. 'myTNS'

    $conn->PConnect(false, 'scott', 'tiger', 'myTNS');

or

     $conn->PConnect('myTNS', 'scott', 'tiger');

c. Host Address and SID

    $conn->connectSID = true;
    $conn->Connect('192.168.0.1', 'scott', 'tiger', 'SID');

d. Host Address and Service Name

    $conn->Connect('192.168.0.1', 'scott', 'tiger', 'servicename');

e. Oracle connection string:

    $cstr = "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=$host)(PORT=$port))
            (CONNECT_DATA=(SID=$sid)))";
    $conn->Connect($cstr, 'scott', 'tiger');

f. ADOdb dsn:

    $dsn = 'oci8://user:pwd@tnsname/?persist';  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

    $dsn = 'oci8://user:pwd@host/sid';
    $conn = ADONewConnection($dsn);

    $dsn = 'oci8://user:pwd@/';   # oracle on local machine
    $conn = ADONewConnection($dsn);

You can also set the charSet for Oracle 9.2 and later, supported since PHP 4.3.2, ADOdb 4.54:

    $conn->charSet = 'we8iso8859p1';
    $conn->Connect(...);

    # or
    $dsn = 'oci8://user:pwd@tnsname/?charset=WE8MSWIN1252';
    $db = ADONewConnection($dsn);

DSN-less ODBC (Access, MSSQL and DB2 examples)

ODBC DSN's can be created in the ODBC control panel, or you can use a DSN-less connection.To use DSN-less connections with ODBC you need PHP 4.3 or later.

For Microsoft Access:

    $db =& ADONewConnection('access');
    $dsn = "Driver={Microsoft Access Driver (*.mdb)};Dbq=d:\\northwind.mdb;Uid=Admin;Pwd=;";
    $db->Connect($dsn);
For Microsoft SQL Server:
    $db =& ADONewConnection('odbc_mssql');
    $dsn = "Driver={SQL Server};Server=localhost;Database=northwind;";
    $db->Connect($dsn,'userid','password');
or if you prefer to use the mssql extension (which is limited to mssql 6.5 functionality):
    $db =& ADONewConnection('mssql');
    $db->Execute("localhost', 'userid', 'password', 'northwind');
For DB2:
    $db =& ADONewConnection('db2');
    $dsn = "driver={IBM db2 odbc DRIVER};Database=sample;hostname=localhost;port=50000;protocol=TCPIP;".
            "uid=root; pwd=secret";
    $db->Connect($dsn);
DSN-less Connections with ADO
If you are using versions of PHP earlier than PHP 4.3.0, DSN-less connections only work with Microsoft's ADO, which is Microsoft's COM based API. An example using the ADOdb library and Microsoft's ADO:
<?php
    include('adodb.inc.php');
    $db = &ADONewConnection("ado_mssql");
    print "<h1>Connecting DSN-less $db->databaseType...</h1>";

    $myDSN="PROVIDER=MSDASQL;DRIVER={SQL Server};"
        . "SERVER=flipper;DATABASE=ai;UID=sa;PWD=;"  ;
    $db->Connect($myDSN);

    $rs = $db->Execute("select * from table");
    $arr = $rs->GetArray();
    print_r($arr);
?>

High Speed ADOdb

ADOdb is a big class library, yet it consistently beats all other PHP class libraries in performance. This is because it is designed in a layered fashion, like an onion, with the fastest functions in the innermost layer. Stick to the following functions for best performance:

Innermost Layer

Connect, PConnect, NConnect
Execute, CacheExecute
SelectLimit, CacheSelectLimit
MoveNext, Close
qstr, Affected_Rows, Insert_ID

The fastest way to access the fields is by accessing the array $recordset->fields directly. Also set the global variables $ADODB_FETCH_MODE = ADODB_FETCH_NUM, and $ADODB_COUNTRECS = false before you connect to your database.

Consider using bind parameters if your database supports it, as it improves query plan reuse. Use ADOdb's performance tuning system to identify bottlenecks quickly.

Installing the ADOdb C extension will speed up GetAll() and GetArray() by 100%, and GetAssoc() by 30%. It will also speed up oci8 select statements by 30%.

Lastly make sure you have a PHP accelerator cache installed such as APC, Turck MMCache, Zend Accelerator or ionCube.

Some examples:

Fastest data retrieval using PHP Fastest data retrieval using ADOdb extension
$rs =& $rs->Execute($sql);
while (!$rs->EOF) {
    var_dump($rs->fields);
    $rs->MoveNext();
}

$rs =& $rs->Execute($sql);
$array = adodb_getall($rs);
var_dump($array);

Advanced Tips

If you have the ADOdb C extension installed, you can replace your calls to $rs->MoveNext() with adodb_movenext($rs). This doubles the speed of this operation. For retrieving entire recordsets at once, use GetArray(), which uses the high speed extension function adodb_getall() internally.

Execute() is the default way to run queries. You can use the low-level functions _Execute() and _query() to reduce query overhead. Both these functions share the same parameters as Execute().

If you do not have any bind parameters or your database supports binding (without emulation), then you can call _Execute() directly. Calling this function bypasses bind emulation. Debugging is still supported in _Execute().

If you do not require debugging facilities nor emulated binding, and do not require a recordset to be returned, then you can call _query. This is great for inserts, updates and deletes. Calling this function bypasses emulated binding, debugging, and recordset handling. Either the resultid, true or false are returned by _query().

For Informix, you can disable scrollable cursors with $db->cursorType = 0.

Hacking ADOdb Safely

You might want to modify ADOdb for your own purposes. Luckily you can still maintain backward compatibility by sub-classing ADOdb and using the $ADODB_NEWCONNECTION variable. $ADODB_NEWCONNECTION allows you to override the behaviour of ADONewConnection(). ADOConnection() checks for this variable and will call the function-name stored in this variable if it is defined.

In the following example, new functionality for the connection object is placed in the hack_mysql and hack_postgres7 classes. The recordset class naming convention can be controlled using $rsPrefix. Here we set it to 'hack_rs_', which will make ADOdb use hack_rs_mysql and hack_rs_postgres7 as the recordset classes.

class hack_mysql extends adodb_mysql {
var $rsPrefix = 'hack_rs_';
  /* Your mods here */
}

class hack_rs_mysql extends ADORecordSet_mysql {
 /* Your mods here */
}

class hack_postgres7 extends adodb_postgres7 {
var $rsPrefix = 'hack_rs_';
  /* Your mods here */
}

class hack_rs_postgres7 extends ADORecordSet_postgres7 {
 /* Your mods here */
}

$ADODB_NEWCONNECTION = 'hack_factory';

function& hack_factory($driver)
{
    if ($driver !== 'mysql' && $driver !== 'postgres7') return false;

    $driver = 'hack_'.$driver;
    $obj = new $driver();
    return $obj;
}

include_once('adodb.inc.php');

Don't forget to call the constructor of the parent class in your constructor. If you want to use the default ADOdb drivers return false in the above hack_factory() function.

PHP5 Features

ADOdb 4.02 or later will transparently determine which version of PHP you are using. If PHP5 is detected, the following features become available:

  • PDO: PDO drivers are available. See the connection examples. Currently PDO drivers are not as powerful as native drivers, and should be treated as experimental.

  • Foreach iterators: This is a very natural way of going through a recordset:
        $ADODB_FETCH_MODE = ADODB_FETCH_NUM;
        $rs = $db->Execute($sql);
        foreach($rs as $k => $row) {
            echo "r1=".$row[0]." r2=".$row[1]."<br>";
        }

  • Exceptions: Just include adodb-exceptions.inc.php and you can now catch exceptions on errors as they occur.
        include("../adodb-exceptions.inc.php");
        include("../adodb.inc.php");
        try {
            $db = NewADOConnection("oci8");
            $db->Connect('','scott','bad-password');
        } catch (exception $e) {
            var_dump($e);
            adodb_backtrace($e->gettrace());
        }

    Note that reaching EOF is not considered an error nor an exception.

Prev | Home | Next
Installation Guide | Up | Supported Databases


Supported Databases

Prev Supported Databases Next

Databases Supported

The name below is the value you pass to NewADOConnection($name) to create a connection object for that database.

Name | Tested | Database | RecordCount() usable | Prerequisites | Operating Systems
access | B | Microsoft Access/Jet. You need to create an ODBC DSN. | Y/N | ODBC | Windows only
ado B

Generic ADO, not tuned for specific databases. Allows DSN-less connections. For best performance, use an OLEDB provider. This is the base class for all ado drivers.

You can set $db->codePage before connecting.

 ? depends on database ADO or OLEDB provider Windows only
ado_access | B | Microsoft Access/Jet using ADO. Allows DSN-less connections. For best performance, use an OLEDB provider. | Y/N | ADO or OLEDB provider | Windows only
ado_mssql | B | Microsoft SQL Server using ADO. Allows DSN-less connections. For best performance, use an OLEDB provider. | Y/N | ADO or OLEDB provider | Windows only
db2 C Uses PHP's db2-specific extension for better performance. Y/N DB2 CLI/ODBC interface

Unix and Windows. Requires IBM DB2 Universal Database client.
odbc_db2 C Connects to DB2 using generic ODBC extension. Y/N DB2 CLI/ODBC interface

Unix and Windows. Unix install hints. I have had reports that the $host and $database params have to be reversed in Connect() when using the CLI interface.
vfp | A | Microsoft Visual FoxPro. You need to create an ODBC DSN. | Y/N | ODBC | Windows only
fbsql C FrontBase. Y ?

Unix and Windows
ibase B Interbase 6 or earlier. Some users report you might need to use this
$db->PConnect('localhost:c:/ibase/employee.gdb', "sysdba", "masterkey") to connect. Lacks Affected_Rows currently.

You can set $db->role, $db->dialect, $db->buffers and $db->charSet before connecting. 		Y/N Interbase client Unix and Windows
firebird | B | Firebird version of interbase. | Y/N | Interbase client | Unix and Windows
borland_ibase | C | Borland version of Interbase 6.5 or later. Very sad that the forks differ. | Y/N | Interbase client | Unix and Windows
informix | C | Generic informix driver. Use this if you are using Informix 7.3 or later. | Y/N | Informix client | Unix and Windows
informix72 | C | Informix databases before Informix 7.3 that do no support SELECT FIRST. | Y/N | Informix client | Unix and Windows
ldap C LDAP driver. See this example for usage information. LDAP extension ?
mssql A

Microsoft SQL Server 7 and later. Works with Microsoft SQL Server 2000 also. Note that date formating is problematic with this driver. For example, the PHP mssql extension does not return the seconds for datetime!

 Y/N Mssql client

Unix and Windows.
Unix install howto and another one.

mssqlpo A

Portable mssql driver. Identical to above mssql driver, except that '||', the concatenation operator, is converted to '+'. Useful for porting scripts from most other sql variants that use ||.

 Y/N Mssql client

Unix and Windows.
Unix install howto.
mysql | A | MySQL without transaction support. You can also set $db->clientFlags before connecting. | Y | MySQL client | Unix and Windows
mysqli | B | Supports the newer PHP5 mysql api. | Y | MySQL 4.1+ client | Unix and Windows
mysqlt or maxsql A

MySQL with transaction support. We recommend using || as the concat operator for best portability. This can be done by running MySQL using:
mysqld --ansi or mysqld --sql-mode=PIPES_AS_CONCAT

 Y/N MySQL client Unix and Windows
oci8 A Oracle 8/9. Has more functionality than oracle driver (eg. Affected_Rows). You might have to putenv('ORACLE_HOME=...') before Connect/PConnect.

There are 2 ways of connecting - with server IP and service name:
PConnect('serverip:1521','scott','tiger','service')
or using an entry in TNSNAMES.ORA or ONAMES or HOSTNAMES:
PConnect(false, 'scott', 'tiger', $oraname).

Since 2.31, we support Oracle REF cursor variables directly (see ExecuteCursor).

Y/N Oracle client Unix and Windows
oci805 | C | Supports reduced Oracle functionality for Oracle 8.0.5. SelectLimit is not as efficient as in the oci8 or oci8po drivers. | Y/N | Oracle client | Unix and Windows
oci8po A Oracle 8/9 portable driver. This is nearly identical with the oci8 driver except (a) bind variables in Prepare() use the ? convention, instead of :bindvar, (b) field names use the more common PHP convention of lowercase names.

Use this driver if porting from other databases is important. Otherwise the oci8 driver offers better performance.

Y/N Oracle client Unix and Windows
odbc A Generic ODBC, not tuned for specific databases. To connect, use
PConnect('DSN','user','pwd'). This is the base class for all odbc derived drivers. 		? depends on database ODBC Unix and Windows. Unix hints.
odbc_mssql | A | Uses ODBC to connect to MSSQL | Y/N | ODBC | Unix and Windows.
odbc_oracle | C | Uses ODBC to connect to Oracle | Y/N | ODBC | Unix and Windows.
odbtp | B | Generic odbtp driver. Odbtp is a software for accessing Windows ODBC data sources from other operating systems. | Y/N | odbtp | Unix and Windows
odbtp_unicode | C | Odtbp with unicode support | Y/N | odbtp | Unix and Windows
oracle | C | Implements old Oracle 7 client API. Use oci8 driver if possible for better performance. | Y/N | Oracle client | Unix and Windows
netezza C Netezza driver. Netezza is based on postgres code-base. Y ? ?
pdo | C | Generic PDO driver for PHP5. | Y | PDO extension and database specific drivers | Unix and Windows.
postgres | A | Generic PostgreSQL driver. Currently identical to postgres7 driver. | Y | PostgreSQL client | Unix and Windows.
postgres64 | A | For PostgreSQL 6.4 and earlier which does not support LIMIT internally. | Y | PostgreSQL client | Unix and Windows.
postgres7 | A | PostgreSQL which supports LIMIT and other version 7 functionality. | Y | PostgreSQL client | Unix and Windows.
postgres8 | A | Currently identical to postgres7 | Y | PostgreSQL client | Unix and Windows.
sapdb C SAP DB. Should work reliably as based on ODBC driver. Y/N SAP ODBC client

?
sqlanywhere C Sybase SQL Anywhere. Should work reliably as based on ODBC driver. Y/N SQL Anywhere ODBC client

?
sqlite B SQLite. Y -

Unix and Windows.
sqlitepo B Portable SQLite driver. This is because assoc mode does not work like other drivers in sqlite. Namely, when selecting (joining) multiple tables, the table names are included in the assoc keys in the "sqlite" driver.

In "sqlitepo" driver, the table names are stripped from the returned column names. When this results in a conflict, the first field get preference.

Y -

Unix and Windows.
sybase C Sybase. Y/N Sybase client

Unix and Windows.

The "Tested" column indicates how extensively the code has been tested and used.
A = well tested and used by many people
B = tested and usable, but some features might not be implemented
C = user contributed or experimental driver. Might not fully support all of the latest features of ADOdb.

The column "RecordCount() usable" indicates whether RecordCount() return the number of rows, or returns -1 when a SELECT statement is executed. If this column displays Y/N then the RecordCount() is emulated when the global variable $ADODB_COUNTRECS=true, which is the default. Note that for large recordsets, it might be better to disable RecordCount() emulation because substantial amounts of memory are required to cache the recordset for counting. This variable is checked every time a query is executed, so you can selectively choose which recordsets to count.

Prev | Home | Next
Code Initialization | Up | Tutorial


Tutorials

  • Select
  • Advanced Select with Field Objects
  • Inserting
  • Debugging
  • MySQL and Menus
  • Connecting to Multiple Databases at once
  • Generating Update and Insert SQL
  • Implementing Scrolling with Next and Previous
  • Exporting in CSV or Tab-Delimited Format
  • Recordset Filters
Prev | Home | Next
Supported Databases | Up | Select Statement


Select Statement

Task: Connect to the Access Northwind DSN, display the first 2 columns of each row.

In this example, we create a ADOConnection object, which represents the connection to the database. The connection is initiated with PConnect, which is a persistent connection. Whenever we want to query the database, we call the ADOConnection.Execute() function. This returns an ADORecordSet object which is actually a cursor that holds the current row in the array fields[]. We use MoveNext() to move from row to row.

NB: A useful function that is not used in this example is SelectLimit, which allows us to limit the number of rows shown.

 <?php
include('adodb.inc.php'); #
load code common to ADOdb
$conn = &ADONewConnection('access'); #
create a connection
$conn->PConnect('northwind'); #
connect to MS-Access, northwind DSN

$recordSet = &$conn->Execute('select
* from products');

if (!$recordSet)
print $conn->ErrorMsg();
else
while (!$recordSet->EOF) {
print $recordSet->fields[0].'
'.$recordSet->fields[1].'<BR>';
$recordSet->MoveNext();
}    $recordSet->Close(); #
optional
$conn->Close(); #
optional

?>

The $recordSet returned stores the current row in the $recordSet->fields array, indexed by column number (starting from zero). We use the MoveNext() function to move to the next row. The EOF property is set to true when end-of-file is reached. If an error occurs in Execute(), we return false instead of a recordset.

The $recordSet->fields[] array is generated by the PHP database extension. Some database extensions only index by number and do not index the array by field name. To force indexing by name - that is associative arrays - use the SetFetchMode function. Each recordset saves and uses whatever fetch mode was set when the recordset was created in Execute() or SelectLimit().

    $db->SetFetchMode(ADODB_FETCH_NUM);
    $rs1 = $db->Execute('select * from table');
    $db->SetFetchMode(ADODB_FETCH_ASSOC);
    $rs2 = $db->Execute('select * from table');
    print_r($rs1->fields); # shows array([0]=>'v0',[1] =>'v1')
    print_r($rs2->fields); # shows array(['col1']=>'v0',['col2'] =>'v1')

To get the number of rows in the select statement, you can use $recordSet->RecordCount(). Note that it can return -1 if the number of rows returned cannot be determined.

Prev | Home | Next
Tutorial | Up | Advanced Select with Field Objects


Advanced Select with Field Objects

Select a table, display the first two columns. If the second column is a date or timestamp, reformat the date to US format.

 <?php
include('adodb.inc.php');       #
load code common to ADOdb
$conn = &ADONewConnection('access');    #
create a connection
$conn->PConnect('northwind');   #
connect to MS-Access, northwind dsn
$recordSet = &$conn->Execute('select
CustomerID,OrderDate from Orders');
if (!$recordSet)
print $conn->ErrorMsg();
else
while (!$recordSet->EOF) {
$fld = $recordSet->FetchField(1);
$type = $recordSet->MetaType($fld->type);

if ( $type == 'D' || $type == 'T')
print $recordSet->fields[0].'
'.$recordSet->UserDate($recordSet->fields[1],'m/d/Y').'<BR>';
else
print $recordSet->fields[0].'
'.$recordSet->fields[1].'<BR>';

recordSet->MoveNext();
}

$recordSet->Close(); #
optional
$conn->Close(); #
optional
?>

In this example, we check the field type of the second column using FetchField(). This returns an object with at least 3 fields.

  • name: name of column
  • type: native field type of column
  • max_length: maximum length of field. Some databases such as MySQL do not return the maximum length of the field correctly. In these cases max_length will be set to -1.

We then use MetaType() to translate the native type to a generic type. Currently the following generic types are defined:

  • C: character fields that should be shown in a <input type="text"> tag.
  • X: TeXt, large text fields that should be shown in a <textarea>
  • B: Blobs, or Binary Large Objects. Typically images.
  • D: Date field
  • T: Timestamp field
  • L: Logical field (boolean or bit-field)
  • I: Integer field
  • N: Numeric field. Includes autoincrement, numeric, floating point, real and integer.
  • R: Serial field. Includes serial, autoincrement integers. This works for selected databases.

If the metatype is of type date or timestamp, then we print it using the user defined date format with UserDate(), which converts the PHP SQL date string format to a user defined one. Another use for MetaType() is data validation before doing an SQL insert or update.

Prev | Home | Next
Select Statement | Up | Inserting


Inserting

Insert a row to the Orders table containing dates and strings that need to be quoted before they can be accepted by the database, eg: the single-quote in the word John's.

 <?php
include('adodb.inc.php');       #
load code common to ADOdb
$conn = &ADONewConnection('access');    #
create a connection

$conn->PConnect('northwind');   #
connect to MS-Access, northwind dsn
$shipto = $conn->qstr("John's
Old Shoppe");

$sql = "insert
into orders (customerID,EmployeeID,OrderDate,ShipName) ";
$sql .= "values
('ANATR',2,".$conn->DBDate(time()).",$shipto)";

if ($conn->Execute($sql) === false) {
print 'error
inserting: '.$conn->ErrorMsg().'<BR>';
}
?>

In this example, we see the advanced date and quote handling facilities of ADOdb. The unix timestamp (which is a long integer) is appropriately formated for Access with DBDate(), and the right escape character is used for quoting the John's Old Shoppe, which is John''s Old Shoppe and not PHP's default John's Old Shoppe with qstr().

Observe the error-handling of the Execute statement. False is returned by Execute() if an error occured. The error message for the last error that occurred is displayed in ErrorMsg(). Note: php_track_errors might have to be enabled for error messages to be saved.

Prev | Home | Next
Advanced Select with Field Objects | Up | Debugging


Debugging

 <?php
include('adodb.inc.php');       #
load code common to ADOdb
$conn = &ADONewConnection('access');    #
create a connection
$conn->PConnect('northwind');   #
connect to MS-Access, northwind dsn
$shipto = $conn->qstr("John's
Old Shoppe");
$sql = "insert
into orders (customerID,EmployeeID,OrderDate,ShipName) ";
$sql .= "values
('ANATR',2,".$conn->FormatDate(time()).",$shipto)";
$conn->debug = true;
if ($conn->Execute($sql) === false) print 'error
inserting';
?>

In the above example, we have turned on debugging by setting debug = true. This will display the SQL statement before execution, and also show any error messages. There is no need to call ErrorMsg() in this case. For displaying the recordset, see the rs2html() example.

Also see the section on Custom Error Handlers.

Prev | Home | Next
Inserting | Up | MySQL and Menus


MySQL and Menus

Connect to MySQL database agora, and generate a <select> menu from an SQL statement where the <option> captions are in the 1st column, and the value to send back to the server is in the 2nd column.

 <?php
include('adodb.inc.php');    #
load code common to ADOdb
$conn = &ADONewConnection('mysql');    #
create a connection
$conn->PConnect('localhost','userid','','agora');    #
connect to MySQL, agora db
$sql = 'select
CustomerName, CustomerID from customers';
$rs = $conn->Execute($sql);
print $rs->GetMenu('GetCust','Mary
Rosli');
?>

Here we define a menu named GetCust, with the menu option 'Mary Rosli' selected. See GetMenu(). We also have functions that return the recordset as an array: GetArray(), and as an associative array with the key being the first column: GetAssoc().

Prev | Home | Next
Debugging | Up | Connecting to Multiple Databases at once


Connecting to Multiple Databases at once

 <?php
include('adodb.inc.php');     #
  load code common to ADOdb
$conn1 = &ADONewConnection('mysql');  #
  create a mysql connection
$conn2 = &ADONewConnection('oracle');  #
  create a oracle connection

$conn1->PConnect($server, $userid, $password, $database);
$conn2->PConnect(false, $ora_userid, $ora_pwd, $oraname);

$conn1->Execute('insert
  ...');
$conn2->Execute('update
  ...');
?>

Prev | Home | Next
MySQL and Menus | Up | Generating Update and Insert SQL


Generating Update and Insert SQL

Note: Since ADOdb 4.56, we support AutoExecute(), which simplifies things by providing an advanced wrapper for GetInsertSQL() and GetUpdateSQL(). For example, an INSERT can be carried out with:

    $record["firstname"] = "Bob";
    $record["lastname"] = "Smith";
    $record["created"] = time();
    $insertSQL = $conn->AutoExecute($rs, $record, 'INSERT');
and an UPDATE with:
    $record["firstname"] = "Caroline";
    $record["lastname"] = "Smith"; # Update Caroline's lastname from Miranda to Smith
    $insertSQL = $conn->AutoExecute($rs, $record, 'UPDATE', 'id = 1');

The rest of this section is out-of-date:

ADOdb 1.31 and later supports two new recordset functions: GetUpdateSQL( ) and GetInsertSQL( ). This allow you to perform a "SELECT * FROM table query WHERE...", make a copy of the $rs->fields, modify the fields, and then generate the SQL to update or insert into the table automatically.

We show how the functions can be used when accessing a table with the following fields: (ID, FirstName, LastName, Created).

Before these functions can be called, you need to initialize the recordset by performing a select on the table. Idea and code by Jonathan Younger jyounger#unilab.com.

<?php
    #==============================================
    # SAMPLE GetUpdateSQL() and GetInsertSQL() code
    #==============================================
    include('adodb.inc.php');
    include('tohtml.inc.php');

    #==========================
    # This code tests an insert

    $sql = "SELECT * FROM ADOXYZ WHERE id = -1";
    # Select an empty record from the database

    $conn = &ADONewConnection("mysql"); # create a connection
    $conn->debug=1;
    $conn->PConnect("localhost", "admin", "", "test"); # connect to MySQL, testdb
    $rs = $conn->Execute($sql); # Execute the query and get the empty recordset

    $record = array(); # Initialize an array to hold the record data to insert

    # Set the values for the fields in the record
    $record["firstname"] = "Bob";
    $record["lastname"] = "Smith";
    $record["created"] = time();

    # Pass the empty recordset and the array containing the data to insert
    # into the GetInsertSQL function. The function will process the data and return
    # a fully formatted insert sql statement.
    $insertSQL = $conn->GetInsertSQL($rs, $record);

    $conn->Execute($insertSQL); # Insert the record into the database

    #==========================
    # This code tests an update
    $sql = "SELECT * FROM ADOXYZ WHERE id = 1";

    # Select a record to update
    $rs = $conn->Execute($sql); # Execute the query and get the existing record to update
    $record = array(); # Initialize an array to hold the record data to update

    # Set the values for the fields in the record
    $record["firstname"] = "Caroline";
    $record["lastname"] = "Smith"; # Update Caroline's lastname from Miranda to Smith

    # Pass the single record recordset and the array containing the data to update
    # into the GetUpdateSQL function. The function will process the data and return
    # a fully formatted update sql statement with the correct WHERE clause.
    # If the data has not changed, no recordset is returned
    $updateSQL = $conn->GetUpdateSQL($rs, $record);

    $conn->Execute($updateSQL); # Update the record in the database
    $conn->Close();
?>

$ADODB_FORCE_TYPE

The behaviour of GetUpdateSQL() and GetInsertSQL() when converting empty or null PHP variables to SQL is controlled by the global $ADODB_FORCE_TYPE variable. Set it to one of the values below. Default is ADODB_FORCE_VALUE (3):

0 = ignore empty fields. All empty fields in array are ignored.
1 = force null. All empty, php null and string 'null' fields are changed to sql NULL values.
2 = force empty. All empty, php null and string 'null' fields are changed to sql empty '' or 0 values.
3 = force value. Value is left as it is. Php null and string 'null' are set to sql NULL values and
    empty fields '' are set to empty '' sql values.

define('ADODB_FORCE_IGNORE',0);
define('ADODB_FORCE_NULL',1);
define('ADODB_FORCE_EMPTY',2);
define('ADODB_FORCE_VALUE',3);

Thanks to Niko (nuko#mbnet.fi) for the $ADODB_FORCE_TYPE code.

Prev | Home | Next
Connecting to Multiple Databases at once | Up | Implementing Scrolling with Next and Previous


Implementing Scrolling with Next and Previous

The following code creates a very simple recordset pager, where you can scroll from page to page of a recordset.

    include_once('adodb.inc.php');
    include_once('adodb-pager.inc.php');
    session_start();

    $db = NewADOConnection('mysql');
    $db->Connect('localhost','root','','xphplens');
    $sql = "select * from adoxyz ";

    $pager = new ADODB_Pager($db,$sql);
    $pager->Render($rows_per_page=5);

This will create a basic record pager that looks like this:

|< << >> >|

ID | First Name | Last Name | Date Created
36 | Alan | Turing | Sat 06, Oct 2001
37 | Serena | Williams | Sat 06, Oct 2001
38 | Yat Sun | Sun | Sat 06, Oct 2001
39 | Wai Hun | See | Sat 06, Oct 2001
40 | Steven | Oey | Sat 06, Oct 2001
Page 8/10

The number of rows to display at one time is controled by the Render($rows) method. If you do not pass any value to Render(), ADODB_Pager will default to 10 records per page.

You can control the column titles by modifying your SQL (supported by most databases):

    $sql = 'select id as "ID", firstname as "First Name", lastname as "Last Name", created as "Date Created" from adoxyz';

The above code can be found in the adodb/tests/testpaging.php example included with this release, and the class ADODB_Pager in adodb/adodb-pager.inc.php. The ADODB_Pager code can be adapted by a programmer so that the text links can be replaced by images, and the dull white background be replaced with more interesting colors.

You can also allow display of html by setting $pager->htmlSpecialChars = false.

Some of the code used here was contributed by Iván Oliva and Cornel G.

Prev | Home | Next
Generating Update and Insert SQL | Up | Exporting in CSV or Tab-Delimited Format


Exporting in CSV or Tab-Delimited Format

We provide some helper functions to export in comma-separated-value (CSV) and tab-delimited formats:

<?php
    include_once('toexport.inc.php');
    include_once('adodb.inc.php');

    $db = &NewADOConnection('mysql');
    $db->Connect($server, $userid, $password, $database);
    $rs = $db->Execute('select fname as "First Name", surname as "Surname" from table');

    print "<pre>";
    print rs2csv($rs); # return a string, CSV format
    print '<hr>';
    $rs->MoveFirst(); # note, some databases do not support MoveFirst
    print rs2tab($rs,false); # return a string, tab-delimited false == suppress field names in first line

    print '<hr>';
    $rs->MoveFirst();
    rs2tabout($rs); # send to stdout directly (there is also an rs2csvout function)
    print "</pre>";

    $rs->MoveFirst();
    $fp = fopen($path, "w");
    if ($fp) {
        rs2csvfile($rs, $fp); # write to file (there is also an rs2tabfile function)
        fclose($fp);
    }
?>

Carriage-returns or newlines are converted to spaces. Field names are returned in the first line of text. Strings containing the delimiter character are quoted with double-quotes. Double-quotes are double-quoted again. This conforms to Excel import and export guide-lines.

All the above functions take as an optional last parameter, $addtitles which defaults to true. When set to false field names in the first line are suppressed.

Prev | Home | Next
Implementing Scrolling with Next and Previous | Up | Recordset Filters


Recordset Filters

Sometimes we want to pre-process all rows in a recordset before we use it. For example, we want to ucwords all text in recordset.

      include_once('adodb/rsfilter.inc.php');
include_once('adodb/adodb.inc.php');

// ucwords() every element
in the recordset
function do_ucwords(&$arr,$rs)
{
foreach($arr
as $k =>
$v) {
$arr[$k]
= ucwords($v);
}
}

$db =
NewADOConnection('mysql');
$db->PConnect('server','user','pwd','db');

$rs =
$db->Execute('select
... from table');
$rs =
RSFilter($rs,'do_ucwords');

The RSFilter function takes 2 parameters, the recordset, and the name of the filter function. It returns the processed recordset scrolled to the first record. The filter function takes two parameters, the current row as an array, and the recordset object. For future compatibility, you should not use the original recordset object.

Prev | Home | Next
Exporting in CSV or Tab-Delimited Format | Up | Smart Transactions


Smart Transactions

 The old way of doing transactions required you to use

$conn->BeginTrans();
$ok =
  $conn->Execute($sql);
if ($ok)
  $ok = $conn->Execute($sql2);
if (!$ok)
  $conn->RollbackTrans();
else $conn->CommitTrans();

This is very complicated for large projects because you have to track the error
  status. Smart Transactions is much simpler. You start a smart transaction by
  calling StartTrans():

$conn->StartTrans();
$conn->Execute($sql);
$conn->Execute($Sql2);
$conn->CompleteTrans();

CompleteTrans() detects when an SQL error occurs, and will Rollback/Commit as appropriate. To specificly force a rollback even if no error occured, use FailTrans(). Note that the rollback is done in CompleteTrans(), and not in FailTrans().

You can also check if a transaction has failed, using HasFailedTrans(), which
  returns true if FailTrans() was called, or there was an error in the SQL execution.
  Make sure you call HasFailedTrans() before you call CompleteTrans(), as it is
  only works between StartTrans/CompleteTrans.

$conn->StartTrans();
$conn->Execute($sql);
if (!CheckRecords())
  $conn->FailTrans();
$conn->Execute($Sql2);
$conn->CompleteTrans();

Lastly, StartTrans/CompleteTrans is nestable, and only the outermost block
  is executed. In contrast, BeginTrans/CommitTrans/RollbackTrans is NOT nestable.

$conn->StartTrans();
$conn->Execute($sql);
$conn->StartTrans();
  # ignored
if (!CheckRecords())
  $conn->FailTrans();
$conn->CompleteTrans();
  # ignored
$conn->Execute($Sql2);
$conn->CompleteTrans();

Note: Savepoints are currently not supported.

Prev | Home | Next
Recordset Filters | Up | Using Custom Error Handlers and PEAR_Error


Using Custom Error Handlers and PEAR_Error

ADOdb supports PHP5 exceptions. Just include adodb-exceptions.inc.php and you can now catch exceptions on errors as they occur.

    include("../adodb-exceptions.inc.php");
    include("../adodb.inc.php");
    try {
        $db = NewADOConnection("oci8://scott:bad-password@mytns/");
    } catch (exception $e) {
        var_dump($e);
        adodb_backtrace($e->gettrace());
    }

ADOdb also provides two custom handlers which you can modify for your needs. The first one is in the adodb-errorhandler.inc.php file. This makes use of the standard PHP functions error_reporting to control what error messages types to display, and trigger_error which invokes the default PHP error handler.

Including the above file will cause trigger_error($errorstring,E_USER_ERROR) to be called when
(a) Connect() or PConnect() fails, or
(b) a function that executes SQL statements such as Execute() or SelectLimit() has an error.
(c) GenID() appears to go into an infinite loop.

The $errorstring is generated by ADOdb and will contain useful debugging information similar to the error.log data generated below. This file adodb-errorhandler.inc.php should be included before you create any ADOConnection objects.

If you define error_reporting(0), no errors will be passed to the error handler. If you set error_reporting(E_ALL), all errors will be passed to the error handler. You still need to use ini_set("display_errors", "0" or "1") to control the display of errors.

 <?php
error_reporting(E_ALL); #
pass any error messages triggered to error handler
include('adodb-errorhandler.inc.php');
include('adodb.inc.php');
include('tohtml.inc.php');
$c = NewADOConnection('mysql');
$c->PConnect('localhost','root','','northwind');
$rs=$c->Execute('select
* from productsz'); #invalid
table productsz');
if ($rs) rs2html($rs);
?>

If you want to log the error message, you can do so by defining the following optional constants ADODB_ERROR_LOG_TYPE and ADODB_ERROR_LOG_DEST. ADODB_ERROR_LOG_TYPE is the error log message type (see error_log in the PHP manual). In this case we set it to 3, which means log to the file defined by the constant ADODB_ERROR_LOG_DEST.

 <?php
error_reporting(E_ALL); # report all errors
ini_set("display_errors", "0"); #
do not echo any errors
define('ADODB_ERROR_LOG_TYPE',3);
define('ADODB_ERROR_LOG_DEST','C:/errors.log');
include('adodb-errorhandler.inc.php');
include('adodb.inc.php');
include('tohtml.inc.php');

$c = NewADOConnection('mysql');
$c->PConnect('localhost','root','','northwind');
$rs=$c->Execute('select
* from productsz'); ##
invalid table productsz
if ($rs) rs2html($rs);
?>

The following message will be logged in the error.log file:

(2001-10-28 14:20:38) mysql error: [1146: Table 'northwind.productsz' doesn't exist] in EXECUTE("select * from productsz")

PEAR_ERROR

The second error handler is adodb-errorpear.inc.php. This will create a PEAR_Error derived object whenever an error occurs. The last PEAR_Error object created can be retrieved using ADODB_Pear_Error().

<?php
    include('adodb-errorpear.inc.php');
    include('adodb.inc.php');
    include('tohtml.inc.php');
    $c = NewADOConnection('mysql');
    $c->PConnect('localhost','root','','northwind');
    $rs=$c->Execute('select * from productsz'); #invalid table productsz');
    if ($rs) rs2html($rs);
    else {
        $e = ADODB_Pear_Error();
        echo '<p>',$e->message,'</p>';
    }
?>

You can use a PEAR_Error derived class by defining the constant ADODB_PEAR_ERROR_CLASS before the adodb-errorpear.inc.php file is included. For easy debugging, you can set the default error handler in the beginning of the PHP script to PEAR_ERROR_DIE, which will cause an error message to be printed, then halt script execution:

    include('PEAR.php');
    PEAR::setErrorHandling('PEAR_ERROR_DIE');

Note that we do not explicitly return a PEAR_Error object to you when an error occurs. We return false instead. You have to call ADODB_Pear_Error() to get the last error or use the PEAR_ERROR_DIE technique.

Error Messages

Error messages are outputted using the static method ADOConnnection::outp($msg,$newline=true). By default, it sends the messages to the client. You can override this to perform error-logging.

MetaError and MetaErrMsg

If you need error messages that work across multiple databases, then use MetaError(), which returns a virtualized error number, based on PEAR DB's error number system, and MetaErrMsg().

Prev | Home | Next
Recordset Filters | Up | Data Source Names


Data Source Names

We now support connecting using PEAR style DSN's. A DSN is a connection string of the form:

$dsn = "$driver://$username:$password@$hostname/$databasename";

You pass the DSN to the static class function DB::Connect, or directly to ADONewConnection(). An example:

<?php
    $username = 'root';
    $password = '';
    $hostname = 'localhost';
    $databasename = 'xphplens';
    $driver = 'mysql';
    $dsn = "$driver://$username:$password@$hostname/$databasename";;
    $db =& ADONewConnection($dsn);
    # DB::Connect($dsn); also works if you include 'adodb/adodb-pear.inc.php' at the top
    $rs = $db->Execute('select firstname,lastname from adoxyz');
    $cnt = 0;
    while ($arr = $rs->FetchRow()) {
        print_r($arr); print "<br>";
    }
?>

More info and connection examples on the DSN format.

Prev | Home | Next
Using Custom Error Handlers and PEAR_Error | Up | Caching of Recordsets


Caching of Recordsets

ADOdb now supports caching of recordsets using the CacheExecute( ), CachePageExecute( ) and CacheSelectLimit( ) functions. There are similar to the non-cache functions, except that they take a new first parameter, $secs2cache.

An example:

      include('adodb.inc.php'); #
load code common to ADOdb
$ADODB_CACHE_DIR = '/usr/ADODB_cache';
$conn = &ADONewConnection('mysql');  #
create a connection
$conn->PConnect('localhost','userid','','agora');#
connect to MySQL, agora db
$sql = 'select
CustomerName, CustomerID from customers';
$rs = $conn->CacheExecute(15,$sql);

The first parameter is the number of seconds to cache the query. Subsequent calls to that query will used the cached version stored in $ADODB_CACHE_DIR. To force a query to execute and flush the cache, call CacheExecute() with the first parameter set to zero. Alternatively, use the CacheFlush($sql) call.

For the sake of security, we recommend you set register_globals=off in php.ini if you are using $ADODB_CACHE_DIR.

In ADOdb 1.80 onwards, the secs2cache parameter is optional in CacheSelectLimit() and CacheExecute(). If you leave it out, it will use the $connection->cacheSecs parameter, which defaults to 60 minutes.

    $conn->Connect(...);
    $conn->cacheSecs = 3600*24; # cache 24 hours
    $rs = $conn->CacheExecute('select * from table');

Please note that magic_quotes_runtime should be turned off. More info.

Prev | Home | Next
Data Source Names | Up | Pivot Tables


Pivot Tables

Since ADOdb 2.30, we support the generation of SQL to create pivot tables, also known as cross-tabulations. For further explanation read this DevShed Cross-Tabulation tutorial. We assume that your database supports the SQL case-when expression.

In this example, we will use the Northwind database from Microsoft. In the database, we have a products table, and we want to analyze this table by suppliers versus product categories. We will place the suppliers on each row, and pivot on categories. So from the table on the left, we generate the pivot-table on the right:

Supplier | Category
supplier1 | category1
supplier2 | category1
supplier2 | category2
 -->
 | category1 | category2 | total
supplier1 | 1 | 0 | 1
supplier2 | 1 | 1 | 2

    # Query the main "product" table
    # Set the rows to SupplierName
    # and the columns to the values of Categories
    # and define the joins to link to lookup tables
    # "categories" and "suppliers"
    #
    include "adodb/pivottable.inc.php";
    $sql = PivotTableSQL(
        $gDB,                                      # adodb connection
        'products p ,categories c ,suppliers s',   # tables
        'SupplierName',                             # rows (multiple fields allowed)
        'CategoryName',                            # column to pivot on
        'p.CategoryID = c.CategoryID and s.SupplierID= p.SupplierID' # joins/where
    );

This will generate the following SQL:

SELECT SupplierName,
SUM(CASE WHEN CategoryName='Beverages' THEN 1 ELSE 0 END) AS "Beverages",
SUM(CASE WHEN CategoryName='Condiments' THEN 1 ELSE 0 END) AS "Condiments",
SUM(CASE WHEN CategoryName='Confections' THEN 1 ELSE 0 END) AS "Confections",
SUM(CASE WHEN CategoryName='Dairy Products' THEN 1 ELSE 0 END) AS "Dairy
    Products",
SUM(CASE WHEN CategoryName='Grains/Cereals' THEN 1 ELSE 0 END) AS "Grains/Cereals",
SUM(CASE WHEN CategoryName='Meat/Poultry' THEN 1 ELSE 0 END) AS "Meat/Poultry",
SUM(CASE WHEN CategoryName='Produce' THEN 1 ELSE 0 END) AS "Produce",
SUM(CASE WHEN CategoryName='Seafood' THEN 1 ELSE 0 END) AS "Seafood",
SUM(1) as Total
FROM products p ,categories c ,suppliers s WHERE p.CategoryID = c.CategoryID
    and s.SupplierID= p.SupplierID
GROUP BY SupplierName

You can also pivot on numerical columns and generate totals by using ranges. This code was revised in ADODB 2.41 and is not backward compatible. The second example shows this:

    $sql = PivotTableSQL(
        $gDB, # adodb connection
        'products p ,categories c ,suppliers s', # tables
        'SupplierName', # rows (multiple fields allowed)
        array( # column ranges
            ' 0 ' => 'UnitsInStock <= 0',
            "1 to 5" => '0 < UnitsInStock and UnitsInStock <= 5',
            "6 to 10" => '5 < UnitsInStock and UnitsInStock <= 10',
            "11 to 15" => '10 < UnitsInStock and UnitsInStock <= 15',
            "16+" => '15 < UnitsInStock'
        ),
        ' p.CategoryID = c.CategoryID and s.SupplierID= p.SupplierID', # joins/where
        'UnitsInStock', # sum this field
        'Sum ' # sum label prefix
    );

Which generates:

SELECT SupplierName,
SUM(CASE WHEN UnitsInStock <= 0 THEN UnitsInStock ELSE 0 END) AS "Sum 0 ",
SUM(CASE WHEN 0 < UnitsInStock and UnitsInStock <= 5 THEN UnitsInStock ELSE 0 END) AS "Sum 1 to 5",
SUM(CASE WHEN 5 < UnitsInStock and UnitsInStock <= 10 THEN UnitsInStock ELSE 0 END) AS "Sum 6 to 10",
SUM(CASE WHEN 10 < UnitsInStock and UnitsInStock <= 15 THEN UnitsInStock ELSE 0 END) AS "Sum 11 to 15",
SUM(CASE WHEN 15 < UnitsInStock THEN UnitsInStock ELSE 0 END) AS "Sum 16+",
SUM(UnitsInStock) AS "Sum UnitsInStock",
SUM(1) as Total,
FROM products p ,categories c ,suppliers s WHERE p.CategoryID = c.CategoryID and s.SupplierID= p.SupplierID
GROUP BY SupplierName

Prev | Home | Next
Caching of Recordsets | Up | Class Reference


Class Reference

  • Variables:
    • $ADODB_COUNTRECS
    • $ADODB_CACHE_DIR
    • $ADODB_LANG
    • $ADODB_FETCH_MODE
  • Constants:
    • ADODB_ASSOC_CASE
  • Variables:
    • $ADODB_COUNTRECS
    • $ADODB_CACHE_DIR
    • $ADODB_LANG
    • $ADODB_FETCH_MODE
  • Constants:
    • ADODB_ASSOC_CASE
  • ADOConnection
    • Connection
    • Connect
    • PConnect
    • NConnect
    • Executing SQL
    • Execute
    • CacheExecute
    • ExecuteCursor (oci8 only)
    • SelectLimit
    • CacheSelectLimit
    • CacheFlush
    • Prepare
    • PrepareSP
    • Parameter
    • GetOne
    • CacheGetOne
    • GetRow
    • CacheGetRow
    • GetAll
    • CacheGetAll
    • GetCol
    • CacheGetCol
    • Replace
    • Generates SQL
    • GetUpdateSQL
    • GetInsertSQL
    • Blob/Clob Handling
    • UpdateBlob
    • UpdateClob
    • UpdateBlobFile
    • BlobEncode
    • BlobDecode
    • Paging/Scrolling
    • PageExecute
    • CachePageExecute
    • CleanUp
    • Close
    • CacheFlush
    • Transactions
    • BeginTrans
    • CommitTrans
    • RollbackTrans
    • SetFetchMode
    • String Manipulation
    • Concat
    • qstr
    • quote
    • Date Handling
    • DBDate
    • DBTimeStamp
    • UnixDate
    • UnixTimeStamp
    • OffsetDate
    • SQLDate
    • Row Management
    • Affected_Rows
    • Insert_ID
    • Sequences
    • GenID
    • CreateSequence
    • DropSequence
    • Error Handling
    • ErrorMsg
    • ErrorNo
    • Data Dictionary
    • MetaDatabases
    • MetaTables
    • MetaColumns
    • MetaColumnNames
    • MetaPrimaryKeys
    • ServerInfo
    • Statistics and Query Rewriting
    • fnExecute and fnCacheExecute
    • Deprecated
    • Bind
    • BlankRecordSet
  • ADORecordSet
    • Returns one row
    • FetchRow
    • FetchInto
    • FetchObject
    • FetchNextObject
    • FetchObj
    • FetchNextObj
    • Returns all rows
    • GetArray
    • GetRows
    • GetAssoc
    • Scrolling
    • Move
    • MoveNext
    • MoveFirst
    • MoveLast
    • AbsolutePosition
    • CurrentRow
    • AtFirstPage
    • AtLastPage
    • AbsolutePage
    • Menu generation
    • GetMenu
    • GetMenu2
    • Dates
    • UserDate
    • UserTimeStamp
    • Recordset info
    • RecordCount
    • PO_RecordSet
    • NextRecordSet
    • Field info
    • FieldCount
    • FetchField
    • MetaType
    • Cleanup
    • Close
    • Deprecated
    • GetRowAssoc
    • Fields
  • rs2html
Prev | Home | Next
Pivot Tables | Up | $ADODB_COUNTRECS


$ADODB_COUNTRECS

If the database driver API does not support counting the number of records returned in a SELECT statement, the function RecordCount() is emulated when the global variable $ADODB_COUNTRECS is set to true, which is the default. We emulate this by buffering the records, which can take up large amounts of memory for big recordsets. Set this variable to false for the best performance. This variable is checked every time a query is executed, so you can selectively choose which recordsets to count.

Prev | Home | Next
Class Reference | Up | $ADODB_CACHE_DIR


$ADODB_CACHE_DIR

If you are using recordset caching, this is the directory to save your recordsets in. Define this before you call any caching functions such as CacheExecute( ). We recommend setting register_globals=off in php.ini if you use this feature for security reasons.

If you are using Unix and apache, you might need to set your cache directory permissions to something similar to the following:

chown -R apache /path/to/adodb/cache
chgrp -R apache /path/to/adodb/cache

Prev | Home | Next
$ADODB_COUNTRECS | Up | $ADODB_LANG


$ADODB_LANG and $ADODB_ANSI_PADDING_OFF

Prev $ADODB_LANG Next

$ADODB_LANG

Determines the language used in MetaErrorMsg(). The default is 'en', for English. To find out what languages are supported, see the files in adodb/lang/adodb-$lang.inc.php, where $lang is the supported language.

$ADODB_ANSI_PADDING_OFF

Determines whether to right trim CHAR fields (and also VARCHAR for ibase/firebird). Set to true to trim. Default is false. Currently works for oci8po, ibase and firebird drivers. Added in ADOdb 4.01.

Prev | Home | Next
$ADODB_CACHE_DIR | Up | $ADODB_FETCH_MODE


$ADODB_FETCH_MODE

This is a global variable that determines how arrays are retrieved by recordsets. The recordset saves this value on creation (eg. in Execute( ) or SelectLimit( )), and any subsequent changes to $ADODB_FETCH_MODE have no affect on existing recordsets, only on recordsets created in the future.

The following constants are defined:

define('ADODB_FETCH_DEFAULT',0);
define('ADODB_FETCH_NUM',1);
define('ADODB_FETCH_ASSOC',2);
define('ADODB_FETCH_BOTH',3);

An example:

      $ADODB_FETCH_MODE
= ADODB_FETCH_NUM;
$rs1 =
$db->Execute('select
* from table');
$ADODB_FETCH_MODE
= ADODB_FETCH_ASSOC;
$rs2 =
$db->Execute('select
* from table');
print_r($rs1->fields);
# shows array([0]=>'v0',[1] =>'v1')
print_r($rs2->fields);
# shows array(['col1']=>'v0',['col2'] =>'v1')

As you can see in the above example, both recordsets store and use different fetch modes based on the $ADODB_FETCH_MODE setting when the recordset was created by Execute().

If no fetch mode is predefined, the fetch mode defaults to ADODB_FETCH_DEFAULT. The behaviour of this default mode varies from driver to driver, so do not rely on ADODB_FETCH_DEFAULT. For portability, we recommend sticking to ADODB_FETCH_NUM or ADODB_FETCH_ASSOC. Many drivers do not support ADODB_FETCH_BOTH.

SetFetchMode Function

If you have multiple connection objects, and want to have different fetch modes for each connection, then use SetFetchMode. Once this function is called for a connection object, that connection object will ignore the global variable $ADODB_FETCH_MODE and will use the internal fetchMode property exclusively.

    $db->SetFetchMode(ADODB_FETCH_NUM);
    $rs1 = $db->Execute('select * from table');
    $db->SetFetchMode(ADODB_FETCH_ASSOC);
    $rs2 = $db->Execute('select * from table');
    print_r($rs1->fields); # shows array([0]=>'v0',[1] =>'v1')
    print_r($rs2->fields); # shows array(['col1']=>'v0',['col2'] =>'v1')

To retrieve the previous fetch mode, you can use check the $db->fetchMode property, or use the return value of SetFetchMode( ).

Prev | Home | Next
$ADODB_LANG | Up | ADODB_ASSOC_CASE


ADODB_ASSOC_CASE

You can control the associative fetch case for certain drivers which behave differently. For the postgres, sybase, oci8po, mssql, odbc and ibase drivers and all drivers derived from them, ADODB_ASSOC_CASE will by default generate recordsets where the field name keys are lower-cased. Use the constant ADODB_ASSOC_CASE to change the case of the keys. There are 3 possible values:

0 = assoc lowercase field names. $rs->fields['orderid']
1 = assoc uppercase field names. $rs->fields['ORDERID']
2 = use native-case field names. $rs->fields['OrderID'] -- this is the default
  since ADOdb 2.90

To use it, declare it before you include adodb.inc.php.

    define('ADODB_ASSOC_CASE', 2); # use native-case for ADODB_FETCH_ASSOC
    include('adodb.inc.php');

Prev | Home | Next
$ADODB_FETCH_MODE | Up | ADOConnection


ADOConnection

Constructor function. Do not call this directly. Use ADONewConnection( ) instead.

Object that performs the connection to the database, executes SQL statements and has a set of utility functions for standardising the format of SQL statements for issues such as concatenation and date formats.

  • Connections: Connect PConnect NConnect
  • Executing SQL: Execute CacheExecute SelectLimit CacheSelectLimit Prepare PrepareSP Parameter GetOne CacheGetOne GetRow CacheGetRow GetAll CacheGetAll GetCol CacheGetCol Replace ExecuteCursor (oci8 only)
  • Generates SQL: GetUpdateSQL GetInsertSQL
  • Blobs: UpdateBlob UpdateClob UpdateBlobFile BlobEncode BlobDecode
  • Paging/Scrolling: PageExecute CachePageExecute
  • Cleanup: CacheFlush Close
  • Transactions: BeginTrans CommitTrans RollbackTrans
  • Fetching Data: SetFetchMode
  • Strings: concat qstr quote
  • Dates: DBDate DBTimeStamp UnixDate UnixTimeStamp OffsetDate SQLDate
  • Rows Management: Affected_Rows Insert_ID GenID CreateSequence DropSequence
  • Error Handling: ErrorMsg ErrorNo
  • Data Dictionary (metadata): MetaDatabases MetaTables MetaColumns MetaColumnNames MetaPrimaryKeys ServerInfo
  • Statistics and Query-Rewriting: fnExecute and fnCacheExecute
  • Deprecated: Bind BlankRecordSet

ADOConnection Fields

databaseType: Name of the database system we are connecting to. Eg. odbc or mssql or mysql.

dataProvider: The underlying mechanism used to connect to the database. Normally set to native, unless using odbc or ado.

host: Name of server or data source name (DSN) to connect to.

database: Name of the database or to connect to. If ado is used, it will hold the ado data provider.

user: Login id to connect to database. Password is not saved for security reasons.

raiseErrorFn: Allows you to define an error handling function. See adodb-errorhandler.inc.php for an example.

debug: Set to true to make debug statements to appear.

concat_operator: Set to '+' or '||' normally. The operator used to concatenate strings in SQL. Used by the Concat function.

fmtDate: The format used by the DBDate function to send dates to the database. is '#Y-m-d#' for Microsoft Access, and ''Y-m-d'' for MySQL.

fmtTimeStamp: The format used by the DBTimeStamp function to send timestamps to the database.

true: The value used to represent true.Eg. '.T.'. for Foxpro, '1' for Microsoft SQL.

false: The value used to represent false. Eg. '.F.'. for Foxpro, '0' for Microsoft SQL.

replaceQuote: The string used to escape quotes. Eg. double single-quotes for Microsoft SQL, and backslash-quote for MySQL. Used by qstr.

autoCommit: indicates whether automatic commit is enabled. Default is true.

charSet: set the default charset to use. Currently only interbase supports this.

dialect: set the default sql dialect to use. Currently only interbase supports this.

metaTablesSQL: SQL statement to return a list of available tables. Eg. SHOW TABLES in MySQL.

genID: The latest id generated by GenID() if supported by the database.

cacheSecs: The number of seconds to cache recordsets if CacheExecute() or CacheSelectLimit() omit the $secs2cache parameter. Defaults to 60 minutes.

sysDate: String that holds the name of the database function to call to get the current date. Useful for inserts and updates.

sysTimeStamp: String that holds the name of the database function to call to get the current timestamp/datetime value.

leftOuter: String that holds operator for left outer join, if known. Otherwise set to false.

rightOuter: String that holds operator for left outer join, if known. Otherwise set to false.

ansiOuter: Boolean that if true indicates that ANSI style outer joins are permitted. Eg. select * from table1 left join table2 on p1=p2.

connectSID: Boolean that indicates whether to treat the $database parameter in connects as the SID for the oci8 driver. Defaults to false. Useful for Oracle 8.0.5 and earlier.

autoRollback: Persistent connections are auto-rollbacked in PConnect( ) if this is set to true. Default is false.

Prev | Home | Next
ADODB_ASSOC_CASE | Up | Connect


Connect

Prev Connect Next

Connect($host,[$user],[$password],[$database])

Non-persistent connect to data source or server $host, using userid $user and password $password. If the server supports multiple databases, connect to database $database.

Returns true/false depending on connection.

ADO Note: If you are using a Microsoft ADO and not OLEDB, you can set the $database parameter to the OLEDB data provider you are using.

PostgreSQL: An alternative way of connecting to the database is to pass the standard PostgreSQL connection string in the first parameter $host, and the other parameters will be ignored.

For Oracle and Oci8, there are two ways to connect. First is to use the TNS name defined in your local tnsnames.ora (or ONAMES or HOSTNAMES). Place the name in the $database field, and set the $host field to false. Alternatively, set $host to the server, and $database to the database SID, this bypassed tnsnames.ora.

Examples:

    # $oraname in tnsnames.ora/ONAMES/HOSTNAMES
    $conn->Connect(false, 'scott', 'tiger', $oraname);
    $conn->Connect('server:1521', 'scott', 'tiger', 'ServiceName'); # bypass tnsnames.ora

There are many examples of connecting to a database at php.weblogs.com/ADOdb, and in the testdatabases.inc.php file included in the release.

Prev | Home | Next
ADOConnection | Up | PConnect


PConnect

Prev PConnect Next

PConnect($host,[$user],[$password],[$database])

Persistent connect to data source or server $host, using userid $user and password $password. If the server supports multiple databases, connect to database $database.

We now perform a rollback on persistent connection for selected databases since 2.21, as advised in the PHP manual. See change log or source code for which databases are affected.

Returns true/false depending on connection. See Connect( ) above for more info.

Since ADOdb 2.21, we also support autoRollback. If you set:

      $conn
= &NewADOConnection('mysql');
$conn->autoRollback = true; # default is false
$conn->PConnect(...); # rollback here

Then when doing a persistent connection with PConnect( ), ADOdb will perform a rollback first. This is because it is documented that PHP is not guaranteed to rollback existing failed transactions when persistent connections are used. This is implemented in Oracle, MySQL, PgSQL, MSSQL, ODBC currently.

Since ADOdb 3.11, you can force non-persistent connections even if PConnect is called by defining the constant ADODB_NEVER_PERSIST before you call PConnect.

Prev | Home | Next
Connect | Up | NConnect


NConnect

Prev NConnect Next

NConnect($host,[$user],[$password],[$database])

Always force new connection. In contrast, PHP sometimes reuses connections when you use Connect() or PConnect(). Currently works only on mysql (PHP 4.3.0 or later),postgresql and oci8-derived drivers. For other drivers, NConnect() works like Connect().

IsConnected()

Return true if connected to database.

Prev | Home | Next
Connect | Up | Execute


Execute

Prev Execute Next

Execute($sql,$inputarr=false)

Execute SQL statement $sql and return derived class of ADORecordSet if successful. Note that a record set is always returned on success, even if we are executing an insert or update statement. You can also pass in $sql a statement prepared in Prepare().

Returns derived class of ADORecordSet. Eg. if connecting via mysql, then ADORecordSet_mysql would be returned. False is returned if there was an error in executing the sql.

The $inputarr parameter can be used for binding variables to parameters. Below is an Oracle example:

      $conn->Execute("SELECT
  * FROM TABLE WHERE COND=:val", array('val'=>
  $val));

Another example, using ODBC,which uses the ? convention:

    $conn->Execute("SELECT * FROM TABLE WHERE COND=?", array($val));

Binding variables

Variable binding speeds the compilation and caching of SQL statements, leading to higher performance. Currently Oracle, Interbase and ODBC supports variable binding. Interbase/ODBC style ? binding is emulated in databases that do not support binding. Note that you do not have to quote strings if you use binding.

Variable binding in the odbc, interbase and oci8po drivers.

$rs = $db->Execute('select * from table where val=?', array('10'));
Variable binding in the oci8 driver:
$rs = $db->Execute('select name from table where val=:key',
  array('key' => 10));
Bulk binding

Since ADOdb 3.80, we support bulk binding in Execute(), in which you pass in a 2-dimensional array to be bound to an INSERT/UPDATE or DELETE statement.

$arr = array(
    array('Ahmad',32),
    array('Zulkifli', 24),
    array('Rosnah', 21)
    );
$ok = $db->Execute('insert into table (name,age) values (?,?)',$arr);

This provides very high performance as the SQL statement is prepared first. The prepared statement is executed repeatedly for each array row until all rows are completed, or until the first error. Very useful for importing data.

Prev | Home | Next
Connect | Up | CacheExecute


CacheExecute

Prev CacheExecute Next

CacheExecute([$secs2cache,]$sql,$inputarr=false)

Similar to Execute, except that the recordset is cached for $secs2cache seconds in the $ADODB_CACHE_DIR directory, and $inputarr only accepts 1-dimensional arrays. If CacheExecute() is called again with the same $sql, $inputarr, and also the same database, same userid, and the cached recordset has not expired, the cached recordset is returned.

    include('adodb.inc.php');
    include('tohtml.inc.php');
    $ADODB_CACHE_DIR = '/usr/local/ADOdbcache';
    $conn = &ADONewConnection('mysql');
    $conn->PConnect('localhost','userid','password','database');
    $rs = $conn->CacheExecute(15, 'select * from table'); # cache 15 secs
    rs2html($rs); /* recordset to html table */

Alternatively, since ADOdb 1.80, the $secs2cache parameter is optional:

    $conn->Connect(...);
    $conn->cacheSecs = 3600*24; // cache 24 hours
    $rs = $conn->CacheExecute('select * from table');

If $secs2cache is omitted, we use the value in $connection->cacheSecs (default is 3600 seconds, or 1 hour). Use CacheExecute() only with SELECT statements.

Performance note: I have done some benchmarks and found that they vary so greatly that it's better to talk about when caching is of benefit. When your database server is much slower than your Web server or the database is very overloaded then ADOdb's caching is good because it reduces the load on your database server. If your database server is lightly loaded or much faster than your Web server, then caching could actually reduce performance.

Prev | Home | Next
Execute | Up | ExecuteCursor


ExecuteCursor

Prev ExecuteCursor Next

ExecuteCursor($sql,$cursorName='rs',$parameters=false)

Execute an Oracle stored procedure, and returns an Oracle REF cursor variable as a regular ADOdb recordset. Does not work with any other database except oci8. Thanks to Robert Tuttle for the design.

    $db = ADONewConnection("oci8");
    $db->Connect("foo.com:1521", "uid", "pwd", "FOO");
    $rs = $db->ExecuteCursor("begin :cursorvar := getdata(:param1); end;",
                    'cursorvar',
                    array('param1'=>10));
    # $rs is now just like any other ADOdb recordset object    rs2html($rs);

ExecuteCursor() is a helper function that does the following internally:

    $stmt = $db->Prepare("begin :cursorvar := getdata(:param1); end;", true);
    $db->Parameter($stmt, $cur, 'cursorvar', false, -1, OCI_B_CURSOR);
    $rs = $db->Execute($stmt,$bindarr);

ExecuteCursor only accepts 1 out parameter. So if you have 2 out parameters, use:

    $vv = 'A%';
    $stmt = $db->PrepareSP("BEGIN list_tabs(:crsr,:tt); END;");
    $db->OutParameter($stmt, $cur, 'crsr', -1, OCI_B_CURSOR);
    $db->OutParameter($stmt, $vv, 'tt', 32); # return varchar(32)
    $arr = $db->GetArray($stmt);
    print_r($arr);
    echo " val = $vv"; ## outputs 'TEST'
for the following PL/SQL:
    TYPE TabType IS REF CURSOR RETURN TAB%ROWTYPE;

    PROCEDURE list_tabs(tabcursor IN OUT TabType,tablenames IN OUT VARCHAR) IS
    BEGIN
        OPEN tabcursor FOR SELECT * FROM TAB WHERE tname LIKE tablenames;
        tablenames := 'TEST';
    END list_tabs;

Prev | Home | Next
CacheExecute | Up | SelectLimit


SelectLimit

Prev SelectLimit Next

SelectLimit($sql,$numrows=-1,$offset=-1,$inputarr=false)

Returns a recordset if successful. Returns false otherwise. Performs a select statement, simulating PostgreSQL's SELECT statement, LIMIT $numrows OFFSET $offset clause.

In PostgreSQL, SELECT * FROM TABLE LIMIT 3 will return the first 3 records only. The equivalent is $connection->SelectLimit('SELECT * FROM TABLE',3). This functionality is simulated for databases that do not possess this feature.

And SELECT * FROM TABLE LIMIT 3 OFFSET 2 will return records 3, 4 and 5 (eg. after record 2, return 3 rows). The equivalent in ADOdb is $connection->SelectLimit('SELECT * FROM TABLE',3,2).

Note that this is the opposite of MySQL's LIMIT clause. You can also set $connection->SelectLimit('SELECT * FROM TABLE',-1,10) to get rows 11 to the last row.

The last parameter $inputarr is for databases that support variable binding such as Oracle oci8. This substantially reduces SQL compilation overhead. Below is an Oracle example:

       $conn->SelectLimit("SELECT
  * FROM TABLE WHERE COND=:val", 100,-1,array('val'=>
  $val));;

The oci8po driver (oracle portable driver) uses the more standard bind variable
  of ?:

      $conn->SelectLimit("SELECT
* FROM TABLE WHERE COND=?", 100,-1,array('val'=>
$val));

Ron Wilson reports that SelectLimit does not work with UNIONs.

Prev | Home | Next
ExecuteCursor | Up | CacheSelectLimit


CacheSelectLimit

Prev CacheSelectLimit Next

CacheSelectLimit([$secs2cache,] $sql, $numrows=-1,$offset=-1,$inputarr=false)

Similar to SelectLimit, except that the recordset returned is cached for $secs2cache seconds in the $ADODB_CACHE_DIR directory.

Since 1.80, $secs2cache has been optional, and you can define the caching time in $connection->cacheSecs.

    $conn->Connect(...);
    $conn->cacheSecs = 3600*24; // cache 24 hours
    $rs = $conn->CacheSelectLimit('select * from table',10);

CacheSelectLimit() rewrites the SQL query, so you won't be able to pass the SQL to CacheFlush. In this case, to flush the cached SQL recordset returned by CacheSelectLimit(), set $secs2cache to -1:

    $db->CacheSelectLimit(-1, $sql, $nrows);

Prev | Home | Next
SelectLimit | Up | CacheFlush


CacheFlush

Prev CacheFlush Next

CacheFlush($sql=false)

Flush (delete) any cached recordsets for the SQL statement $sql in $ADODB_CACHE_DIR.

If no parameter is passed in, then all adodb_*.cache files are deleted.

If you want to flush all cached recordsets manually, execute the following PHP code (works only under Unix):

    system("rm -f `find ".$ADODB_CACHE_DIR." -name adodb_*.cache`");

CacheSelectLimit() rewrites the SQL query, so you won't be able to pass the SQL to CacheFlush. In this case, to flush the cached SQL recordset returned by CacheSelectLimit(), set $secs2cache to 0:

    $db->CacheSelectLimit(0, $sql, $nrows);

For general cleanup of all expired files, you should use crontab on Unix, or at.exe on Windows, and a shell script similar to the following:

#------------------------------------------------------
# TRUNCATING OUTPUT FILES OLDER THAN N DAYS
#
# Everything between the 3 lines above and their matching
# lines at the bottom of this section show you how to
# delete any log files whose modification time
# is older than AGED. The AGED variable can be coded in the
# script or passed on the command line.
#------------------------------------------------------
# This particular example deletes files in the TMPPATH
# directory with the string ".cache" in their name that
# are more than 7 days old.
#------------------------------------------------------
AGED=7
find ${TMPPATH} -mtime +$AGED | grep ".cache" | xargs rm -f

Prev | Home | Next
CacheSelectLimit | Up | Prepare


Prepare

Prev Prepare Next

Prepare($sql )

Prepares (compiles) an SQL query for repeated execution. Bind parameters are denoted by ?, except for the oci8 driver, which uses the traditional Oracle :varname convention.

Returns an array containing the original sql statement in the first array element; the remaining elements of the array are driver dependent. If there is an error, or we are emulating Prepare( ), we return the original $sql string. This is because all error-handling has been centralized in Execute( ).

Example:

      $stmt
  = $DB->Prepare('insert
  into table (col1,col2) values (?,?)');
for ($i=0; $i < $max; $i++)
$DB->Execute($stmt,array((string)
  rand(), $i));

Also see PrepareSP(). Only supported internally by interbase, oci8 and selected ODBC-based drivers, otherwise it is emulated. There is no performance advantage to using Prepare() with emulation.

Important: Due to limitations or bugs in PHP, if you are getting errors when you using prepared queries, try setting $ADODB_COUNTRECS = false before preparing. This behaviour has been observed with ODBC.

Prev | Home | Next
CacheFlush | Up | PrepareSP


PrepareSP

Prev PrepareSP Next

PrepareSP($sql,$cursor=false)

When calling stored procedures in mssql and oci8 (oracle), and you might want to directly bind to parameters that return values, or for special LOB handling. PrepareSP() allows you to do so.

Returns the same array or $sql string as Prepare( ). If you do not need to bind to return values, you should use Prepare( ) instead.

The 2nd parameter, $cursor is not used except with oci8. Setting it to true will force OCINewCursor to be called; this is to support output REF CURSORs.

For examples of usage, see Parameter().

Note: in the mssql driver, preparing stored procedures requires a special function call, mssql_init( ). PrepareSP( ) is available in all other drivers, and is emulated by calling Prepare( ).

Prev | Home | Next
Prepare | Up | Parameter


InParameter, OutParameter, Parameter

Prev InParameter, OutParameter, Param and Parameter Next

InParameter($stmt, $var, $name, $maxLen = 4000, $type = false )

Binds a PHP variable as input to a stored procedure variable. The parameter $stmt is the value returned by PrepareSP(), $var is the PHP variable you want to bind, $name is the name of the stored procedure variable. Optional is $maxLen, the maximum length of the data to bind, and $type which is database dependant. Consult mssql_bind and ocibindbyname docs at php.net for more info on legal values for $type.

InParameter() is a wrapper function that calls Parameter() with $isOutput=false. The advantage of this function is that it is self-documenting, because the $isOutput parameter is no longer needed. Only for mssql and oci8 currently.

Here is an example using oci8:

# For oracle, Prepare and PrepareSP are identical
$stmt = $db->PrepareSP(
    "declare RETVAL integer;
    begin
    :RETVAL := SP_RUNSOMETHING(:myid,:group);
    end;");
$db->InParameter($stmt,$id,'myid');
$db->InParameter($stmt,$group,'group',64);
$db->OutParameter($stmt,$ret,'RETVAL');
$db->Execute($stmt);

The same example using mssql:

# @RETVAL = SP_RUNSOMETHING @myid,@group
$stmt = $db->PrepareSP('SP_RUNSOMETHING');
# note that the parameter name does not have @ in front!
$db->InParameter($stmt,$id,'myid');
$db->InParameter($stmt,$group,'group',64);
# return value in mssql - RETVAL is hard-coded name
$db->OutParameter($stmt,$ret,'RETVAL');
$db->Execute($stmt);

Note that the only difference between the oci8 and mssql implementations is $sql.

If $type parameter is set to false, in mssql, $type will be dynamicly determined based on the type of the PHP variable passed (string => SQLCHAR, boolean =>SQLINT1, integer =>SQLINT4 or float/double=>SQLFLT8).

In oci8, $type can be set to OCI_B_FILE (Binary-File), OCI_B_CFILE (Character-File), OCI_B_CLOB (Character-LOB), OCI_B_BLOB (Binary-LOB) and OCI_B_ROWID (ROWID). To pass in a null, use $db->Parameter($stmt, $null=null, 'param').

OutParameter($stmt, $var, $name, $maxLen = 4000, $type = false )

Binds a PHP variable as output from a stored procedure variable. The parameter $stmt is the value returned by PrepareSP(), $var is the PHP variable you want to bind, $name is the name of the stored procedure variable. Optional is $maxLen, the maximum length of the data to bind, and $type which is database dependant.

OutParameter() is a wrapper function that calls Parameter() with $isOutput=true. The advantage of this function is that it is self-documenting, because the $isOutput parameter is no longer needed. Only for mssql and oci8 currently.

For an example, see InParameter.

Parameter($stmt, $var, $name, $isOutput=false, $maxLen = 4000, $type = false )

This function is deprecated. Use InParameter( ) and OutParameter( ) instead.

Adds a bind parameter suitable for return values or special data handling (eg. LOBs) after a statement has been prepared using PrepareSP(). Only for mssql and oci8 currently. The parameters are:

$stmt Statement returned by Prepare() or PrepareSP().
$var PHP variable to bind to. Make sure you pre-initialize it!
$name Name of stored procedure variable name to bind to.
[$isOutput] Indicates direction of parameter 0/false=IN 1=OUT 2= IN/OUT. This is ignored in oci8 as this driver auto-detects the direction.
[$maxLen] Maximum length of the parameter variable.
[$type] Consult mssql_bind and ocibindbyname docs at php.net for more info on legal values for type.

Param($name )

Generates a bind placeholder portably. For most databases, the bind placeholder is "?". However some databases use named bind parameters such as Oracle, eg ":somevar". This allows us to portably define an SQL statement with bind parameters:

$sql = 'insert into table (col1,col2) values ('.$DB->Param('a').','.$DB->Param('b').')';
# generates 'insert into table (col1,col2) values (?,?)'
# or        'insert into table (col1,col2) values (:a,:b)'
$stmt = $DB->Prepare($sql);
$stmt = $DB->Execute($stmt,array('one','two'));

Prev | Home | Next
PrepareSP | Up | GetOne


GetOne

Prev GetOne Next

GetOne($sql)

Adds a bind parameter in a fashion that is compatible with Microsoft SQL Server and Oracle oci8. The parameters are:

Executes the SQL and returns the first field of the first row. The recordset and remaining rows are discarded for you automatically. If an error occur, false is returned.

GetAssoc($sql,$inputarr=false,$force_array=false,$first2cols=false)

Returns an associative array for the given query $sql with optional bind parameters in $inputarr. If the number of columns returned is greater to two, a 2-dimensional array is returned, with the first column of the recordset becomes the keys to the rest of the rows. If the columns is equal to two, a 1-dimensional array is created, where the the keys directly map to the values (unless $force_array is set to true, when an array is created for each value).

Examples:

We have the following data in a recordset:

row1: Apple, Fruit, Edible
row2: Cactus, Plant, Inedible
row3: Rose, Flower, Edible

GetAssoc will generate the following 2-dimensional associative array:

Apple => array[Fruit, Edible]
Cactus => array[Plant, Inedible]
Rose => array[Flower,Edible]

If the dataset is:

row1: Apple, Fruit
row2: Cactus, Plant
row3: Rose, Flower

GetAssoc will generate the following 1-dimensional associative array (with $force_array==false):

Apple => Fruit
Cactus=>Plant
Rose=>Flower

The function returns:

The associative array, or false if an error occurs.

CacheGetAssoc([$secs2cache,] $sql,$inputarr=false,$force_array=false,$first2cols=false)

Caching version of GetAssoc function above.

Prev | Home | Next
Parameter | Up | CacheGetOne


StartTrans, CompleteTrans, FailTrans, HasFailedTrans

Prev StartTrans, CompleteTrans, FailTrans Next

StartTrans( )

Start a monitored transaction. As SQL statements are executed, ADOdb will monitor for SQL errors, and if any are detected, when CompleteTrans() is called, we auto-rollback.

To understand why StartTrans() is superior to BeginTrans(), let us examine a few ways of using BeginTrans(). The following is the wrong way to use transactions:

$DB->BeginTrans();
$DB->Execute("update table1 set val=$val1 where id=$id");
$DB->Execute("update table2 set val=$val2 where id=$id");
$DB->CommitTrans();

because you perform no error checking. It is possible to update table1 and for the update on table2 to fail. Here is a better way:

$DB->BeginTrans();
$ok = $DB->Execute("update table1 set val=$val1 where id=$id");
if ($ok) $ok = $DB->Execute("update table2 set val=$val2 where id=$id");
if ($ok) $DB->CommitTrans();
else $DB->RollbackTrans();

Another way is (since ADOdb 2.0):

$DB->BeginTrans();
$ok = $DB->Execute("update table1 set val=$val1 where id=$id");
if ($ok) $ok = $DB->Execute("update table2 set val=$val2 where id=$id");
$DB->CommitTrans($ok);

Now it is a headache monitoring $ok all over the place. StartTrans() is an improvement because it monitors all SQL errors for you. This is particularly useful if you are calling black-box functions in which SQL queries might be executed. Also all BeginTrans, CommitTrans and RollbackTrans calls inside a StartTrans block will be disabled, so even if the black box function does a commit, it will be ignored.

$DB->StartTrans();
CallBlackBox();
$DB->Execute("update table1 set val=$val1 where id=$id");
$DB->Execute("update table2 set val=$val2 where id=$id");
$DB->CompleteTrans();

Note that a StartTrans blocks are nestable, the inner blocks are ignored.

CompleteTrans($autoComplete=true)

Complete a transaction called with StartTrans(). This function monitors for SQL errors, and will commit if no errors have occured, otherwise it will rollback. Returns true on commit, false on rollback. If the parameter $autoComplete is true monitor sql errors and commit and rollback as appropriate. Set $autoComplete to false to force rollback even if no SQL error detected.

FailTrans( )

Fail a transaction started with StartTrans(). The rollback will only occur when CompleteTrans() is called.

HasFailedTrans( )

Check whether smart transaction has failed, eg. returns true if SQL execution failed, or FailTrans() was called. If not within smart transaction, returns false.

SetTransactionMode($mode )

SetTransactionMode allows you to pass in the transaction mode to use for all subsequent transactions for that connection session. Note: if you have persistent connections and using mysql or mssql, you might have to explicitly reset your transaction mode at the beginning of each page request. This is only supported in postgresql, mssql, mysql with InnoDB and oci8 currently. For example:

$db->SetTransactionMode("SERIALIZABLE");
$db->BeginTrans();
$db->Execute(...); $db->Execute(...);
$db->CommiTrans();

$db->SetTransactionMode(""); // restore to default
$db->StartTrans();
$db->Execute(...); $db->Execute(...);
$db->CompleteTrans();

Supported values to pass in:

  • READ UNCOMMITTED (allows dirty reads, but fastest)
  • READ COMMITTED (default postgres, mssql and oci8)
  • REPEATABLE READ (default mysql)
  • SERIALIZABLE (slowest and most restrictive)

You can also pass in database specific values such as 'SNAPSHOT' for mssql or 'READ ONLY' for oci8/postgres.

See transaction levels for PostgreSQL, Oracle, MySQL, and MS SQL Server.

Prev | Home | Next
Close | Up | BeginTrans


CacheGetOne

Prev GetOne Next

CacheGetOne([$secs2cache,] $sql)

Similar to above Get* functions, except that the recordset is serialized and cached in the $ADODB_CACHE_DIR directory for $secs2cache seconds. Good for speeding up queries on rarely changing data. Note that the $secs2cache parameter is optional. If omitted, we use the value in $connection->cacheSecs (default is 3600 seconds, or 1 hour).

Prev | Home | Next
GetOne | Up | GetRow


GetRow

Prev GetRow Next

GetRow($sql)

Executes the SQL and returns the first row as an array. The recordset and remaining rows are discarded for you automatically. If an error occurs, false is returned.

Prev | Home | Next
CacheGetOne | Up | CacheGetRow


CacheGetRow

Prev CacheGetRow Next

CacheGetRow([$secs2cache,] $sql)

Similar to above Get* functions, except that the recordset is serialized and cached in the $ADODB_CACHE_DIR directory for $secs2cache seconds. Good for speeding up queries on rarely changing data. Note that the $secs2cache parameter is optional. If omitted, we use the value in $connection->cacheSecs (default is 3600 seconds, or 1 hour).

Prev | Home | Next
GetRow | Up | GetAll


GetAll

Prev GetAll Next

GetAll($sql,$inputarr=false)

Executes the SQL and returns the all the rows as a 2-dimensional array. The recordset is discarded for you automatically. If an error occurs, false is returned.GetArray is a synonym for GetAll.

Prev | Home | Next
CacheGetRow | Up | CacheGetAll


CacheGetAll

Prev CacheGetAll Next

CacheGetAll([$secs2cache,] $sql)

Similar to above Get* functions, except that the recordset is serialized and cached in the $ADODB_CACHE_DIR directory for $secs2cache seconds. Good for speeding up queries on rarely changing data. Note that the $secs2cache parameter is optional. If omitted, we use the value in $connection->cacheSecs (default is 3600 seconds, or 1 hour).

Prev | Home | Next
GetAll | Up | GetCol


GetCol

Prev GetCol Next

GetCol($sql)

Executes the SQL and returns all elements of the first column as a 1-dimensional array. The recordset is discarded for you automatically. If an error occurs, false is returned.

Prev | Home | Next
CacheGetAll | Up | CacheGetCol


CacheGetCol

Prev CacheGetCol Next

CacheGetCol([$secs2cache,] $sql)

Similar to above Get* functions, except that the recordset is serialized and cached in the $ADODB_CACHE_DIR directory for $secs2cache seconds. Good for speeding up queries on rarely changing data. Note that the $secs2cache parameter is optional. If omitted, we use the value in $connection->cacheSecs (default is 3600 seconds, or 1 hour).

Prev | Home | Next
GetCol | Up | Replace


Replace

Prev Replace Next

Replace($table, $arrFields, $keyCols,$autoQuote=false)

Try to update a record, and if the record is not found, an insert statement is generated and executed. Returns 0 on failure, 1 if update statement worked, 2 if no record was found and the insert was executed successfully. This differs from MySQL's replace which deletes the record and inserts a new record. This also means you cannot update the primary key. The only exception to this is Interbase and its derivitives, which uses delete and insert because of some Interbase API limitations.

The parameters are $table which is the table name, the $arrFields which is an associative array where the keys are the field names, and keyCols is the name of the primary key, or an array of field names if it is a compound key. If $autoQuote is set to true, then Replace() will quote all values that are non-numeric; auto-quoting will not quote nulls. Note that auto-quoting will not work if you use SQL functions or operators.

Examples:

# single field primary key
$ret = $db->Replace('atable',
    array('id'=>1000,'firstname'=>'Harun','lastname'=>'Al-Rashid'),
    'id',$autoquote = true);
# generates UPDATE atable SET firstname='Harun',lastname='Al-Rashid' WHERE id=1000
# or INSERT INTO atable (id,firstname,lastname) VALUES (1000,'Harun','Al-Rashid')

# compound key
$ret = $db->Replace('atable2',
    array('firstname'=>'Harun','lastname'=>'Al-Rashid', 'age' => 33, 'birthday' => 'null'),
    array('lastname','firstname'),
    $autoquote = true);

# no auto-quoting
$ret = $db->Replace('atable2',
    array('firstname'=>"'Harun'",'lastname'=>"'Al-Rashid'", 'age' => 'null'),
    array('lastname','firstname'));

Prev | Home | Next
CacheGetCol | Up | GetUpdateSQL


GetUpdateSQL

Prev AutoExecute/GetUpdateSQL Next

AutoExecute($table, $arrFields, $mode, $where=false, $forceUpdate=true,$magicq=false)

Since ADOdb 4.56, you can automatically generate and execute INSERTs and UPDATEs on a given table with this function, which is a wrapper for GetInsertSQL() and GetUpdateSQL().

AutoExecute() inserts or updates $table given an array of $arrFields, where the keys are the field names and the array values are the field values to store. Note that there is some overhead because the table is first queried to extract key information before the SQL is generated. We generate an INSERT or UPDATE based on $mode (see below).

Legal values for $mode are

  • 'INSERT' or 1 or DB_AUTOQUERY_INSERT
  • 'UPDATE' or 2 or DB_AUTOQUERY_UPDATE

You have to define the constants DB_AUTOQUERY_UPDATE and DB_AUTOQUERY_INSERT yourself or include adodb-pear.inc.php.

The $where clause is required if $mode == 'UPDATE'. If $forceUpdate=false then we will query the database first and check if the field value returned by the query matches the current field value; only if they differ do we update that field.

Returns true on success, false on error.

An example of its use is:

$record["firstName"] = "Carol";
$record["lasTname"] = "Smith";
$conn->AutoExecute($table,$record,'INSERT');
# executes "INSERT INTO $table (firstName,lasTname) values ('Carol',Smith')";

$record["firstName"] = "Carol";
$record["lasTname"] = "Jones";
$conn->AutoExecute($table,$record,'UPDATE', "lastname like 'Sm%'");
# executes "UPDATE $table SET firstName='Carol',lasTname='Jones' WHERE lastname like 'Sm%'";

Note: One of the strengths of ADOdb's AutoExecute() is that only valid field names for $table are updated. If $arrFields contains keys that are invalid field names for $table, they are ignored. There is some overhead in doing this as we have to query the database to get the field names, but given that you are not directly coding the SQL yourself, you probably aren't interested in speed at all, but convenience.

Since 4.62, the table name to be used can be overridden by setting $rs->tableName before AutoExecute(), GetInsertSQL() or GetUpdateSQL() is called.

GetUpdateSQL(&$rs, $arrFields, $forceUpdate=false,$magicq=false,$forcenulls=false)

Generate SQL to update a table given a recordset $rs, and the modified fields of the array $arrFields (which must be an associative array holding the column names and the new values) are compared with the current recordset. If $forceUpdate is true, then we also generate the SQL even if $arrFields is identical to $rs->fields. Requires the recordset to be associative. $magicq is used to indicate whether magic quotes are enabled (see qstr()).

Since 4.52, we allow you to pass the $force type parameter, and this overrides the $ADODB_FORCE_TYPE global variable.

Since 4.62, the table name to be used can be overridden by setting $rs->tableName before AutoExecute(), GetInsertSQL() or GetUpdateSQL() is called.

Prev | Home | Next
Replace | Up | GetInsertSQL


GetInsertSQL

Prev GetInsertSQL Next

GetInsertSQL(&$rs, $arrFields,$magicq=false,$forcenulls=false)

Generate SQL to insert into a table given a recordset $rs. Requires the query to be associative. $magicq is used to indicate whether magic quotes are enabled (for qstr()).

Since 2.42, you can pass a table name instead of a recordset into GetInsertSQL (in $rs), and it will generate an insert statement for that table.

Since 4.52, we allow you to pass the $force type parameter, and this overrides the $ADODB_FORCE_TYPE global variable.

Since 4.62, the table name to be used can be overridden by setting $rs->tableName before AutoExecute(), GetInsertSQL() or GetUpdateSQL() is called.

Prev | Home | Next
GetUpdateSQL | Up | UpdateBlob


UpdateBlob

Prev UpdateBlob Next

UpdateBlob($table,$column,$val,$where)

Allows you to store a blob (in $val) into $table into $column in a row at $where.
Usage:

    # for oracle
    $conn->Execute('INSERT INTO blobtable (id, blobcol) VALUES (1, empty_blob())');
    $conn->UpdateBlob('blobtable','blobcol',$blobvalue,'id=1');

    # non oracle databases
    $conn->Execute('INSERT INTO blobtable (id, blobcol) VALUES (1, null)');
    $conn->UpdateBlob('blobtable','blobcol',$blobvalue,'id=1');

Returns true if succesful, false otherwise. Supported by MySQL, PostgreSQL, Oci8, Oci8po and Interbase drivers. Other drivers might work, depending on the state of development.

Note that when an Interbase blob is retrieved using SELECT, it still needs to be decoded using $connection->DecodeBlob($blob); to derive the original value in versions of PHP before 4.1.0.

For PostgreSQL, you can store your blob using blob oid's or as a bytea field. You can use bytea fields but not blob oid's currently with UpdateBlob( ). Conversely UpdateBlobFile( ) supports oid's, but not bytea data.

If you do not pass in an oid, then UpdateBlob() assumes that you are storing in bytea fields.

If you do not have any blob fields, you can improve general SQL query performance by disabling blob handling with $connection->disableBlobs = true.

Prev | Home | Next
GetUpdateSQL | Up | UpdateClob


UpdateClob

Prev UpdateClob Next

UpdateClob($table,$column,$val,$where)

Allows you to store a clob (in $val) into $table into $column in a row at $where. Similar to UpdateBlob (see above), but for Character Large OBjects.
Usage:

    # for oracle
    $conn->Execute('INSERT INTO clobtable (id, clobcol) VALUES (1, empty_clob())');
    $conn->UpdateClob('clobtable','clobcol',$clobvalue,'id=1');

    # non oracle databases
    $conn->Execute('INSERT INTO clobtable (id, clobcol) VALUES (1, null)');
    $conn->UpdateClob('clobtable','clobcol',$clobvalue,'id=1');

Prev | Home | Next
UpdateBlob | Up | UpdateBlobFile


UpdateBlobFile

Prev UpdateBlobFile Next

UpdateBlobFile($table,$column,$path,$where,$blobtype='BLOB')

Similar to UpdateBlob, except that we pass in a file path to where the blob resides.

For PostgreSQL, if you are using blob oid's, use this interface. This interface does not support bytea fields.

Returns true if successful, false otherwise.

Prev | Home | Next
UpdateClob | Up | BlobEncode


BlobEncode

Prev BlobEncode Next

BlobEncode($blob)

Some databases require blob's to be encoded manually before upload. Note if you use UpdateBlob( ) or UpdateBlobFile( ) the conversion is done automatically for you and you do not have to call this function. For PostgreSQL, currently, BlobEncode() can only be used for bytea fields.

Returns the encoded blob value.

Note that there is a connection property called blobEncodeType which has 3 legal values:

false - no need to perform encoding or decoding.
'I' - blob encoding required, and returned encoded blob is a numeric value (no need to quote).
'C' - blob encoding required, and returned encoded blob is a character value (requires quoting).

This is purely for documentation purposes, so that programs that accept multiple database drivers know what is the right thing to do when processing blobs.

Prev | Home | Next
UpdateBlobFile | Up | BlobDecode


BlobDecode

Prev BlobDecode Next

BlobDecode($blob,$maxblobsize=false)

Some databases require blob's to be decoded manually after doing a select statement. If the database does not require decoding, then this function will return the blob unchanged. Currently BlobDecode is only required for one database, PostgreSQL, and only if you are using blob oid's (if you are using bytea fields, we auto-decode for you). The default maxblobsize is set in $connection->maxblobsize, which is set to 256K in adodb 4.54.

In ADOdb 4.54 and later, the blob is the return value. In earlier versions, the blob data is sent to stdout.

      $rs
  = $db->Execute("select
  bloboid from postgres_table where id=$key");
$blob =
  $db->BlobDecode(
  reset($rs->fields)
  );

Prev | Home | Next
BlobEncode | Up | PageExecute


PageExecute

Prev PageExecute Next

PageExecute($sql, $nrows, $page, $inputarr=false)

Used for pagination of recordset. $page is 1-based. See Example 8.

Prev | Home | Next
BlobDecode | Up | CachePageExecute


CachePageExecute

Prev CachePageExecute Next

CachePageExecute($secs2cache, $sql, $nrows, $page, $inputarr=false)

Used for pagination of recordset. $page is 1-based. See Example 8. Caching version of PageExecute..

Prev | Home | Next
PageExecute | Up | Close


Close

Prev Close Next

Close( )

Close the database connection. PHP4 proudly states that we no longer have to clean up at the end of the connection because the reference counting mechanism of PHP4 will automatically clean up for us.

Prev | Home | Next
CachePageExecute | Up | Smart Transactions


BeginTrans

Prev BeginTrans Next

BeginTrans( )

Begin a transaction. Turns off autoCommit. Returns true if successful. Some databases will always return false if transaction support is not available. Among the databases that support transactions are Oracle, PostgreSQL, Interbase, MSSQL, certain versions of MySQL, DB2, Informix, Sybase, etc. Any open transactions will be rolled back when the connection is closed.

The following is the wrong way to use transactions:

    $DB->BeginTrans();
    $DB->Execute("update table1 set val=$val1 where id=$id");
    $DB->Execute("update table2 set val=$val2 where id=$id");
    $DB->CommitTrans();

because you perform no error checking. It is possible to update table1 and for the update on table2 to fail. Here is a better way:

    $DB->BeginTrans();
    $ok = $DB->Execute("update table1 set val=$val1 where id=$id");
    if ($ok) $ok = $DB->Execute("update table2 set val=$val2 where id=$id");
    if ($ok) $DB->CommitTrans();
    else $DB->RollbackTrans();

Another way is (since ADOdb 2.0):

    $DB->BeginTrans();
    $ok = $DB->Execute("update table1 set val=$val1 where id=$id");
    if ($ok) $ok = $DB->Execute("update table2 set val=$val2 where id=$id");
    $DB->CommitTrans($ok);

You can also use the ADOdb error handler to die and rollback your transactions for you transparently. Some buggy database extensions are known to commit all outstanding tranasactions, so you might want to explicitly do a $DB->RollbackTrans() in your error handler for safety.

Prev | Home | Next
Smart Transactions | Up | CommitTrans


CommitTrans

Prev CommitTrans Next

CommitTrans($ok=true)

End a transaction successfully. Returns true if successful. If the database does not support transactions, will return true also as data is always committed.

If you pass the parameter $ok=false, the data is rolled back. See example in BeginTrans().

Prev | Home | Next
BeginTrans | Up | RollbackTrans


RollbackTrans

Prev RollbackTrans Next

RollbackTrans($ok=true)

End a transaction, rollback all changes. Returns true if successful. If the database does not support transactions, will return false as data is never rollbacked.

Prev | Home | Next
CommitTrans | Up | SetFetchMode


SetFetchMode

Prev SetFetchMode Next

SetFetchMode($mode)

Sets the current fetch mode for the connection and stores it in $db->fetchMode. Legal modes are ADODB_FETCH_ASSOC and ADODB_FETCH_NUM. For more info, see $ADODB_FETCH_MODE.

Prev | Home | Next
RollbackTrans | Up | Concat


Concat, IfNull, length, random, substr

Prev Concat, IfNull, length, random, substr Next

Concat($s1,$s2,....)

Generates the sql string used to concatenate $s1, $s2, etc together. Uses the string in the concat_operator field to generate the concatenation. Override this function if a concatenation operator is not used, eg. MySQL.

Returns the concatenated string.

IfNull($field, $nullReplacementValue)

Portable IFNULL function (NVL in Oracle). Returns a string that represents the function that checks whether a $field is null for the given database, and if null, change the value returned to $nullReplacementValue. Eg.

$sql = 'SELECT '.$db->IfNull('name', "'- unknown -'"). ' FROM table';

length

This is not a function, but a property. Some databases have "length" and others "len" as the function to measure the length of a string. To use this property:

  $sql = "SELECT ".$db->length."(field) from table";
  $rs = $db->Execute($sql);

random

This is not a function, but a property. This is a string that holds the sql to generate a random number between 0.0 and 1.0 inclusive.

substr

This is not a function, but a property. Some databases have "substr" and others "substring" as the function to retrieve a sub-string. To use this property:

  $sql = "SELECT ".$db->substr."(field, $offset, $length) from table";
  $rs = $db->Execute($sql);

For all databases, the 1st parameter of substr is the field, the 2nd is the offset (1-based) to the beginning of the sub-string, and the 3rd is the length of the sub-string.

Prev | Home | Next
SetFetchMode | Up | qstr


qstr

Prev qstr Next

qstr($s,[$magic_quotes_enabled=false])

Quotes a string to be sent to the database. The $magic_quotes_enabled parameter may look funny, but the idea is if you are quoting a string extracted from a POST/GET variable, then pass get_magic_quotes_gpc() as the second parameter. This will ensure that the variable is not quoted twice, once by qstr and once by the magic_quotes_gpc.

Eg. $s = $db->qstr(HTTP_GET_VARS['name'],get_magic_quotes_gpc());

Returns the quoted string.

Prev | Home | Next
Concat | Up | Quote


Quote

Prev Quote Next

Quote($s)

Quotes the string $s, escaping the database specific quote character as appropriate. Formerly checked magic quotes setting, but this was disabled since 3.31 for compatibility with PEAR DB.

Prev | Home | Next
qstr | Up | DBDate


DBDate

Prev DBDate Next

DBDate($date)

Format the $date in the format the database accepts. This is used for sending dates to the database (eg. in UPDATE, INSERT or the where clause of SELECT statements). When retrieving date columns with the SELECT statement use SQLDate. The $date parameter can be a Unix integer timestamp or an ISO format Y-m-d. Uses the fmtDate field, which holds the format to use. If null or false or '' is passed in, it will be converted to an SQL null.

Returns the date as a quoted string.

    $sql = "select * from atable where created > ".$db->DBDate("$year-$month-$day");
    $db->Execute($sql);

BindDate($date)

Format the $date in the bind format the database accepts. Normally this means that the date string is not quoted, unlike DBDate, which quotes the string.

    $sql = "select * from atable where created > ".$db->Param('0');
    // or
    $sql = "select * from atable where created > ?";
    $db->Execute($sql,array($db->BindDate("$year-$month-$day"));

Prev | Home | Next
Quote | Up | DBTimeStamp


DBTimeStamp

Prev DBDate Next

DBTimeStamp($ts)

Format the timestamp $ts in the format the database accepts; this can be a Unix integer timestamp or an ISO format Y-m-d H:i:s. Uses the fmtTimeStamp field, which holds the format to use. If null or false or '' is passed in, it will be converted to an SQL null.

Returns the timestamp as a quoted string.

    $sql = "select * from atable where created > ".$db->DBTimeStamp("$year-$month-$day $hr:$min:$secs");
    $db->Execute($sql);

BindTimeStamp($ts)

Format the timestamp $ts in the bind format the database accepts. Normally this means that the timestamp string is not quoted, unlike DBTimeStamp, which quotes the string.

    $sql = "select * from atable where created > ".$db->Param('0');
    // or
    $sql = "select * from atable where created > ?";
    $db->Execute($sql,array($db->BindTimeStamp("$year-$month-$day $hr:$min:$secs"));

Prev | Home | Next
DBDate | Up | UnixDate


UnixDate

Prev UnixDate Next

UnixDate($str)

Parses the date string $str and returns it in unix mktime format (eg. a number indicating the seconds after January 1st, 1970). Expects the date to be in Y-m-d H:i:s format, except for Sybase and Microsoft SQL Server, where M d Y is also accepted (the 3 letter month strings are controlled by a global array, which might need localisation).

This function is available in both ADORecordSet and ADOConnection since 1.91.

Prev | Home | Next
DBTimeStamp | Up | UnixTimeStamp


UnixTimeStamp

Prev UnixTimeStamp Next

UnixTimeStamp($str)

Parses the timestamp string $str and returns it in unix mktime format (eg. a number indicating the seconds after January 1st, 1970). Expects the date to to be in "Y-m-d, H:i:s" (1970-12-24, 00:00:00) or "Y-m-d H:i:s" (1970-12-24 00:00:00) or "YmdHis" (19701225000000) format, except for Sybase and Microsoft SQL Server, where "M d Y h:i:sA" (Dec 25 1970 00:00:00AM) is also accepted (the 3 letter month strings are controlled by a global array, which might need localisation).

This function is available in both ADORecordSet and ADOConnection since 1.91.

Prev | Home | Next
UnixDate | Up | OffsetDate


OffsetDate

Prev OffsetDate Next

OffsetDate($dayFraction, $basedate=false)

Allows you to calculate future and past dates based on $basedate in a portable fashion. If $basedate is not defined, then the current date (at 12 midnight) is used. Returns the SQL string that performs the calculation when passed to Execute().

For example, in Oracle, to find the date and time that is 2.5 days from today, you can use:

    # get date one week from now
    $fld = $conn->OffsetDate(7); // returns "(trunc(sysdate)+7")

    # get date and time that is 60 hours from current date and time
    $fld = $conn->OffsetDate(2.5, $conn->sysTimeStamp);    // returns "(sysdate+2.5)"

    $conn->Execute("UPDATE TABLE SET dodate=$fld WHERE ID=$id");

This function is available for mysql, mssql, oracle, oci8 and postgresql drivers since 2.13. It might work with other drivers provided they allow performing numeric day arithmetic on dates.

Prev | Home | Next
UnixTimeStamp | Up | SQLDate


SQLDate

Prev SQLDate Next

SQLDate($dateFormat, $basedate=false)

Returns a string which contains the native SQL functions to format a date or date column $basedate. This is used when retrieving date columns in SELECT statements. For sending dates to the database (eg. in UPDATE, INSERT or the where clause of SELECT statements) use DBDate( ). It uses a $dateFormat string, which supports:

 Y: 4-digit Year
 Q: Quarter (1-4)
 M: Month (Jan-Dec)
 m: Month (01-12)
 d: Day (01-31)
 H: Hour (00-23)
 h: Hour (1-12)
 i: Minute (00-59)
 s: Second (00-60)
 w: day of week (0-6 or 1-7 depending on DB)
 l: day of week (as string - lowercase L)
 W: week in year (0..53 for MySQL, 1..53 for PostgreSQL and Oracle)
 A: AM/PM indicator

All other characters are treated as strings. You can also use to escape characters. Available on selected databases, including mysql, postgresql, mssql, oci8 and DB2.

This is useful in writing portable sql statements that GROUP BY on dates. For example to display total cost of goods sold broken by quarter (dates are stored in a field called postdate):

    $sqlfn = $db->SQLDate('Y-QQ','postdate'); # get sql that formats postdate to output 2002-Q1
    $sql = "SELECT $sqlfn,SUM(cogs) FROM table GROUP BY $sqlfn ORDER BY 1 desc";

Prev | Home | Next
OffsetDate | Up | Affected_Rows


Affected_Rows

Prev Affected_Rows Next

Affected_Rows( )

Returns the number of rows affected by a update or delete statement. Returns false if function not supported.

Not supported by interbase/firebird currently.

Prev | Home | Next
SQLDate | Up | Insert_ID


Insert_ID and RowLock

Prev Insert_ID and RowLock Next

Insert_ID( )

Returns the last autonumbering ID inserted. Returns false if function not supported.

Only supported by databases that support auto-increment or object id's, such as PostgreSQL, MySQL and MS SQL Server currently. PostgreSQL returns the OID, which can change on a database reload.

RowLock($table,$where)

Lock a table row for the duration of a transaction. For example to lock record $id in table1:

    $DB->StartTrans();
    $DB->RowLock("table1","rowid=$id");
    $DB->Execute($sql1);
    $DB->Execute($sql2);
    $DB->CompleteTrans();

Supported in db2, interbase, informix, mssql, oci8, postgres, sybase.

Prev | Home | Next
Affected_Rows | Up | GenID


GenID

Prev GenID Next

GenID($seqName = 'adodbseq',$startID=1)

Generate a sequence number (an integer except for mssql). Works for interbase, mysql, postgresql, oci8, oci8po, mssql, ODBC based (access,vfp,db2,etc) drivers currently. Uses $seqName as the name of the sequence. GenID() will automatically create the sequence for you if it does not exist (provided the userid has permission to do so). Otherwise you will have to create the sequence yourself.

If your database driver emulates sequences, the name of the table is the sequence name. The table has one column, "id" which should be of type integer, or if you need something larger - numeric(16).

For ODBC and databases that do not support sequences natively (eg mssql, mysql), we create a table for each sequence. If the sequence has not been defined earlier, it is created with the starting value set in $startID.

Note that the mssql driver's GenID() used to generate 16 byte GUID's. We now return integers since 1.90.

Prev | Home | Next
Insert_ID | Up | CreateSequence


CreateSequence

Prev CreateSequence Next

CreateSequence($seqName = 'adodbseq',$startID=1)

Create a sequence. The next time GenID( ) is called, the value returned will be $startID. Added in 2.60.

Prev | Home | Next
GenID | Up | DropSequenceD


DropSequenceD

Prev DropSequenceD Next

DropSequence($seqName = 'adodbseq')

Delete a sequence. Added in 2.60.

Prev | Home | Next
CreateSequence | Up | ErrorMsg


ErrorMsg

Prev ErrorMsg Next

ErrorMsg()

Returns the last status or error message. Returns the last status or error message. The error message is reset when Execute() is called.

This can return a string even if no error occurs. In general you do not need to call this function unless an ADOdb function returns false on an error.

Note: If debug is enabled, the SQL error message is always displayed when the Execute function is called.

IgnoreErrors($saveErrHandlers=false)

Allows you to ignore errors so that StartTrans()/CompleteTrans() is not affected, nor is the default error handler called if an error occurs. Useful when you want to check if a field or table exists in a database without invoking an error if it does not exist.

Usage:

$saveErrHandlers = $conn->IgnoreErrors();
$rs = $conn->Execute("select field from some_table_that_might_not_exist");
$conn->IgnoreErrors($saveErrHandlers);

Warning: do not call StartTrans()/CompleteTrans() inside a code block that is using IgnoreErrors().

Prev | Home | Next
DropSequenceD | Up | ErrorNo


ErrorNo

Prev ErrorNo Next

ErrorNo()

Returns the last error number. The error number is reset after every call to Execute(). If 0 is returned, no error occurred.

Note that old versions of PHP (pre 4.0.6) do not support error number for ODBC. In general you do not need to call this function unless an ADOdb function returns false on an error.

MetaError($errno=false)

Returns a virtualized error number, based on PEAR DB's error number system. You might need to include adodb-error.inc.php before you call this function. The parameter $errno is the native error number you want to convert. If you do not pass any parameter, MetaError will call ErrorNo() for you and convert it. If the error number cannot be virtualized, MetaError will return -1 (DB_ERROR).

MetaErrorMsg($errno)

Pass the error number returned by MetaError() for the equivalent textual error message.

ErrorMsg()

Returns the last status or error message. The error message is reset after every call to Execute().

This can return a string even if no error occurs. In general you do not need to call this function unless an ADOdb function returns false on an error.

Note: If debug is enabled, the SQL error message is always displayed when the Execute function is called.

Prev | Home | Next
ErrorMsg | Up | MetaDatabases


MetaDatabases

Prev MetaDatabases Next

MetaDatabases()

Returns a list of databases available on the server as an array. You have to connect to the server first. Only available for ODBC, MySQL and ADO.

Prev | Home | Next
ErrorNo | Up | MetaTables


MetaTables

Prev MetaTables Next

MetaTables($ttype=false, $showSchema=false)

Returns an array of tables and views for the current database as an array. The array should exclude system catalog tables if possible. To only show tables, use $db->MetaTables('TABLES'). To show only views, use $db->MetaTables('VIEWS'). The $showSchema parameter currently works only for DB2, and when set to true, will add the schema name to the table, eg. "SCHEMA.TABLE".

Prev | Home | Next
MetaDatabases | Up | MetaColumns


MetaColumns

Prev MetaColumns Next

MetaColumns($table, $notcasesensitive=true)

Returns an array of ADOFieldObject's, one field object for every column of $table. A field object is a class instance with (name, type, max_length) defined. Currently Sybase does not recognise date types, and ADO cannot identify the correct data type (so we default to varchar).

The $notcasesensitive parameter determines whether we uppercase or lowercase the table name to normalize it (required for some databases). Does not work with MySQL ISAM tables.

For schema support, pass in the $table parameter, "$schema.$tablename". This is only supported for selected databases.

Prev | Home | Next
MetaTables | Up | MetaColumnNames


MetaColumnNames

Prev MetaColumnNames Next

MetaColumnNames($table)

Returns an array of column names for $table. Since ADOdb 4.22, this is an associative array, with the keys in uppercase.

e.g. array('FIELD1' => 'Field1', 'FIELD2'=>'Field2')

Prev | Home | Next
MetaColumns | Up | MetaPrimaryKeys


MetaPrimaryKeys and MetaForeignKeys

Prev MetaPrimaryKeys Next

MetaPrimaryKeys($table)

Returns an array containing column names that are the primary keys of $table. Supported by mysql, odbc (including db2, odbc_mssql, etc), mssql, postgres, interbase/firebird, oci8 currently.

Views (and some tables) have primary keys, but sometimes this information is not available from the database. You can define a function ADODB_View_PrimaryKeys($databaseType, $database, $view, $owner) that should return an array containing the fields that make up the primary key. If that function exists, it will be called when MetaPrimaryKeys() cannot find a primary key for a table or view.

// In this example: dbtype = 'oci8', $db = 'mydb', $view = 'dataView', $owner = false
function ADODB_View_PrimaryKeys($dbtype,$db,$view,$owner)
{
    switch(strtoupper($view)) {
    case 'DATAVIEW': return array('DATAID');
    default: return false;
    }
}

$db = NewADOConnection('oci8');
$db->Connect('localhost','root','','mydb');
$db->MetaPrimaryKeys('dataView');

MetaForeignKeys($table, $owner=false, $upper=false)

Returns an associate array of foreign keys, or false if not supported. For example, if table employee has a foreign key where employee.deptkey points to dept_table.deptid, and employee.posn=posn_table.postionid and employee.poscategory=posn_table.category, then $conn->MetaForeignKeys('employee') will return

    array(
        'dept_table' => array('deptkey=deptid'),
        'posn_table' => array('posn=positionid','poscategory=category')
    )

The optional schema or owner can be defined in $owner. If $upper is true, then the table names (array keys) are upper-cased.

Prev | Home | Next
MetaColumnNames | Up | ServerInfo


ServerInfo

Prev ServerInfo Next

ServerInfo()

Returns an array of containing two elements 'description' and 'version'. The 'description' element contains the string description of the database. The 'version' naturally holds the version number (which is also a string).

Prev | Home | Next
MetaPrimaryKeys | Up | fnExecute and fnCacheExecute properties


LogSQL, fnExecute and fnCacheExecute properties

Prev LogSQL method, fnExecute and fnCacheExecute properties Next

LogSQL($enable=true)

Call this method to install a SQL logging and timing function (using fnExecute). Then all SQL statements are logged into an adodb_logsql table in a database. If the adodb_logsql table does not exist, ADOdb will create the table if you have the appropriate permissions. Here are samples of the DDL for selected databases:

        mysql:
        CREATE TABLE adodb_logsql (
          created datetime NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 text NOT NULL,
          params text NOT NULL,
          tracer text NOT NULL,
          timer decimal(16,6) NOT NULL
        )

        postgres:
        CREATE TABLE adodb_logsql (
          created timestamp NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 text NOT NULL,
          params text NOT NULL,
          tracer text NOT NULL,
          timer decimal(16,6) NOT NULL
        )

        mssql:
        CREATE TABLE adodb_logsql (
          created datetime NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 varchar(4000) NOT NULL,
          params varchar(3000) NOT NULL,
          tracer varchar(500) NOT NULL,
          timer decimal(16,6) NOT NULL
        )

        oci8:
        CREATE TABLE adodb_logsql (
          created date NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 varchar(4000) NOT NULL,
          params varchar(4000),
          tracer varchar(4000),
          timer decimal(16,6) NOT NULL
        )
Usage:
    $conn->LogSQL(); // turn on logging
      :
    $conn->Execute(...);
      :
    $conn->LogSQL(false); // turn off logging

    # output summary of SQL logging results
    $perf = NewPerfMonitor($conn);
    echo $perf->SuspiciousSQL();
    echo $perf->ExpensiveSQL();

One limitation of logging is that rollback also prevents SQL from being logged.

Since ADOdb 3.91. Also see Performance Monitor.

fnExecute and fnCacheExecute properties

These two properties allow you to define bottleneck functions for all sql statements processed by ADOdb. This allows you to perform statistical analysis and query-rewriting of your sql. For example, to count all cached queries and non-cached queries, you can do this:

# $db is the connection object
function &CountExecs($db, $sql, $inputarray)
{
global $EXECS;

    if (!is_array(inputarray)) $EXECS++;
    # handle 2-dimensional input arrays
    else if (is_array(reset($inputarray))) $EXECS += sizeof($inputarray);
    else $EXECS++;

    $null = null;
    return $null;
}

# $db is the connection object
function CountCachedExecs($db, $secs2cache, $sql, $inputarray)
{
global $CACHED; $CACHED++;
}

$db = NewADOConnection('mysql');
$db->Connect(...);
$db->fnExecute = 'CountExecs';
$db->fnCacheExecute = 'CountCachedExecs';
 :
 :
# After many sql statements:`
printf("<p>Total queries=%d; total cached=%d</p>",$EXECS+$CACHED, $CACHED);

The fnExecute function is called before the sql is parsed and executed, so you can perform a query rewrite. If you are passing in a prepared statement, then $sql is an array (see Prepare). The fnCacheExecute function is only called if the recordset returned was cached. The function parameters match the Execute and CacheExecute functions respectively, except that $this (the connection object) is passed as the first parameter.

Since ADOdb 3.91, the behaviour of fnExecute varies depending on whether the defined function returns a value. If it does not return a value, then the $sql is executed as before. This is useful for query rewriting or counting sql queries.

On the other hand, you might want to replace the Execute function with one of your own design. If this is the case, then have your function return a value. If a value is returned, that value is returned immediately, without any further processing. This is used internally by ADOdb to implement LogSQL() functionality.

Prev | Home | Next
MetaPrimaryKeys | Up | Bind


Bind

Prev Bind Next

Bind($stmt, $var, $size=4001, $type=false, $name=false)

This is a low-level function supported only by the oci8 driver. Avoid using unless you only want to support Oracle. The Parameter( ) function is the recommended way to go with bind variables.

Bind( ) allows you to use bind variables in your sql statement. This binds a PHP variable to a name defined in an Oracle sql statement that was previously prepared using Prepare(). Oracle named variables begin with a colon, and ADOdb requires the named variables be called :0, :1, :2, :3, etc. The first invocation of Bind() will match :0, the second invocation will match :1, etc. Binding can provide 100% speedups for insert, select and update statements.

The other variables, $size sets the buffer size for data storage, $type is the optional descriptor type OCI_B_FILE (Binary-File), OCI_B_CFILE (Character-File), OCI_B_CLOB (Character-LOB), OCI_B_BLOB (Binary-LOB) and OCI_B_ROWID (ROWID). Lastly, instead of using the default :0, :1, etc names, you can define your own bind-name using $name.

The following example shows 3 bind variables being used: p1, p2 and p3. These variables are bound to :0, :1 and :2.

      $stmt
= $DB->Prepare("insert
into table (col0, col1, col2) values (:0, :1, :2)");
$DB->Bind($stmt, $p1);
$DB->Bind($stmt, $p2);
$DB->Bind($stmt, $p3);
for ($i = 0; $i < $max; $i++) {
$p1 = ?; $p2 = ?; $p3 = ?;
$DB->Execute($stmt);
}
You can also use named variables:

$stmt = $DB->Prepare("insert into table (col0, col1, col2) values (:name0, :name1, :name2)");
$DB->Bind($stmt, $p1, "name0");
$DB->Bind($stmt, $p2, "name1");
$DB->Bind($stmt, $p3, "name2");
for ($i = 0; $i < $max; $i++) {
$p1 = ?; $p2 = ?; $p3 = ?;
$DB->Execute($stmt);
}

Prev | Home | Next
fnExecute and fnCacheExecute | Up | BlankRecordSet


BlankRecordSet

Prev Bind Next

BlankRecordSet([$queryid])

No longer available - removed since 1.99.

Prev | Home | Next
Bind | Up | ADORecordSet


ADORecordSet

When an SQL statement successfully is executed by ADOConnection->Execute($sql),an ADORecordSet object is returned. This object contains a virtual cursor so we can move from row to row, functions to obtain information about the columns and column types, and helper functions to deal with formating the results to show to the user.

  • Returns one row: FetchRow FetchInto FetchObject FetchNextObject FetchObj FetchNextObj
  • Returns all rows: GetArray GetRows GetAssoc
  • Scrolling: Move MoveNext MoveFirst MoveLast AbsolutePosition CurrentRow AtFirstPage AtLastPage AbsolutePage
  • Menu generation: GetMenu GetMenu2
  • Dates: UserDate UserTimeStamp UnixDate UnixTimeStamp
  • Recordset Info: RecordCount PO_RecordSet NextRecordSet
  • Field Info: FieldCount FetchField MetaType
  • Cleanup: Close
  • Deprecated: GetRowAssoc Fields

ADORecordSet( )

Constructer. Normally you never call this function yourself.

ADORecordSet Fields

fields: Array containing the current row. This is not associative, but is an indexed array from 0 to columns-1. See also the function Fields, which behaves like an associative array.

dataProvider: The underlying mechanism used to connect to the database. Normally set to native, unless using odbc or ado.

blobSize: Maximum size of a char, string or varchar object before it is treated as a Blob (Blob's should be shown with textarea's). See the MetaType function.

sql: Holds the sql statement used to generate this record set.

canSeek: Set to true if Move( ) function works.

EOF: True if we have scrolled the cursor past the last record.

Prev | Home | Next
BlankRecordSet | Up | FetchRow


FetchRow

Prev FetchRow Next

FetchRow()

Returns array containing current row, or false if EOF. FetchRow( ) internally moves to the next record after returning the current row.

Warning: Do not mix using FetchRow() with MoveNext().

Usage:

$rs = $db->Execute($sql);
if ($rs)
while ($arr
  = $rs->FetchRow())
  {
#
  process $arr
}

Prev | Home | Next
ADORecordSet | Up | FetchInto


FetchInto

Prev FetchInto Next

FetchInto(&$array)

Sets $array to the current row. Returns PEAR_Error object if EOF, 1 if ok (DB_OK constant). If PEAR is undefined, false is returned when EOF. FetchInto( ) internally moves to the next record after returning the current row.

FetchRow() is easier to use. See above.

Prev | Home | Next
FetchRow | Up | FetchObject


FetchObject

Prev FetchObject Next

FetchObject($toupper=true)

Returns the current row as an object. If you set $toupper to true, then the object fields are set to upper-case. Note: The newer FetchNextObject() is the recommended way of accessing rows as objects. See below.

Prev | Home | Next
FetchInto | Up | FetchNextObject


FetchNextObject

Prev FetchNextObject Next

FetchNextObject($toupper=true)

Gets the current row as an object and moves to the next row automatically. Returns false if at end-of-file. If you set $toupper to true, then the object fields are set to upper-case.

      $rs
= $db->Execute('select
firstname,lastname from table');
if ($rs) {
while ($o = $rs->FetchNextObject()) {
print "$o->FIRSTNAME, $o->LASTNAME<BR>";
}
}

There is some trade-off in speed in using FetchNextObject(). If performance is important, you should access rows with the fields[] array. FetchObj()

Returns the current record as an object. Fields are not upper-cased, unlike FetchObject.

Prev | Home | Next
FetchObject | Up | FetchObj


FetchObj

Prev FetchObj Next

FetchObj()

Returns the current record as an object. Fields are not upper-cased, unlike FetchObject.

Prev | Home | Next
FetchNextObject | Up | FetchNextObj


FetchNextObj

Prev FetchNextObj Next

FetchNextObj()

Returns the current record as an object. Fields are not upper-cased, unlike FetchObject.

Prev | Home | Next
FetchObj | Up | GetArray


GetArray

Prev GetArray Next

GetArray([$number_of_rows])

Generate a 2-dimensional array of records from the current cursor position, indexed from 0 to $number_of_rows - 1. If $number_of_rows is undefined, till EOF.

Prev | Home | Next
FetchNextObj | Up | GetRows


GetRows

Prev GetRows Next

GetRows([$number_of_rows])

Generate a 2-dimensional array of records from the current cursor position, indexed from 0 to $number_of_rows - 1. If $number_of_rows is undefined, till EOF.

Prev | Home | Next
GetArray | Up | GetAssoc


GetAssoc

Prev GetAssoc Next

GetAssoc([$force_array])

Returns an associative array for the recordset. If the number of columns returned is greater to two, a 2-dimensional array is returned, with the first column of the recordset becomes the keys to the rest of the rows. If the columns is equal to two, a 1-dimensional array is created, where the the keys directly map to the values (unless $force_array is set to true, when an array is created for each value).

Example:

We have the following data in a recordset:

row1: Apple, Fruit, Edible
row2: Cactus, Plant, Inedible
row3: Rose, Flower, Edible

GetAssoc will generate the following associative array:

Apple => [Fruit, Edible]
Cactus => [Plant, Inedible]
Rose => [Flower,Edible]

Returns:

The associative array, or false if an error occurs.

Prev | Home | Next
GetRows | Up | Move


Move

Prev Move Next

Move($to)

Moves the internal cursor to a specific row $to. Rows are zero-based eg. 0 is the first row. The fields array is automatically updated. For databases that do not support scrolling internally, ADOdb will simulate forward scrolling. Some databases do not support backward scrolling. If the $to position is after the EOF, $to will move to the end of the RecordSet for most databases. Some obscure databases using odbc might not behave this way.

Note: This function uses absolute positioning, unlike Microsoft's ADO.

Returns true or false. If false, the internal cursor is not moved in most implementations, so AbsolutePosition( ) will return the last cursor position before the Move( ).

Prev | Home | Next
GetAssoc | Up | MoveNext


MoveNext

Prev MoveNext Next

MoveNext( )

Move the internal cursor to the next row. The fields array is automatically updated. Return false if unable to do so, otherwise true.

If EOF is reached, then the $this->fields array is set to false (this was only implemented consistently in ADOdb 3.30). For the pre-3.30 behaviour of $this->fields (at EOF), set the global variable $ADODB_COMPAT_FETCH = true.

Example:

      $rs
  = $db->Execute($sql);
if ($rs)
while (!$rs->EOF)
  {
ProcessArray($rs->fields);
$rs->MoveNext();
}

Prev | Home | Next
Move | Up | MoveFirst


MoveFirst

Prev MoveFirst Next

MoveFirst()

Internally calls Move(0). Note that some databases do not support this function.

Prev | Home | Next
MoveNext | Up | MoveLast


MoveLast

Prev MoveLast Next

MoveLast()

Internally calls Move(RecordCount()-1). Note that some databases do not support this function.

Prev | Home | Next
MoveFirst | Up | AbsolutePosition


AbsolutePosition

Prev AbsolutePosition Next

AbsolutePosition( )

Synonym for CurrentRow for compatibility with ADO. Returns the current row of the record set. 0 is the first row.

Prev | Home | Next
MoveLast | Up | CurrentRow


CurrentRow

Prev CurrentRow Next

CurrentRow( )

Returns the current row of the record set. 0 is the first row.

Prev | Home | Next
AbsolutePosition | Up | AtFirstPage


AtFirstPage

Prev AtFirstPage Next

AtFirstPage($status='')

Returns true if at first page (1-based). Requires PageExecute()/CachePageExecute() to be called. See Example 8.

Prev | Home | Next
CurrentRow | Up | AtLastPage


AtLastPage

Prev AtLastPage Next

AtLastPage($status='')

Returns true if at last page (1-based). Requires PageExecute()/CachePageExecute() to be called. See Example 8.

Prev | Home | Next
AtFirstPage | Up | AbsolutePage


AbsolutePage

Prev AbsolutePage Next

AbsolutePage($page=-1)

Returns the current page. Requires PageExecute()/CachePageExecute() to be called. See Example 8.

Prev | Home | Next
AtLastPage | Up | GetMenu


GetMenu

Prev GetMenu Next

GetMenu($name, [$default_str=''], [$blank1stItem=true], [$multiple_select=false], [$size=0], [$moreAttr=''])

Generate a HTML menu (<select><option><option></select>). The first column of the recordset (fields[0]) will hold the string to display in the option tags. If the recordset has more than 1 column, the second column (fields[1]) is the value to send back to the web server.. The menu will be given the name $name.

If $default_str is defined, then if $default_str == fields[0], that field is selected. If $blank1stItem is true, the first option is empty. $Default_str can be array for a multiple select listbox.

To get a listbox, set the $size to a non-zero value (or pass $default_str as an array). If $multiple_select is true then a listbox will be generated with $size items (or if $size==0, then 5 items) visible, and we will return an array to a server. Lastly use $moreAttr to add additional attributes such as javascript or styles.

Menu Example 1: GetMenu('menu1','A',true) will generate a menu: for the data (A,1), (B,2), (C,3). Also see example 5.

Menu Example 2: For the same data, GetMenu('menu1',array('A','B'),false) will generate a menu with both A and B selected:

Prev | Home | Next
AbsolutePage | Up | GetMenu2


GetMenu2

Prev GetMenu2 Next

GetMenu2($name, [$default_str=''], [$blank1stItem=true], [$multiple_select=false], [$size=0], [$moreAttr=''])

This is nearly identical to GetMenu, except that the $default_str is matched to fields[1] (the option values).

Menu Example 3: Given the data in menu example 2, GetMenu2('menu1',array('1','2'),false) will generate a menu with both A and B selected in menu example 2, but this time the selection is based on the 2nd column, which holds the values to return to the Web server.

Prev | Home | Next
GetMenu | Up | UserDate


UserDate

Prev UserDate Next

UserDate($str, [$fmt])

Converts the date string $str to another format. The date format is Y-m-d, or Unix timestamp format. The default $fmt is Y-m-d.

Prev | Home | Next
GetMenu2 | Up | UserTimeStamp


UserTimeStamp

Prev UserTimeStamp Next

UserTimeStamp($str, [$fmt])

Converts the timestamp string $str to another format. The timestamp format is Y-m-d H:i:s, as in '2002-02-28 23:00:12', or Unix timestamp format. UserTimeStamp calls UnixTimeStamp to parse $str, and $fmt defaults to Y-m-d H:i:s if not defined.

Prev | Home | Next
UserDate | Up | RecordCount


RecordCount

Prev RecordCount Next

RecordCount( )

Returns the number of rows in the record set. If the number of records returned cannot be determined from the database driver API, we will buffer all rows and return a count of the rows after all the records have been retrieved. This buffering can be disabled (for performance reasons) by setting the global variable $ADODB_COUNTRECS = false. When disabled, RecordCount( ) will return -1 for certain databases. See the supported databases list above for more details.

RowCount is a synonym for RecordCount.

Prev | Home | Next
UserTimeStamp | Up | PO_RecordCount


PO_RecordCount

Prev PO_RecordCount Next

PO_RecordCount($table, $where)

Returns the number of rows in the record set. If the number of records returned cannot be determined from the database driver API, we will buffer all rows and return a count of the rows after all the records have been retrieved. This buffering can be disabled (for performance reasons) by setting the global variable $ADODB_COUNTRECS = false. When disabled, RecordCount( ) will return -1 for certain databases. See the supported databases list above for more details.

RowCount is a synonym for RecordCount.

Prev | Home | Next
RecordCount | Up | NextRecordSet


NextRecordSet

Prev NextRecordSet Next

NextRecordSet()

For databases that allow multiple recordsets to be returned in one query, this function allows you to switch to the next recordset. Currently only supported by mssql driver.

      $rs
  = $db->Execute('execute
  return_multiple_rs');
$arr1 = $rs->GetArray();
$rs->NextRecordSet();
$arr2 =
  $rs->GetArray();

Prev | Home | Next
PO_RecordCount | Up | FieldCount


FieldCount

Prev FieldCount Next

FieldCount( )

Returns the number of fields (columns) in the record set.

Prev | Home | Next
NextRecordSet | Up | FetchField


FetchField

Prev FetchField Next

FetchField($column_number)

Returns an object containing the name, type and max_length of the associated field. If the max_length cannot be determined reliably, it will be set to -1. The column numbers are zero-based.

Prev | Home | Next
FieldCount | Up | MetaType


MetaType

Prev MetaType Next

MetaType($nativeDBType[,$field_max_length],[$fieldobj])

Determine what generic meta type a database field type is given its native type $nativeDBType as a string and the length of the field $field_max_length. Note that field_max_length can be -1 if it is not known. The field object returned by FetchField() can be passed in $fieldobj or as the 1st parameter $nativeDBType. This is useful for databases such as mysql which has additional properties in the field object such as primary_key.

Uses the field blobSize and compares it with $field_max_length to determine whether the character field is actually a blob.

For example, $db->MetaType('char') will return 'C'.
Returns:

  • C: Character fields that should be shown in a <input type="text"> tag.
  • X: Clob (character large objects), or large text fields that should be shown in a <textarea>
  • D: Date field
  • T: Timestamp field
  • L: Logical field (boolean or bit-field)
  • N: Numeric field. Includes decimal, numeric, floating point, and real.
  • I: Integer field.
  • R: Counter or Autoincrement field. Must be numeric.
  • B: Blob, or binary large objects.

Since ADOdb 3.0, MetaType accepts $fieldobj as the first parameter, instead of $nativeDBType.

Prev | Home | Next
FetchField | Up | Close


Close

Prev Close Next

Close( )

Closes the recordset, cleaning all memory and resources associated with the recordset.

If memory management is not an issue, you do not need to call this function as recordsets are closed for you by PHP at the end of the script. SQL statements such as INSERT/UPDATE/DELETE do not really return a recordset, so you do not have to call Close() for such SQL statements.

Prev | Home | Next
MetaType | Up | GetRowAssoc


GetRowAssoc

Prev GetRowAssoc Next

GetRowAssoc($toUpper=true)

Returns an associative array containing the current row. The keys to the array are the column names. The column names are upper-cased for easy access. To get the next row, you will still need to call MoveNext().

For example:
Array ( [ID] => 1 [FIRSTNAME] => Caroline [LASTNAME] => Miranda [CREATED] => 2001-07-05 )

Note: do not use GetRowAssoc() with $ADODB_FETCH_MODE = ADODB_FETCH_ASSOC. Because they have the same functionality, they will interfere with each other.

Prev | Home | Next
Close2 | Up | Fields


Fields

Prev Fields Next

Fields($colname)

Returns the value of the associated column $colname for the current row. The column name is case-insensitive.

This is a convenience function. For higher performance, use $ADODB_FETCH_MODE.

Prev | Home | Next
GetRowAssoc | Up | rs2html


rs2html

Prev rs2html Next

rs2html($adorecordset,[$tableheader_attributes], [$col_titles])

This is a standalone function (rs2html = recordset to html) that is similar to PHP's odbc_result_all function, it prints a ADORecordSet, $adorecordset as a HTML table. $tableheader_attributes allow you to control the table cellpadding, cellspacing and border attributes. Lastly you can replace the database column names with your own column titles with the array $col_titles. This is designed more as a quick debugging mechanism, not a production table recordset viewer.

You will need to include the file tohtml.inc.php.

Example of rs2html:

<?php
    include('tohtml.inc.php'); # load code common to ADOdb
    include('adodb.inc.php'); # load code common to ADOdb
    $conn = &ADONewConnection('mysql');   # create a connection
    $conn->PConnect('localhost','userid','','agora');# connect to MySQL, agora db
    $sql = 'select CustomerName, CustomerID from customers';
    $rs   = $conn->Execute($sql);
    rs2html($rs,'border=2 cellpadding=3',array('Customer Name','Customer ID'));
?>

Prev | Home | Next
Fields | Up | Database Driver Guide


Database Driver Guide

This describes how to create a class to connect to a new database. To ensure there is no duplication of work, kindly email me at jlim#natsoft.com.my if you decide to create such a class.

First decide on a name in lower case to call the database type. Let's say we call it xbase.

Then we need to create two classes ADODB_xbase and ADORecordSet_xbase in the file adodb-xbase.inc.php.

The simplest form of database driver is an adaptation of an existing ODBC driver. Then we just need to create the class ADODB_xbase extends ADODB_odbc to support the new date and timestamp formats, the concatenation operator used, true and false. For the ADORecordSet_xbase extends ADORecordSet_odbc we need to change the MetaType function. See adodb-vfp.inc.php as an example.

More complicated is a totally new database driver that connects to a new PHP extension. Then you will need to implement several functions. Fortunately, you do not have to modify most of the complex code. You only need to override a few stub functions. See adodb-mysql.inc.php for an example.

The default date format of ADOdb internally is YYYY-MM-DD (Ansi-92). All dates should be converted to that format when passing to an ADOdb date function. See Oracle for an example how we use ALTER SESSION to change the default date format in _pconnect _connect.

ADOConnection Functions to Override

Defining a constructor for your ADOConnection derived function is optional. There is no need to call the base class constructor.

_connect: Low level implementation of Connect. Returns true or false. Should set the _connectionID.

_pconnect: Low level implemention of PConnect. Returns true or false. Should set the _connectionID.

_query: Execute a query. Returns the queryID, or false.

_close: Close the connection -- PHP should clean up all recordsets.

ErrorMsg: Stores the error message in the private variable _errorMsg.

ADOConnection Fields to Set

_bindInputArray: Set to true if binding of parameters for SQL inserts and updates is allowed using ?, eg. as with ODBC.

fmtDate

fmtTimeStamp

true

false

concat_operator

replaceQuote

hasLimit support SELECT * FROM TABLE LIMIT 10 of MySQL.

hasTop support Microsoft style SELECT TOP 10 * FROM TABLE.

ADORecordSet Functions to Override

You will need to define a constructor for your ADORecordSet derived class that calls the parent class constructor.

FetchField: as documented above in ADORecordSet

_initrs: low level initialization of the recordset: setup the _numOfRows and _numOfFields fields -- called by the constructor.

_seek: seek to a particular row. Do not load the data into the fields array. This is done by _fetch. Returns true or false. Note that some implementations such as Interbase do not support seek. Set canSeek to false.

_fetch: fetch a row using the database extension function and then move to the next row. Sets the fields array. If the parameter $ignore_fields is true then there is no need to populate the fields array, just move to the next row. then Returns true or false.

_close: close the recordset

Fields: If the array row returned by the PHP extension is not an associative one, you will have to override this. See adodb-odbc.inc.php for an example. For databases such as MySQL and MSSQL where an associative array is returned, there is no need to override this function.

ADOConnection Fields to Set

canSeek: Set to true if the _seek function works.

Prev | Home | Next
rs2html | Up | ToDo


ToDo

See the RoadMap article.

Also see the ADOdb proxy article for bridging Windows and Unix databases using http remote procedure calls. For your education, visit palslib.com for database info, and read this article on Optimizing PHP.

Prev | Home | Next
Database Driver Guide | Up | Change Log


Change Log

Please refer to http://phplens.com/lens/adodb/docs-adodb.htm#changes for the latest changes.
Prev | Home | Next
ToDo | Up | Introduction


ADOdb Data Dictionary Manual

ADOdb Data Dictionary Library for PHP

V4.91 2 Aug 2006 (c) 2000-2006 John Lim (jlim#natsoft.com.my).
AXMLS (c) 2004 ars Cognita, Inc

This software is dual licensed using BSD-Style and LGPL. This means you can use it in compiled proprietary and commercial products.

Useful ADOdb links: Download Other Docs

This documentation describes a PHP class library to automate the creation of tables, indexes and foreign key constraints portably for multiple databases. Richard Tango-Lowy and Dan Cech have been kind enough to contribute AXMLS, an XML schema system for defining databases. You can contact them at dcech#phpwerx.net and richtl#arscognita.com.

Currently the following databases are supported:

Well-tested: PostgreSQL, MySQL, Oracle, MSSQL.
Beta-quality: DB2, Informix, Sybase, Interbase, Firebird.
Alpha-quality: MS Access (does not support DEFAULT values) and generic ODBC.

Example Usage

  include_once('adodb.inc.php');
  # First create a normal connection
  $db = NewADOConnection('mysql');
  $db->Connect(...);

  # Then create a data dictionary object, using this connection
  $dict = NewDataDictionary($db);

  # We have a portable declarative data dictionary format in ADOdb, similar to SQL.
  # Field types use 1 character codes, and fields are separated by commas.
  # The following example creates three fields: "col1", "col2" and "col3":
  $flds = "
   col1 C(32) NOTNULL DEFAULT 'abc',
   col2 I  DEFAULT 0,
   col3 N(12.2)
  ";

  # We demonstrate creating tables and indexes
  $sqlarray = $dict->CreateTableSQL($tabname, $flds, $taboptarray);
  $dict->ExecuteSQLArray($sqlarray);

  $idxflds = 'co11, col2';
  $sqlarray = $dict->CreateIndexSQL($idxname, $tabname, $idxflds);
  $dict->ExecuteSQLArray($sqlarray);

Class Factory

NewDataDictionary($connection, $drivername=false)

Creates a new data dictionary object. You pass a database connection object in $connection. The $connection does not have to be actually connected to the database. Some database connection objects are generic (eg. odbtp and odbc). Since 4.53, you can tell ADOdb the actual database with $drivername. E.g.

$db =& NewADOConnection('odbtp');
$datadict = NewDataDictionary($db, 'mssql'); # force mssql

Class Functions

function CreateDatabase($dbname, $optionsarray=false)

Create a database with the name $dbname;

function CreateTableSQL($tabname, $fldarray, $taboptarray=false)

  RETURNS:      an array of strings, the sql to be executed, or false
  $tabname:     name of table
  $fldarray:    string (or array) containing field info
  $taboptarray: array containing table options

The new format of $fldarray uses a free text format, where each field is comma-delimited. The first token for each field is the field name, followed by the type and optional field size. Then optional keywords in $otheroptions:

  "$fieldname $type $colsize $otheroptions"

The older (and still supported) format of $fldarray is a 2-dimensional array, where each row in the 1st dimension represents one field. Each row has this format:

  array($fieldname, $type, [,$colsize] [,$otheroptions]*)

The first 2 fields must be the field name and the field type. The field type can be a portable type codes or the actual type for that database.

Legal portable type codes include:

  C:  Varchar, capped to 255 characters.
  X:  Larger varchar, capped to 4000 characters (to be compatible with Oracle).
  XL: For Oracle, returns CLOB, otherwise the largest varchar size.

  C2: Multibyte varchar
  X2: Multibyte varchar (largest size)

  B:  BLOB (binary large object)

  D:  Date (some databases do not support this, and we return a datetime type)
  T:  Datetime or Timestamp
  L:  Integer field suitable for storing booleans (0 or 1)
  I:  Integer (mapped to I4)
  I1: 1-byte integer
  I2: 2-byte integer
  I4: 4-byte integer
  I8: 8-byte integer
  F:  Floating point number
  N:  Numeric or decimal number

The $colsize field represents the size of the field. If a decimal number is used, then it is assumed that the number following the dot is the precision, so 6.2 means a number of size 6 digits and 2 decimal places. It is recommended that the default for number types be represented as a string to avoid any rounding errors.

The $otheroptions include the following keywords (case-insensitive):

  AUTO            For autoincrement number. Emulated with triggers if not available.
                  Sets NOTNULL also.
  AUTOINCREMENT   Same as auto.
  KEY             Primary key field. Sets NOTNULL also. Compound keys are supported.
  PRIMARY         Same as KEY.
  DEF             Synonym for DEFAULT for lazy typists.
  DEFAULT         The default value. Character strings are auto-quoted unless
                  the string begins and ends with spaces, eg ' SYSDATE '.
  NOTNULL         If field is not null.
  DEFDATE         Set default value to call function to get today's date.
  DEFTIMESTAMP    Set default to call function to get today's datetime.
  NOQUOTE         Prevents autoquoting of default string values.
  CONSTRAINTS     Additional constraints defined at the end of the field
                  definition.

The Data Dictonary accepts two formats, the older array specification:

  $flds = array(
    array('COLNAME',   'DECIMAL', '8.4', 'DEFAULT' => 0, 'NOTNULL'),
    array('id',        'I'      , 'AUTO'),
    array('`MY DATE`', 'D'      , 'DEFDATE'),
    array('NAME',      'C'      , '32', 'CONSTRAINTS' => 'FOREIGN KEY REFERENCES reftable')
  );

Or the simpler declarative format:

  $flds = "
    COLNAME DECIMAL(8.4) DEFAULT 0 NOTNULL,
    id I AUTO,
    `MY DATE` D DEFDATE,
    NAME C(32) CONSTRAINTS 'FOREIGN KEY REFERENCES reftable'
  ";

Note that if you have special characters in the field name (e.g. My Date), you should enclose it in back-quotes. Normally field names are not case-sensitive, but if you enclose it in back-quotes, some databases will treat the names as case-sensitive (eg. Oracle) , and others won't. So be careful.

The $taboptarray is the 3rd parameter of the CreateTableSQL function. This contains table specific settings. Legal keywords include:

  • REPLACE
    Indicates that the previous table definition should be removed (dropped)together with ALL data. See first example below.
  • DROP
    Drop table. Useful for removing unused tables.
  • CONSTRAINTS
    Define this as the key, with the constraint as the value. See the postgresql example below. Additional constraints defined for the whole table. You will probably need to prefix this with a comma.

Database specific table options can be defined also using the name of the database type as the array key. In the following example, create the table as ISAM with MySQL, and store the table in the "users" tablespace if using Oracle. And because we specified REPLACE, drop the table first.

  $taboptarray = array('mysql' => 'TYPE=ISAM', 'oci8' => 'tablespace users', 'REPLACE');

You can also define foreign key constraints. The following is syntax for postgresql:

  $taboptarray = array('constraints' => ', FOREIGN KEY (col1) REFERENCES reftable (refcol)');

function DropTableSQL($tabname)

Returns the SQL to drop the specified table.

function ChangeTableSQL($tabname, $flds)

Checks to see if table exists, if table does not exist, behaves like CreateTableSQL. If table exists, generates appropriate ALTER TABLE MODIFY COLUMN commands if field already exists, or ALTER TABLE ADD $column if field does not exist.

The class must be connected to the database for ChangeTableSQL to detect the existence of the table. Idea and code contributed by Florian Buzin.

function RenameTableSQL($tabname,$newname)

Rename a table. Returns the an array of strings, which is the SQL required to rename a table. Since ADOdb 4.53. Contributed by Ralf Becker.

function RenameColumnSQL($tabname,$oldcolumn,$newcolumn,$flds='')

Rename a table field. Returns the an array of strings, which is the SQL required to rename a column. The optional $flds is a complete column-defintion-string like for AddColumnSQL, only used by mysql at the moment. Since ADOdb 4.53. Contributed by Ralf Becker.

function CreateIndexSQL($idxname, $tabname, $flds, $idxoptarray=false)

  RETURNS:      an array of strings, the sql to be executed, or false
  $idxname:     name of index
  $tabname:     name of table
  $flds:        list of fields as a comma delimited string or an array of strings
  $idxoptarray: array of index creation options

$idxoptarray is similar to $taboptarray in that index specific information can be embedded in the array. Other options include:

  CLUSTERED     Create clustered index (only mssql)
  BITMAP        Create bitmap index (only oci8)
  UNIQUE        Make unique index
  FULLTEXT      Make fulltext index (only mysql)
  HASH          Create hash index (only postgres)
  DROP          Drop legacy index

function DropIndexSQL ($idxname, $tabname = NULL)

Returns the SQL to drop the specified index.

function AddColumnSQL($tabname, $flds)

Add one or more columns. Not guaranteed to work under all situations.

function AlterColumnSQL($tabname, $flds)

Warning, not all databases support this feature.

function DropColumnSQL($tabname, $flds)

Drop 1 or more columns.

function SetSchema($schema)

Set the schema.

function &MetaTables()

function &MetaColumns($tab, $upper=true, $schema=false)

function &MetaPrimaryKeys($tab,$owner=false,$intkey=false)

function &MetaIndexes($table, $primary = false, $owner = false)

These functions are wrappers for the corresponding functions in the connection object. However, the table names will be autoquoted by the TableName function (see below) before being passed to the connection object.

function NameQuote($name = NULL)

If the provided name is quoted with backquotes (`) or contains special characters, returns the name quoted with the appropriate quote character, otherwise the name is returned unchanged.

function TableName($name)

The same as NameQuote, but will prepend the current schema if specified

function MetaType($t,$len=-1,$fieldobj=false)

function ActualType($meta)

Convert between database-independent 'Meta' and database-specific 'Actual' type codes.

function ExecuteSQLArray($sqlarray, $contOnError = true)

  RETURNS:      0 if failed, 1 if executed all but with errors, 2 if executed successfully
  $sqlarray:    an array of strings with sql code (no semicolon at the end of string)
  $contOnError: if true, then continue executing even if error occurs

Executes an array of SQL strings returned by CreateTableSQL or CreateIndexSQL.

ADOdb XML Schema (AXMLS)

This is a class contributed by Richard Tango-Lowy and Dan Cech that allows the user to quickly and easily build a database using the excellent ADODB database library and a simple XML formatted file. You can download the latest version of AXMLS here.

Quick Start

Adodb-xmlschema, or AXMLS, is a set of classes that allow the user to quickly and easily build or upgrade a database on almost any RDBMS using the excellent ADOdb database library and a simple XML formatted schema file. Our goal is to give developers a tool that's simple to use, but that will allow them to create a single file that can build, upgrade, and manipulate databases on most RDBMS platforms.

Installing axmls

The easiest way to install AXMLS to download and install any recent version of the ADOdb database abstraction library. To install AXMLS manually, simply copy the adodb-xmlschema.inc.php file and the xsl directory into your adodb directory.

Using AXMLS in Your Application

There are two steps involved in using AXMLS in your application: first, you must create a schema, or XML representation of your database, and second, you must create the PHP code that will parse and execute the schema.

Let's begin with a schema that describes a typical, if simplistic user management table for an application.

<?xml version="1.0"?>
<schema version="0.2">

  <table name="users">
    <desc>A typical users table for our application.</desc>
    <field name="userId" type="I">
      <descr>A unique ID assigned to each user.</descr>

      <KEY/>
      <AUTOINCREMENT/>
    </field>

    <field name="userName" type="C" size="16"><NOTNULL/></field>

    <index name="userName">
      <descr>Put a unique index on the user name</descr>
      <col>userName</col>
      <UNIQUE/>

    </index>
  </table>

  <sql>
    <descr>Insert some data into the users table.</descr>
    <query>insert into users (userName) values ( 'admin' )</query>

    <query>insert into users (userName) values ( 'Joe' )</query>
  </sql>
</schema>

Let's take a detailed look at this schema.

The opening <?xml version="1.0"?> tag is required by XML. The <schema> tag tells the parser that the enclosed markup defines an XML schema. The version="0.2" attribute sets the version of the AXMLS DTD used by the XML schema.

All versions of AXMLS prior to version 1.0 have a schema version of "0.1". The current schema version is "0.2".

<?xml version="1.0"?>
<schema version="0.2">
  ...
</schema>

Next we define one or more tables. A table consists of a fields (and other objects) enclosed by <table> tags. The name="" attribute specifies the name of the table that will be created in the database.

<table name="users">

    <desc>A typical users table for our application.</desc>
    <field name="userId" type="I">

      <descr>A unique ID assigned to each user.</descr>
      <KEY/>
      <AUTOINCREMENT/>
    </field>

    <field name="userName" type="C" size="16"><NOTNULL/></field>

</table>

This table is called "users" and has a description and two fields. The description is optional, and is currently only for your own information; it is not applied to the database.

The first <field> tag will create a field named "userId" of type "I", or integer. (See the ADOdb Data Dictionary documentation for a list of valid types.) This <field> tag encloses two special field options: <KEY/>, which specifies this field as a primary key, and <AUTOINCREMENT/>, which specifies that the database engine should automatically fill this field with the next available value when a new row is inserted.

The second <field> tag will create a field named "userName" of type "C", or character, and of length 16 characters. The <NOTNULL/> option specifies that this field does not allow NULLs.

There are two ways to add indexes to a table. The simplest is to mark a field with the <KEY/> option as described above; a primary key is a unique index. The second and more powerful method uses the <index> tags.

<table name="users">
  ...

  <index name="userName">
    <descr>Put a unique index on the user name</descr>
    <col>userName</col>

    <UNIQUE/>
  </index>

</table>

The <index> tag specifies that an index should be created on the enclosing table. The name="" attribute provides the name of the index that will be created in the database. The description, as above, is for your information only. The <col> tags list each column that will be included in the index. Finally, the <UNIQUE/> tag specifies that this will be created as a unique index.

Finally, AXMLS allows you to include arbitrary SQL that will be applied to the database when the schema is executed.

<sql>
  <descr>Insert some data into the users table.</descr>
  <query>insert into users (userName) values ( 'admin' )</query>

  <query>insert into users (userName) values ( 'Joe' )</query>
</sql>

The <sql> tag encloses any number of SQL queries that you define for your own use.

Now that we've defined an XML schema, you need to know how to apply it to your database. Here's a simple PHP script that shows how to load the schema.

<?PHP
/* You must tell the script where to find the ADOdb and
 * the AXMLS libraries.
 */
require( "path_to_adodb/adodb.inc.php");
require( "path_to_adodb/adodb-xmlschema.inc.php" ); # or adodb-xmlschema03.inc.php

/* Configuration information. Define the schema filename,
 * RDBMS platform (see the ADODB documentation for valid
 * platform names), and database connection information here.
 */
$schemaFile = 'example.xml';
$platform = 'mysql';
$dbHost = 'localhost';
$dbName = 'database';
$dbUser = 'username';
$dbPassword = 'password';

/* Start by creating a normal ADODB connection.
 */
$db = ADONewConnection( $platform );
$db->Connect( $dbHost, $dbUser, $dbPassword, $dbName );

/* Use the database connection to create a new adoSchema object.
 */
$schema = new adoSchema( $db );

/* Call ParseSchema() to build SQL from the XML schema file.
 * Then call ExecuteSchema() to apply the resulting SQL to
 * the database.
 */
$sql = $schema->ParseSchema( $schemaFile );
$result = $schema->ExecuteSchema();
?>

Let's look at each part of the example in turn. After you manually create the database, there are three steps required to load (or upgrade) your schema.

First, create a normal ADOdb connection. The variables and values here should be those required to connect to your database.

$db = ADONewConnection( 'mysql' );
$db->Connect( 'host', 'user', 'password', 'database' );

Second, create the adoSchema object that load and manipulate your schema. You must pass an ADOdb database connection object in order to create the adoSchema object.

$schema = new adoSchema( $db );

Third, call ParseSchema() to parse the schema and then ExecuteSchema() to apply it to the database. You must pass ParseSchema() the path and filename of your schema file.

$schema->ParseSchema( $schemaFile );
$schema->ExecuteSchema();

Execute the above code and then log into your database. If you've done all this right, you should see your tables, indexes, and SQL.

You can find the source files for this tutorial in the examples directory as tutorial_shema.xml and tutorial.php. See the class documentation for a more detailed description of the adoSchema methods, including methods and schema elements that are not described in this tutorial.

XML Schema Version 3

In March 2006, we added adodb-xmlschema03.inc.php to the release, which supports version 3 of XML Schema. The adodb-xmlschema.inc.php remains the same as previous releases, and supports version 2 of XML Schema. Version 3 provides some enhancements:

  • Support for updating table data during an upgrade.
  • Support for platform-specific table options and platform negation.
  • Support for unsigned fields.
  • Fixed opt and constraint support
  • Many other fixes such as OPT tag, which allows you to set optional platform settings:

Example usage:

<?xml version="1.0"?>
<schema version="0.3">
 <table name="ats_kb">
  <descr>ATS KnowledgeBase</descr>
  <opt platform="mysql">TYPE=INNODB</opt>
  <field name="recid" type="I"/>
  <field name="organization_code" type="I4"/>
  <field name="sub_code" type="C" size="20"/>
  etc...

To use it, change your code to include adodb-xmlschema03.inc.php.

Upgrading

If your schema version is older, than XSLT is used to transform the schema to the newest version. This means that if you are using an older XML schema format, you need to have the XSLT extension installed. If you do not want to require your users to have the XSLT extension installed, make sure you modify your XML schema to conform to the latest version.

If you have any questions or comments, please email them to Richard at richtl#arscognita.com.


ADODB Session Management Manual

ADODB Session 2 Management Manual

V4.91 2 Aug 2006 (c) 2000-2006 John Lim (jlim#natsoft.com.my)

This software is dual licensed using BSD-Style and LGPL. This means you can use it in compiled proprietary and commercial products.

Useful ADOdb links: Download Other Docs

Introduction

This document discusses the newer session handler adodb-session2.php. If you have used the older adodb-session.php, then be forewarned that you will need to alter your session table format. Otherwise everything is backward compatible. Here are the older docs for adodb-session.php.

Why Session Variables in a Database?

We store state information specific to a user or web client in session variables. These session variables persist throughout a session, as the user moves from page to page.

To use session variables, call session_start() at the beginning of your web page, before your HTTP headers are sent. Then for every variable you want to keep alive for the duration of the session, call session_register($variable_name). By default, the session handler will keep track of the session by using a cookie. You can save objects or arrays in session variables also.

The default method of storing sessions is to store it in a file. However if you have special needs such as you:

  • Have multiple web servers that need to share session info
  • Need to do special processing of each session
  • Require notification when a session expires

The ADOdb session handler provides you with the above additional capabilities by storing the session information as records in a database table that can be shared across multiple servers.

These records will be garbage collected based on the php.ini [session] timeout settings. You can register a notification function to notify you when the record has expired and is about to be freed by the garbage collector.

An alternative to using a database backed session handler is to use memcached. This is a distributed memory based caching system suitable for storing session information.

The Improved Session Handler

In ADOdb 4.91, we added a new session handler, in adodb-session2.php. It features the following improvements:

  • Fully supports server farms using a new database table format. The previous version used the web server time for timestamps, which can cause problems on a system with multiple web servers with possibly inconsistent times. The new version uses the database server time instead for all timestamps.
  • The older database table format is obsolete. The database table must be modified to support storage of the database server time mentioned above. Also the field named DATA has been changed to SESSDATA. In some databases, DATA is a reserved word.
  • The functions dataFieldName() and syncSeconds() is obsolete.

Usage is

include_once("adodb/session/adodb-session2.php");
ADOdb_Session::config($driver, $host, $user, $password, $database,$options=false);
session_start();

#
# Test session vars, the following should increment on refresh
#
$_SESSION['AVAR'] += 1;
print "<p>\$_SESSION['AVAR']={$_SESSION['AVAR']}</p>";

When the session is created in session_start( ), the global variable $ADODB_SESS_CONN holds the connection object.

The default name of the table is sessions2. If you want to override it:

include_once("adodb/session/adodb-session2.php");
$options['table'] = 'mytablename';
ADOdb_Session::config($driver, $host, $user, $password, $database,$options);
session_start();

ADOdb Session Handler Features

  • Ability to define a notification function that is called when a session expires. Typically used to detect session logout and release global resources.
  • Optimization of database writes. We crc32 the session data and only perform an update to the session data if there is a data change.
  • Support for large amounts of session data with CLOBs (see adodb-session-clob2.php). Useful for Oracle.
  • Support for encrypted session data, see adodb-cryptsession2.php. Enabling encryption is simply a matter of including adodb-cryptsession2.php instead of adodb-session2.php.

Session Handler Files

There are 3 session management files that you can use:

adodb-session2.php        : The default
adodb-cryptsession2.php   : Use this if you want to store encrypted session data in the database
adodb-session-clob2.php   : Use this if you are storing DATA in clobs and you are NOT using oci8 driver

Usage Examples

To force non-persistent connections, call Persist() first before session_start():

include_once("adodb/session/adodb-session2.php");
$driver = 'mysql'; $host = 'localhost'; $user = 'auser'; $pwd = 'secret'; $database = 'sessiondb';
ADOdb_Session::config($driver, $host, $user, $password, $database,$options=false);
ADOdb_session::Persist($connectMode=false);
session_start();

The parameter to the Persist( ) method sets the connection mode. You can pass the following:

$connectMode | Connection Method
true | PConnect( )
false | Connect( )
'N' | NConnect( )
'P' | PConnect( )
'C' | Connect( )

To use a encrypted sessions, simply replace the file adodb-session2.php:

include('adodb/session/adodb-cryptsession2.php');
$driver = 'mysql'; $host = 'localhost'; $user = 'auser'; $pwd = 'secret'; $database = 'sessiondb';
ADOdb_Session::config($driver, $host, $user, $password, $database,$options=false);
adodb_sess_open(false,false,$connectMode=false);
session_start();

And the same technique for adodb-session-clob2.php:

include('adodb/session/adodb-session2-clob2.php');
$driver = 'oci8'; $host = 'localhost'; $user = 'auser'; $pwd = 'secret'; $database = 'sessiondb';
ADOdb_Session::config($driver, $host, $user, $password, $database,$options=false);
adodb_sess_open(false,false,$connectMode=false);
session_start();

Installation

1. Create this table in your database. Here is the MySQL version:

CREATE TABLE sessions2(
      sesskey VARCHAR( 64 ) NOT NULL DEFAULT '',
      expiry TIMESTAMP NOT NULL ,
      expireref VARCHAR( 250 ) DEFAULT '',
      created TIMESTAMP NOT NULL ,
      modified TIMESTAMP NOT NULL ,
      sessdata LONGTEXT DEFAULT '',
    PRIMARY KEY ( sesskey ) ,
    INDEX sess2_expiry( expiry ),
    INDEX sess2_expireref( expireref )
)

For PostgreSQL, use:

CREATE TABLE sessions2(
 sesskey VARCHAR( 64 ) NOT NULL DEFAULT '',
 expiry TIMESTAMP NOT NULL ,
 expireref VARCHAR( 250 ) DEFAULT '',
 created TIMESTAMP NOT NULL ,
 modified TIMESTAMP NOT NULL ,
 sessdata TEXT DEFAULT '',
 PRIMARY KEY ( sesskey )
 );

create INDEX sess2_expiry on sessions2( expiry );
create INDEX sess2_expireref on sessions2 ( expireref );

Here is the Oracle definition, which uses a CLOB for the SESSDATA field:

  CREATE TABLE SESSIONS2
(
   SESSKEY    VARCHAR2(48 BYTE)                  NOT NULL,
   EXPIRY     DATE                               NOT NULL,
   EXPIREREF  VARCHAR2(200 BYTE),
   CREATED    DATE                               NOT NULL,
   MODIFIED   DATE                               NOT NULL,
   SESSDATA   CLOB,
  PRIMARY KEY(SESSKEY)
);

CREATE INDEX SESS2_EXPIRY ON SESSIONS2(EXPIRY);
CREATE INDEX SESS2_EXPIREREF ON SESSIONS2(EXPIREREF);

We need to use a CLOB here because for text greater than 4000 bytes long, Oracle requires you to use the CLOB data type. If you are using the oci8 driver, ADOdb will automatically enable CLOB handling. So you can use either adodb-session2.php or adodb-session-clob2.php - in this case it doesn't matter.

Notifications

You can receive notification when your session is cleaned up by the session garbage collector or when you call session_destroy().

PHP's session extension will automatically run a special garbage collection function based on your php.ini session.cookie_lifetime and session.gc_probability settings. This will in turn call adodb's garbage collection function, which can be setup to do notification.

    PHP Session --> ADOdb Session  --> Find all recs  --> Send          --> Delete queued
    GC Function     GC Function        to be deleted      notification      records
    executed at     called by                             for all recs
    random time     Session Extension                     queued for deletion

When a session is created, we need to store a value in the session record (in the EXPIREREF field), typically the userid of the session. Later when the session has expired, just before the record is deleted, we reload the EXPIREREF field and call the notification function with the value of EXPIREREF, which is the userid of the person being logged off.

ADOdb uses a global variable $ADODB_SESSION_EXPIRE_NOTIFY that you must predefine before session start to store the notification configuration. $ADODB_SESSION_EXPIRE_NOTIFY is an array with 2 elements, the first being the name of the session variable you would like to store in the EXPIREREF field, and the 2nd is the notification function's name.

For example, suppose we want to be notified when a user's session has expired, based on the userid. When the user logs in, we store the id in the global session variable $USERID. The function name is 'NotifyFn'.

So we define (before session_start() is called):

    $ADODB_SESSION_EXPIRE_NOTIFY = array('USERID','NotifyFn');
And when the NotifyFn is called (when the session expires), the $USERID is passed in as the first parameter, eg. NotifyFn($userid, $sesskey). The session key (which is the primary key of the record in the sessions table) is the 2nd parameter.

Here is an example of a Notification function that deletes some records in the database and temporary files:

    function NotifyFn($expireref, $sesskey)
    {
        global $ADODB_SESS_CONN; # the session connection object
        $user = $ADODB_SESS_CONN->qstr($expireref);

        $ADODB_SESS_CONN->Execute("delete from shopping_cart where user=$user");
        system("rm /work/tmpfiles/$expireref/*");
    }

NOTE 1: If you have register_globals disabled in php.ini, then you will have to manually set the EXPIREREF. E.g.

$GLOBALS['USERID'] = GetUserID();
$ADODB_SESSION_EXPIRE_NOTIFY = array('USERID','NotifyFn');

NOTE 2: If you want to change the EXPIREREF after the session record has been created, you will need to modify any session variable to force a database record update.

Neat Notification Tricks

ExpireRef normally holds the user id of the current session.

1. You can then write a session monitor, scanning expireref to see who is currently logged on.

2. If you delete the sessions record for a specific user, eg.

delete from sessions where expireref = '$USER'
then the user is logged out. Useful for ejecting someone from a site.

3. You can scan the sessions table to ensure no user can be logged in twice. Useful for security reasons.

Compression/Encryption Schemes

Since ADOdb 4.05, thanks to Ross Smith, multiple encryption and compression schemes are supported. Currently, supported are:

  MD5Crypt (crypt.inc.php)
  MCrypt
  Secure (Horde's emulation of MCrypt, if MCrypt module is not available.)
  GZip
  BZip2

These are stackable. E.g.

ADODB_Session::filter(new ADODB_Compress_Bzip2());
ADODB_Session::filter(new ADODB_Encrypt_MD5());
will compress and then encrypt the record in the database.

Session Cookie Regeneration: adodb_session_regenerate_id()

Dynamically change the current session id with a newly generated one and update database. Currently only works with cookies. Useful to improve security by reducing the risk of session-hijacking. See this article on Session Fixation for more info on the theory behind this feature. Usage:

    include('path/to/adodb/session/adodb-session2.php');

    session_start();
    # Approximately every 10 page loads, reset cookie for safety.
    # This is extremely simplistic example, better
    # to regenerate only when the user logs in or changes
    # user privilege levels.
    if ((rand()%10) == 0) adodb_session_regenerate_id();

This function calls session_regenerate_id() internally or simulates it if the function does not exist.

Vacuum/Optimize Database

During session garbage collection, if postgresql is detected, ADOdb can be set to run VACUUM. If mysql is detected, then optimize database could be called.You can turn this on or off using:

$turnOn = true; # or false
ADODB_Session::optimize($turnOn);

The default is optimization is disabled.

Backwards Compatability

The older method of connecting to ADOdb using global variables is still supported:

 $ADODB_SESSION_DRIVER='mysql';
 $ADODB_SESSION_CONNECT='localhost';
 $ADODB_SESSION_USER ='root';
 $ADODB_SESSION_PWD ='abc';
 $ADODB_SESSION_DB ='phplens';

 include('path/to/adodb/session/adodb-session2.php');

In the above example, the only things you need to change in your code to upgrade is

  • your session table format to the new one.
  • the include file from adodb-session.php to adodb-session2.php.

More Info

Also see the core ADOdb documentation. And if you are interested in the obsolete adodb-session.php, see old session documentation.


ADOdb Performance Monitoring Library

The ADOdb Performance Monitoring Library

V4.91 2 Aug 2006 (c) 2000-2006 John Lim (jlim#natsoft.com.my)

This software is dual licensed using BSD-Style and LGPL. This means you can use it in compiled proprietary and commercial products.

Useful ADOdb links: Download Other Docs

Introduction

This module, part of the ADOdb package, provides both CLI and HTML interfaces for viewing key performance indicators of your database. This is very useful because web apps such as the popular phpMyAdmin currently do not provide effective database health monitoring tools. The module provides the following:

  • A quick health check of your database server using $perf->HealthCheck() or $perf->HealthCheckCLI().
  • User interface for performance monitoring, $perf->UI(). This UI displays:
    • the health check,
    • all SQL logged and their query plans,
    • a list of all tables in the current database
    • an interface to continiously poll the server for key performance indicators such as CPU, Hit Ratio, Disk I/O
    • a form where you can enter and run SQL interactively.
  • Gives you an API to build database monitoring tools for a server farm, for example calling $perf->DBParameter('data cache hit ratio') returns this very important statistic in a database independant manner.

ADOdb also has the ability to log all SQL executed, using LogSQL. All SQL logged can be analyzed through the performance monitor UI. In the View SQL mode, we categorize the SQL into 3 types:

  • Suspicious SQL: queries with high average execution times, and are potential candidates for rewriting
  • Expensive SQL: queries with high total execution times (#executions * avg execution time). Optimizing these queries will reduce your database server load.
  • Invalid SQL: queries that generate errors.

Each query is hyperlinked to a description of the query plan, and every PHP script that executed that query is also shown.

Please note that the information presented is a very basic database health check, and does not provide a complete overview of database performance. Although some attempt has been made to make it work across multiple databases in the same way, it is impossible to do so. For the health check, we do try to display the following key database parameters for all drivers:

  • data cache size - The amount of memory allocated to the cache.
  • data cache hit ratio - A measure of how effective the cache is, as a percentage. The higher, the better.
  • current connections - The number of sessions currently connected to the database.

You will need to connect to the database as an administrator to view most of the parameters.

Code improvements as very welcome, particularly adding new database parameters and automated tuning hints.

Usage

Currently, the following drivers: mysql, postgres, oci8, mssql, informix and db2 are supported. To create a new performance monitor, call NewPerfMonitor( ) as demonstrated below:

<?php
include_once('adodb.inc.php');
session_start(); # session variables required for monitoring
$conn = ADONewConnection($driver);
$conn->Connect($server,$user,$pwd,$db);
$perf =& NewPerfMonitor($conn);
$perf->UI($pollsecs=5);
?>

It is also possible to retrieve a single database parameter:

$size = $perf->DBParameter('data cache size');

Thx to Fernando Ortiz for the informix module.

Methods

function UI($pollsecs=5)

Creates a web-based user interface for performance monitoring. When you click on Poll, server statistics will be displayed every $pollsecs seconds. See Usage above.

Since 4.11, we allow users to enter and run SQL interactively via the "Run SQL" link. To disable this for security reasons, set this constant before calling $perf->UI().

define('ADODB_PERF_NO_RUN_SQL',1);

Sample output follows below:

ADOdb Performance Monitor for localhost, db=test
PostgreSQL 7.3.2 on i686-pc-cygwin, compiled by GCC gcc (GCC) 3.2 20020927 (prerelease)
Performance Stats View SQL View Tables Poll Stats

postgres7
Parameter | Value | Description
Ratios
statistics collector | TRUE | Value must be TRUE to enable hit ratio statistics (stats_start_collector,stats_row_level and stats_block_level must be set to true in postgresql.conf)
data cache hit ratio | 99.7967555299239
IO
data reads | 125
data writes | 21.78125000000000000 | Count of inserts/updates/deletes * coef
Data Cache
data cache buffers | 640 | Number of cache buffers. Tuning
cache blocksize | 8192 | (estimate)
data cache size | 5M
operating system cache size | 80M | (effective cache size)
Memory Usage
sort buffer size | 1M | Size of sort buffer (per query)
Connections
current connections | 0
max connections | 32
Parameters
rollback buffers | 8 | WAL buffers
random page cost | 4 | Cost of doing a seek (default=4). See random_page_cost

function HealthCheck()

Returns database health check parameters as a HTML table. You will need to echo or print the output of this function,

function HealthCheckCLI()

Returns database health check parameters formatted for a command line interface. You will need to echo or print the output of this function. Sample output for mysql:

-- Ratios --
          MyISAM cache hit ratio => 56.5635738832
          InnoDB cache hit ratio => 0
             sql cache hit ratio => 0
 -- IO --
                      data reads => 2622
                     data writes => 2415.5
 -- Data Cache --
          MyISAM data cache size => 512K
             BDB data cache size => 8388600
          InnoDB data cache size => 8M
 -- Memory Pools --
                read buffer size => 131072
                sort buffer size => 65528
                     table cache => 4
 -- Connections --
             current connections => 3
                 max connections => 100

function Poll($pollSecs=5)

Run in infinite loop, displaying the following information every $pollSecs. This will not work properly if output buffering is enabled. In the example below, $pollSecs=3:

Accumulating statistics...
 Time   WS-CPU%   Hit%   Sess        Reads/s          Writes/s
11:08:30    0.7  56.56      1         0.0000            0.0000
11:08:33    1.8  56.56      2         0.0000            0.0000
11:08:36   11.1  56.55      3         2.5000            0.0000
11:08:39    9.8  56.55      2         3.1121            0.0000
11:08:42    2.8  56.55      1         0.0000            0.0000
11:08:45    7.4  56.55      2         0.0000            1.5000

WS-CPU% is the Web Server CPU load of the server that PHP is running from (eg. the database client), and not the database. The Hit% is the data cache hit ratio. Sess is the current number of sessions connected to the database. If you are using persistent connections, this should not change much. The Reads/s and Writes/s are synthetic values to give the viewer a rough guide to I/O, and are not to be taken literally.

function SuspiciousSQL($numsql=10)

Returns SQL which have high average execution times as a HTML table. Each sql statement is hyperlinked to a new window which details the execution plan and the scripts that execute this SQL.

The number of statements returned is determined by $numsql. Data is taken from the adodb_logsql table, where the sql statements are logged when $connection->LogSQL(true) is enabled. The adodb_logsql table is populated using $conn->LogSQL.

For Oracle, Ixora Suspicious SQL returns a list of SQL statements that are most cache intensive as a HTML table. These are data intensive SQL statements that could benefit most from tuning.

function ExpensiveSQL($numsql=10)

Returns SQL whose total execution time (avg time * #executions) is high as a HTML table. Each sql statement is hyperlinked to a new window which details the execution plan and the scripts that execute this SQL.

The number of statements returned is determined by $numsql. Data is taken from the adodb_logsql table, where the sql statements are logged when $connection->LogSQL(true) is enabled. The adodb_logsql table is populated using $conn->LogSQL.

For Oracle, Ixora Expensive SQL returns a list of SQL statements that are taking the most CPU load when run.

function InvalidSQL($numsql=10)

Returns a list of invalid SQL as an HTML table.

Data is taken from the adodb_logsql table, where the sql statements are logged when $connection->LogSQL(true) is enabled.

function Tables($orderby=1)

Returns information on all tables in a database, with the first two fields containing the table name and table size, the remaining fields depend on the database driver. If $orderby is set to 1, it will sort by name. If $orderby is set to 2, then it will sort by table size. Some database drivers (mssql and mysql) will ignore the $orderby clause. For postgresql, the information is up-to-date since the last vacuum. Not supported currently for db2.

Raw Functions

Raw functions return values without any formatting.

function DBParameter($paramname)

Returns the value of a database parameter, such as $this->DBParameter("data cache size").

function CPULoad()

Returns the CPU load of the database client (NOT THE SERVER) as a percentage. Only works for Linux and Windows. For Windows, WMI must be available.

Format of $settings Property

To create new database parameters, you need to understand $settings. The $settings data structure is an associative array. Each element of the array defines a database parameter. The key is the name of the database parameter. If no key is defined, then it is assumed to be a section break, and the value is the name of the section break. If this is too confusing, looking at the source code will help a lot!

Each database parameter is itself an array consisting of the following elements:

  1. Category code, used to group related db parameters. If the category code is 'HIDE', then the database parameter is not shown when HTML() is called.
  2. either
    1. sql string to retrieve value, eg. "select value from v\$parameter where name='db_block_size'",
    2. array holding sql string and field to look for, e.g. array('show variables','table_cache'); optional 3rd parameter is the $rs->fields[$index] to use (otherwise $index=1), and optional 4th parameter is a constant to multiply the result with (typically 100 for percentage calculations),
    3. a string prefixed by =, then a PHP method of the class is invoked, e.g. to invoke $this->GetIndexValue(), set this array element to '=GetIndexValue',
  3. Description of database parameter. If description begins with an =, then it is interpreted as a method call, just as in (1c) above, taking one parameter, the current value. E.g. '=GetIndexDescription' will invoke $this->GetIndexDescription($val). This is useful for generating tuning suggestions. For an example, see WarnCacheRatio().

Example from MySQL, table_cache database parameter:

'table cache' => array('CACHE',            # category code
   array("show variables", 'table_cache'), # array (type 1b)
   'Number of tables to keep open'),       # description

Example Health Check Output

db2 informix mysql mssql oci8 postgres

db2
Parameter | Value | Description
Ratios
data cache hit ratio | 0
Data Cache
data cache buffers | 250 | See tuning reference.
cache blocksize | 4096
data cache size | 1000K
Connections
current connections | 2

informix
Parameter | Val ue | Description
Ratios
data cache hit ratio | 95.89
IO
data reads | 1883884 | Page reads
data writes | 1716724 | Page writes
Connections
current connections | 263.0 | Number of sessions

mysql
Parameter | Value | Description
Ratios
MyISAM cache hit ratio | 56.5658301822 | Cache ratio should be at least 90%
InnoDB cache hit ratio | 0 | Cache ratio should be at least 90%
sql cache hit ratio | 0
IO
data reads | 2622 | Number of selects (Key_reads is not accurate)
data writes | 2415.5 | Number of inserts/updates/deletes * coef (Key_writes is not accurate)
Data Cache
MyISAM data cache size | 512K
BDB data cache size | 8388600
InnoDB data cache size | 8M
Memory Pools
read buffer size | 131072 | (per session)
sort buffer size | 65528 | Size of sort buffer (per session)
table cache | 4 | Number of tables to keep open
Connections
current connections | 3
max connections | 100

mssql
Parameter | Value | Description
Ratios
data cache hit ratio | 99.9999694824
prepared sql hit ratio | 99.7738579828
adhoc sql hit ratio | 98.4540169133
IO
data reads | 2858
data writes | 1438
Data Cache
data cache size | 4362 | in K
Connections
current connections | 14
max connections | 32767

oci8
Parameter | Value | Description
Ratios
data cache hit ratio | 96.98
sql cache hit ratio | 99.96
IO
data reads | 842938
data writes | 16852
Data Cache
data cache buffers | 3072 | Number of cache buffers
data cache blocksize | 8192
data cache size | 48M | shared_pool_size
Memory Pools
java pool size | 0 | java_pool_size
sort buffer size | 512K | sort_area_size (per query)
user session buffer size | 8M | large_pool_size
Connections
current connections | 1
max connections | 170
data cache utilization ratio | 88.46 | Percentage of data cache actually in use
user cache utilization ratio | 91.76 | Percentage of user cache (large_pool) actually in use
rollback segments | 11
Transactions
peak transactions | 24 | Taken from high-water-mark
max transactions | 187 | max transactions / rollback segments < 3.5 (or transactions_per_rollback_segment)
Parameters
cursor sharing | EXACT | Cursor reuse strategy. Recommended is FORCE (8i+) or SIMILAR (9i+). See cursor_sharing.
index cache cost | 0 | % of indexed data blocks expected in the cache. Recommended is 20-80. Default is 0. See optimizer_index_caching.
random page cost | 100 | Recommended is 10-50 for TP, and 50 for data warehouses. Default is 100. See optimizer_index_cost_adj.

Suspicious SQL

LOAD | EXECUTES | SQL_TEXT
.73% | 89 | select u.name, o.name, t.spare1, t.pctfree$ from sys.obj$ o, sys.user$ u, sys.tab$ t where (bitand(t.trigflag, 1048576) = 1048576) and o.obj#=t.obj# and o.owner# = u.user# select i.obj#, i.flags, u.name, o.name from sys.obj$ o, sys.user$ u, sys.ind$ i where (bitand(i.flags, 256) = 256 or bitand(i.flags, 512) = 512) and (not((i.type# = 9) and bitand(i.flags,8) = 8)) and o.obj#=i.obj# and o.owner# = u.user#
.84% | 3 | select /*+ RULE */ distinct tabs.table_name, tabs.owner , partitioned, iot_type , TEMPORARY, table_type, table_type_owner from DBA_ALL_TABLES tabs where tabs.owner = :own
3.95% | 6 | SELECT round(count(1)*avg(buf.block_size)/1048576) FROM DBA_OBJECTS obj, V$BH bh, dba_segments seg, v$buffer_pool buf WHERE obj.object_id = bh.objd AND obj.owner != 'SYS' and obj.owner = seg.owner and obj.object_name = seg.segment_name and obj.object_type = seg.segment_type and seg.buffer_pool = buf.name and buf.name = 'DEFAULT'
4.50% | 6 | SELECT round(count(1)*avg(tsp.block_size)/1048576) FROM DBA_OBJECTS obj, V$BH bh, dba_segments seg, dba_tablespaces tsp WHERE obj.object_id = bh.objd AND obj.owner != 'SYS' and obj.owner = seg.owner and obj.object_name = seg.segment_name and obj.object_type = seg.segment_type and seg.tablespace_name = tsp.tablespace_name
57.34% | 9267 | select t.schema, t.name, t.flags, q.name from system.aq$_queue_tables t, sys.aq$_queue_table_affinities aft, system.aq$_queues q where aft.table_objno = t.objno and aft.owner_instance = :1 and q.table_objno = t.objno and q.usage = 0 and bitand(t.flags, 4+16+32+64+128+256) = 0 for update of t.name, aft.table_objno skip locked

Expensive SQL

LOAD | EXECUTES | SQL_TEXT
5.24% | 1 | select round(sum(bytes)/1048576) from dba_segments
6.89% | 6 | SELECT round(count(1)*avg(buf.block_size)/1048576) FROM DBA_OBJECTS obj, V$BH bh, dba_segments seg, v$buffer_pool buf WHERE obj.object_id = bh.objd AND obj.owner != 'SYS' and obj.owner = seg.owner and obj.object_name = seg.segment_name and obj.object_type = seg.segment_type and seg.buffer_pool = buf.name and buf.name = 'DEFAULT'
7.85% | 6 | SELECT round(count(1)*avg(tsp.block_size)/1048576) FROM DBA_OBJECTS obj, V$BH bh, dba_segments seg, dba_tablespaces tsp WHERE obj.object_id = bh.objd AND obj.owner != 'SYS' and obj.owner = seg.owner and obj.object_name = seg.segment_name and obj.object_type = seg.segment_type and seg.tablespace_name = tsp.tablespace_name
33.69% | 89 | select u.name, o.name, t.spare1, t.pctfree$ from sys.obj$ o, sys.user$ u, sys.tab$ t where (bitand(t.trigflag, 1048576) = 1048576) and o.obj#=t.obj# and o.owner# = u.user#
36.44% | 89 | select i.obj#, i.flags, u.name, o.name from sys.obj$ o, sys.user$ u, sys.ind$ i where (bitand(i.flags, 256) = 256 or bitand(i.flags, 512) = 512) and (not((i.type# = 9) and bitand(i.flags,8) = 8)) and o.obj#=i.obj# and o.owner# = u.user#

postgres7
Parameter | Value | Description
Ratios
statistics collector | FALSE | Must be set to TRUE to enable hit ratio statistics (stats_start_collector,stats_row_level and stats_block_level must be set to true in postgresql.conf)
data cache hit ratio | 99.9666031916603
IO
data reads | 15
data writes | 0.000000000000000000 | Count of inserts/updates/deletes * coef
Data Cache
data cache buffers | 1280 | Number of cache buffers. Tuning
cache blocksize | 8192 | (estimate)
data cache size | 10M
operating system cache size | 80000K | (effective cache size)
Memory Pools
sort buffer size | 1M | Size of sort buffer (per query)
Connections
current connections | 13
max connections | 32
Parameters
rollback buffers | 8 | WAL buffers
random page cost | 4 | Cost of doing a seek (default=4). See random_page_cost


Tips on Writing Portable SQL for Multiple Databases for PHP

Tips on Writing Portable SQL

Updated 18 Sep 2003. Added Portable Native SQL section.

If you are writing an application that is used in multiple environments and operating systems, you need to plan to support multiple databases. This article is based on my experiences with multiple database systems, stretching from 4th Dimension in my Mac days, to the databases I currently use, which are: Oracle, FoxPro, Access, MS SQL Server and MySQL. Although most of the advice here applies to using SQL with Perl, Python and other programming languages, I will focus on PHP and how the ADOdb database abstraction library offers some solutions.

Most database vendors practice product lock-in. The best or fastest way to do things is often implemented using proprietary extensions to SQL. This makes it extremely hard to write portable SQL code that performs well under all conditions. When the first ANSI committee got together in 1984 to standardize SQL, the database vendors had such different implementations that they could only agree on the core functionality of SQL. Many important application specific requirements were not standardized, and after so many years since the ANSI effort began, it looks as if much useful database functionality will never be standardized. Even though ANSI-92 SQL has codified much more, we still have to implement portability at the application level.

Selects

The SELECT statement has been standardized to a great degree. Nearly every database supports the following:

SELECT [cols] FROM [tables]
[WHERE conditions]
[GROUP BY cols]
[HAVING conditions]
[ORDER BY cols]

But so many useful techniques can only be implemented by using proprietary extensions. For example, when writing SQL to retrieve the first 10 rows for paging, you could write...

Database | SQL Syntax
DB2 | select * from table fetch first 10 rows only
Informix | select first 10 * from table
Microsoft SQL Server and Access | select top 10 * from table
MySQL and PostgreSQL | select * from table limit 10
Oracle 8i | select * from (select * from table) where rownum <= 10

This feature of getting a subset of data is so useful that in the PHP class library ADOdb, we have a SelectLimit( ) function that allows you to hide the implementation details within a function that will rewrite your SQL for you:

$connection->SelectLimit('select * from table', 10);

Selects: Fetch Modes

PHP allows you to retrieve database records as arrays. You can choose to have the arrays indexed by field name or number. However different low-level PHP database drivers are inconsistent in their indexing efforts. ADOdb allows you to determine your prefered mode. You set this by setting the variable $ADODB_FETCH_MODE to either of the constants ADODB_FETCH_NUM (for numeric indexes) or ADODB_FETCH_ASSOC (using field names as an associative index).

The default behaviour of ADOdb varies depending on the database you are using. For consistency, set the fetch mode to either ADODB_FETCH_NUM (for speed) or ADODB_FETCH_ASSOC (for convenience) at the beginning of your code.

Selects: Counting Records

Another problem with SELECTs is that some databases do not return the number of rows retrieved from a select statement. This is because the highest performance databases will return records to you even before the last record has been found.

In ADOdb, RecordCount( ) returns the number of rows returned, or will emulate it by buffering the rows and returning the count after all rows have been returned. This can be disabled for performance reasons when retrieving large recordsets by setting the global variable $ADODB_COUNTRECS = false. This variable is checked every time a query is executed, so you can selectively choose which recordsets to count.

If you prefer to set $ADODB_COUNTRECS = false, ADOdb still has the PO_RecordCount( ) function. This will return the number of rows, or if it is not found, it will return an estimate using SELECT COUNT(*):

$rs = $db->Execute("select * from table where state=$state");
$numrows = $rs->PO_RecordCount('table', "state=$state");

Selects: Locking

SELECT statements are commonly used to implement row-level locking of tables. Other databases such as Oracle, Interbase, PostgreSQL and MySQL with InnoDB do not require row-level locking because they use versioning to display data consistent with a specific point in time.

Currently, I recommend encapsulating the row-level locking in a separate function, such as RowLock($table, $where):

$connection->BeginTrans( );
$connection->RowLock($table, $where);
# some operation
if ($ok) $connection->CommitTrans( );
else $connection->RollbackTrans( );

Selects: Outer Joins

Not all databases support outer joins. Furthermore the syntax for outer joins differs dramatically between database vendors. One portable (and possibly slower) method of implementing outer joins is using UNION.

For example, an ANSI-92 left outer join between two tables t1 and t2 could look like:

SELECT t1.col1, t1.col2, t2.cola
  FROM t1 LEFT JOIN t2 ON t1.col = t2.col

This can be emulated using:

SELECT t1.col1, t1.col2, t2.cola FROM t1, t2
       WHERE t1.col = t2.col
   UNION ALL
SELECT col1, col2, null FROM t1
       WHERE t1.col not in (select distinct col from t2)

Since ADOdb 2.13, we provide some hints in the connection object as to legal join variations. This is still incomplete and sometimes depends on the database version you are using, but is useful as a general guideline:

$conn->leftOuter: holds the operator used for left outer joins (eg. '*='), or false if not known or not available.
$conn->rightOuter: holds the operator used for right outer joins (eg '=*'), or false if not known or not available.
$conn->ansiOuter: boolean that if true means that ANSI-92 style outer joins are supported, or false if not known.

Inserts

When you create records, you need to generate unique id's for each record. There are two common techniques: (1) auto-incrementing columns and (2) sequences.

Auto-incrementing columns are supported by MySQL, Sybase and Microsoft Access and SQL Server. However most other databases do not support this feature. So for portability, you have little choice but to use sequences. Sequences are special functions that return a unique incrementing number every time you call it, suitable to be used as database keys. In ADOdb, we use the GenID( ) function. It has takes a parameter, the sequence name. Different tables can have different sequences.

$id = $connection->GenID('sequence_name');
$connection->Execute("insert into table (id, firstname, lastname)
               values ($id, $firstname, $lastname)");

For databases that do not support sequences natively, ADOdb emulates sequences by creating a table for every sequence.

Binding

Binding variables in an SQL statement is another tricky feature. Binding is useful because it allows pre-compilation of SQL. When inserting multiple records into a database in a loop, binding can offer a 50% (or greater) speedup. However many databases such as Access and MySQL do not support binding natively and there is some overhead in emulating binding. Furthermore, different databases (specificly Oracle!) implement binding differently. My recommendation is to use binding if your database queries are too slow, but make sure you are using a database that supports it like Oracle.

ADOdb supports portable Prepare/Execute with:

$stmt = $db->Prepare('select * from customers where custid=? and state=?');
$rs = $db->Execute($stmt, array($id,'New York'));

Oracle uses named bind placeholders, not "?", so to support portable binding, we have Param() that generates the correct placeholder (available since ADOdb 3.92):

$sql = 'insert into table (col1,col2) values ('.$DB->Param('a').','.$DB->Param('b').')';
# generates 'insert into table (col1,col2) values (?,?)'
# or        'insert into table (col1,col2) values (:a,:b)'
$stmt = $DB->Prepare($sql);
$stmt = $DB->Execute($stmt,array('one','two'));

Portable Native SQL

ADOdb provides the following functions for portably generating SQL functions as strings to be merged into your SQL statements (some are only available since ADOdb 3.92):

Function | Description
DBDate($date) | Pass in a UNIX timestamp or ISO date and it will convert it to a date string formatted for INSERT/UPDATE
DBTimeStamp($date) | Pass in a UNIX timestamp or ISO date and it will convert it to a timestamp string formatted for INSERT/UPDATE
SQLDate($date, $fmt) | Portably generate a date formatted using $fmt mask, for use in SELECT statements.
OffsetDate($date, $ndays) | Portably generate a $date offset by $ndays.
Concat($s1, $s2, ...) | Portably concatenate strings. Alternatively, for mssql use mssqlpo driver, which allows || operator.
IfNull($fld, $replaceNull) | Returns a string that is the equivalent of MySQL IFNULL or Oracle NVL.
Param($name) | Generates bind placeholders, using ? or named conventions as appropriate.
$db->sysDate | Property that holds the SQL function that returns today's date
$db->sysTimeStamp | Property that holds the SQL function that returns the current timestamp (date+time).
$db->concat_operator | Property that holds the concatenation operator
$db->length | Property that holds the name of the SQL strlen function.
$db->upperCase | Property that holds the name of the SQL strtoupper function.
$db->random | Property that holds the SQL to generate a random number between 0.00 and 1.00.
$db->substr | Property that holds the name of the SQL substring function.

DDL and Tuning

There are database design tools such as ERWin or Dezign that allow you to generate data definition language commands such as ALTER TABLE or CREATE INDEX from Entity-Relationship diagrams.

However if you prefer to use a PHP-based table creation scheme, adodb provides you with this feature. Here is the code to generate the SQL to create a table with:

  1. Auto-increment primary key 'ID',
  2. The person's 'NAME' VARCHAR(32) NOT NULL and defaults to '',
  3. The date and time of record creation 'CREATED',
  4. The person's 'AGE', defaulting to 0, type NUMERIC(16).

Also create a compound index consisting of 'NAME' and 'AGE':

$datadict = NewDataDictionary($connection);
$flds = "
  ID I AUTOINCREMENT PRIMARY,
  NAME C(32) DEFAULT '' NOTNULL,
  CREATED T DEFTIMESTAMP,
  AGE N(16) DEFAULT 0
";
$sql1 = $datadict->CreateTableSQL('tabname', $flds);
$sql2 = $datadict->CreateIndexSQL('idx_name_age', 'tabname', 'NAME,AGE');

Data Types

Stick to a few data types that are available in most databases. Char, varchar and numeric/number are supported by most databases. Most other data types (including integer, boolean and float) cannot be relied on being available. I recommend using char(1) or number(1) to hold booleans.

Different databases have different ways of representing dates and timestamps/datetime. ADOdb attempts to display all dates in ISO (YYYY-MM-DD) format. ADOdb also provides DBDate( ) and DBTimeStamp( ) to convert dates to formats that are acceptable to that database. Both functions accept Unix integer timestamps and date strings in ISO format.

$date1 = $connection->DBDate(time( ));
$date2 = $connection->DBTimeStamp('2002-02-23 13:03:33');

We also provide functions to convert database dates to Unix timestamps:

$unixts = $recordset->UnixDate('#2002-02-30#'); # MS Access date => unix timestamp

The maximum length of a char/varchar field is also database specific. You can only assume that field lengths of up to 250 characters are supported. This is normally impractical for web based forum or content management systems. You will need to be familiar with how databases handle large objects (LOBs). ADOdb implements two functions, UpdateBlob( ) and UpdateClob( ) that allow you to update fields holding Binary Large Objects (eg. pictures) and Character Large Objects (eg. HTML articles):

# for oracle
$conn->Execute('INSERT INTO blobtable (id, blobcol) VALUES (1,empty_blob())');
$conn->UpdateBlob('blobtable','blobcol',$blobvalue,'id=1');

# non-oracle databases
$conn->Execute('INSERT INTO blobtable (id, blobcol) VALUES (1, null)');
$conn->UpdateBlob('blobtable','blobcol',$blobvalue,'id=1');

Null handling is another area where differences can occur. This is a mine-field, because 3-value logic is tricky.

In general, I avoid using nulls except for dates and default all my numeric and character fields to 0 or the empty string. This maintains consistency with PHP, where empty strings and zero are treated as equivalent, and avoids SQL ambiguities when you use the ANY and EXISTS operators. However if your database has significant amounts of missing or unknown data, using nulls might be a good idea.

ADOdb also supports a portable IfNull function, so you can define what to display if the field contains a null.

Stored Procedures

Stored procedures are another problem area. Some databases allow recordsets to be returned in a stored procedure (Microsoft SQL Server and Sybase), and others only allow output parameters to be returned. Stored procedures sometimes need to be wrapped in special syntax. For example, Oracle requires such code to be wrapped in an anonymous block with BEGIN and END. Also internal sql operators and functions such as +, ||, TRIM( ), SUBSTR( ) or INSTR( ) vary between vendors.

An example of how to call a stored procedure with 2 parameters and 1 return value follows:

    switch ($db->databaseType) {
    case 'mssql':
      $sql = 'SP_RUNSOMETHING'; break;
    case 'oci8':
      $sql =
      "declare RETVAL integer;begin :RETVAL := SP_RUNSOMETHING(:myid,:group);end;";
      break;
    default:
      die('Unsupported feature');
    }
    # @RETVAL = SP_RUNSOMETHING @myid,@group
    $stmt = $db->PrepareSP($sql);
    $db->Parameter($stmt,$id,'myid');
    $db->Parameter($stmt,$group,'group');
    # true indicates output parameter
    $db->Parameter($stmt,$ret,'RETVAL',true);
    $db->Execute($stmt);

As you can see, the ADOdb API is the same for both databases. But the stored procedure SQL syntax is quite different between databases and is not portable, so be forewarned! However sometimes you have little choice as some systems only allow data to be accessed via stored procedures. This is when the ultimate portability solution might be the only solution: treating portable SQL as a localization exercise...

SQL as a Localization Exercise

In general to provide real portability, you will have to treat SQL coding as a localization exercise. In PHP, it has become common to define separate language files for English, Russian, Korean, etc. Similarly, I would suggest you have separate Sybase, Intebase, MySQL, etc files, and conditionally include the SQL based on the database. For example, each MySQL SQL statement would be stored in a separate variable, in a file called 'mysql-lang.inc.php'.

$sqlGetPassword = 'select password from users where userid=%s';
$sqlSearchKeyword = "SELECT * FROM articles WHERE match (title,body) against (%s)";

In our main PHP file:

# define which database to load...
$database = 'mysql';
include_once("$database-lang.inc.php");

$db = &NewADOConnection($database);
$db->PConnect(...) or die('Failed to connect to database');

# search for a keyword $word
$rs = $db->Execute(sprintf($sqlSearchKeyWord,$db->qstr($word)));

Note that we quote the $word variable using the qstr( ) function. This is because each database quotes strings using different conventions.

Final Thoughts

The best way to ensure that you have portable SQL is to have your data tables designed using sound principles. Learn the theory of normalization and entity-relationship diagrams and model your data carefully. Understand how joins and indexes work and how they are used to tune performance.

Visit the following page for more references on database theory and vendors: http://php.weblogs.com/sql_tutorial. Also read this article on Optimizing PHP.

(c) 2002-2003 John Lim.


ADOdb Active Record

(c) 2000-2006 John Lim (jlim#natsoft.com)

This software is dual licensed using BSD-Style and LGPL. This means you can use it in compiled proprietary and commercial products.

  1. Introduction

    2. ADOdb_Active_Record is an Object Relation Mapping (ORM) implementation using PHP. In an ORM system, the tables and rows of the database are abstracted into native PHP objects. This allows the programmer to focus more on manipulating the data and less on writing SQL queries.

    This implementation differs from Zend Framework's implementation in the following ways:

    • Works with PHP4 and PHP5 and provides equivalent functionality in both versions of PHP.

    • ADOdb_Active_Record works when you are connected to multiple databases. Zend's only works when connected to a default database.

    • Support for $ADODB_ASSOC_CASE. The field names are upper-cased, lower-cased or left in natural case depending on this setting.

    • No field name conversion to camel-caps style, unlike Zend's implementation which will convert field names such as 'first_name' to 'firstName'.

    • NewADOConnection::GetActiveRecords() and ADOConnection::GetActiveRecordsClass() functions in adodb.inc.php.

    • Caching of table metadata so it is only queried once per table, no matter how many Active Records are created.

    • The additional functionality is described below.

    ADOdb_Active_Record is designed upon the principles of the "ActiveRecord" design pattern, which was first described by Martin Fowler. The ActiveRecord pattern has been implemented in many forms across the spectrum of programming languages. ADOdb_Active_Record attempts to represent the database as closely to native PHP objects as possible.

    ADOdb_Active_Record maps a database table to a PHP class, and each instance of that class represents a table row. Relations between tables can also be defined, allowing the ADOdb_Active_Record objects to be nested.

  2. Setting the Database Connection

    3. The first step to using ADOdb_Active_Record is to set the default connection that an ADOdb_Active_Record objects will use to connect to a database.

    require_once('adodb/adodb-active-record.inc.php');

$db = NewADOConnection('mysql://root:pwd@localhost/dbname');
ADOdb_Active_Record::SetDatabaseAdapter($db);

  3. Table Rows as Objects

    4. First, let's create a temporary table in our MySQL database that we can use for demonstrative purposes throughout the rest of this tutorial. We can do this by sending a CREATE query:

    $db->Execute("CREATE TEMPORARY TABLE `persons` (
                `id` int(10) unsigned NOT NULL auto_increment,
                `name_first` varchar(100) NOT NULL default '',
                `name_last` varchar(100) NOT NULL default '',
                `favorite_color` varchar(100) NOT NULL default '',
                PRIMARY KEY  (`id`)
            ) ENGINE=MyISAM;
           ");

    ADOdb_Active_Record's are object representations of table rows. Each table in the database is represented by a class in PHP. To begin working with a table as a ADOdb_Active_Record, a class that extends ADOdb_Active_Records needs to be created for it.

    class Person extends ADOdb_Active_Record{}
$person = new Person();

    In the above example, a new ADOdb_Active_Record object $person was created to access the "persons" table. Zend_Db_DataObject takes the name of the class, pluralizes it (according to American English rules), and assumes that this is the name of the table in the database.

    This kind of behavior is typical of ADOdb_Active_Record. It will assume as much as possible by convention rather than explicit configuration. In situations where it isn't possible to use the conventions that ADOdb_Active_Record expects, options can be overridden as we'll see later.

  4. Table Columns as Object Properties

    5. When the $person object was instantiated, ADOdb_Active_Record read the table metadata from the database itself, and then exposed the table's columns (fields) as object properties.

    Our "persons" table has three fields: "name_first", "name_last", and "favorite_color". Each of these fields is now a property of the $person object. To see all these properties, use the ADOdb_Active_Record::getAttributeNames() method:

    var_dump($person->getAttributeNames());

/**
 * Outputs the following:
 * array(4) {
 *    [0]=>
 *    string(2) "id"
 *    [1]=>
 *    string(9) "name_first"
 *    [2]=>
 *    string(8) "name_last"
 *    [3]=>
 *    string(13) "favorite_color"
 *  }
 */

    One big difference between ADOdb and Zend's implementation is we do not automatically convert to camelCaps style.

  5. Inserting and Updating a Record

    6. An ADOdb_Active_Record object is a representation of a single table row. However, when our $person object is instantiated, it does not reference any particular row. It is a blank record that does not yet exist in the database. An ADOdb_Active_Record object is considered blank when its primary key is NULL. The primary key in our persons table is "id".

    To insert a new record into the database, change the object's properties and then call the ADOdb_Active_Record::save() method:

    $person = new Person();
$person->nameFirst = 'Andi';
$person->nameLast  = 'Gutmans';
$person->save();

    Oh, no! The above code snippet does not insert a new record into the database. Instead, outputs an error:

    1048: Column 'name_first' cannot be null

    This error occurred because MySQL rejected the INSERT query that was generated by ADOdb_Active_Record. If exceptions are enabled in ADOdb and you are using PHP5, an error will be thrown. In the definition of our table, we specified all of the fields as NOT NULL; i.e., they must contain a value.

    ADOdb_Active_Records are bound by the same contraints as the database tables they represent. If the field in the database cannot be NULL, the corresponding property in the ADOdb_Active_Record also cannot be NULL. In the example above, we failed to set the property $person->favoriteColor, which caused the INSERT to be rejected by MySQL.

    To insert a new ADOdb_Active_Record in the database, populate all of ADOdb_Active_Record's properties so that they satisfy the constraints of the database table, and then call the save() method:

    /**
 * Calling the save() method will successfully INSERT
 * this $person into the database table.
 */
$person = new Person();
$person->name_first     = 'Andi';
$person->name_last      = 'Gutmans';
$person->favorite_color = 'blue';
$person->save();

    Once this $person has been INSERTed into the database by calling save(), the primary key can now be read as a property. Since this is the first row inserted into our temporary table, its "id" will be 1:

    var_dump($person->id);

/**
 * Outputs the following:
 * string(1)
 */

    From this point on, updating it is simply a matter of changing the object's properties and calling the save() method again:

    $person->favorite_color = 'red';
$person->save();

    The code snippet above will change the favorite color to red, and then UPDATE the record in the database.

    ADOdb Specific Functionality

  6. Setting the Table Name

    7. The default behaviour on creating an ADOdb_Active_Record is to "pluralize" the class name and use that as the table name. Often, this is not the case. For example, the Person class could be reading from the "People" table.

    We provide two ways to define your own table:

    1. Use a constructor parameter to override the default table naming behaviour.

        class Person extends ADOdb_Active_Record{}
    $person = new Person('People');

    2. Define it in a class declaration:

        class Person extends ADOdb_Active_Record
    {
    var $_table = 'People';
    }
    $person = new Person();

  7. $ADODB_ASSOC_CASE

    8. This allows you to control the case of field names and properties. For example, all field names in Oracle are upper-case by default. So you can force field names to be lowercase using $ADODB_ASSOC_CASE. Legal values are as follows:

     0: lower-case
 1: upper-case
 2: native-case

    So to force all Oracle field names to lower-case, use

    $ADODB_ASSOC_CASE = 0;
$person = new Person('People');
$person->name = 'Lily';
$ADODB_ASSOC_CASE = 2;
$person2 = new Person('People');
$person2->NAME = 'Lily';

    Also see $ADODB_ASSOC_CASE.

  8. ADOdb_Active_Record::Save()

    9. Saves a record by executing an INSERT or UPDATE SQL statement as appropriate.

    Returns false on unsuccessful INSERT, true if successsful INSERT.

    Returns 0 on failed UPDATE, and 1 on UPDATE if data has changed, and -1 if no data was changed, so no UPDATE statement was executed.

  9. ADOdb_Active_Record::Replace()

    10. ADOdb supports replace functionality, whereby the record is inserted if it does not exists, or updated otherwise.

    $rec = new ADOdb_Active_Record("product");
$rec->name = 'John';
$rec->tel_no = '34111145';
$ok = $rec->replace(); // 0=failure, 1=update, 2=insert

  10. ADOdb_Active_Record::Load($where)

    11. Sometimes, we want to load a single record into an Active Record. We can do so using:

    $person->load("id=3");

// or using bind parameters

$person->load("id=?", array(3));

    Returns false if an error occurs.

  11. ADOdb_Active_Record::Find($whereOrderBy, $bindarr=false, $pkeyArr=false)

    12. We want to retrieve an array of active records based on some search criteria. For example:

    class Person extends ADOdb_Active_Record {
var $_table = 'people';
}

$person = new Person();
$peopleArray =& $person->Find("name like ? order by age", array('Sm%'));

  12. Error Handling and Debugging

    13. In PHP5, if adodb-exceptions.inc.php is included, then errors are thrown. Otherwise errors are handled by returning a value. False by default means an error has occurred. You can get the last error message using the ErrorMsg() function.

    To check for errors in ADOdb_Active_Record, do not poll ErrorMsg() as the last error message will always be returned, even if it occurred several operations ago. Do this instead:

    # right!
$ok = $rec->Save();
if (!$ok) $err = $rec->ErrorMsg();

# wrong :(
$rec->Save();
if ($rec->ErrorMsg()) echo "Wrong way to detect error";

    The ADOConnection::Debug property is obeyed. So if $db->debug is enabled, then ADOdb_Active_Record errors are also outputted to standard output and written to the browser.

  13. ADOdb_Active_Record::Set()

    14. You can convert an array to an ADOdb_Active_Record using Set(). The array must be numerically indexed, and have all fields of the table defined in the array. The elements of the array must be in the table's natural order too.

    $row = $db->GetRow("select * from tablex where id=$id");

# PHP4 or PHP5 without enabling exceptions
$obj =& new ADOdb_Active_Record('Products');
if ($obj->ErrorMsg()){
    echo $obj->ErrorMsg();
} else {
    $obj->Set($row);
}

# in PHP5, with exceptions enabled:

include('adodb-exceptions.inc.php');
try {
    $obj =& new ADOdb_Active_Record('Products');
    $obj->Set($row);
} catch(exceptions $e) {
    echo $e->getMessage();
}

  14. Primary Keys

    15. ADOdb_Active_Record does not require the table to have a primary key. You can insert records for such a table, but you will not be able to update nor delete.

    Sometimes you are retrieving data from a view or table that has no primary key, but has a unique index. You can dynamically set the primary key of a table through the constructor, or using ADOdb_Active_Record::SetPrimaryKeys():

        $pkeys = array('category','prodcode');

    // set primary key using constructor
    $rec = new ADOdb_Active_Record('Products', $pkeys);

     // or use method
    $rec->SetPrimaryKeys($pkeys);

  15. Retrieval of Auto-incrementing ID

    16. When creating a new record, the retrieval of the last auto-incrementing ID is not reliable for databases that do not support the Insert_ID() function call (check $connection->hasInsertID). In this case we perform a SELECT MAX($primarykey) FROM $table, which will not work reliably in a multi-user environment. You can override the ADOdb_Active_Record::LastInsertID() function in this case.

  16. Dealing with Multiple Databases

    17. Sometimes we want to load data from one database and insert it into another using ActiveRecords. This can be done using the optional parameter of the ADOdb_Active_Record constructor. In the following example, we read data from db.table1 and store it in db2.table2:

    $db = NewADOConnection(...);
$db2 = NewADOConnection(...);

ADOdb_Active_Record::SetDatabaseAdapter($db2);

$activeRecs = $db->GetActiveRecords('table1');

foreach($activeRecs as $rec) {
    $rec2 = new ADOdb_Active_Record('table2',$db2);
    $rec2->id = $rec->id;
    $rec2->name = $rec->name;

    $rec2->Save();
}

    If you have to pass in a primary key called "id" and the 2nd db connection in the constructor, you can do so too:

    $rec = new ADOdb_Active_Record("table1",array("id"),$db2);

  17. $ADODB_ACTIVE_CACHESECS

    18. You can cache the table metadata (field names, types, and other info such primary keys) in $ADODB_CACHE_DIR (which defaults to /tmp) by setting the global variable $ADODB_ACTIVE_CACHESECS to a value greater than 0. This will be the number of seconds to cache. You should set this to a value of 30 seconds or greater for optimal performance.

  18. Active Record Considered Bad?

    19. Although the Active Record concept is useful, you have to be aware of some pitfalls when using Active Record. The level of granularity of Active Record is individual records. It encourages code like the following, used to increase the price of all furniture products by 10%:

     $recs = $db->GetActiveRecords("Products","category='Furniture'");
 foreach($recs as $rec) {
    $rec->price *= 1.1; // increase price by 10% for all Furniture products
    $rec->save();
 }
    Of course a SELECT statement is superior because it's simpler and much more efficient (probably by a factor of x10 or more):
       $db->Execute("update Products set price = price * 1.1 where category='Furniture'");

    Another issue is performance. For performance sensitive code, using direct SQL will always be faster than using Active Records due to overhead and the fact that all fields in a row are retrieved (rather than only the subset you need) whenever an Active Record is loaded.

  19. Transactions

    20. The default transaction mode in ADOdb is autocommit. So that is the default with active record too. The general rules for managing transactions still apply. Active Record to the database is a set of insert/update/delete statements, and the db has no knowledge of active records.

    Smart transactions, that does an auto-rollback if an error occurs, is still the best method to multiple activities (inserts/updates/deletes) that need to be treated as a single transaction:

    $conn->StartTrans();
$parent->save();
$child->save();
$conn->CompleteTrans();

    ADOConnection Supplement

  20. ADOConnection::GetActiveRecords()

    21. This allows you to retrieve an array of ADOdb_Active_Records. Returns false if an error occurs.

    $table = 'products';
$whereOrderBy = "name LIKE 'A%' ORDER BY Name";
$activeRecArr = $db->GetActiveRecords($table, $whereOrderBy);
foreach($activeRecArr as $rec) {
    $rec->id = rand();
    $rec->save();
}

    And to retrieve all records ordered by specific fields:

    $whereOrderBy = "1=1 ORDER BY Name";
$activeRecArr = $db->ADOdb_Active_Records($table);

    To use bind variables (assuming ? is the place-holder for your database):

    $activeRecArr = $db->GetActiveRecords($tableName, 'name LIKE ?',
                        array('A%'));

    You can also define the primary keys of the table by passing an array of field names:

    $activeRecArr = $db->GetActiveRecords($tableName, 'name LIKE ?',
                        array('A%'), array('id'));

  21. ADOConnection::GetActiveRecordsClass()

    22. This allows you to retrieve an array of objects derived from ADOdb_Active_Records. Returns false if an error occurs.

    class Product extends ADOdb_Active_Records{};
$table = 'products';
$whereOrderBy = "name LIKE 'A%' ORDER BY Name";
$activeRecArr = $db->GetActiveRecordsClass('Product',$table, $whereOrderBy);

# the objects in $activeRecArr are of class 'Product'
foreach($activeRecArr as $rec) {
    $rec->id = rand();
    $rec->save();
}

    To use bind variables (assuming ? is the place-holder for your database):

    $activeRecArr = $db->GetActiveRecordsClass($className,$tableName, 'name LIKE ?',
                        array('A%'));

    You can also define the primary keys of the table by passing an array of field names:

    $activeRecArr = $db->GetActiveRecordsClass($className,$tableName, 'name LIKE ?',
                        array('A%'), array('id'));

Code Sample

The following works with PHP4 and PHP5

include('../adodb.inc.php');
include('../adodb-active-record.inc.php');

// uncomment the following if you want to test exceptions
#if (PHP_VERSION >= 5) include('../adodb-exceptions.inc.php');

$db = NewADOConnection('mysql://root@localhost/northwind');
$db->debug=1;
ADOdb_Active_Record::SetDatabaseAdapter($db);

$db->Execute("CREATE TEMPORARY TABLE `persons` (
                `id` int(10) unsigned NOT NULL auto_increment,
                `name_first` varchar(100) NOT NULL default '',
                `name_last` varchar(100) NOT NULL default '',
                `favorite_color` varchar(100) NOT NULL default '',
                PRIMARY KEY  (`id`)
            ) ENGINE=MyISAM;
           ");

class Person extends ADOdb_Active_Record{}
$person = new Person();

echo "<p>Output of getAttributeNames: ";
var_dump($person->getAttributeNames());

/**
 * Outputs the following:
 * array(4) {
 *    [0]=>
 *    string(2) "id"
 *    [1]=>
 *    string(9) "name_first"
 *    [2]=>
 *    string(8) "name_last"
 *    [3]=>
 *    string(13) "favorite_color"
 *  }
 */

$person = new Person();
$person->nameFirst = 'Andi';
$person->nameLast  = 'Gutmans';
$person->save(); // this save() will fail on INSERT as favorite_color is a must fill...

$person = new Person();
$person->name_first     = 'Andi';
$person->name_last      = 'Gutmans';
$person->favorite_color = 'blue';
$person->save(); // this save will perform an INSERT successfully

echo "<p>The Insert ID generated:"; print_r($person->id);

$person->favorite_color = 'red';
$person->save(); // this save() will perform an UPDATE

$person = new Person();
$person->name_first     = 'John';
$person->name_last      = 'Lim';
$person->favorite_color = 'lavender';
$person->save(); // this save will perform an INSERT successfully

// load record where id=2 into a new ADOdb_Active_Record
$person2 = new Person();
$person2->Load('id=2');
var_dump($person2);

// retrieve an array of records
$activeArr = $db->GetActiveRecordsClass($class = "Person",$table = "persons","id=".$db->Param(0),array(2));
$person2 =& $activeArr[0];
echo "<p>Name first (should be John): ",$person->name_first, "<br>Class = ",get_class($person2);

Todo (Code Contributions welcome)

Check _original and current field values before update, only update changes. Also if the primary key value is changed, then on update, we should save and use the original primary key values in the WHERE clause!

Handle 1-to-many relationships.

PHP5 specific: Make GetActiveRecords*() return an Iterator.

PHP5 specific: Change PHP5 implementation of Active Record to use __get() and __set() for better performance.

Change Log

0.05

If inserting a record and the value of a primary key field is null, then we do not insert that field in as we assume it is an auto-increment field. Needed by mssql.

0.04 5 June 2006

Added support for declaring table name in $_table in class declaration. Thx Bill Dueber for idea.

Added find($where,$bindarr=false) method to retrieve an array of active record objects.

0.03
- Now we only update fields that have changed, using $this->_original.
- We do not include auto_increment fields in replace(). Thx Travis Cline
- Added ADODB_ACTIVE_CACHESECS.

0.02
- Much better error handling. ErrorMsg() implemented. Throw implemented if adodb-exceptions.inc.php detected.
- You can now define the primary keys of the view or table you are accessing manually.
- The Active Record allows you to create an object which does not have a primary key. You can INSERT but not UPDATE in this case. - Set() documented.
- Fixed _pluralize bug with y suffix.

0.01 6 Mar 2006
- Fixed handling of nulls when saving (it didn't save nulls, saved them as '').
- Better error handling messages.
- Factored out a new method GetPrimaryKeys().

0.00 5 Mar 2006
1st release


ADODB Manual

ADOdb Library for PHP

V4.91 2 Aug 2006 (c) 2000-2006 John Lim (jlim#natsoft.com)

This software is dual licensed using BSD-Style and LGPL. This means you can use it in compiled proprietary and commercial products.

Useful ADOdb links: Download Other Docs

Introduction
Unique Features
How People are using ADOdb
Feature Requests and Bug Reports
Installation
Minimum Install
Initializing Code and Connectioning to Databases
 Data Source Name (DSN) Support Connection Examples
High Speed ADOdb - tuning tips
Hacking and Modifying ADOdb Safely
PHP5 Features
foreach iterators exceptions
Supported Databases
Tutorials
Example 1: Select
Example 2: Advanced Select
Example 3: Insert
Example 4: Debugging rs2html example
Example 5: MySQL and Menus
Example 6: Connecting to Multiple Databases at once
Example 7: Generating Update and Insert SQL
Example 8: Implementing Scrolling with Next and Previous
Example 9: Exporting in CSV or Tab-Delimited Format
Example 10: Custom filters
Example 11: Smart Transactions

Using Custom Error Handlers and PEAR_Error
Data Source Names
Caching
Pivot Tables

REFERENCE

Variables: $ADODB_COUNTRECS $ADODB_ANSI_PADDING_OFF $ADODB_CACHE_DIR
$ADODB_FORCE_TYPE $ADODB_FETCH_MODE $ADODB_LANG
Constants: ADODB_ASSOC_CASE
ADOConnection
Connections: Connect PConnect NConnect IsConnected
Executing SQL: Execute CacheExecute SelectLimit CacheSelectLimit Param Prepare PrepareSP InParameter OutParameter AutoExecute
GetOne CacheGetOne GetRow CacheGetRow GetAll CacheGetAll GetCol CacheGetCol GetAssoc CacheGetAssoc Replace
ExecuteCursor (oci8 only)
Generates SQL strings: GetUpdateSQL GetInsertSQL Concat IfNull length random substr qstr Param OffsetDate SQLDate DBDate DBTimeStamp BindDate BindTimeStamp
Blobs: UpdateBlob UpdateClob UpdateBlobFile BlobEncode BlobDecode
Paging/Scrolling: PageExecute CachePageExecute
Cleanup: CacheFlush Close
Transactions: StartTrans CompleteTrans FailTrans HasFailedTrans BeginTrans CommitTrans RollbackTrans SetTransactionMode
Fetching Data: SetFetchMode
Strings: concat length qstr quote substr
Dates: DBDate DBTimeStamp UnixDate BindDate BindTimeStamp UnixTimeStamp OffsetDate SQLDate
Row Management: Affected_Rows Insert_ID RowLock GenID CreateSequence DropSequence
Error Handling: ErrorMsg ErrorNo MetaError MetaErrorMsg
Data Dictionary (metadata): MetaDatabases MetaTables MetaColumns MetaColumnNames MetaPrimaryKeys MetaForeignKeys ServerInfo
Statistics and Query-Rewriting: LogSQL fnExecute and fnCacheExecute
Deprecated: Bind BlankRecordSet Parameter
ADORecordSet
Returns one field: Fields
Returns one row:FetchRow FetchInto FetchObject FetchNextObject FetchObj FetchNextObj GetRowAssoc
Returns all rows:GetArray GetRows GetAssoc
Scrolling:Move MoveNext MoveFirst MoveLast AbsolutePosition CurrentRow AtFirstPage AtLastPage AbsolutePage
Menu generation:GetMenu GetMenu2
Dates:UserDate UserTimeStamp UnixDate UnixTimeStamp
Recordset Info:RecordCount PO_RecordCount NextRecordSet
Field Info:FieldCount FetchField MetaType
Cleanup: Close

rs2html example
Differences between ADOdb and ADO
Database Driver Guide
 Change Log

Introduction

PHP's database access functions are not standardised. This creates a need for a database class library to hide the differences between the different database API's (encapsulate the differences) so we can easily switch databases. PHP 4.0.5 or later is now required (because we use array-based str_replace).

We currently support MySQL, Oracle, Microsoft SQL Server, Sybase, Sybase SQL Anywhere, Informix, PostgreSQL, FrontBase, SQLite, Interbase (Firebird and Borland variants), Foxpro, Access, ADO, DB2, SAP DB and ODBC. We have had successful reports of connecting to Progress and CacheLite via ODBC. We hope more people will contribute drivers to support other databases.

PHP4 supports session variables. You can store your session information using ADOdb for true portability and scalability. See adodb-session.php for more information.

Also read tips_portable_sql.htm for tips on writing portable SQL.

Unique Features of ADOdb

  • Easy for Windows programmers to adapt to because many of the conventions are similar to Microsoft's ADO.
  • Unlike other PHP database classes which focus only on select statements, we provide support code to handle inserts and updates which can be adapted to multiple databases quickly. Methods are provided for date handling, string concatenation and string quoting characters for differing databases.
  • A metatype system is built in so that we can figure out that types such as CHAR, TEXT and STRING are equivalent in different databases.
  • Easy to port because all the database dependant code are stored in stub functions. You do not need to port the core logic of the classes.
  • Portable table and index creation with the datadict classes.
  • Database performance monitoring and SQL tuning with the performance monitoring classes.
  • Database-backed sessions with the session management classes. Supports session expiry notification.
  • Object-Relational Mapping using ADOdb_Active_Record classes.

How People are using ADOdb

Here are some examples of how people are using ADOdb (for a much longer list, visit adodb-cool-apps):
  • PhpLens is a commercial data grid component that allows both cool Web designers and serious unshaved programmers to develop and maintain databases on the Web easily. Developed by the author of ADOdb.

  • PHAkt: PHP Extension for DreamWeaver Ultradev allows you to script PHP in the popular Web page editor. Database handling provided by ADOdb.

  • Analysis Console for Intrusion Databases (ACID): PHP-based analysis engine to search and process a database of security incidents generated by security-related software such as IDSes and firewalls (e.g. Snort, ipchains). By Roman Danyliw.

  • PostNuke is a very popular free content management system and weblog system. It offers full CSS support, HTML 4.01 transitional compliance throughout, an advanced blocks system, and is fully multi-lingual enabled.

  • EasyPublish CMS is another free content management system for managing information and integrated modules on your internet, intranet- and extranet-sites. From Norway.

  • NOLA is a full featured accounting, inventory, and job tracking application. It is licensed under the GPL, and developed by Noguska.

Feature Requests and Bug Reports

Feature requests and bug reports can be emailed to jlim#natsoft.com.my or posted to the ADOdb Help forums at http://phplens.com/lens/lensforum/topics.php?id=4.

Installation Guide

Make sure you are running PHP 4.0.5 or later. Unpack all the files into a directory accessible by your webserver.

To test, try modifying some of the tutorial examples. Make sure you customize the connection settings correctly. You can debug using $db->debug = true as shown below:

<?php
    include('adodb/adodb.inc.php');
    $db = ADONewConnection($dbdriver); # eg 'mysql' or 'postgres'
    $db->debug = true;
    $db->Connect($server, $user, $password, $database);
    $rs = $db->Execute('select * from some_small_table');
    print "<pre>";
    print_r($rs->GetRows());
    print "</pre>";
?>

Minimum Install

For developers who want to release a minimal install of ADOdb, you will need:

  • adodb.inc.php
  • adodb-lib.inc.php
  • adodb-time.inc.php
  • drivers/adodb-$database.inc.php
  • license.txt (for legal reasons)
  • adodb-php4.inc.php
  • adodb-iterator.inc.php (php5 functionality)
Optional:
  • adodb-error.inc.php and lang/adodb-$lang.inc.php (if you use MetaError())
  • adodb-csvlib.inc.php (if you use cached recordsets - CacheExecute(), etc)
  • adodb-exceptions.inc.php and adodb-errorhandler.inc.php (if you use adodb error handler or php5 exceptions).
  • adodb-active-record.inc.php if you use Active Records.

Code Initialization Examples

When running ADOdb, at least two files are loaded. First is adodb/adodb.inc.php, which contains all functions used by all database classes. The code specific to a particular database is in the adodb/driver/adodb-????.inc.php file.

For example, to connect to a mysql database:

include('/path/to/set/here/adodb.inc.php');
$conn = &ADONewConnection('mysql');

Whenever you need to connect to a database, you create a Connection object using the ADONewConnection($driver) function. NewADOConnection($driver) is an alternative name for the same function.

At this point, you are not connected to the database (no longer true if you pass in a dsn). You will first need to decide whether to use persistent or non-persistent connections. The advantage of persistent connections is that they are faster, as the database connection is never closed (even when you call Close()). Non-persistent connections take up much fewer resources though, reducing the risk of your database and your web-server becoming overloaded.

For persistent connections, use $conn->PConnect(), or $conn->Connect() for non-persistent connections. Some database drivers also support NConnect(), which forces the creation of a new connection.

Connection Gotcha: If you create two connections, but both use the same userid and password, PHP will share the same connection. This can cause problems if the connections are meant to different databases. The solution is to always use different userid's for different databases, or use NConnect().

Data Source Name (DSN) Support

Since ADOdb 4.51, you can connect to a database by passing a dsn to NewADOConnection() (or ADONewConnection, which is the same function). The dsn format is:

    $driver://$username:$password@hostname/$database?options[=value]

NewADOConnection() calls Connect() or PConnect() internally for you. If the connection fails, false is returned.

    # non-persistent connection
    $dsn = 'mysql://root:pwd@localhost/mydb';
    $db = NewADOConnection($dsn);
    if (!$db) die("Connection failed");

    # no need to call connect/pconnect!
    $arr = $db->GetArray("select * from table");

    # persistent connection
    $dsn2 = 'mysql://root:pwd@localhost/mydb?persist';

If you have special characters such as /:?_ in your dsn, then you need to rawurlencode them first:

    $pwd = rawurlencode($pwd);
    $dsn = "mysql://root:$pwd@localhost/mydb";
    $dsn2=rawurlencode("sybase_ase")."://user:pass@host/path?query";

Legal options are:

For all drivers | 'persist', 'persistent', 'debug', 'fetchmode', 'new'
Interbase/Firebird | 'dialect','charset','buffers','role'
M'soft ADO | 'charpage'
MySQL | 'clientflags'
MySQLi | 'port', 'socket', 'clientflags'
Oci8 | 'nls_date_format','charset'

For all drivers, when the options persist or persistent are set, a persistent connection is forced; similarly, when new is set, then a new connection will be created using NConnect if the underlying driver supports it. The debug option enables debugging. The fetchmode calls SetFetchMode(). If no value is defined for an option, then the value is set to 1.

ADOdb DSN's are compatible with version 1.0 of PEAR DB's DSN format.

Examples of Connecting to Databases

MySQL and Most Other Database Drivers

MySQL connections are very straightforward, and the parameters are identical to mysql_connect:

    $conn = &ADONewConnection('mysql');
    $conn->PConnect('localhost','userid','password','database');

    # or dsn
    $dsn = 'mysql://user:pwd@localhost/mydb';
    $conn = ADONewConnection($dsn);  # no need for Connect()

    # or persistent dsn
    $dsn = 'mysql://user:pwd@localhost/mydb?persist';
    $conn = ADONewConnection($dsn);  # no need for PConnect()

    # a more complex example:
    $pwd = urlencode($pwd);
    $flags =  MYSQL_CLIENT_COMPRESS;
    $dsn = "mysql://user:$pwd@localhost/mydb?persist&clientflags=$flags";
    $conn = ADONewConnection($dsn);  # no need for PConnect()

For most drivers, you can use the standard function: Connect($server, $user, $password, $database), or a DSN since ADOdb 4.51. Exceptions to this are listed below.

PDO

PDO, which only works with PHP5, accepts a driver specific connection string:

    $conn =& NewADConnection('pdo');
    $conn->Connect('mysql:host=localhost',$user,$pwd,$mydb);
    $conn->Connect('mysql:host=localhost;dbname=mydb',$user,$pwd);
    $conn->Connect("mysql:host=localhost;dbname=mydb;username=$user;password=$pwd");

The DSN mechanism is also supported:

    $conn =& NewADConnection("pdo_mysql://user:pwd@localhost/mydb?persist"); # persist is optional

PostgreSQL

PostgreSQL 7 and 8 accepts connections using:

a. the standard connection string:

    $conn = &ADONewConnection('postgres');
    $conn->PConnect('host=localhost port=5432 dbname=mary');

b. the classical 4 parameters:

    $conn->PConnect('localhost','userid','password','database');

c. dsn:

    $dsn = 'postgres://user:pwd@localhost/mydb?persist';  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

LDAP

Here is an example of querying a LDAP server. Thanks to Josh Eldridge for the driver and this example:

require('/path/to/adodb.inc.php');

/* Make sure to set this BEFORE calling Connect() */
$LDAP_CONNECT_OPTIONS = Array(
    Array ("OPTION_NAME"=>LDAP_OPT_DEREF, "OPTION_VALUE"=>2),
    Array ("OPTION_NAME"=>LDAP_OPT_SIZELIMIT,"OPTION_VALUE"=>100),
    Array ("OPTION_NAME"=>LDAP_OPT_TIMELIMIT,"OPTION_VALUE"=>30),
    Array ("OPTION_NAME"=>LDAP_OPT_PROTOCOL_VERSION,"OPTION_VALUE"=>3),
    Array ("OPTION_NAME"=>LDAP_OPT_ERROR_NUMBER,"OPTION_VALUE"=>13),
    Array ("OPTION_NAME"=>LDAP_OPT_REFERRALS,"OPTION_VALUE"=>FALSE),
    Array ("OPTION_NAME"=>LDAP_OPT_RESTART,"OPTION_VALUE"=>FALSE)
);
$host = 'ldap.baylor.edu';
$ldapbase = 'ou=People,o=Baylor University,c=US';

$ldap = NewADOConnection( 'ldap' );
$ldap->Connect( $host, $user_name='', $password='', $ldapbase );

echo "<pre>";

print_r( $ldap->ServerInfo() );
$ldap->SetFetchMode(ADODB_FETCH_ASSOC);
$userName = 'eldridge';
$filter="(|(CN=$userName*)(sn=$userName*)(givenname=$userName*)(uid=$userName*))";

$rs = $ldap->Execute( $filter );
if ($rs)
    while ($arr = $rs->FetchRow()) {
         print_r($arr);
    }

$rs = $ldap->Execute( $filter );
if ($rs)
    while (!$rs->EOF) {
         print_r($rs->fields);
        $rs->MoveNext();
    }

print_r( $ldap->GetArray( $filter ) );
print_r( $ldap->GetRow( $filter ) );

$ldap->Close();
echo "</pre>";

Using DSN:

$dsn = "ldap://ldap.baylor.edu/ou=People,o=Baylor University,c=US";
$db = NewADOConnection($dsn);

Interbase/Firebird

You define the database in the $host parameter:
    $conn = &ADONewConnection('ibase');
    $conn->PConnect('localhost:c:\ibase\employee.gdb','sysdba','masterkey');

Or dsn:

    $dsn = 'firebird://user:pwd@localhost/mydb?persist&dialect=3';  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

SQLite

Sqlite will create the database file if it does not exist.
    $conn = &ADONewConnection('sqlite');
    $conn->PConnect('c:\path\to\sqlite.db'); # sqlite will create if does not exist

Or dsn:

    $path = urlencode('c:\path\to\sqlite.db');
    $dsn = "sqlite://$path/?persist";  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

Oracle (oci8)

With oci8, you can connect in multiple ways. Note that oci8 works fine with newer versions of the Oracle, eg. 9i and 10g.

a. PHP and Oracle reside on the same machine, use default SID.

    $conn->Connect(false, 'scott', 'tiger');

b. TNS Name defined in tnsnames.ora (or ONAMES or HOSTNAMES), eg. 'myTNS'

    $conn->PConnect(false, 'scott', 'tiger', 'myTNS');

or

     $conn->PConnect('myTNS', 'scott', 'tiger');

c. Host Address and SID

    $conn->connectSID = true;
    $conn->Connect('192.168.0.1', 'scott', 'tiger', 'SID');

d. Host Address and Service Name

    $conn->Connect('192.168.0.1', 'scott', 'tiger', 'servicename');

e. Oracle connection string:

    $cstr = "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=$host)(PORT=$port))
            (CONNECT_DATA=(SID=$sid)))";
    $conn->Connect($cstr, 'scott', 'tiger');

f. ADOdb dsn:

    $dsn = 'oci8://user:pwd@tnsname/?persist';  # persist is optional
    $conn = ADONewConnection($dsn);  # no need for Connect/PConnect

    $dsn = 'oci8://user:pwd@host/sid';
    $conn = ADONewConnection($dsn);

    $dsn = 'oci8://user:pwd@/';   # oracle on local machine
    $conn = ADONewConnection($dsn);

You can also set the charSet for Oracle 9.2 and later, supported since PHP 4.3.2, ADOdb 4.54:

    $conn->charSet = 'we8iso8859p1';
    $conn->Connect(...);

    # or
    $dsn = 'oci8://user:pwd@tnsname/?charset=WE8MSWIN1252';
    $db = ADONewConnection($dsn);

DSN-less ODBC ( Access, MSSQL and DB2 examples)

ODBC DSN's can be created in the ODBC control panel, or you can use a DSN-less connection.To use DSN-less connections with ODBC you need PHP 4.3 or later.

For Microsoft Access:

    $db =& ADONewConnection('access');
    $dsn = "Driver={Microsoft Access Driver (*.mdb)};Dbq=d:\\northwind.mdb;Uid=Admin;Pwd=;";
    $db->Connect($dsn);
For Microsoft SQL Server:
    $db =& ADONewConnection('odbc_mssql');
    $dsn = "Driver={SQL Server};Server=localhost;Database=northwind;";
    $db->Connect($dsn,'userid','password');
or if you prefer to use the mssql extension (which is limited to mssql 6.5 functionality):
    $db =& ADONewConnection('mssql');
    $db->Execute('localhost', 'userid', 'password', 'northwind');
For DB2:
    $dbms = 'db2'; # or 'odbc_db2' if db2 extension not available
    $db =& ADONewConnection($dbms);
    $dsn = "driver={IBM db2 odbc DRIVER};Database=sample;hostname=localhost;port=50000;protocol=TCPIP;".
                "uid=root; pwd=secret";
    $db->Connect($dsn);
DSN-less Connections with ADO
If you are using versions of PHP earlier than PHP 4.3.0, DSN-less connections only work with Microsoft's ADO, which is Microsoft's COM based API. An example using the ADOdb library and Microsoft's ADO:
<?php
    include('adodb.inc.php');
    $db = &ADONewConnection("ado_mssql");
    print "<h1>Connecting DSN-less $db->databaseType...</h1>";

    $myDSN="PROVIDER=MSDASQL;DRIVER={SQL Server};"
        . "SERVER=flipper;DATABASE=ai;UID=sa;PWD=;"  ;
    $db->Connect($myDSN);

    $rs = $db->Execute("select * from table");
    $arr = $rs->GetArray();
    print_r($arr);
?>

High Speed ADOdb - tuning tips

ADOdb is a big class library, yet it consistently beats all other PHP class libraries in performance. This is because it is designed in a layered fashion, like an onion, with the fastest functions in the innermost layer. Stick to the following functions for best performance:

Innermost Layer

Connect, PConnect, NConnect
Execute, CacheExecute
SelectLimit, CacheSelectLimit
MoveNext, Close
qstr, Affected_Rows, Insert_ID

The fastest way to access the field data is by accessing the array $recordset->fields directly. Also set the global variables $ADODB_FETCH_MODE = ADODB_FETCH_NUM, and (for oci8, ibase/firebird and odbc) $ADODB_COUNTRECS = false before you connect to your database.

Consider using bind parameters if your database supports it, as it improves query plan reuse. Use ADOdb's performance tuning system to identify bottlenecks quickly. At the time of writing (Dec 2003), this means oci8 and odbc drivers.

Lastly make sure you have a PHP accelerator cache installed such as APC, Turck MMCache, Zend Accelerator or ionCube.

Some examples:

Fastest data retrieval using PHP Fastest data retrieval using ADOdb extension
$rs =& $rs->Execute($sql);
while (!$rs->EOF) {
    var_dump($rs->fields);
    $rs->MoveNext();
}

$rs =& $rs->Execute($sql);
$array = adodb_getall($rs);
var_dump($array);

Advanced Tips

If you have the ADOdb C extension installed, you can replace your calls to $rs->MoveNext() with adodb_movenext($rs). This doubles the speed of this operation. For retrieving entire recordsets at once, use GetArray(), which uses the high speed extension function adodb_getall($rs) internally.

Execute() is the default way to run queries. You can use the low-level functions _Execute() and _query() to reduce query overhead. Both these functions share the same parameters as Execute().

If you do not have any bind parameters or your database supports binding (without emulation), then you can call _Execute() directly. Calling this function bypasses bind emulation. Debugging is still supported in _Execute().

If you do not require debugging facilities nor emulated binding, and do not require a recordset to be returned, then you can call _query. This is great for inserts, updates and deletes. Calling this function bypasses emulated binding, debugging, and recordset handling. Either the resultid, true or false are returned by _query().

For Informix, you can disable scrollable cursors with $db->cursorType = 0.

Hacking ADOdb Safely

You might want to modify ADOdb for your own purposes. Luckily you can still maintain backward compatibility by sub-classing ADOdb and using the $ADODB_NEWCONNECTION variable. $ADODB_NEWCONNECTION allows you to override the behaviour of ADONewConnection(). ADOConnection() checks for this variable and will call the function-name stored in this variable if it is defined.

In the following example, new functionality for the connection object is placed in the hack_mysql and hack_postgres7 classes. The recordset class naming convention can be controlled using $rsPrefix. Here we set it to 'hack_rs_', which will make ADOdb use hack_rs_mysql and hack_rs_postgres7 as the recordset classes.

class hack_mysql extends adodb_mysql {
var $rsPrefix = 'hack_rs_';
  /* Your mods here */
}

class hack_rs_mysql extends ADORecordSet_mysql {
     /* Your mods here */
}

class hack_postgres7 extends adodb_postgres7 {
var $rsPrefix = 'hack_rs_';
  /* Your mods here */
}

class hack_rs_postgres7 extends ADORecordSet_postgres7 {
 /* Your mods here */
}

$ADODB_NEWCONNECTION = 'hack_factory';

function& hack_factory($driver)
{
    if ($driver !== 'mysql' && $driver !== 'postgres7') return false;

    $driver = 'hack_'.$driver;
    $obj = new $driver();
    return $obj;
}

include_once('adodb.inc.php');

Don't forget to call the constructor of the parent class in your constructor. If you want to use the default ADOdb drivers return false in the above hack_factory() function.

PHP5 Features

ADOdb 4.02 or later will transparently determine which version of PHP you are using. If PHP5 is detected, the following features become available:
  • PDO: PDO drivers are available. See the connection examples. Currently PDO drivers are not as powerful as native drivers, and should be treated as experimental.

  • Foreach iterators: This is a very natural way of going through a recordset:
        $ADODB_FETCH_MODE = ADODB_FETCH_NUM;
        $rs = $db->Execute($sql);
        foreach($rs as $k => $row) {
            echo "r1=".$row[0]." r2=".$row[1]."<br>";
        }

  • Exceptions: Just include adodb-exceptions.inc.php and you can now catch exceptions on errors as they occur.
        include("../adodb-exceptions.inc.php");
        include("../adodb.inc.php");
        try {
            $db = NewADOConnection("oci8");
            $db->Connect('','scott','bad-password');
        } catch (exception $e) {
            var_dump($e);
            adodb_backtrace($e->gettrace());
        }

    Note that reaching EOF is not considered an error nor an exception.

Databases Supported

The name below is the value you pass to NewADOConnection($name) to create a connection object for that database.

Name | Tested | Database | RecordCount() usable | Prerequisites | Operating Systems
access | B | Microsoft Access/Jet. You need to create an ODBC DSN. | Y/N | ODBC | Windows only
ado B

Generic ADO, not tuned for specific databases. Allows DSN-less connections. For best performance, use an OLEDB provider. This is the base class for all ado drivers.

You can set $db->codePage before connecting.

 ? depends on database ADO or OLEDB provider Windows only
ado_access | B | Microsoft Access/Jet using ADO. Allows DSN-less connections. For best performance, use an OLEDB provider. | Y/N | ADO or OLEDB provider | Windows only
ado_mssql | B | Microsoft SQL Server using ADO. Allows DSN-less connections. For best performance, use an OLEDB provider. | Y/N | ADO or OLEDB provider | Windows only
db2 C Uses PHP's db2-specific extension for better performance. Y/N DB2 CLI/ODBC interface

Unix and Windows. Requires IBM DB2 Universal Database client.
odbc_db2 C Connects to DB2 using generic ODBC extension. Y/N DB2 CLI/ODBC interface

Unix and Windows. Unix install hints. I have had reports that the $host and $database params have to be reversed in Connect() when using the CLI interface.
vfp | A | Microsoft Visual FoxPro. You need to create an ODBC DSN. | Y/N | ODBC | Windows only
fbsql C FrontBase. Y ?

Unix and Windows
ibase B Interbase 6 or earlier. Some users report you might need to use this
$db->PConnect('localhost:c:/ibase/employee.gdb', "sysdba", "masterkey") to connect. Lacks Affected_Rows currently.

You can set $db->role, $db->dialect, $db->buffers and $db->charSet before connecting. 		Y/N Interbase client Unix and Windows
firebird | C | Firebird version of interbase. | Y/N | Interbase client | Unix and Windows
borland_ibase | C | Borland version of Interbase 6.5 or later. Very sad that the forks differ. | Y/N | Interbase client | Unix and Windows
informix | C | Generic informix driver. Use this if you are using Informix 7.3 or later. | Y/N | Informix client | Unix and Windows
informix72 | C | Informix databases before Informix 7.3 that do no support SELECT FIRST. | Y/N | Informix client | Unix and Windows
ldap C LDAP driver. See this example for usage information. LDAP extension ?
mssql A

Microsoft SQL Server 7 and later. Works with Microsoft SQL Server 2000 also. Note that date formating is problematic with this driver. For example, the PHP mssql extension does not return the seconds for datetime!

 Y/N Mssql client

Unix and Windows.
Unix install howto and another one.

mssqlpo A

Portable mssql driver. Identical to above mssql driver, except that '||', the concatenation operator, is converted to '+'. Useful for porting scripts from most other sql variants that use ||.

 Y/N Mssql client

Unix and Windows.
Unix install howto.
mysql | A | MySQL without transaction support. You can also set $db->clientFlags before connecting. | Y | MySQL client | Unix and Windows
mysqlt or maxsql A

MySQL with transaction support. We recommend using || as the concat operator for best portability. This can be done by running MySQL using:
mysqld --ansi or mysqld --sql-mode=PIPES_AS_CONCAT

 Y/N MySQL client Unix and Windows
oci8 A Oracle 8/9. Has more functionality than oracle driver (eg. Affected_Rows). You might have to putenv('ORACLE_HOME=...') before Connect/PConnect.

There are 2 ways of connecting - with server IP and service name:
PConnect('serverip:1521','scott','tiger','service')
or using an entry in TNSNAMES.ORA or ONAMES or HOSTNAMES:
PConnect(false, 'scott', 'tiger', $oraname).

Since 2.31, we support Oracle REF cursor variables directly (see ExecuteCursor).

Y/N Oracle client Unix and Windows
oci805 | C | Supports reduced Oracle functionality for Oracle 8.0.5. SelectLimit is not as efficient as in the oci8 or oci8po drivers. | Y/N | Oracle client | Unix and Windows
oci8po A Oracle 8/9 portable driver. This is nearly identical with the oci8 driver except (a) bind variables in Prepare() use the ? convention, instead of :bindvar, (b) field names use the more common PHP convention of lowercase names.

Use this driver if porting from other databases is important. Otherwise the oci8 driver offers better performance.

Y/N Oracle client Unix and Windows
odbc A Generic ODBC, not tuned for specific databases. To connect, use
PConnect('DSN','user','pwd'). This is the base class for all odbc derived drivers. 		? depends on database ODBC Unix and Windows. Unix hints.
odbc_mssql | C | Uses ODBC to connect to MSSQL | Y/N | ODBC | Unix and Windows.
odbc_oracle | C | Uses ODBC to connect to Oracle | Y/N | ODBC | Unix and Windows.
odbtp | C | Generic odbtp driver. Odbtp is a software for accessing Windows ODBC data sources from other operating systems. | Y/N | odbtp | Unix and Windows
odbtp_unicode | C | Odtbp with unicode support | Y/N | odbtp | Unix and Windows
oracle | C | Implements old Oracle 7 client API. Use oci8 driver if possible for better performance. | Y/N | Oracle client | Unix and Windows
netezza C Netezza driver. Netezza is based on postgres code-base. Y ? ?
pdo | C | Generic PDO driver for PHP5. | Y | PDO extension and database specific drivers | Unix and Windows.
postgres | A | Generic PostgreSQL driver. Currently identical to postgres7 driver. | Y | PostgreSQL client | Unix and Windows.
postgres64 | A | For PostgreSQL 6.4 and earlier which does not support LIMIT internally. | Y | PostgreSQL client | Unix and Windows.
postgres7 | A | PostgreSQL which supports LIMIT and other version 7 functionality. | Y | PostgreSQL client | Unix and Windows.
postgres8 | A | PostgreSQL which supports version 8 functionality. | Y | PostgreSQL client | Unix and Windows.
sapdb C SAP DB. Should work reliably as based on ODBC driver. Y/N SAP ODBC client

?
sqlanywhere C Sybase SQL Anywhere. Should work reliably as based on ODBC driver. Y/N SQL Anywhere ODBC client

?
sqlite B SQLite. Y -

Unix and Windows.
sqlitepo B Portable SQLite driver. This is because assoc mode does not work like other drivers in sqlite. Namely, when selecting (joining) multiple tables, the table names are included in the assoc keys in the "sqlite" driver.

In "sqlitepo" driver, the table names are stripped from the returned column names. When this results in a conflict, the first field get preference.

Y -

Unix and Windows.
sybase C Sybase. Y/N Sybase client

Unix and Windows.
sybase_ase C Sybase ASE. Y/N Sybase client

Unix and Windows.

The "Tested" column indicates how extensively the code has been tested and used.
A = well tested and used by many people
B = tested and usable, but some features might not be implemented
C = user contributed or experimental driver. Might not fully support all of the latest features of ADOdb.

The column "RecordCount() usable" indicates whether RecordCount() return the number of rows, or returns -1 when a SELECT statement is executed. If this column displays Y/N then the RecordCount() is emulated when the global variable $ADODB_COUNTRECS=true (this is the default). Note that for large recordsets, it might be better to disable RecordCount() emulation because substantial amounts of memory are required to cache the recordset for counting. Also there is a speed penalty of 40-50% if emulation is required. This is emulated in most databases except for PostgreSQL and MySQL. This variable is checked every time a query is executed, so you can selectively choose which recordsets to count.

Tutorials

Example 1: Select Statement

Task: Connect to the Access Northwind DSN, display the first 2 columns of each row.

In this example, we create a ADOConnection object, which represents the connection to the database. The connection is initiated with PConnect, which is a persistent connection. Whenever we want to query the database, we call the ADOConnection.Execute() function. This returns an ADORecordSet object which is actually a cursor that holds the current row in the array fields[]. We use MoveNext() to move from row to row.

NB: A useful function that is not used in this example is SelectLimit, which allows us to limit the number of rows shown.

<?
include('adodb.inc.php');	   # load code common to ADOdb
$conn = &ADONewConnection('access');	# create a connection
$conn->PConnect('northwind');   # connect to MS-Access, northwind DSN
$recordSet = &$conn->Execute('select * from products');
if (!$recordSet)
    print $conn->ErrorMsg();
else
while (!$recordSet->EOF) {
    print $recordSet->fields[0].' '.$recordSet->fields[1].'<BR>';
    $recordSet->MoveNext();
}

$recordSet->Close(); # optional
$conn->Close(); # optional

?>

The $recordSet returned stores the current row in the $recordSet->fields array, indexed by column number (starting from zero). We use the MoveNext() function to move to the next row. The EOF property is set to true when end-of-file is reached. If an error occurs in Execute(), we return false instead of a recordset.

The $recordSet->fields[] array is generated by the PHP database extension. Some database extensions only index by number and do not index the array by field name. To force indexing by name - that is associative arrays - use the SetFetchMode function. Each recordset saves and uses whatever fetch mode was set when the recordset was created in Execute() or SelectLimit().

    $db->SetFetchMode(ADODB_FETCH_NUM);
    $rs1 = $db->Execute('select * from table');
    $db->SetFetchMode(ADODB_FETCH_ASSOC);
    $rs2 = $db->Execute('select * from table');
    print_r($rs1->fields); # shows array([0]=>'v0',[1] =>'v1')
    print_r($rs2->fields); # shows array(['col1']=>'v0',['col2'] =>'v1')

To get the number of rows in the select statement, you can use $recordSet->RecordCount(). Note that it can return -1 if the number of rows returned cannot be determined.

Example 2: Advanced Select with Field Objects

Select a table, display the first two columns. If the second column is a date or timestamp, reformat the date to US format.

<?
include('adodb.inc.php');	   # load code common to ADOdb
$conn = &ADONewConnection('access');	# create a connection
$conn->PConnect('northwind');   # connect to MS-Access, northwind dsn
$recordSet = &$conn->Execute('select CustomerID,OrderDate from Orders');
if (!$recordSet)
    print $conn->ErrorMsg();
else
while (!$recordSet->EOF) {
    $fld = $recordSet->FetchField(1);
    $type = $recordSet->MetaType($fld->type);

    if ( $type == 'D' || $type == 'T')
        print $recordSet->fields[0].' '.
            $recordSet->UserDate($recordSet->fields[1],'m/d/Y').'<BR>';
    else
        print $recordSet->fields[0].' '.$recordSet->fields[1].'<BR>';

    $recordSet->MoveNext();
}
$recordSet->Close(); # optional
$conn->Close(); # optional

?>

In this example, we check the field type of the second column using FetchField(). This returns an object with at least 3 fields.

  • name: name of column
  • type: native field type of column
  • max_length: maximum length of field. Some databases such as MySQL do not return the maximum length of the field correctly. In these cases max_length will be set to -1.

We then use MetaType() to translate the native type to a generic type. Currently the following generic types are defined:

  • C: character fields that should be shown in a <input type="text"> tag.
  • X: TeXt, large text fields that should be shown in a <textarea>
  • B: Blobs, or Binary Large Objects. Typically images.
  • D: Date field
  • T: Timestamp field
  • L: Logical field (boolean or bit-field)
  • I: Integer field
  • N: Numeric field. Includes autoincrement, numeric, floating point, real and integer.
  • R: Serial field. Includes serial, autoincrement integers. This works for selected databases.

If the metatype is of type date or timestamp, then we print it using the user defined date format with UserDate(), which converts the PHP SQL date string format to a user defined one. Another use for MetaType() is data validation before doing an SQL insert or update.

Example 3: Inserting

Insert a row to the Orders table containing dates and strings that need to be quoted before they can be accepted by the database, eg: the single-quote in the word John's.

<?
include('adodb.inc.php');	   # load code common to ADOdb
$conn = &ADONewConnection('access');	# create a connection

$conn->PConnect('northwind');   # connect to MS-Access, northwind dsn
$shipto = $conn->qstr("John's Old Shoppe");

$sql = "insert into orders (customerID,EmployeeID,OrderDate,ShipName) ";
$sql .= "values ('ANATR',2,".$conn->DBDate(time()).",$shipto)";

if ($conn->Execute($sql) === false) {
    print 'error inserting: '.$conn->ErrorMsg().'<BR>';
}
?>

In this example, we see the advanced date and quote handling facilities of ADOdb. The unix timestamp (which is a long integer) is appropriately formated for Access with DBDate(), and the right escape character is used for quoting the John's Old Shoppe, which is John''s Old Shoppe and not PHP's default John's Old Shoppe with qstr().

Observe the error-handling of the Execute statement. False is returned by Execute() if an error occured. The error message for the last error that occurred is displayed in ErrorMsg(). Note: php_track_errors might have to be enabled for error messages to be saved.

Example 4: Debugging

<?
include('adodb.inc.php');	   # load code common to ADOdb
$conn = &ADONewConnection('access');	# create a connection
$conn->PConnect('northwind');   # connect to MS-Access, northwind dsn
$shipto = $conn->qstr("John's Old Shoppe");
$sql = "insert into orders (customerID,EmployeeID,OrderDate,ShipName) ";
$sql .= "values ('ANATR',2,".$conn->FormatDate(time()).",$shipto)";
$conn->debug = true;
if ($conn->Execute($sql) === false) print 'error inserting';
?>

In the above example, we have turned on debugging by setting debug = true. This will display the SQL statement before execution, and also show any error messages. There is no need to call ErrorMsg() in this case. For displaying the recordset, see the rs2html() example.

Also see the section on Custom Error Handlers.

Example 5: MySQL and Menus

Connect to MySQL database agora, and generate a <select> menu from an SQL statement where the <option> captions are in the 1st column, and the value to send back to the server is in the 2nd column.

<?
include('adodb.inc.php'); # load code common to ADOdb
$conn = &ADONewConnection('mysql');  # create a connection
$conn->PConnect('localhost','userid','','agora');# connect to MySQL, agora db
$sql = 'select CustomerName, CustomerID from customers';
$rs = $conn->Execute($sql);
print $rs->GetMenu('GetCust','Mary Rosli');
?>

Here we define a menu named GetCust, with the menu option 'Mary Rosli' selected. See GetMenu (). We also have functions that return the recordset as an array: GetArray(), and as an associative array with the key being the first column: GetAssoc().

Example 6: Connecting to 2 Databases At Once

<?
include('adodb.inc.php');	 # load code common to ADOdb
$conn1 = &ADONewConnection('mysql');  # create a mysql connection
$conn2 = &ADONewConnection('oracle');  # create a oracle connection

$conn1->PConnect($server, $userid, $password, $database);
$conn2->PConnect(false, $ora_userid, $ora_pwd, $oraname);

$conn1->Execute('insert ...');
$conn2->Execute('update ...');
?>

Example 7: Generating Update and Insert SQL

Since ADOdb 4.56, we support AutoExecute(), which simplifies things by providing an advanced wrapper for GetInsertSQL() and GetUpdateSQL(). For example, an INSERT can be carried out with:

    $record["firstname"] = "Bob";
    $record["lastname"] = "Smith";
    $record["created"] = time();
    $insertSQL = $conn->AutoExecute($rs, $record, 'INSERT');
and an UPDATE with:
    $record["firstname"] = "Caroline";
    $record["lastname"] = "Smith"; # Update Caroline's lastname from Miranda to Smith
    $insertSQL = $conn->AutoExecute($rs, $record, 'UPDATE', 'id = 1');

The rest of this section is out-of-date:

ADOdb 1.31 and later supports two new recordset functions: GetUpdateSQL( ) and GetInsertSQL( ). This allow you to perform a "SELECT * FROM table query WHERE...", make a copy of the $rs->fields, modify the fields, and then generate the SQL to update or insert into the table automatically.

We show how the functions can be used when accessing a table with the following fields: (ID, FirstName, LastName, Created).

Before these functions can be called, you need to initialize the recordset by performing a select on the table. Idea and code by Jonathan Younger jyounger#unilab.com. Since ADOdb 2.42, you can pass a table name instead of a recordset into GetInsertSQL (in $rs), and it will generate an insert statement for that table.

<?
#==============================================
# SAMPLE GetUpdateSQL() and GetInsertSQL() code
#==============================================
include('adodb.inc.php');
include('tohtml.inc.php');

#==========================
# This code tests an insert

$sql = "SELECT * FROM ADOXYZ WHERE id = -1";
# Select an empty record from the database

$conn = &ADONewConnection("mysql");  # create a connection
$conn->debug=1;
$conn->PConnect("localhost", "admin", "", "test"); # connect to MySQL, testdb
$rs = $conn->Execute($sql); # Execute the query and get the empty recordset

$record = array(); # Initialize an array to hold the record data to insert

# Set the values for the fields in the record
# Note that field names are case-insensitive
$record["firstname"] = "Bob";
$record["lastNamE"] = "Smith";
$record["creaTed"] = time();

# Pass the empty recordset and the array containing the data to insert
# into the GetInsertSQL function. The function will process the data and return
# a fully formatted insert sql statement.
$insertSQL = $conn->GetInsertSQL($rs, $record);

$conn->Execute($insertSQL); # Insert the record into the database

#==========================
# This code tests an update

$sql = "SELECT * FROM ADOXYZ WHERE id = 1";
# Select a record to update

$rs = $conn->Execute($sql); # Execute the query and get the existing record to update

$record = array(); # Initialize an array to hold the record data to update

# Set the values for the fields in the record
# Note that field names are case-insensitive
$record["firstname"] = "Caroline";
$record["LasTnAme"] = "Smith"; # Update Caroline's lastname from Miranda to Smith

# Pass the single record recordset and the array containing the data to update
# into the GetUpdateSQL function. The function will process the data and return
# a fully formatted update sql statement with the correct WHERE clause.
# If the data has not changed, no recordset is returned
$updateSQL = $conn->GetUpdateSQL($rs, $record);

$conn->Execute($updateSQL); # Update the record in the database
$conn->Close();
?>
$ADODB_FORCE_TYPE

The behaviour of AutoExecute(), GetUpdateSQL() and GetInsertSQL() when converting empty or null PHP variables to SQL is controlled by the global $ADODB_FORCE_TYPE variable. Set it to one of the values below. Default is ADODB_FORCE_VALUE (3):

0 = ignore empty fields. All empty fields in array are ignored.
1 = force null. All empty, php null and string 'null' fields are changed to sql NULL values.
2 = force empty. All empty, php null and string 'null' fields are changed to sql empty '' or 0 values.
3 = force value. Value is left as it is. Php null and string 'null' are set to sql NULL values and
    empty fields '' are set to empty '' sql values.

define('ADODB_FORCE_IGNORE',0);
define('ADODB_FORCE_NULL',1);
define('ADODB_FORCE_EMPTY',2);
define('ADODB_FORCE_VALUE',3);

Thanks to Niko (nuko#mbnet.fi) for the $ADODB_FORCE_TYPE code.

Note: the constant ADODB_FORCE_NULLS is obsolete since 4.52 and is ignored. Set $ADODB_FORCE_TYPE = ADODB_FORCE_NULL for equivalent behaviour.

Since 4.62, the table name to be used can be overridden by setting $rs->tableName before AutoExecute(), GetInsertSQL() or GetUpdateSQL() is called.

Example 8: Implementing Scrolling with Next and Previous

The following code creates a very simple recordset pager, where you can scroll from page to page of a recordset.

include_once('../adodb.inc.php');
include_once('../adodb-pager.inc.php');
session_start();

$db = NewADOConnection('mysql');

$db->Connect('localhost','root','','xphplens');

$sql = "select * from adoxyz ";

$pager = new ADODB_Pager($db,$sql);
$pager->Render($rows_per_page=5);

This will create a basic record pager that looks like this:

|< << >> >|
ID | First Name | Last Name | Date Created
36 | Alan | Turing | Sat 06, Oct 2001
37 | Serena | Williams | Sat 06, Oct 2001
38 | Yat Sun | Sun | Sat 06, Oct 2001
39 | Wai Hun | See | Sat 06, Oct 2001
40 | Steven | Oey | Sat 06, Oct 2001
Page 8/10

The number of rows to display at one time is controled by the Render($rows) method. If you do not pass any value to Render(), ADODB_Pager will default to 10 records per page.

You can control the column titles by modifying your SQL (supported by most databases):

$sql = 'select id as "ID", firstname as "First Name",
          lastname as "Last Name", created as "Date Created"
        from adoxyz';

The above code can be found in the adodb/tests/testpaging.php example included with this release, and the class ADODB_Pager in adodb/adodb-pager.inc.php. The ADODB_Pager code can be adapted by a programmer so that the text links can be replaced by images, and the dull white background be replaced with more interesting colors.

You can also allow display of html by setting $pager->htmlSpecialChars = false.

Some of the code used here was contributed by Iván Oliva and Cornel G.

Example 9: Exporting in CSV or Tab-Delimited Format

We provide some helper functions to export in comma-separated-value (CSV) and tab-delimited formats:

include_once('/path/to/adodb/toexport.inc.php');
include_once('/path/to/adodb/adodb.inc.php');

$db = &NewADOConnection('mysql');
$db->Connect($server, $userid, $password, $database);

$rs = $db->Execute('select fname as "First Name", surname as "Surname" from table');

print "<pre>";
print rs2csv($rs); # return a string, CSV format
print '<hr>';

$rs->MoveFirst(); # note, some databases do not support MoveFirst
print rs2tab($rs,false); # return a string, tab-delimited
                         # false == suppress field names in first line
print '<hr>';
$rs->MoveFirst();
rs2tabout($rs); # send to stdout directly (there is also an rs2csvout function)
print "</pre>";

$rs->MoveFirst();
$fp = fopen($path, "w");
if ($fp) {
  rs2csvfile($rs, $fp); # write to file (there is also an rs2tabfile function)
  fclose($fp);
}

Carriage-returns or newlines are converted to spaces. Field names are returned in the first line of text. Strings containing the delimiter character are quoted with double-quotes. Double-quotes are double-quoted again. This conforms to Excel import and export guide-lines.

All the above functions take as an optional last parameter, $addtitles which defaults to true. When set to false field names in the first line are suppressed.

Example 10: Recordset Filters

Sometimes we want to pre-process all rows in a recordset before we use it. For example, we want to ucwords all text in recordset.

include_once('adodb/rsfilter.inc.php');
include_once('adodb/adodb.inc.php');

// ucwords() every element in the recordset
function do_ucwords(&$arr,$rs)
{
    foreach($arr as $k => $v) {
        $arr[$k] = ucwords($v);
    }
}

$db = NewADOConnection('mysql');
$db->PConnect('server','user','pwd','db');

$rs = $db->Execute('select ... from table');
$rs = RSFilter($rs,'do_ucwords');

The RSFilter function takes 2 parameters, the recordset, and the name of the filter function. It returns the processed recordset scrolled to the first record. The filter function takes two parameters, the current row as an array, and the recordset object. For future compatibility, you should not use the original recordset object.

Example 11: Smart Transactions

The old way of doing transactions required you to use
$conn->BeginTrans();
$ok = $conn->Execute($sql);
if ($ok) $ok = $conn->Execute($sql2);
if (!$ok) $conn->RollbackTrans();
else $conn->CommitTrans();
This is very complicated for large projects because you have to track the error status. Smart Transactions is much simpler. You start a smart transaction by calling StartTrans():
$conn->StartTrans();
$conn->Execute($sql);
$conn->Execute($Sql2);
$conn->CompleteTrans();
CompleteTrans() detects when an SQL error occurs, and will Rollback/Commit as appropriate. To specificly force a rollback even if no error occured, use FailTrans(). Note that the rollback is done in CompleteTrans(), and not in FailTrans().
$conn->StartTrans();
$conn->Execute($sql);
if (!CheckRecords()) $conn->FailTrans();
$conn->Execute($Sql2);
$conn->CompleteTrans();

You can also check if a transaction has failed, using HasFailedTrans(), which returns true if FailTrans() was called, or there was an error in the SQL execution. Make sure you call HasFailedTrans() before you call CompleteTrans(), as it is only works between StartTrans/CompleteTrans.

Lastly, StartTrans/CompleteTrans is nestable, and only the outermost block is executed. In contrast, BeginTrans/CommitTrans/RollbackTrans is NOT nestable.

$conn->StartTrans();
$conn->Execute($sql);
  $conn->StartTrans();    # ignored
  if (!CheckRecords()) $conn->FailTrans();
  $conn->CompleteTrans(); # ignored
$conn->Execute($Sql2);
$conn->CompleteTrans();

Note: Savepoints are currently not supported.

Using Custom Error Handlers and PEAR_Error

ADOdb supports PHP5 exceptions. Just include adodb-exceptions.inc.php and you can now catch exceptions on errors as they occur.

    include("../adodb-exceptions.inc.php");
    include("../adodb.inc.php");
    try {
        $db = NewADOConnection("oci8://scott:bad-password@mytns/");
    } catch (exception $e) {
        var_dump($e);
        adodb_backtrace($e->gettrace());
    }

ADOdb also provides two custom handlers which you can modify for your needs. The first one is in the adodb-errorhandler.inc.php file. This makes use of the standard PHP functions error_reporting to control what error messages types to display, and trigger_error which invokes the default PHP error handler.

Including the above file will cause trigger_error($errorstring,E_USER_ERROR) to be called when
(a) Connect() or PConnect() fails, or
(b) a function that executes SQL statements such as Execute() or SelectLimit() has an error.
(c) GenID() appears to go into an infinite loop.

The $errorstring is generated by ADOdb and will contain useful debugging information similar to the error.log data generated below. This file adodb-errorhandler.inc.php should be included before you create any ADOConnection objects.

If you define error_reporting(0), no errors will be passed to the error handler. If you set error_reporting(E_ALL), all errors will be passed to the error handler. You still need to use ini_set("display_errors", "0" or "1") to control the display of errors.

<?php
error_reporting(E_ALL); # pass any error messages triggered to error handler
include('adodb-errorhandler.inc.php');
include('adodb.inc.php');
include('tohtml.inc.php');
$c = NewADOConnection('mysql');
$c->PConnect('localhost','root','','northwind');
$rs=$c->Execute('select * from productsz'); #invalid table productsz');
if ($rs) rs2html($rs);
?>

If you want to log the error message, you can do so by defining the following optional constants ADODB_ERROR_LOG_TYPE and ADODB_ERROR_LOG_DEST. ADODB_ERROR_LOG_TYPE is the error log message type (see error_log in the PHP manual). In this case we set it to 3, which means log to the file defined by the constant ADODB_ERROR_LOG_DEST.

<?php
error_reporting(E_ALL); # report all errors
ini_set("display_errors", "0"); # but do not echo the errors
define('ADODB_ERROR_LOG_TYPE',3);
define('ADODB_ERROR_LOG_DEST','C:/errors.log');
include('adodb-errorhandler.inc.php');
include('adodb.inc.php');
include('tohtml.inc.php');

$c = NewADOConnection('mysql');
$c->PConnect('localhost','root','','northwind');
$rs=$c->Execute('select * from productsz'); ## invalid table productsz
if ($rs) rs2html($rs);
?>
The following message will be logged in the error.log file:
(2001-10-28 14:20:38) mysql error: [1146: Table 'northwind.productsz' doesn't exist] in
 EXECUTE("select * from productsz")

PEAR_ERROR

The second error handler is adodb-errorpear.inc.php. This will create a PEAR_Error derived object whenever an error occurs. The last PEAR_Error object created can be retrieved using ADODB_Pear_Error().
<?php
include('adodb-errorpear.inc.php');
include('adodb.inc.php');
include('tohtml.inc.php');
$c = NewADOConnection('mysql');
$c->PConnect('localhost','root','','northwind');
$rs=$c->Execute('select * from productsz'); #invalid table productsz');
if ($rs) rs2html($rs);
else {
    $e = ADODB_Pear_Error();
    echo '<p>',$e->message,'</p>';
}
?>

You can use a PEAR_Error derived class by defining the constant ADODB_PEAR_ERROR_CLASS before the adodb-errorpear.inc.php file is included. For easy debugging, you can set the default error handler in the beginning of the PHP script to PEAR_ERROR_DIE, which will cause an error message to be printed, then halt script execution:

include('PEAR.php');
PEAR::setErrorHandling('PEAR_ERROR_DIE');

Note that we do not explicitly return a PEAR_Error object to you when an error occurs. We return false instead. You have to call ADODB_Pear_Error() to get the last error or use the PEAR_ERROR_DIE technique.

MetaError and MetaErrMsg

If you need error messages that work across multiple databases, then use MetaError(), which returns a virtualized error number, based on PEAR DB's error number system, and MetaErrMsg().

Error Messages

Error messages are outputted using the static method ADOConnnection::outp($msg,$newline=true). By default, it sends the messages to the client. You can override this to perform error-logging.

Data Source Names

We now support connecting using PEAR style DSN's. A DSN is a connection string of the form:

$dsn = "$driver://$username:$password@$hostname/$databasename";

An example:

   $username = 'root';
   $password = '';
   $hostname = 'localhost';
   $databasename = 'xphplens';
   $driver = 'mysql';
   $dsn = "$driver://$username:$password@$hostname/$databasename"
   $db = NewADOConnection();
   # DB::Connect($dsn) also works if you include 'adodb/adodb-pear.inc.php' at the top
   $rs = $db->query('select firstname,lastname from adoxyz');
   $cnt = 0;
   while ($arr = $rs->fetchRow()) {
        print_r($arr); print "<br>";
   }

More info and connection examples on the DSN format.

PEAR Compatibility

We support DSN's (see above), and the following functions:
 DB_Common
     query - returns PEAR_Error on error
    limitQuery - return PEAR_Error on error
    prepare - does not return PEAR_Error on error
    execute - does not return PEAR_Error on error
    setFetchMode - supports ASSOC and ORDERED
    errorNative
    quote
    nextID
    disconnect

    getOne
    getAssoc
    getRow
    getCol

 DB_Result
     numRows - returns -1 if not supported
    numCols
    fetchInto - does not support passing of fetchmode
    fetchRows - does not support passing of fetchmode
    free

Caching of Recordsets

ADOdb now supports caching of recordsets using the CacheExecute( ), CachePageExecute( ) and CacheSelectLimit( ) functions. There are similar to the non-cache functions, except that they take a new first parameter, $secs2cache.

An example:

include('adodb.inc.php'); # load code common to ADOdb
$ADODB_CACHE_DIR = '/usr/ADODB_cache';
$conn = &ADONewConnection('mysql');  # create a connection
$conn->PConnect('localhost','userid','','agora');# connect to MySQL, agora db
$sql = 'select CustomerName, CustomerID from customers';
$rs = $conn->CacheExecute(15,$sql);

The first parameter is the number of seconds to cache the query. Subsequent calls to that query will used the cached version stored in $ADODB_CACHE_DIR. To force a query to execute and flush the cache, call CacheExecute() with the first parameter set to zero. Alternatively, use the CacheFlush($sql) call.

For the sake of security, we recommend you set register_globals=off in php.ini if you are using $ADODB_CACHE_DIR.

In ADOdb 1.80 onwards, the secs2cache parameter is optional in CacheSelectLimit() and CacheExecute(). If you leave it out, it will use the $connection->cacheSecs parameter, which defaults to 60 minutes.

    $conn->Connect(...);
    $conn->cacheSecs = 3600*24; # cache 24 hours
    $rs = $conn->CacheExecute('select * from table');

Please note that magic_quotes_runtime should be turned off. More info, and do not change $ADODB_FETCH_MODE (or SetFetchMode) as the cached recordset will use the $ADODB_FETCH_MODE set when the query was executed.

Pivot Tables

Since ADOdb 2.30, we support the generation of SQL to create pivot tables, also known as cross-tabulations. For further explanation read this DevShed Cross-Tabulation tutorial. We assume that your database supports the SQL case-when expression.

In this example, we will use the Northwind database from Microsoft. In the database, we have a products table, and we want to analyze this table by suppliers versus product categories. We will place the suppliers on each row, and pivot on categories. So from the table on the left, we generate the pivot-table on the right:

Supplier | Category
supplier1 | category1
supplier2 | category1
supplier2 | category2
 -->
 | category1 | category2 | total
supplier1 | 1 | 0 | 1
supplier2 | 1 | 1 | 2

The following code will generate the SQL for a cross-tabulation:

# Query the main "product" table
# Set the rows to SupplierName
# and the columns to the values of Categories
# and define the joins to link to lookup tables
# "categories" and "suppliers"
#
 include "adodb/pivottable.inc.php";
 $sql = PivotTableSQL(
     $gDB,                                      # adodb connection
     'products p ,categories c ,suppliers s',   # tables
    'SupplierName',                             # rows (multiple fields allowed)
    'CategoryName',                            # column to pivot on
    'p.CategoryID = c.CategoryID and s.SupplierID= p.SupplierID' # joins/where
);

This will generate the following SQL:

SELECT SupplierName,
SUM(CASE WHEN CategoryName='Beverages' THEN 1 ELSE 0 END) AS "Beverages",
SUM(CASE WHEN CategoryName='Condiments' THEN 1 ELSE 0 END) AS "Condiments",
SUM(CASE WHEN CategoryName='Confections' THEN 1 ELSE 0 END) AS "Confections",
SUM(CASE WHEN CategoryName='Dairy Products' THEN 1 ELSE 0 END) AS "Dairy
  Products",
SUM(CASE WHEN CategoryName='Grains/Cereals' THEN 1 ELSE 0 END) AS "Grains/Cereals",
SUM(CASE WHEN CategoryName='Meat/Poultry' THEN 1 ELSE 0 END) AS "Meat/Poultry",
SUM(CASE WHEN CategoryName='Produce' THEN 1 ELSE 0 END) AS "Produce",
SUM(CASE WHEN CategoryName='Seafood' THEN 1 ELSE 0 END) AS "Seafood",
SUM(1) as Total
FROM products p ,categories c ,suppliers s WHERE p.CategoryID = c.CategoryID
  and s.SupplierID= p.SupplierID
GROUP BY SupplierName

You can also pivot on numerical columns and generate totals by using ranges. This code was revised in ADODB 2.41 and is not backward compatible. The second example shows this:

 $sql = PivotTableSQL(
     $gDB,                                       # adodb connection
     'products p ,categories c ,suppliers s',    # tables
    'SupplierName',                              # rows (multiple fields allowed)
   array(                                       # column ranges
    ' 0 '      => 'UnitsInStock <= 0',
    "1 to 5"   => '0 < UnitsInStock and UnitsInStock <= 5',
    "6 to 10"  => '5 < UnitsInStock and UnitsInStock <= 10',
    "11 to 15" => '10 < UnitsInStock and UnitsInStock <= 15',
    "16+"      => '15 < UnitsInStock'
    ),
    ' p.CategoryID = c.CategoryID and s.SupplierID= p.SupplierID', # joins/where
    'UnitsInStock',                             # sum this field
    'Sum '                                      # sum label prefix
);

Which generates:

SELECT SupplierName,
SUM(CASE WHEN UnitsInStock <= 0 THEN UnitsInStock ELSE 0 END) AS "Sum 0 ",
SUM(CASE WHEN 0 < UnitsInStock and UnitsInStock <= 5 THEN UnitsInStock ELSE 0 END) AS "Sum 1 to 5",
SUM(CASE WHEN 5 < UnitsInStock and UnitsInStock <= 10 THEN UnitsInStock ELSE 0 END) AS "Sum 6 to 10",
SUM(CASE WHEN 10 < UnitsInStock and UnitsInStock <= 15 THEN UnitsInStock ELSE 0 END) AS "Sum 11 to 15",
SUM(CASE WHEN 15 < UnitsInStock THEN UnitsInStock ELSE 0 END) AS "Sum 16+",
SUM(UnitsInStock) AS "Sum UnitsInStock",
SUM(1) as Total,
FROM products p ,categories c ,suppliers s WHERE p.CategoryID = c.CategoryID and s.SupplierID= p.SupplierID
GROUP BY SupplierName

Class Reference

Function parameters with [ ] around them are optional.

Global Variables

$ADODB_COUNTRECS

If the database driver API does not support counting the number of records returned in a SELECT statement, the function RecordCount() is emulated when the global variable $ADODB_COUNTRECS is set to true, which is the default. We emulate this by buffering the records, which can take up large amounts of memory for big recordsets. Set this variable to false for the best performance. This variable is checked every time a query is executed, so you can selectively choose which recordsets to count.

$ADODB_CACHE_DIR

If you are using recordset caching, this is the directory to save your recordsets in. Define this before you call any caching functions such as CacheExecute( ). We recommend setting register_globals=off in php.ini if you use this feature for security reasons.

If you are using Unix and apache, you might need to set your cache directory permissions to something similar to the following:

chown -R apache /path/to/adodb/cache
chgrp -R apache /path/to/adodb/cache

$ADODB_ANSI_PADDING_OFF

Determines whether to right trim CHAR fields (and also VARCHAR for ibase/firebird). Set to true to trim. Default is false. Currently works for oci8po, ibase and firebird drivers. Added in ADOdb 4.01.

$ADODB_LANG

Determines the language used in MetaErrorMsg(). The default is 'en', for English. To find out what languages are supported, see the files in adodb/lang/adodb-$lang.inc.php, where $lang is the supported langauge.

$ADODB_FETCH_MODE

This is a global variable that determines how arrays are retrieved by recordsets. The recordset saves this value on creation (eg. in Execute( ) or SelectLimit( )), and any subsequent changes to $ADODB_FETCH_MODE have no affect on existing recordsets, only on recordsets created in the future.

The following constants are defined:

define('ADODB_FETCH_DEFAULT',0);
define('ADODB_FETCH_NUM',1);
define('ADODB_FETCH_ASSOC',2);
define('ADODB_FETCH_BOTH',3);

An example:

    $ADODB_FETCH_MODE = ADODB_FETCH_NUM;
    $rs1 = $db->Execute('select * from table');
    $ADODB_FETCH_MODE = ADODB_FETCH_ASSOC;
    $rs2 = $db->Execute('select * from table');
    print_r($rs1->fields); # shows array([0]=>'v0',[1] =>'v1')
    print_r($rs2->fields); # shows array(['col1']=>'v0',['col2'] =>'v1')

As you can see in the above example, both recordsets store and use different fetch modes based on the $ADODB_FETCH_MODE setting when the recordset was created by Execute().

If no fetch mode is predefined, the fetch mode defaults to ADODB_FETCH_DEFAULT. The behaviour of this default mode varies from driver to driver, so do not rely on ADODB_FETCH_DEFAULT. For portability, we recommend sticking to ADODB_FETCH_NUM or ADODB_FETCH_ASSOC. Many drivers do not support ADODB_FETCH_BOTH.

SetFetchMode Function

If you have multiple connection objects, and want to have different fetch modes for each connection, then use SetFetchMode. Once this function is called for a connection object, that connection object will ignore the global variable $ADODB_FETCH_MODE and will use the internal fetchMode property exclusively.

    $db->SetFetchMode(ADODB_FETCH_NUM);
    $rs1 = $db->Execute('select * from table');
    $db->SetFetchMode(ADODB_FETCH_ASSOC);
    $rs2 = $db->Execute('select * from table');
    print_r($rs1->fields); # shows array([0]=>'v0',[1] =>'v1')
    print_r($rs2->fields); # shows array(['col1']=>'v0',['col2'] =>'v1')

To retrieve the previous fetch mode, you can use check the $db->fetchMode property, or use the return value of SetFetchMode( ).

ADODB_ASSOC_CASE

You can control the associative fetch case for certain drivers which behave differently. For the sybase, oci8po, mssql, odbc and ibase drivers and all drivers derived from them, ADODB_ASSOC_CASE will by default generate recordsets where the field name keys are lower-cased. Use the constant ADODB_ASSOC_CASE to change the case of the keys. There are 3 possible values:

0 = assoc lowercase field names. $rs->fields['orderid']
1 = assoc uppercase field names. $rs->fields['ORDERID']
2 = use native-case field names. $rs->fields['OrderID'] -- this is the
    default since ADOdb 2.90

To use it, declare it before you incldue adodb.inc.php.

define('ADODB_ASSOC_CASE', 2); # use native-case for ADODB_FETCH_ASSOC
include('adodb.inc.php');

$ADODB_FORCE_TYPE

See the GetUpdateSQL tutorial.

ADOConnection

Object that performs the connection to the database, executes SQL statements and has a set of utility functions for standardising the format of SQL statements for issues such as concatenation and date formats.

ADOConnection Fields

databaseType: Name of the database system we are connecting to. Eg. odbc or mssql or mysql.

dataProvider: The underlying mechanism used to connect to the database. Normally set to native, unless using odbc or ado.

host: Name of server or data source name (DSN) to connect to.

database: Name of the database or to connect to. If ado is used, it will hold the ado data provider.

user: Login id to connect to database. Password is not saved for security reasons.

raiseErrorFn: Allows you to define an error handling function. See adodb-errorhandler.inc.php for an example.

debug: Set to true to make debug statements to appear.

concat_operator: Set to '+' or '||' normally. The operator used to concatenate strings in SQL. Used by the Concat function.

fmtDate: The format used by the DBDate function to send dates to the database. is '#Y-m-d#' for Microsoft Access, and ''Y-m-d'' for MySQL.

fmtTimeStamp: The format used by the DBTimeStamp function to send timestamps to the database.

true: The value used to represent true.Eg. '.T.'. for Foxpro, '1' for Microsoft SQL.

false: The value used to represent false. Eg. '.F.'. for Foxpro, '0' for Microsoft SQL.

replaceQuote: The string used to escape quotes. Eg. double single-quotes for Microsoft SQL, and backslash-quote for MySQL. Used by qstr.

autoCommit: indicates whether automatic commit is enabled. Default is true.

charSet: set the default charset to use. Currently only interbase/firebird supports this.

dialect: set the default sql dialect to use. Currently only interbase/firebird supports this.

role: set the role. Currently only interbase/firebird supports this.

metaTablesSQL: SQL statement to return a list of available tables. Eg. SHOW TABLES in MySQL.

genID: The latest id generated by GenID() if supported by the database.

cacheSecs: The number of seconds to cache recordsets if CacheExecute() or CacheSelectLimit() omit the $secs2cache parameter. Defaults to 60 minutes.

sysDate: String that holds the name of the database function to call to get the current date. Useful for inserts and updates.

sysTimeStamp: String that holds the name of the database function to call to get the current timestamp/datetime value.

leftOuter: String that holds operator for left outer join, if known. Otherwise set to false.

rightOuter: String that holds operator for left outer join, if known. Otherwise set to false.

ansiOuter: Boolean that if true indicates that ANSI style outer joins are permitted. Eg. select * from table1 left join table2 on p1=p2.

connectSID: Boolean that indicates whether to treat the $database parameter in connects as the SID for the oci8 driver. Defaults to false. Useful for Oracle 8.0.5 and earlier.

autoRollback: Persistent connections are auto-rollbacked in PConnect( ) if this is set to true. Default is false.

ADOConnection Main Functions

ADOConnection( )

Constructor function. Do not call this directly. Use ADONewConnection( ) instead.

Connect($host,[$user],[$password],[$database])

Non-persistent connect to data source or server $host, using userid $user and password $password. If the server supports multiple databases, connect to database $database.

Returns true/false depending on connection success. Since 4.23, null is returned if the extension is not loaded.

ADO Note: If you are using a Microsoft ADO and not OLEDB, you can set the $database parameter to the OLEDB data provider you are using.

PostgreSQL: An alternative way of connecting to the database is to pass the standard PostgreSQL connection string in the first parameter $host, and the other parameters will be ignored.

For Oracle and Oci8, there are two ways to connect. First is to use the TNS name defined in your local tnsnames.ora (or ONAMES or HOSTNAMES). Place the name in the $database field, and set the $host field to false. Alternatively, set $host to the server, and $database to the database SID, this bypassed tnsnames.ora.

Examples:

 # $oraname in tnsnames.ora/ONAMES/HOSTNAMES
 $conn->Connect(false, 'scott', 'tiger', $oraname);
 $conn->Connect('server:1521', 'scott', 'tiger', 'ServiceName'); # bypass tnsnames.ora

There are many examples of connecting to a database. See Connection Examples for many examples.

PConnect($host,[$user],[$password],[$database])

Persistent connect to data source or server $host, using userid $user and password $password. If the server supports multiple databases, connect to database $database.

We now perform a rollback on persistent connection for selected databases since 2.21, as advised in the PHP manual. See change log or source code for which databases are affected.

Returns true/false depending on connection. Since 4.23, 0 is returned if the extension is not loaded. See Connect( ) above for more info.

Since ADOdb 2.21, we also support autoRollback. If you set:

 $conn = &NewADOConnection('mysql');
 $conn->autoRollback = true; # default is false
 $conn->PConnect(...); # rollback here

Then when doing a persistent connection with PConnect( ), ADOdb will perform a rollback first. This is because it is documented that PHP is not guaranteed to rollback existing failed transactions when persistent connections are used. This is implemented in Oracle, MySQL, PgSQL, MSSQL, ODBC currently.

Since ADOdb 3.11, you can force non-persistent connections even if PConnect is called by defining the constant ADODB_NEVER_PERSIST before you call PConnect.

Since 4.23, null is returned if the extension is not loaded.

NConnect($host,[$user],[$password],[$database])

Always force a new connection. In contrast, PHP sometimes reuses connections when you use Connect() or PConnect(). Currently works only on mysql (PHP 4.3.0 or later), postgresql and oci8-derived drivers. For other drivers, NConnect() works like Connect().

IsConnected( )

Returns true if connected to database. Added in 4.53.

Execute($sql,$inputarr=false)

Execute SQL statement $sql and return derived class of ADORecordSet if successful. Note that a record set is always returned on success, even if we are executing an insert or update statement. You can also pass in $sql a statement prepared in Prepare().

Returns derived class of ADORecordSet. Eg. if connecting via mysql, then ADORecordSet_mysql would be returned. False is returned if there was an error in executing the sql.

The $inputarr parameter can be used for binding variables to parameters. Below is an Oracle example:

 $conn->Execute("SELECT * FROM TABLE WHERE COND=:val", array('val'=> $val));

Another example, using ODBC,which uses the ? convention:

  $conn->Execute("SELECT * FROM TABLE WHERE COND=?", array($val));
Binding variables

Variable binding speeds the compilation and caching of SQL statements, leading to higher performance. Currently Oracle, Interbase and ODBC supports variable binding. Interbase/ODBC style ? binding is emulated in databases that do not support binding. Note that you do not have to quote strings if you use binding.

Variable binding in the odbc, interbase and oci8po drivers.

$rs = $db->Execute('select * from table where val=?', array('10'));
Variable binding in the oci8 driver:
$rs = $db->Execute('select name from table where val=:key',
  array('key' => 10));
Bulk binding

Since ADOdb 3.80, we support bulk binding in Execute(), in which you pass in a 2-dimensional array to be bound to an INSERT/UPDATE or DELETE statement.

$arr = array(
    array('Ahmad',32),
    array('Zulkifli', 24),
    array('Rosnah', 21)
    );
$ok = $db->Execute('insert into table (name,age) values (?,?)',$arr);

This provides very high performance as the SQL statement is prepared first. The prepared statement is executed repeatedly for each array row until all rows are completed, or until the first error. Very useful for importing data.

CacheExecute([$secs2cache,]$sql,$inputarr=false)

Similar to Execute, except that the recordset is cached for $secs2cache seconds in the $ADODB_CACHE_DIR directory, and $inputarr only accepts 1-dimensional arrays. If CacheExecute() is called again with the same $sql, $inputarr, and also the same database, same userid, and the cached recordset has not expired, the cached recordset is returned.

  include('adodb.inc.php');
  include('tohtml.inc.php');
  $ADODB_CACHE_DIR = '/usr/local/ADOdbcache';
  $conn = &ADONewConnection('mysql');
  $conn->PConnect('localhost','userid','password','database');
  $rs = $conn->CacheExecute(15, 'select * from table'); # cache 15 secs
  rs2html($rs); /* recordset to html table */

Alternatively, since ADOdb 1.80, the $secs2cache parameter is optional:

    $conn->Connect(...);
       $conn->cacheSecs = 3600*24; // cache 24 hours
    $rs = $conn->CacheExecute('select * from table');
If $secs2cache is omitted, we use the value in $connection->cacheSecs (default is 3600 seconds, or 1 hour). Use CacheExecute() only with SELECT statements.

Performance note: I have done some benchmarks and found that they vary so greatly that it's better to talk about when caching is of benefit. When your database server is much slower than your Web server or the database is very overloaded then ADOdb's caching is good because it reduces the load on your database server. If your database server is lightly loaded or much faster than your Web server, then caching could actually reduce performance.

ExecuteCursor($sql,$cursorName='rs',$parameters=false)

Execute an Oracle stored procedure, and returns an Oracle REF cursor variable as a regular ADOdb recordset. Does not work with any other database except oci8. Thanks to Robert Tuttle for the design.

    $db = ADONewConnection("oci8");
    $db->Connect("foo.com:1521", "uid", "pwd", "FOO");
    $rs = $db->ExecuteCursor("begin :cursorvar := getdata(:param1); end;",
                    'cursorvar',
                    array('param1'=>10));
    # $rs is now just like any other ADOdb recordset object
    rs2html($rs);

ExecuteCursor() is a helper function that does the following internally:

    $stmt = $db->Prepare("begin :cursorvar := getdata(:param1); end;", true);
    $db->Parameter($stmt, $cur, 'cursorvar', false, -1, OCI_B_CURSOR);
    $rs = $db->Execute($stmt,$bindarr);

ExecuteCursor only accepts 1 out parameter. So if you have 2 out parameters, use:

    $vv = 'A%';
    $stmt = $db->PrepareSP("BEGIN list_tabs(:crsr,:tt); END;");
    $db->OutParameter($stmt, $cur, 'crsr', -1, OCI_B_CURSOR);
    $db->OutParameter($stmt, $vv, 'tt', 32); # return varchar(32)
    $arr = $db->GetArray($stmt);
    print_r($arr);
    echo " val = $vv"; ## outputs 'TEST'
for the following PL/SQL:
    TYPE TabType IS REF CURSOR RETURN TAB%ROWTYPE;

    PROCEDURE list_tabs(tabcursor IN OUT TabType,tablenames IN OUT VARCHAR) IS
    BEGIN
        OPEN tabcursor FOR SELECT * FROM TAB WHERE tname LIKE tablenames;
        tablenames := 'TEST';
    END list_tabs;

SelectLimit($sql,$numrows=-1,$offset=-1,$inputarr=false)

Returns a recordset if successful. Returns false otherwise. Performs a select statement, simulating PostgreSQL's SELECT statement, LIMIT $numrows OFFSET $offset clause.

In PostgreSQL, SELECT * FROM TABLE LIMIT 3 will return the first 3 records only. The equivalent is $connection->SelectLimit('SELECT * FROM TABLE',3). This functionality is simulated for databases that do not possess this feature.

And SELECT * FROM TABLE LIMIT 3 OFFSET 2 will return records 3, 4 and 5 (eg. after record 2, return 3 rows). The equivalent in ADOdb is $connection->SelectLimit('SELECT * FROM TABLE',3,2).

Note that this is the opposite of MySQL's LIMIT clause. You can also set $connection->SelectLimit('SELECT * FROM TABLE',-1,10) to get rows 11 to the last row.

The last parameter $inputarr is for databases that support variable binding such as Oracle oci8. This substantially reduces SQL compilation overhead. Below is an Oracle example:

 $conn->SelectLimit("SELECT * FROM TABLE WHERE COND=:val", 100,-1,array('val'=> $val));

The oci8po driver (oracle portable driver) uses the more standard bind variable of ?:

 $conn->SelectLimit("SELECT * FROM TABLE WHERE COND=?", 100,-1,array('val'=> $val));

Ron Wilson reports that SelectLimit does not work with UNIONs.

CacheSelectLimit([$secs2cache,] $sql, $numrows=-1,$offset=-1,$inputarr=false)

Similar to SelectLimit, except that the recordset returned is cached for $secs2cache seconds in the $ADODB_CACHE_DIR directory.

Since 1.80, $secs2cache has been optional, and you can define the caching time in $connection->cacheSecs.

    $conn->Connect(...);
   $conn->cacheSecs = 3600*24; // cache 24 hours
    $rs = $conn->CacheSelectLimit('select * from table',10);

CacheFlush($sql=false,$inputarr=false)

Flush (delete) any cached recordsets for the SQL statement $sql in $ADODB_CACHE_DIR.

If no parameter is passed in, then all adodb_*.cache files are deleted.

CacheSelectLimit() rewrites the SQL query, so you won't be able to pass the SQL to CacheFlush. In this case, to flush the cached SQL recordset returned by CacheSelectLimit(), set $secs2cache to 0:

    $db->CacheSelectLimit(0, $sql, $nrows);

If you want to flush all cached recordsets manually, execute the following PHP code (works only under Unix):
  system("rm -f `find ".$ADODB_CACHE_DIR." -name adodb_*.cache`");

For general cleanup of all expired files, you should use crontab on Unix, or at.exe on Windows, and a shell script similar to the following:
#------------------------------------------------------
# This particular example deletes files in the TMPPATH
# directory with the string ".cache" in their name that
# are more than 7 days old.
#------------------------------------------------------
AGED=7
find ${TMPPATH} -mtime +$AGED | grep "\.cache" | xargs rm -f

MetaError($errno=false)

Returns a virtualized error number, based on PEAR DB's error number system. You might need to include adodb-error.inc.php before you call this function. The parameter $errno is the native error number you want to convert. If you do not pass any parameter, MetaError will call ErrorNo() for you and convert it. If the error number cannot be virtualized, MetaError will return -1 (DB_ERROR).

MetaErrorMsg($errno)

Pass the error number returned by MetaError() for the equivalent textual error message.

ErrorMsg()

Returns the last status or error message. The error message is reset after every call to Execute().

This can return a string even if no error occurs. In general you do not need to call this function unless an ADOdb function returns false on an error.

Note: If debug is enabled, the SQL error message is always displayed when the Execute function is called.

ErrorNo()

Returns the last error number. The error number is reset after every call to Execute(). If 0 is returned, no error occurred.

Note that old versions of PHP (pre 4.0.6) do not support error number for ODBC. In general you do not need to call this function unless an ADOdb function returns false on an error.

SetFetchMode($mode)

Sets the current fetch mode for the connection and stores it in $db->fetchMode. Legal modes are ADODB_FETCH_ASSOC and ADODB_FETCH_NUM. For more info, see $ADODB_FETCH_MODE.

Returns the previous fetch mode, which could be false if SetFetchMode( ) has not been called before.

CreateSequence($seqName = 'adodbseq',$startID=1)

Create a sequence. The next time GenID( ) is called, the value returned will be $startID. Added in 2.60.

DropSequence($seqName = 'adodbseq')

Delete a sequence. Added in 2.60.

GenID($seqName = 'adodbseq',$startID=1)

Generate a sequence number . Works for interbase, mysql, postgresql, oci8, oci8po, mssql, ODBC based (access,vfp,db2,etc) drivers currently. Uses $seqName as the name of the sequence. GenID() will automatically create the sequence for you if it does not exist (provided the userid has permission to do so). Otherwise you will have to create the sequence yourself.

If your database driver emulates sequences, the name of the table is the sequence name. The table has one column, "id" which should be of type integer, or if you need something larger - numeric(16).

For ODBC and databases that do not support sequences natively (eg mssql, mysql), we create a table for each sequence. If the sequence has not been defined earlier, it is created with the starting value set in $startID.

Note that the mssql driver's GenID() before 1.90 used to generate 16 byte GUID's.

UpdateBlob($table,$column,$val,$where)

Allows you to store a blob (in $val) into $table into $column in a row at $where.

Usage:

    # for oracle
    $conn->Execute('INSERT INTO blobtable (id, blobcol) VALUES (1, empty_blob())');
    $conn->UpdateBlob('blobtable','blobcol',$blobvalue,'id=1');

    # non oracle databases
    $conn->Execute('INSERT INTO blobtable (id, blobcol) VALUES (1, null)');
    $conn->UpdateBlob('blobtable','blobcol',$blobvalue,'id=1');

Returns true if succesful, false otherwise. Supported by MySQL, PostgreSQL, Oci8, Oci8po and Interbase drivers. Other drivers might work, depending on the state of development.

Note that when an Interbase blob is retrieved using SELECT, it still needs to be decoded using $connection->DecodeBlob($blob); to derive the original value in versions of PHP before 4.1.0.

For PostgreSQL, you can store your blob using blob oid's or as a bytea field. You can use bytea fields but not blob oid's currently with UpdateBlob( ). Conversely UpdateBlobFile( ) supports oid's, but not bytea data.

If you do not pass in an oid, then UpdateBlob() assumes that you are storing in bytea fields.

If you do not have any blob fields, you can improve you can improve general SQL query performance by disabling blob handling with $connection->disableBlobs = true.

UpdateClob($table,$column,$val,$where)

Allows you to store a clob (in $val) into $table into $column in a row at $where. Similar to UpdateBlob (see above), but for Character Large OBjects.

Usage:

    # for oracle
    $conn->Execute('INSERT INTO clobtable (id, clobcol) VALUES (1, empty_clob())');
    $conn->UpdateBlob('clobtable','clobcol',$clobvalue,'id=1');

    # non oracle databases
    $conn->Execute('INSERT INTO clobtable (id, clobcol) VALUES (1, null)');
    $conn->UpdateBlob('clobtable','clobcol',$clobvalue,'id=1');

UpdateBlobFile($table,$column,$path,$where,$blobtype='BLOB')

Similar to UpdateBlob, except that we pass in a file path to where the blob resides.

For PostgreSQL, if you are using blob oid's, use this interface. This interface does not support bytea fields.

Returns true if successful, false otherwise.

BlobEncode($blob)

Some databases require blob's to be encoded manually before upload. Note if you use UpdateBlob( ) or UpdateBlobFile( ) the conversion is done automatically for you and you do not have to call this function. For PostgreSQL, currently, BlobEncode() can only be used for bytea fields.

Returns the encoded blob value.

Note that there is a connection property called blobEncodeType which has 3 legal values:

false - no need to perform encoding or decoding.
'I' - blob encoding required, and returned encoded blob is a numeric value (no need to quote).
'C' - blob encoding required, and returned encoded blob is a character value (requires quoting).

This is purely for documentation purposes, so that programs that accept multiple database drivers know what is the right thing to do when processing blobs.

BlobDecode($blob, $maxblobsize = false)

Some databases require blob's to be decoded manually after doing a select statement. If the database does not require decoding, then this function will return the blob unchanged. Currently BlobDecode is only required for one database, PostgreSQL, and only if you are using blob oid's (if you are using bytea fields, we auto-decode for you). The default maxblobsize is set in $connection->maxblobsize, which is set to 256K in adodb 4.54.

In ADOdb 4.54 and later, the blob is the return value. In earlier versions, the blob data is sent to stdout.

$rs = $db->Execute("select bloboid from postgres_table where id=$key");
$blob = $db->BlobDecode( reset($rs->fields) );

Replace($table, $arrFields, $keyCols,$autoQuote=false)

Try to update a record, and if the record is not found, an insert statement is generated and executed. Returns 0 on failure, 1 if update statement worked, 2 if no record was found and the insert was executed successfully. This differs from MySQL's replace which deletes the record and inserts a new record. This also means you cannot update the primary key. The only exception to this is Interbase and its derivitives, which uses delete and insert because of some Interbase API limitations.

The parameters are $table which is the table name, the $arrFields which is an associative array where the keys are the field names, and $keyCols is the name of the primary key, or an array of field names if it is a compound key. If $autoQuote is set to true, then Replace() will quote all values that are non-numeric; auto-quoting will not quote nulls. Note that auto-quoting will not work if you use SQL functions or operators.

Examples:

# single field primary key
$ret = $db->Replace('atable',
    array('id'=>1000,'firstname'=>'Harun','lastname'=>'Al-Rashid'),
    'id',$autoquote = true);
# generates UPDATE atable SET firstname='Harun',lastname='Al-Rashid' WHERE id=1000
# or INSERT INTO atable (id,firstname,lastname) VALUES (1000,'Harun','Al-Rashid')

# compound key
$ret = $db->Replace('atable2',
    array('firstname'=>'Harun','lastname'=>'Al-Rashid', 'age' => 33, 'birthday' => 'null'),
    array('lastname','firstname'),
    $autoquote = true);

# no auto-quoting
$ret = $db->Replace('atable2',
    array('firstname'=>"'Harun'",'lastname'=>"'Al-Rashid'", 'age' => 'null'),
    array('lastname','firstname'));

AutoExecute($table, $arrFields, $mode, $where=false, $forceUpdate=true,$magicq=false)

Since ADOdb 4.56, you can automatically generate and execute INSERTs and UPDATEs on a given table with this function, which is a wrapper for GetInsertSQL() and GetUpdateSQL().

AutoExecute() inserts or updates $table given an array of $arrFields, where the keys are the field names and the array values are the field values to store. Note that there is some overhead because the table is first queried to extract key information before the SQL is generated. We generate an INSERT or UPDATE based on $mode (see below).

Legal values for $mode are

  • 'INSERT' or 1 or DB_AUTOQUERY_INSERT
  • 'UPDATE' or 2 or DB_AUTOQUERY_UPDATE

You have to define the constants DB_AUTOQUERY_UPDATE and DB_AUTOQUERY_INSERT yourself or include adodb-pear.inc.php.

The $where clause is required if $mode == 'UPDATE'. If $forceUpdate=false then we will query the database first and check if the field value returned by the query matches the current field value; only if they differ do we update that field.

Returns true on success, false on error.

An example of its use is:

$record["firstName"] = "Carol";
$record["lasTname"] = "Smith";
$conn->AutoExecute($table,$record,'INSERT');
# executes "INSERT INTO $table (firstName,lasTname) values ('Carol',Smith')";

$record["firstName"] = "Carol";
$record["lasTname"] = "Jones";
$conn->AutoExecute($table,$record,'UPDATE', "lastname like 'Sm%'");
# executes "UPDATE $table SET firstName='Carol',lasTname='Jones' WHERE lastname like 'Sm%'";

Note: One of the strengths of ADOdb's AutoExecute() is that only valid field names for $table are updated. If $arrFields contains keys that are invalid field names for $table, they are ignored. There is some overhead in doing this as we have to query the database to get the field names, but given that you are not directly coding the SQL yourself, you probably aren't interested in speed at all, but convenience.

Since 4.62, the table name to be used can be overridden by setting $rs->tableName before AutoExecute(), GetInsertSQL() or GetUpdateSQL() is called.

GetUpdateSQL(&$rs, $arrFields, $forceUpdate=false,$magicq=false, $force=null)

Generate SQL to update a table given a recordset $rs, and the modified fields of the array $arrFields (which must be an associative array holding the column names and the new values) are compared with the current recordset. If $forceUpdate is true, then we also generate the SQL even if $arrFields is identical to $rs->fields. Requires the recordset to be associative. $magicq is used to indicate whether magic quotes are enabled (see qstr()). The field names in the array are case-insensitive.

Since 4.52, we allow you to pass the $force type parameter, and this overrides the $ADODB_FORCE_TYPE global variable.

Since 4.62, the table name to be used can be overridden by setting $rs->tableName before AutoExecute(), GetInsertSQL() or GetUpdateSQL() is called.

GetInsertSQL(&$rs, $arrFields,$magicq=false,$force_type=false)

Generate SQL to insert into a table given a recordset $rs. Requires the query to be associative. $magicq is used to indicate whether magic quotes are enabled (for qstr()). The field names in the array are case-insensitive.

Since 2.42, you can pass a table name instead of a recordset into GetInsertSQL (in $rs), and it will generate an insert statement for that table.

Since 4.52, we allow you to pass the $force_type parameter, and this overrides the $ADODB_FORCE_TYPE global variable.

Since 4.62, the table name to be used can be overridden by setting $rs->tableName before AutoExecute(), GetInsertSQL() or GetUpdateSQL() is called.

PageExecute($sql, $nrows, $page, $inputarr=false)

Used for pagination of recordset. $page is 1-based. See Example 8.

CachePageExecute($secs2cache, $sql, $nrows, $page, $inputarr=false)

Used for pagination of recordset. $page is 1-based. See Example 8. Caching version of PageExecute.

Close( )

Close the database connection. PHP4 proudly states that we no longer have to clean up at the end of the connection because the reference counting mechanism of PHP4 will automatically clean up for us.

StartTrans( )

Start a monitored transaction. As SQL statements are executed, ADOdb will monitor for SQL errors, and if any are detected, when CompleteTrans() is called, we auto-rollback.

To understand why StartTrans() is superior to BeginTrans(), let us examine a few ways of using BeginTrans(). The following is the wrong way to use transactions:

$DB->BeginTrans();
$DB->Execute("update table1 set val=$val1 where id=$id");
$DB->Execute("update table2 set val=$val2 where id=$id");
$DB->CommitTrans();

because you perform no error checking. It is possible to update table1 and for the update on table2 to fail. Here is a better way:

$DB->BeginTrans();
$ok = $DB->Execute("update table1 set val=$val1 where id=$id");
if ($ok) $ok = $DB->Execute("update table2 set val=$val2 where id=$id");
if ($ok) $DB->CommitTrans();
else $DB->RollbackTrans();

Another way is (since ADOdb 2.0):

$DB->BeginTrans();
$ok = $DB->Execute("update table1 set val=$val1 where id=$id");
if ($ok) $ok = $DB->Execute("update table2 set val=$val2 where id=$id");
$DB->CommitTrans($ok);

Now it is a headache monitoring $ok all over the place. StartTrans() is an improvement because it monitors all SQL errors for you. This is particularly useful if you are calling black-box functions in which SQL queries might be executed. Also all BeginTrans, CommitTrans and RollbackTrans calls inside a StartTrans block will be disabled, so even if the black box function does a commit, it will be ignored.

$DB->StartTrans();
CallBlackBox();
$DB->Execute("update table1 set val=$val1 where id=$id");
$DB->Execute("update table2 set val=$val2 where id=$id");
$DB->CompleteTrans();

Note that a StartTrans blocks are nestable, the inner blocks are ignored.

CompleteTrans($autoComplete=true)

Complete a transaction called with StartTrans(). This function monitors for SQL errors, and will commit if no errors have occured, otherwise it will rollback. Returns true on commit, false on rollback. If the parameter $autoComplete is true monitor sql errors and commit and rollback as appropriate. Set $autoComplete to false to force rollback even if no SQL error detected.

FailTrans( )

Fail a transaction started with StartTrans(). The rollback will only occur when CompleteTrans() is called.

HasFailedTrans( )

Check whether smart transaction has failed, eg. returns true if there was an error in SQL execution or FailTrans() was called. If not within smart transaction, returns false.

BeginTrans( )

Begin a transaction. Turns off autoCommit. Returns true if successful. Some databases will always return false if transaction support is not available. Any open transactions will be rolled back when the connection is closed. Among the databases that support transactions are Oracle, PostgreSQL, Interbase, MSSQL, certain versions of MySQL, DB2, Informix, Sybase, etc.

Note that StartTrans() and CompleteTrans() is a superior method of handling transactions, available since ADOdb 3.40. For a explanation, see the StartTrans() documentation.

You can also use the ADOdb error handler to die and rollback your transactions for you transparently. Some buggy database extensions are known to commit all outstanding tranasactions, so you might want to explicitly do a $DB->RollbackTrans() in your error handler for safety.

Detecting Transactions

Since ADOdb 2.50, you are able to detect when you are inside a transaction. Check that $connection->transCnt > 0. This variable is incremented whenever BeginTrans() is called, and decremented whenever RollbackTrans() or CommitTrans() is called.

CommitTrans($ok=true)

End a transaction successfully. Returns true if successful. If the database does not support transactions, will return true also as data is always committed.

If you pass the parameter $ok=false, the data is rolled back. See example in BeginTrans().

RollbackTrans( )

End a transaction, rollback all changes. Returns true if successful. If the database does not support transactions, will return false as data is never rollbacked.

SetTransactionMode($mode )

SetTransactionMode allows you to pass in the transaction mode to use for all subsequent transactions. Note: if you have persistent connections and using mssql or mysql, you might have to explicitly reset your transaction mode at the beginning of each page request. This is only supported in postgresql, mssql, mysql with InnoDB and oci8 currently. For example:

$db->SetTransactionMode("SERIALIZABLE");
$db->BeginTrans();
$db->Execute(...); $db->Execute(...);
$db->CommiTrans();

$db->SetTransactionMode(""); // restore to default
$db->StartTrans();
$db->Execute(...); $db->Execute(...);
$db->CompleteTrans();

Supported values to pass in:

  • READ UNCOMMITTED (allows dirty reads, but fastest)
  • READ COMMITTED (default postgres, mssql and oci8)
  • REPEATABLE READ (default mysql)
  • SERIALIZABLE (slowest and most restrictive)

You can also pass in database specific values such as 'SNAPSHOT' for mssql or 'READ ONLY' for oci8/postgres.

See transaction levels for PostgreSQL, Oracle, MySQL, and MS SQL Server.

GetAssoc($sql,$inputarr=false,$force_array=false,$first2cols=false)

Returns an associative array for the given query $sql with optional bind parameters in $inputarr. If the number of columns returned is greater to two, a 2-dimensional array is returned, with the first column of the recordset becomes the keys to the rest of the rows. If the columns is equal to two, a 1-dimensional array is created, where the the keys directly map to the values (unless $force_array is set to true, when an array is created for each value).

Examples:

We have the following data in a recordset:

row1: Apple, Fruit, Edible
row2: Cactus, Plant, Inedible
row3: Rose, Flower, Edible

GetAssoc will generate the following 2-dimensional associative array:

Apple => array[Fruit, Edible]
Cactus => array[Plant, Inedible]
Rose => array[Flower,Edible]

If the dataset is:

row1: Apple, Fruit
row2: Cactus, Plant
row3: Rose, Flower

GetAssoc will generate the following 1-dimensional associative array (with $force_array==false):

Apple => Fruit
Cactus=>Plant
Rose=>Flower

The function returns:

The associative array, or false if an error occurs.

CacheGetAssoc([$secs2cache,] $sql,$inputarr=false,$force_array=false,$first2cols=false)

Caching version of GetAssoc function above.

GetOne($sql,$inputarr=false)

Executes the SQL and returns the first field of the first row. The recordset and remaining rows are discarded for you automatically. If an error occur, false is returned.

GetRow($sql,$inputarr=false)

Executes the SQL and returns the first row as an array. The recordset and remaining rows are discarded for you automatically. If an error occurs, false is returned.

GetAll($sql,$inputarr=false)

Executes the SQL and returns the all the rows as a 2-dimensional array. The recordset is discarded for you automatically. If an error occurs, false is returned. GetArray is a synonym for GetAll.

GetCol($sql,$inputarr=false,$trim=false)

Executes the SQL and returns all elements of the first column as a 1-dimensional array. The recordset is discarded for you automatically. If an error occurs, false is returned.

CacheGetOne([$secs2cache,] $sql,$inputarr=false), CacheGetRow([$secs2cache,] $sql,$inputarr=false), CacheGetAll([$secs2cache,] $sql,$inputarr=false), CacheGetCol([$secs2cache,] $sql,$inputarr=false,$trim=false)

Similar to above Get* functions, except that the recordset is serialized and cached in the $ADODB_CACHE_DIR directory for $secs2cache seconds. Good for speeding up queries on rarely changing data. Note that the $secs2cache parameter is optional. If omitted, we use the value in $connection->cacheSecs (default is 3600 seconds, or 1 hour).

Prepare($sql )

Prepares (compiles) an SQL query for repeated execution. Bind parameters are denoted by ?, except for the oci8 driver, which uses the traditional Oracle :varname convention.

Returns an array containing the original sql statement in the first array element; the remaining elements of the array are driver dependent. If there is an error, or we are emulating Prepare( ), we return the original $sql string. This is because all error-handling has been centralized in Execute( ).

Prepare( ) cannot be used with functions that use SQL query rewriting techniques, e.g. PageExecute( ) and SelectLimit( ).

Example:

$stmt = $DB->Prepare('insert into table (col1,col2) values (?,?)');
for ($i=0; $i < $max; $i++)
    $DB->Execute($stmt,array((string) rand(), $i));

Also see InParameter(), OutParameter() and PrepareSP() below. Only supported internally by interbase, oci8 and selected ODBC-based drivers, otherwise it is emulated. There is no performance advantage to using Prepare() with emulation.

Important: Due to limitations or bugs in PHP, if you are getting errors when you using prepared queries, try setting $ADODB_COUNTRECS = false before preparing. This behaviour has been observed with ODBC.

IfNull($field, $nullReplacementValue)

Portable IFNULL function (NVL in Oracle). Returns a string that represents the function that checks whether a $field is null for the given database, and if null, change the value returned to $nullReplacementValue. Eg.

$sql = 'SELECT '.$db->IfNull('name', "'- unknown -'"). ' FROM table';

length

This is not a function, but a property. Some databases have "length" and others "len" as the function to measure the length of a string. To use this property:

  $sql = "SELECT ".$db->length."(field) from table";
  $rs = $db->Execute($sql);

random

This is not a function, but a property. This is a string that holds the sql to generate a random number between 0.0 and 1.0 inclusive.

substr

This is not a function, but a property. Some databases have "substr" and others "substring" as the function to retrieve a sub-string. To use this property:

  $sql = "SELECT ".$db->substr."(field, $offset, $length) from table";
  $rs = $db->Execute($sql);

For all databases, the 1st parameter of substr is the field, the 2nd is the offset (1-based) to the beginning of the sub-string, and the 3rd is the length of the sub-string.

Param($name)

Generates a bind placeholder portably. For most databases, the bind placeholder is "?". However some databases use named bind parameters such as Oracle, eg ":somevar". This allows us to portably define an SQL statement with bind parameters:

$sql = 'insert into table (col1,col2) values ('.$DB->Param('a').','.$DB->Param('b').')';
# generates 'insert into table (col1,col2) values (?,?)'
# or        'insert into table (col1,col2) values (:a,:b)'
$stmt = $DB->Prepare($sql);
$stmt = $DB->Execute($stmt,array('one','two'));

PrepareSP($sql, $cursor=false )

When calling stored procedures in mssql and oci8 (oracle), and you might want to directly bind to parameters that return values, or for special LOB handling. PrepareSP() allows you to do so.

Returns the same array or $sql string as Prepare( ) above. If you do not need to bind to return values, you should use Prepare( ) instead.

The 2nd parameter, $cursor is not used except with oci8. Setting it to true will force OCINewCursor to be called; this is to support output REF CURSORs.

For examples of usage of PrepareSP( ), see InParameter( ) below.

Note: in the mssql driver, preparing stored procedures requires a special function call, mssql_init( ), which is called by this function. PrepareSP( ) is available in all other drivers, and is emulated by calling Prepare( ).

InParameter($stmt, $var, $name, $maxLen = 4000, $type = false )

Binds a PHP variable as input to a stored procedure variable. The parameter $stmt is the value returned by PrepareSP(), $var is the PHP variable you want to bind, $name is the name of the stored procedure variable. Optional is $maxLen, the maximum length of the data to bind, and $type which is database dependant. Consult mssql_bind and ocibindbyname docs at php.net for more info on legal values for $type.

InParameter() is a wrapper function that calls Parameter() with $isOutput=false. The advantage of this function is that it is self-documenting, because the $isOutput parameter is no longer needed. Only for mssql and oci8 currently.

Here is an example using oci8:

# For oracle, Prepare and PrepareSP are identical
$stmt = $db->PrepareSP(
    "declare RETVAL integer;
    begin
    :RETVAL := SP_RUNSOMETHING(:myid,:group);
    end;");
$db->InParameter($stmt,$id,'myid');
$db->InParameter($stmt,$group,'group',64);
$db->OutParameter($stmt,$ret,'RETVAL');
$db->Execute($stmt);

The same example using mssql:

# @RETVAL = SP_RUNSOMETHING @myid,@group
$stmt = $db->PrepareSP('SP_RUNSOMETHING');
# note that the parameter name does not have @ in front!
$db->InParameter($stmt,$id,'myid');
$db->InParameter($stmt,$group,'group',64);
# return value in mssql - RETVAL is hard-coded name
$db->OutParameter($stmt,$ret,'RETVAL');
$db->Execute($stmt);

Note that the only difference between the oci8 and mssql implementations is $sql.

If $type parameter is set to false, in mssql, $type will be dynamicly determined based on the type of the PHP variable passed (string => SQLCHAR, boolean =>SQLINT1, integer =>SQLINT4 or float/double=>SQLFLT8).

In oci8, $type can be set to OCI_B_FILE (Binary-File), OCI_B_CFILE (Character-File), OCI_B_CLOB (Character-LOB), OCI_B_BLOB (Binary-LOB) and OCI_B_ROWID (ROWID). To pass in a null, use $db->Parameter($stmt, $null=null, 'param').

OutParameter($stmt, $var, $name, $maxLen = 4000, $type = false )

Binds a PHP variable as output from a stored procedure variable. The parameter $stmt is the value returned by PrepareSP(), $var is the PHP variable you want to bind, $name is the name of the stored procedure variable. Optional is $maxLen, the maximum length of the data to bind, and $type which is database dependant.

OutParameter() is a wrapper function that calls Parameter() with $isOutput=true. The advantage of this function is that it is self-documenting, because the $isOutput parameter is no longer needed. Only for mssql and oci8 currently.

For an example, see InParameter.

Parameter($stmt, $var, $name, $isOutput=false, $maxLen = 4000, $type = false )

Note: This function is deprecated, because of the new InParameter() and OutParameter() functions. These are superior because they are self-documenting, unlike Parameter().

Adds a bind parameter suitable for return values or special data handling (eg. LOBs) after a statement has been prepared using PrepareSP(). Only for mssql and oci8 currently. The parameters are:

$stmt Statement returned by Prepare() or PrepareSP().
$var PHP variable to bind to. Make sure you pre-initialize it!
$name Name of stored procedure variable name to bind to.
[$isOutput] Indicates direction of parameter 0/false=IN 1=OUT 2= IN/OUT. This is ignored in oci8 as this driver auto-detects the direction.
[$maxLen] Maximum length of the parameter variable.
[$type] Consult mssql_bind and ocibindbyname docs at php.net for more info on legal values for type.

Lastly, in oci8, bind parameters can be reused without calling PrepareSP( ) or Parameters again. This is not possible with mssql. An oci8 example:

$id = 0; $i = 0;
$stmt = $db->PrepareSP( "update table set val=:i where id=:id");
$db->Parameter($stmt,$id,'id');
$db->Parameter($stmt,$i, 'i');
for ($cnt=0; $cnt < 1000; $cnt++) {
    $id = $cnt;
    $i = $cnt * $cnt; # works with oci8!
    $db->Execute($stmt);
}

Bind($stmt, $var, $size=4001, $type=false, $name=false)

This is a low-level function supported only by the oci8 driver. Avoid using unless you only want to support Oracle. The Parameter( ) function is the recommended way to go with bind variables.

Bind( ) allows you to use bind variables in your sql statement. This binds a PHP variable to a name defined in an Oracle sql statement that was previously prepared using Prepare(). Oracle named variables begin with a colon, and ADOdb requires the named variables be called :0, :1, :2, :3, etc. The first invocation of Bind() will match :0, the second invocation will match :1, etc. Binding can provide 100% speedups for insert, select and update statements.

The other variables, $size sets the buffer size for data storage, $type is the optional descriptor type OCI_B_FILE (Binary-File), OCI_B_CFILE (Character-File), OCI_B_CLOB (Character-LOB), OCI_B_BLOB (Binary-LOB) and OCI_B_ROWID (ROWID). Lastly, instead of using the default :0, :1, etc names, you can define your own bind-name using $name.

The following example shows 3 bind variables being used: p1, p2 and p3. These variables are bound to :0, :1 and :2.

$stmt = $DB->Prepare("insert into table (col0, col1, col2) values (:0, :1, :2)");
$DB->Bind($stmt, $p1);
$DB->Bind($stmt, $p2);
$DB->Bind($stmt, $p3);
for ($i = 0; $i < $max; $i++) {
   $p1 = ?; $p2 = ?; $p3 = ?;
   $DB->Execute($stmt);
}

You can also use named variables:

$stmt = $DB->Prepare("insert into table (col0, col1, col2) values (:name0, :name1, :name2)");
$DB->Bind($stmt, $p1, "name0");
$DB->Bind($stmt, $p2, "name1");
$DB->Bind($stmt, $p3, "name2");
for ($i = 0; $i < $max; $i++) {
   $p1 = ?; $p2 = ?; $p3 = ?;
   $DB->Execute($stmt);
}

LogSQL($enable=true)

Call this method to install a SQL logging and timing function (using fnExecute). Then all SQL statements are logged into an adodb_logsql table in a database. If the adodb_logsql table does not exist, ADOdb will create the table if you have the appropriate permissions. Returns the previous logging value (true for enabled, false for disabled). Here are samples of the DDL for selected databases:

        mysql:
        CREATE TABLE adodb_logsql (
          created datetime NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 text NOT NULL,
          params text NOT NULL,
          tracer text NOT NULL,
          timer decimal(16,6) NOT NULL
        )

        postgres:
        CREATE TABLE adodb_logsql (
          created timestamp NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 text NOT NULL,
          params text NOT NULL,
          tracer text NOT NULL,
          timer decimal(16,6) NOT NULL
        )

        mssql:
        CREATE TABLE adodb_logsql (
          created datetime NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 varchar(4000) NOT NULL,
          params varchar(3000) NOT NULL,
          tracer varchar(500) NOT NULL,
          timer decimal(16,6) NOT NULL
        )

        oci8:
        CREATE TABLE adodb_logsql (
          created date NOT NULL,
          sql0 varchar(250) NOT NULL,
          sql1 varchar(4000) NOT NULL,
          params varchar(4000),
          tracer varchar(4000),
          timer decimal(16,6) NOT NULL
        )
Usage:
    $conn->LogSQL(); // turn on logging
      :
    $conn->Execute(...);
      :
    $conn->LogSQL(false); // turn off logging

    # output summary of SQL logging results
    $perf = NewPerfMonitor($conn);
    echo $perf->SuspiciousSQL();
    echo $perf->ExpensiveSQL();

One limitation of logging is that rollback also prevents SQL from being logged.

If you prefer to use another name for the table used to store the SQL, you can override it by calling adodb_perf::table($tablename), where $tablename is the new table name (you will still need to manually create the table yourself). An example:

    include('adodb.inc.php');
    include('adodb-perf.inc.php');
    adodb_perf::table('my_logsql_table');
Also see Performance Monitor.

fnExecute and fnCacheExecute properties

These two properties allow you to define bottleneck functions for all sql statements processed by ADOdb. This allows you to perform statistical analysis and query-rewriting of your sql.

Examples of fnExecute

Here is an example of using fnExecute, to count all cached queries and non-cached queries, you can do this:

# $db is the connection object
function CountExecs($db, $sql, $inputarray)
{
global $EXECS;

    if (!is_array(inputarray)) $EXECS++;
    # handle 2-dimensional input arrays
    else if (is_array(reset($inputarray))) $EXECS += sizeof($inputarray);
    else $EXECS++;

    # in PHP4.4 and PHP5, we need to return a value by reference
    $null = null;
    return $null;
}

# $db is the connection object
function CountCachedExecs($db, $secs2cache, $sql, $inputarray)
{
global $CACHED; $CACHED++;
}

$db = NewADOConnection('mysql');
$db->Connect(...);
$db->fnExecute = 'CountExecs';
$db->fnCacheExecute = 'CountCachedExecs';
 :
 :
# After many sql statements:`
printf("<p>Total queries=%d; total cached=%d</p>",$EXECS+$CACHED, $CACHED);

The fnExecute function is called before the sql is parsed and executed, so you can perform a query rewrite. If you are passing in a prepared statement, then $sql is an array (see Prepare). The fnCacheExecute function is only called if the recordset returned was cached. The function parameters match the Execute and CacheExecute functions respectively, except that $this (the connection object) is passed as the first parameter.

Since ADOdb 3.91, the behaviour of fnExecute varies depending on whether the defined function returns a value. If it does not return a value, then the $sql is executed as before. This is useful for query rewriting or counting sql queries.

On the other hand, you might want to replace the Execute function with one of your own design. If this is the case, then have your function return a value. If a value is returned, that value is returned immediately, without any further processing. This is used internally by ADOdb to implement LogSQL() functionality.

ADOConnection Utility Functions

BlankRecordSet([$queryid])

No longer available - removed since 1.99.

Concat($s1,$s2,....)

Generates the sql string used to concatenate $s1, $s2, etc together. Uses the string in the concat_operator field to generate the concatenation. Override this function if a concatenation operator is not used, eg. MySQL.

Returns the concatenated string.

DBDate($date)

Format the $date in the format the database accepts. This is used in INSERT/UPDATE statements; for SELECT statements, use SQLDate. The $date parameter can be a Unix integer timestamp or an ISO format Y-m-d. Uses the fmtDate field, which holds the format to use. If null or false or '' is passed in, it will be converted to an SQL null.

Returns the date as a quoted string.

    $sql = "select * from atable where created > ".$db->DBDate("$year-$month-$day");
    $db->Execute($sql);

BindDate($date)

Format the $date in the bind format the database accepts. Normally this means that the date string is not quoted, unlike DBDate, which quotes the string.

    $sql = "select * from atable where created > ".$db->Param('0');
    // or
    $sql = "select * from atable where created > ?";
    $db->Execute($sql,array($db->BindDate("$year-$month-$day"));

DBTimeStamp($ts)

Format the timestamp $ts in the format the database accepts; this can be a Unix integer timestamp or an ISO format Y-m-d H:i:s. Uses the fmtTimeStamp field, which holds the format to use. If null or false or '' is passed in, it will be converted to an SQL null.

Returns the timestamp as a quoted string.

    $sql = "select * from atable where created > ".$db->DBTimeStamp("$year-$month-$day $hr:$min:$secs");
    $db->Execute($sql);

BindTimeStamp($ts)

Format the timestamp $ts in the bind format the database accepts. Normally this means that the timestamp string is not quoted, unlike DBTimeStamp, which quotes the string.

    $sql = "select * from atable where created > ".$db->Param('0');
    // or
    $sql = "select * from atable where created > ?";
    $db->Execute($sql,array($db->BindTimeStamp("$year-$month-$day $hr:$min:$secs"));

qstr($s,[$magic_quotes_enabled=false])

Quotes a string to be sent to the database. The $magic_quotes_enabled parameter may look funny, but the idea is if you are quoting a string extracted from a POST/GET variable, then pass get_magic_quotes_gpc() as the second parameter. This will ensure that the variable is not quoted twice, once by qstr and once by the magic_quotes_gpc.

Eg. $s = $db->qstr(HTTP_GET_VARS['name'],get_magic_quotes_gpc());

Returns the quoted string.

Quote($s)

Quotes the string $s, escaping the database specific quote character as appropriate. Formerly checked magic quotes setting, but this was disabled since 3.31 for compatibility with PEAR DB.

Affected_Rows( )

Returns the number of rows affected by a update or delete statement. Returns false if function not supported.

Not supported by interbase/firebird currently.

Insert_ID( )

Returns the last autonumbering ID inserted. Returns false if function not supported.

Only supported by databases that support auto-increment or object id's, such as PostgreSQL, MySQL and MS SQL Server currently. PostgreSQL returns the OID, which can change on a database reload.

RowLock($table,$where)

Lock a table row for the duration of a transaction. For example to lock record $id in table1:

    $DB->StartTrans();
    $DB->RowLock("table1","rowid=$id");
    $DB->Execute($sql1);
    $DB->Execute($sql2);
    $DB->CompleteTrans();

Supported in db2, interbase, informix, mssql, oci8, postgres, sybase.

MetaDatabases()

Returns a list of databases available on the server as an array. You have to connect to the server first. Only available for ODBC, MySQL and ADO.

MetaTables($ttype = false, $showSchema = false, $mask=false)

Returns an array of tables and views for the current database as an array. The array should exclude system catalog tables if possible. To only show tables, use $db->MetaTables('TABLES'). To show only views, use $db->MetaTables('VIEWS'). The $showSchema parameter currently works only for DB2, and when set to true, will add the schema name to the table, eg. "SCHEMA.TABLE".

You can define a mask for matching. For example, setting $mask = 'TMP%' will match all tables that begin with 'TMP'. Currently only mssql, oci8, odbc_mssql and postgres* support $mask.

MetaColumns($table,$notcasesensitive=true)

Returns an array of ADOFieldObject's, one field object for every column of $table. A field object is a class instance with (name, type, max_length) defined. Currently Sybase does not recognise date types, and ADO cannot identify the correct data type (so we default to varchar).

The $notcasesensitive parameter determines whether we uppercase or lowercase the table name to normalize it (required for some databases). Does not work with MySQL ISAM tables.

For schema support, pass in the $table parameter, "$schema.$tablename". This is only supported for selected databases.

MetaColumnNames($table,$numericIndex=false)

Returns an array of column names for $table. Since ADOdb 4.22, this is an associative array, with the keys in uppercase. Set $numericIndex=true if you want the old behaviour of numeric indexes (since 4.23).

e.g. array('FIELD1' => 'Field1', 'FIELD2'=>'Field2')

MetaPrimaryKeys($table, $owner=false)

Returns an array containing column names that are the primary keys of $table. Supported by mysql, odbc (including db2, odbc_mssql, etc), mssql, postgres, interbase/firebird, oci8 currently.

Views (and some tables) have primary keys, but sometimes this information is not available from the database. You can define a function ADODB_View_PrimaryKeys($databaseType, $database, $view, $owner) that should return an array containing the fields that make up the primary key. If that function exists, it will be called when MetaPrimaryKeys() cannot find a primary key for a table or view.

// In this example: dbtype = 'oci8', $db = 'mydb', $view = 'dataView', $owner = false
function ADODB_View_PrimaryKeys($dbtype,$db,$view,$owner)
{
    switch(strtoupper($view)) {
    case 'DATAVIEW': return array('DATAID');
    default: return false;
    }
}

$db = NewADOConnection('oci8');
$db->Connect('localhost','root','','mydb');
$db->MetaPrimaryKeys('dataView');

ServerInfo()

Returns an array of containing two elements 'description' and 'version'. The 'description' element contains the string description of the database. The 'version' naturally holds the version number (which is also a string).

MetaForeignKeys($table, $owner=false, $upper=false)

Returns an associate array of foreign keys, or false if not supported. For example, if table employee has a foreign key where employee.deptkey points to dept_table.deptid, and employee.posn=posn_table.postionid and employee.poscategory=posn_table.category, then $conn->MetaForeignKeys('employee') will return

    array(
        'dept_table' => array('deptkey=deptid'),
        'posn_table' => array('posn=positionid','poscategory=category')
    )

The optional schema or owner can be defined in $owner. If $upper is true, then the table names (array keys) are upper-cased.

ADORecordSet

When an SQL statement successfully is executed by ADOConnection->Execute($sql),an ADORecordSet object is returned. This object contains a virtual cursor so we can move from row to row, functions to obtain information about the columns and column types, and helper functions to deal with formating the results to show to the user.

ADORecordSet Fields

fields: Array containing the current row. This is not associative, but is an indexed array from 0 to columns-1. See also the function Fields, which behaves like an associative array.

dataProvider: The underlying mechanism used to connect to the database. Normally set to native, unless using odbc or ado.

blobSize: Maximum size of a char, string or varchar object before it is treated as a Blob (Blob's should be shown with textarea's). See the MetaType function.

sql: Holds the sql statement used to generate this record set.

canSeek: Set to true if Move( ) function works.

EOF: True if we have scrolled the cursor past the last record.

ADORecordSet Functions

ADORecordSet( )

Constructer. Normally you never call this function yourself.

GetAssoc([$force_array])

Generates an associative array from the recordset. Note that is this function is also available in the connection object. More details can be found there.

GetArray([$number_of_rows])

Generate a 2-dimensional array of records from the current cursor position, indexed from 0 to $number_of_rows - 1. If $number_of_rows is undefined, till EOF.

GetRows([$number_of_rows])

Generate a 2-dimensional array of records from the current cursor position. Synonym for GetArray() for compatibility with Microsoft ADO.

GetMenu($name, [$default_str=''], [$blank1stItem=true], [$multiple_select=false], [$size=0], [$moreAttr=''])

Generate a HTML menu (<select><option><option></select>). The first column of the recordset (fields[0]) will hold the string to display in the option tags. If the recordset has more than 1 column, the second column (fields[1]) is the value to send back to the web server.. The menu will be given the name $name.

If $default_str is defined, then if $default_str == fields[0], that field is selected. If $blank1stItem is true, the first option is empty. You can also set the first option strings by setting $blank1stItem = "$value:$text".

$Default_str can be array for a multiple select listbox.

To get a listbox, set the $size to a non-zero value (or pass $default_str as an array). If $multiple_select is true then a listbox will be generated with $size items (or if $size==0, then 5 items) visible, and we will return an array to a server. Lastly use $moreAttr to add additional attributes such as javascript or styles.

Menu Example 1: GetMenu('menu1','A',true) will generate a menu: for the data (A,1), (B,2), (C,3). Also see example 5.

Menu Example 2: For the same data, GetMenu('menu1',array('A','B'),false) will generate a menu with both A and B selected:

GetMenu2($name, [$default_str=''], [$blank1stItem=true], [$multiple_select=false], [$size=0], [$moreAttr=''])

This is nearly identical to GetMenu, except that the $default_str is matched to fields[1] (the option values).

Menu Example 3: Given the data in menu example 2, GetMenu2('menu1',array('1','2'),false) will generate a menu with both A and B selected in menu example 2, but this time the selection is based on the 2nd column, which holds the values to return to the Web server.

UserDate($str, [$fmt])

Converts the date string $str to another format. The date format is Y-m-d, or Unix timestamp format. The default $fmt is Y-m-d.

UserTimeStamp($str, [$fmt])

Converts the timestamp string $str to another format. The timestamp format is Y-m-d H:i:s, as in '2002-02-28 23:00:12', or Unix timestamp format. UserTimeStamp calls UnixTimeStamp to parse $str, and $fmt defaults to Y-m-d H:i:s if not defined.

UnixDate($str)

Parses the date string $str and returns it in unix mktime format (eg. a number indicating the seconds after January 1st, 1970). Expects the date to be in Y-m-d H:i:s format, except for Sybase and Microsoft SQL Server, where M d Y is also accepted (the 3 letter month strings are controlled by a global array, which might need localisation).

This function is available in both ADORecordSet and ADOConnection since 1.91.

UnixTimeStamp($str)

Parses the timestamp string $str and returns it in unix mktime format (eg. a number indicating the seconds after January 1st, 1970). Expects the date to be in "Y-m-d, H:i:s" (1970-12-24, 00:00:00) or "Y-m-d H:i:s" (1970-12-24 00:00:00) or "YmdHis" (19701225000000) format, except for Sybase and Microsoft SQL Server, where "M d Y h:i:sA" (Dec 25 1970 00:00:00AM) is also accepted (the 3 letter month strings are controlled by a global array, which might need localisation).

This function is available in both ADORecordSet and ADOConnection since 1.91.

OffsetDate($dayFraction, $basedate=false)

Returns a string with the native SQL functions to calculate future and past dates based on $basedate in a portable fashion. If $basedate is not defined, then the current date (at 12 midnight) is used. Returns the SQL string that performs the calculation when passed to Execute().

For example, in Oracle, to find the date and time that is 2.5 days from today, you can use:

# get date one week from now
$fld = $conn->OffsetDate(7); // returns "(trunc(sysdate)+7")
# get date and time that is 60 hours from current date and time
$fld = $conn->OffsetDate(2.5, $conn->sysTimeStamp);	// returns "(sysdate+2.5)"

$conn->Execute("UPDATE TABLE SET dodate=$fld WHERE ID=$id");

This function is available for mysql, mssql, oracle, oci8 and postgresql drivers since 2.13. It might work with other drivers provided they allow performing numeric day arithmetic on dates.

SQLDate($dateFormat, $basedate=false)

Returns a string which contains the native SQL functions to format a date or date column $basedate. This is used in SELECT statements. For INSERT/UPDATE statements, use DBDate. It uses a case-sensitive $dateFormat, which supports:

  Y: 4-digit Year
  Q: Quarter (1-4)
  M: Month (Jan-Dec)
  m: Month (01-12)
  d: Day (01-31)
  H: Hour (00-23)
  h: Hour (1-12)
  i: Minute (00-59)
  s: Second (00-60)
  A: AM/PM indicator
  w: day of week (0-6 or 1-7 depending on DB)
  l: day of week (as string - lowercase L)
  W: week in year (0..53 for MySQL, 1..53 for PostgreSQL and Oracle)

All other characters are treated as strings. You can also use \ to escape characters. Available on selected databases, including mysql, postgresql, mssql, oci8 and DB2.

This is useful in writing portable sql statements that GROUP BY on dates. For example to display total cost of goods sold broken by quarter (dates are stored in a field called postdate):

 $sqlfn = $db->SQLDate('Y-\QQ','postdate'); # get sql that formats postdate to output 2002-Q1
 $sql = "SELECT $sqlfn,SUM(cogs) FROM table GROUP BY $sqlfn ORDER BY 1 desc";

MoveNext( )

Move the internal cursor to the next row. The $this->fields array is automatically updated. Returns false if unable to do so (normally because EOF has been reached), otherwise true.

If EOF is reached, then the $this->fields array is set to false (this was only implemented consistently in ADOdb 3.30). For the pre-3.30 behaviour of $this->fields (at EOF), set the global variable $ADODB_COMPAT_FETCH = true.

Example:

$rs = $db->Execute($sql);
if ($rs)
    while (!$rs->EOF) {
         ProcessArray($rs->fields);
        $rs->MoveNext();
    }

Move($to)

Moves the internal cursor to a specific row $to. Rows are zero-based eg. 0 is the first row. The fields array is automatically updated. For databases that do not support scrolling internally, ADOdb will simulate forward scrolling. Some databases do not support backward scrolling. If the $to position is after the EOF, $to will move to the end of the RecordSet for most databases. Some obscure databases using odbc might not behave this way.

Note: This function uses absolute positioning, unlike Microsoft's ADO.

Returns true or false. If false, the internal cursor is not moved in most implementations, so AbsolutePosition( ) will return the last cursor position before the Move( ).

MoveFirst()

Internally calls Move(0). Note that some databases do not support this function.

MoveLast()

Internally calls Move(RecordCount()-1). Note that some databases do not support this function.

GetRowAssoc($toUpper=true)

Returns an associative array containing the current row. The keys to the array are the column names. The column names are upper-cased for easy access. To get the next row, you will still need to call MoveNext().

For example:
Array ( [ID] => 1 [FIRSTNAME] => Caroline [LASTNAME] => Miranda [CREATED] => 2001-07-05 )

Note: do not use GetRowAssoc() with $ADODB_FETCH_MODE = ADODB_FETCH_ASSOC. Because they have the same functionality, they will interfere with each other.

AbsolutePage($page=-1)

Returns the current page. Requires PageExecute()/CachePageExecute() to be called. See Example 8.

AtFirstPage($status='')

Returns true if at first page (1-based). Requires PageExecute()/CachePageExecute() to be called. See Example 8.

AtLastPage($status='')

Returns true if at last page (1-based). Requires PageExecute()/CachePageExecute() to be called. See Example 8.

Fields($colname)

Returns the value of the associated column $colname for the current row. The column name is case-insensitive.

This is a convenience function. For higher performance, use $ADODB_FETCH_MODE.

FetchRow()

Returns array containing current row, or false if EOF. FetchRow( ) internally moves to the next record after returning the current row.

Warning: Do not mix using FetchRow() with MoveNext().

Usage:

$rs = $db->Execute($sql);
if ($rs)
    while ($arr = $rs->FetchRow()) {
         # process $arr
    }

FetchInto(&$array)

Sets $array to the current row. Returns PEAR_Error object if EOF, 1 if ok (DB_OK constant). If PEAR is undefined, false is returned when EOF. FetchInto( ) internally moves to the next record after returning the current row.

FetchRow() is easier to use. See above.

FetchField($column_number)

Returns an object containing the name, type and max_length of the associated field. If the max_length cannot be determined reliably, it will be set to -1. The column numbers are zero-based. See example 2.

FieldCount( )

Returns the number of fields (columns) in the record set.

RecordCount( )

Returns the number of rows in the record set. If the number of records returned cannot be determined from the database driver API, we will buffer all rows and return a count of the rows after all the records have been retrieved. This buffering can be disabled (for performance reasons) by setting the global variable $ADODB_COUNTRECS = false. When disabled, RecordCount( ) will return -1 for certain databases. See the supported databases list above for more details.

RowCount is a synonym for RecordCount.

PO_RecordCount($table, $where)

Returns the number of rows in the record set. If the database does not support this, it will perform a SELECT COUNT(*) on the table $table, with the given $where condition to return an estimate of the recordset size.

$numrows = $rs->PO_RecordCount("articles_table", "group=$group");

NextRecordSet()

For databases that allow multiple recordsets to be returned in one query, this function allows you to switch to the next recordset. Currently only supported by mssql driver.

$rs = $db->Execute('execute return_multiple_rs');
$arr1 = $rs->GetArray();
$rs->NextRecordSet();
$arr2 = $rs->GetArray();

FetchObject($toupper=true)

Returns the current row as an object. If you set $toupper to true, then the object fields are set to upper-case. Note: The newer FetchNextObject() is the recommended way of accessing rows as objects. See below.

FetchNextObject($toupper=true)

Gets the current row as an object and moves to the next row automatically. Returns false if at end-of-file. If you set $toupper to true, then the object fields are set to upper-case. Note that for some drivers such as mssql, you need to SetFetchMode(ADODB_FETCH_ASSOC) or SetFetchMode(ADODB_FETCH_BOTH).

$rs = $db->Execute('select firstname,lastname from table');
if ($rs) {
    while ($o = $rs->FetchNextObject()) {
        print "$o->FIRSTNAME, $o->LASTNAME<BR>";
    }
}

There is some trade-off in speed in using FetchNextObject(). If performance is important, you should access rows with the fields[] array. FetchObj()

Returns the current record as an object. Fields are not upper-cased, unlike FetchObject.

FetchNextObj()

Returns the current record as an object and moves to the next record. If EOF, false is returned. Fields are not upper-cased, unlike FetctNextObject.

CurrentRow( )

Returns the current row of the record set. 0 is the first row.

AbsolutePosition( )

Synonym for CurrentRow for compatibility with ADO. Returns the current row of the record set. 0 is the first row.

MetaType($nativeDBType[,$field_max_length],[$fieldobj])

Determine what generic meta type a database field type is given its native type $nativeDBType as a string and the length of the field $field_max_length. Note that field_max_length can be -1 if it is not known. The field object returned by FetchField() can be passed in $fieldobj or as the 1st parameter $nativeDBType. This is useful for databases such as mysql which has additional properties in the field object such as primary_key.

Uses the field blobSize and compares it with $field_max_length to determine whether the character field is actually a blob.

For example, $db->MetaType('char') will return 'C'.

Returns:

  • C: Character fields that should be shown in a <input type="text"> tag.
  • X: Clob (character large objects), or large text fields that should be shown in a <textarea>
  • D: Date field
  • T: Timestamp field
  • L: Logical field (boolean or bit-field)
  • N: Numeric field. Includes decimal, numeric, floating point, and real.
  • I: Integer field.
  • R: Counter or Autoincrement field. Must be numeric.
  • B: Blob, or binary large objects.

Since ADOdb 3.0, MetaType accepts $fieldobj as the first parameter, instead of $nativeDBType.

Close( )

Closes the recordset, cleaning all memory and resources associated with the recordset.

If memory management is not an issue, you do not need to call this function as recordsets are closed for you by PHP at the end of the script. SQL statements such as INSERT/UPDATE/DELETE do not really return a recordset, so you do not have to call Close() for such SQL statements.

function rs2html($adorecordset,[$tableheader_attributes], [$col_titles])

This is a standalone function (rs2html = recordset to html) that is similar to PHP's odbc_result_all function, it prints a ADORecordSet, $adorecordset as a HTML table. $tableheader_attributes allow you to control the table cellpadding, cellspacing and border attributes. Lastly you can replace the database column names with your own column titles with the array $col_titles. This is designed more as a quick debugging mechanism, not a production table recordset viewer.

You will need to include the file tohtml.inc.php.

Example of rs2html:

<?
include('tohtml.inc.php'); # load code common to ADOdb
include('adodb.inc.php'); # load code common to ADOdb
$conn = &ADONewConnection('mysql');   # create a connection
$conn->PConnect('localhost','userid','','agora');# connect to MySQL, agora db
$sql = 'select CustomerName, CustomerID from customers';
$rs   = $conn->Execute($sql);
rs2html($rs,'border=2 cellpadding=3',array('Customer Name','Customer ID'));
?>

Differences between this ADOdb library and Microsoft ADO

  1. ADOdb only supports recordsets created by a connection object. Recordsets cannot be created independently.
  2. ADO properties are implemented as functions in ADOdb. This makes it easier to implement any enhanced ADO functionality in the future.
  3. ADOdb's ADORecordSet->Move() uses absolute positioning, not relative. Bookmarks are not supported.
  4. ADORecordSet->AbsolutePosition() cannot be used to move the record cursor.
  5. ADO Parameter objects are not supported. Instead we have the ADOConnection::Parameter( ) function, which provides a simpler interface for calling preparing parameters and calling stored procedures.
  6. Recordset properties for paging records are available, but implemented as in Example 8.

Database Driver Guide

This describes how to create a class to connect to a new database. To ensure there is no duplication of work, kindly email me at jlim#natsoft.com.my if you decide to create such a class.

First decide on a name in lower case to call the database type. Let's say we call it xbase.

Then we need to create two classes ADODB_xbase and ADORecordSet_xbase in the file adodb-xbase.inc.php.

The simplest form of database driver is an adaptation of an existing ODBC driver. Then we just need to create the class ADODB_xbase extends ADODB_odbc to support the new date and timestamp formats, the concatenation operator used, true and false. For the ADORecordSet_xbase extends ADORecordSet_odbc we need to change the MetaType function. See adodb-vfp.inc.php as an example.

More complicated is a totally new database driver that connects to a new PHP extension. Then you will need to implement several functions. Fortunately, you do not have to modify most of the complex code. You only need to override a few stub functions. See adodb-mysql.inc.php for example.

The default date format of ADOdb internally is YYYY-MM-DD (Ansi-92). All dates should be converted to that format when passing to an ADOdb date function. See Oracle for an example how we use ALTER SESSION to change the default date format in _pconnect _connect.

ADOConnection Functions to Override

Defining a constructor for your ADOConnection derived function is optional. There is no need to call the base class constructor.

_connect: Low level implementation of Connect. Returns true or false. Should set the _connectionID.

_pconnect: Low level implemention of PConnect. Returns true or false. Should set the _connectionID.

_query: Execute a query. Returns the queryID, or false.

_close: Close the connection -- PHP should clean up all recordsets.

ErrorMsg: Stores the error message in the private variable _errorMsg.

ADOConnection Fields to Set

_bindInputArray: Set to true if binding of parameters for SQL inserts and updates is allowed using ?, eg. as with ODBC.

fmtDate

fmtTimeStamp

true

false

concat_operator

replaceQuote

hasLimit support SELECT * FROM TABLE LIMIT 10 of MySQL.

hasTop support Microsoft style SELECT TOP 10 * FROM TABLE.

ADORecordSet Functions to Override

You will need to define a constructor for your ADORecordSet derived class that calls the parent class constructor.

FetchField: as documented above in ADORecordSet

_initrs: low level initialization of the recordset: setup the _numOfRows and _numOfFields fields -- called by the constructor.

_seek: seek to a particular row. Do not load the data into the fields array. This is done by _fetch. Returns true or false. Note that some implementations such as Interbase do not support seek. Set canSeek to false.

_fetch: fetch a row using the database extension function and then move to the next row. Sets the fields array. If the parameter $ignore_fields is true then there is no need to populate the fields array, just move to the next row. then Returns true or false.

_close: close the recordset

Fields: If the array row returned by the PHP extension is not an associative one, you will have to override this. See adodb-odbc.inc.php for an example. For databases such as MySQL and MSSQL where an associative array is returned, there is no need to override this function.

ADOConnection Fields to Set

canSeek: Set to true if the _seek function works.

Optimizing PHP

For info on tuning PHP, read this article on Optimizing PHP.

Change Log

4.91 2 Aug 2006

Major session code rewrite .... See session docs.

PDO bindinputarray was not set properly for MySQL (changed from true to false).

Changed CacheSelectLimit() to re-cache when $secs2cache==0. This is one way to flush the cache when SelectLimit is called.

Added to quotes to mysql and mysqli: "SHOW COLUMNS FROM `%s`";

Removed accidental optgroup handling in GetMenu(). Fixed ibase _BlobDecode for php5 compat, and also mem alloc issues for small blobs, thx salvatori#interia.pl

Mysql driver OffsetDate() speedup, useful for adodb-sessions.

Fix for GetAssoc() PHP5 compat. See http://phplens.com/lens/lensforum/msgs.php?id=15425

Active Record - If inserting a record and the value of a primary key field is null, then we do not insert that field in as we assume it is an auto-increment field. Needed by mssql.

Changed postgres7 MetaForeignKeys() see http://phplens.com/lens/lensforum/msgs.php?id=15531

DB2 will now return db2_conn_errormsg() when it is a connection error.

4.90 8 June 2006

Changed adodb_countrec() in adodb-lib.inc.php to allow LIMIT to be used as a speedup to reduce no of records counted.

Added support for transaction modes for postgres and oci8 with SetTransactionMode(). These transaction modes affect all subsequent transactions of that connection.

Thanks to Halmai Csongor for suggestion.

Removed $off = $fieldOffset - 1 line in db2 driver, FetchField(). Tx Larry Menard.

Added support for PHP5 objects as Execute() bind parameters using __toString (eg. Simple-XML). Thx Carl-Christian Salvesen.

Rounding in tohtml.inc.php did not work properly. Fixed.

MetaIndexes in postgres fails when fields are deleted then added in again because the attnum has gaps in it. See http://sourceforge.net/tracker/index.php?func=detail&aid=1451245&group_id=42718&atid=433976. Fixed.

MetaForeignkeys in mysql and mysqli did not work when fetchMode==ADODB_FETCH_ASSOC used. Fixed.

Reference error in AutoExecute() fixed.

Added macaddr postgres type to MetaType. Maps to 'C'.

Added to _connect() in adodb-ado5.inc.php support for $database and $dataProvider parameters. Thx Larry Menard.

Added support for sequences in adodb-ado_mssql.inc.php. Thx Larry Menard.

Added ADODB_SESSION_READONLY.

Added session expiryref support to crc32 mode, and in LOB code.

Clear _errorMsg in postgres7 driver, so that ErrorMsg() displays properly when no error occurs.

Added BindDate and BindTimeStamp

4.81 3 May 2006

Fixed variable ref errors in adodb-ado5.inc.php in _query().

Mysqli setcharset fix using method_exists().

The adodb-perf.inc.php CreateLogTable() code now works for user-defined table names.

Error in ibase_blob_open() fixed. See http://phplens.com/lens/lensforum/msgs.php?id=14997

4.80 8 Mar 2006

Added activerecord support.

Added mysql $conn->compat323 = true if you want MySQL 3.23 compat enabled. Fixes GetOne() Select-Limit problems.

Added adodb-xmlschema03.inc.php to support XML Schema version 3 and updated adodb-datadict.htm docs.

Better memory management in Execute. Thx Mike Fedyk.

4.72 21 Feb 2006

Added 'new' DSN parameter for NConnect().

Pager now sanitizes $PHP_SELF to protect against XSS. Thx to James Bercegay and others.

ADOConnection::MetaType changed to setup $rs->connection correctly.

New native DB2 driver contributed by Larry Menard, Dan Scott, Andy Staudacher, Bharat Mediratta.

The mssql CreateSequence() did not BEGIN TRANSACTION correctly. Fixed. Thx Sean Lee.

The _adodb_countrecs() function in adodb-lib.inc.php has been revised to handle more ORDER BY variations.

4.71 24 Jan 2006

Fixes postgresql security issue related to binary strings. Thx to Andy Staudacher.

Several DSN bugs found:

1. Fix bugs in DSN connections introduced in 4.70 when underscores are found in the DSN.

2. DSN with _ did not work properly in PHP5 (fine in PHP4). Fixed.

3. Added support for PDO DSN connections in NewADOConnection(), and database parameter in PDO::Connect().

The oci8 datetime flag not correctly implemented in ADORecordSet_array. Fixed.

Added BlobDelete() to postgres, as a counterpoint to UpdateBlobFile().

Fixed GetInsertSQL() to support oci8po.

Fixed qstr() issue with postgresql with \0 in strings.

Fixed some datadict driver loading issues in _adodb_getdriver().

Added register shutdown function session_write_close in adodb-session.inc.php for PHP 5 compat. See http://phplens.com/lens/lensforum/msgs.php?id=14200.

4.70 6 Jan 2006

Many fixes from Danila Ulyanov to ibase, oci8, postgres, mssql, odbc_oracle, odbtp, etc drivers.

Changed usage of binary hint in adodb-session.inc.php for mysql. See http://phplens.com/lens/lensforum/msgs.php?id=14160

Fixed invalid variable reference problem in undomq(), adodb-perf.inc.php.

Fixed http://phplens.com/lens/lensforum/msgs.php?id=14254 in adodb-perf.inc.php, _DBParameter() settings of fetchmode was wrong.

Fixed security issues in server.php and tmssql.php discussed by Andreas Sandblad in a Secunia security advisory. Added $ACCEPTIP = 127.0.0.1 and changed suggested root password to something more secure.

Changed pager to close recordset after RenderLayout().

4.68 25 Nov 2005

PHP 5 compat for mysqli. MetaForeignKeys repeated twice and MYSQLI_BINARY_FLAG missing.

PHP 5.1 support for postgresql bind parameters using ? did not work if >= 10 parameters. Fixed. Thx to Stanislav Shramko.

Lots of PDO improvements.

Spelling error fixed in mysql MetaForeignKeys, $associative parameter.

4.67 16 Nov 2005

Postgresql not_null flag not set to false correctly. Thx Cristian MARIN.

We now check in Replace() if key is in fieldArray. Thx Sébastien Vanvelthem.

_file_get_contents() function was missing in xmlschema. fixed.

Added week in year support to SQLDate(), using 'W' flag. Thx Spider.

In sqlite metacolumns was repeated twice, causing PHP 5 problems. Fixed.

Made debug output XHTML compliant.

4.66 28 Sept 2005

ExecuteCursor() in oci8 did not clean up properly on failure. Fixed.

Updated xmlschema.dtd, by "Alec Smecher" asmecher#smecher.bc.ca

Hardened SelectLimit, typecasting nrows and offset to integer.

Fixed misc bugs in AutoExecute() and GetInsertSQL().

Added $conn->database as the property holding the database name. The older $conn->databaseName is retained for backward compat.

Changed _adodb_backtrace() compat check to use function_exists().

Bug in postgresql MetaIndexes fixed. Thx Kevin Jamieson.

Improved OffsetDate for MySQL, reducing rounding error.

Metacolumns added to sqlite. Thx Mark Newnham.

PHP 4.4 compat fixes for GetAssoc().

Added postgresql bind support for php 5.1. Thx Cristiano da Cunha Duarte

OffsetDate() fixes for postgresql, typecasting strings to date or timestamp.

DBTimeStamp formats for mssql, odbc_mssql and postgresql made to conform with other db's.

Changed PDO constants from PDO_ to PDO:: to support latest spec.

4.65 22 July 2005

Reverted 'X' in mssql datadict to 'TEXT' to be compat with mssql driver. However now you can set $datadict->typeX = 'varchar(4000)' or 'TEXT' or 'CLOB' for mssql and oci8 drivers.

Added charset support when using DSN for Oracle.

_adodb_getmenu did not use fieldcount() to get number of fields. Fixed.

MetaForeignKeys() for mysql/mysqli contributed by Juan Carlos Gonzalez.

MetaDatabases() now correctly returns an array for mysqli driver. Thx Cristian MARIN.

CompleteTrans(false) did not return false. Fixed. Thx to JMF.

AutoExecute() did not work with Oracle. Fixed. Thx José Moreira.

MetaType() added to connection object.

More PHP 4.4 reference return fixes. Thx Ryan C Bonham and others.

4.64 20 June 2005

In datadict, if the default field value is set to '', then it is not applied when the field is created. Fixed by Eugenio.

MetaPrimaryKeys for postgres did not work because of true/false change in 4.63. Fixed.

Tested ocifetchstatement in oci8. Rejected at the end.

Added port to dsn handling. Supported in postgres, mysql, mysqli,ldap.

Added 'w' and 'l' to mysqli SQLDate().

Fixed error handling in ldap _connect() to be more consistent. Also added ErrorMsg() handling to ldap.

Added support for union in _adodb_getcount, adodb-lib.inc.php for postgres and oci8.

rs2html() did not work with null dates properly.

PHP 4.4 reference return fixes.

4.63 18 May 2005

Added $nrows<0 check to mysqli's SelectLimit().

Added OptimizeTable() and OptimizeTables() in adodb-perf.inc.php. By Markus Staab.

PostgreSQL inconsistencies fixed. true and false set to TRUE and FALSE, and boolean type in datadict-postgres.inc.php set to 'L' => 'BOOLEAN'. Thx Kevin Jamieson.

New adodb_session_create_table() function in adodb-session.inc.php. By Markus Staab.

Added null check to UserTimeStamp().

Fixed typo in mysqlt driver in adorecordset. Thx to Andy Staudacher.

GenID() had a bug in the raiseErrorFn handling. Fixed. Thx Marcos Pont.

Datadict name quoting now handles ( ) in index fields correctly - they aren't part of the index field.

Performance monitoring: (1) oci8 Ixora checks moved down; (2) expensive sql changed so that only those sql with count(*)>1 are shown; (3) changed sql1 field to a length+crc32 checksum - this breaks backward compat.

We remap firebird15 to firebird in data dictionary.

4.62 2 Apr 2005

Added 'w' (dow as 0-6 or 1-7) and 'l' (dow as string) for SQLDate for oci8, postgres and mysql.

Rolled back MetaType() changes for mysqli done in prev version.

Datadict change by chris, cblin#tennaxia.com data mappings from:

oci8:  X->varchar(4000) XL->CLOB
mssql: X->XL->TEXT
mysql: X->XL->LONGTEXT
fbird: X->XL->varchar(4000)

to:

oci8:  X->varchar(4000) XL->CLOB
mssql: X->VARCHAR(4000) XL->TEXT
mysql: X->TEXT          XL->LONGTEXT
fbird: X->VARCHAR(4000) XL->VARCHAR(32000)

Added $connection->disableBlobs to postgresql to improve performance when no bytea is used (2-5% improvement).

Removed all HTTP_* vars.

Added $rs->tableName to be set before calling AutoExecute().

Alex Rootoff rootoff#pisem.net contributed ukrainian language file.

Added new mysql_option() support using $conn->optionFlags array.

Added support for ldap_set_option() using the $LDAP_CONNECT_OPTIONS global variable. Contributed by Josh Eldridge.

Added LDAP_* constant definitions to ldap.

Added support for boolean bind variables. We use $conn->false and $conn->true to hold values to set false/true to.

We now do not close the session connection in adodb-session.inc.php as other objects could be using this connection.

We now strip off \0 at end of Ixora SQL strings in $perf->tohtml() for oci8.

4.61 23 Feb 2005

MySQLi added support for mysqli_connect_errno() and mysqli_connect_error().

Massive improvements to alpha PDO driver.

Quote string bind parameters logged by performance monitor for easy type checking. Thx Jason Judge.

Added support for $role when connecting with Interbase/firebird.

Added support for enum recognition in MetaColumns() mysql and mysqli. Thx Amedeo Petrella.

The sybase_ase driver contributed by Interakt Online. Thx Cristian Marin cristic#interaktonline.com.

Removed not_null, has_default, and default_value from ADOFieldObject.

Sessions code, fixed quoting of keys when handling LOBs in session write() function.

Sessions code, added adodb_session_regenerate_id(), to reduce risk of session hijacking by changing session cookie dynamically. Thx Joe Li.

Perf monitor, polling for CPU did not work for PHP 4.3.10 and 5.0.0-5.0.3 due to PHP bugs, so we special case these versions.

Postgresql, UpdateBlob() added code to handle type==CLOB.

4.60 24 Jan 2005

Implemented PEAR DB's autoExecute(). Simplified design because I don't like using constants when strings work fine.

_rs2serialize will now update $rs->sql and $rs->oldProvider.

Added autoExecute().

Added support for postgres8 driver. Currently just remapped to postgres7 driver.

Changed oci8 _query(), so that OCIBindByName() sets the length to -1 if element size is > 4000. This provides better support for LONGs.

Added SetDateLocale() support for netherlands (Nl).

Spelling error in pivot code ($iff should be $iif).

mysql insert_id() did not work with mysql 3.x. Fixed.

"\r\n" not converted to spaces correctly in exporting data. Fixed.

_nconnect() in mysqli did not return value correctly. Fixed.

Arne Eckmann contributed danish language file.

Added clone() support to FetchObject() for PHP5.

Removed SQL_CUR_USE_ODBC from odbc_mssql.

4.55 5 Jan 2005

Found bug in Execute() with bind params for db's that do not support binding natively.

DropSequence() now correctly uses default parameter.

Now Execute() ignores locale for floats, so 1.23 is NEVER converted to 1,23.

SetFetchMode() not properly saved in adodb-perf, suspicious sql and expensive sql. Fixed.

Added INET to postgresql metatypes. Thx motzel.

Allow oracle hints to work when counting with _adodb_getcount in adodb-lib.inc.php. Thx Chris Wrye.

Changed mysql insert_id() to use SELECT LAST_INSERT_ID().

If alter col in datadict does not modify col type/size of actual col, then it is removed from alter col code. By Mark Newham. Not perfect as MetaType() !== ActualType().

Added handling of view fields in metacolumns() for postgresql. Thx Renato De Giovanni.

Added to informix MetaPrimaryKeys and MetaColumns fixes for null bit. Thx to Cecilio Albero.

Removed obsolete connection_timeout() from perf code.

Added support for arrayClass in adodb-csv.inc.php.

RSFilter now accepts methods of the form $array($obj, 'methodname'). Thx to blake#near-time.com.

Changed CacheFlush to $cmd = 'rm -rf '.$ADODB_CACHE_DIR.'/[0-9a-f][0-9a-f]/';

For better cursor concurrency, added code to free ref cursors in oci8 when $rs->Close() is called. Note that CLose() is called internally by the Get* functions too.

Added IIF support for access when pivoting. Thx Volodia Krupach.

Added mssql datadict support for timestamp. Thx Alexios.

Informix pager fix. By Mario Ramirez.

ADODB_TABLE_REGEX now includes ':'. By Mario Ramirez.

Mark Newnham contributed MetaIndexes for oci8 and db2.

4.54 5 Nov 2004

Now you can set $db->charSet = ?? before doing a Connect() in oci8.

Added adodbFetchMode to sqlite.

Perf code, added a string typecast to substr in adodb_log_sql().

Postgres: Changed BlobDecode() to use po_loread, added new $maxblobsize parameter, and now it returns the blob instead of sending it to stdout - make sure to mention that as a compat warning. Also added $db->IsOID($oid) function; uses a heuristic, not guaranteed to work 100%.

Contributed arabic language file by "El-Shamaa, Khaled" k.el-shamaa#cgiar.org

PHP5 exceptions did not handle @ protocol properly. Fixed.

Added ifnull handling for postgresql (using coalesce).

Added metatables() support for Postgresql 8.0 (no longer uses pg_% dictionary tables).

Improved Sybase ErrorMsg() function. By Gaetano Giunta.

Improved oci8 SelectLimit() to use Prepare(). By Cristiano Duarte.

Type-cast $row parameter in ifx_fetch_row() to int. Thx stefan bodgan.

Ralf becker contributed improvements in postgresql, sapdb, mysql data dictionary handling:
- MySql and Postgres MetaType was reporting every int column which was part of a primary key and unique as serial
- Postgres was not reporting the scale of decimal types
- MaxDB was padding the defaults of none-string types with spaces
- MySql now correctly converts enum columns to varchar

Ralf also changed Postgresql datadict:
- you cant add NOT NULL columns in postgres in one go, they need to be added as NULL and then altered to NOT NULL
- AlterColumnSQL could not change a varchar column with numbers into an integer column, postgres need an explicit conversation
- a re-created sequence was not set to the correct value, if the name was the old name (no implicit sequence), now always the new name of the implicit sequence is used

Sergio Strampelli added extra $intoken check to Lens_ParseArgs() in datadict code.

4.53 28 Sept 2004

FetchMode cached in recordset is sometimes mapped to native db fetchMode. Normally this does not matter, but when using cached recordsets, we need to switch back to using adodb fetchmode. So we cache this in $rs->adodbFetchMode if it differs from the db's fetchMode.

For informix we now set canSeek = false driver because stefan bodgan tells me that seeking doesn't work.

SetDateLocale() never worked till now ;-) Thx david#tomato.it

Set $_bindInputArray = true in sapdb driver. Required for clob support.

Fixed some PEAR::DB emulation issues with isError() and isWarning. Thx to Gert-Rainer Bitterlich.

Empty() used in getupdatesql without strlen() check. Fixed.

Added unsigned detection to mysql and mysqli drivers. Thx to dan cech.

Added hungarian language file. Thx to Halászvári Gábor.

Improved fieldname-type formatting of datadict SQL generated (adding $widespacing parameter to _GenField).

Datadict oci8 DROP CONSTRAINTS misspelt. Fixed. Thx Mark Newnham.

Changed odbtp to dynamically change databaseType based on connection, eg. from 'odbtp' to 'odbtp_mssql' when connecting to mssql database.

In datadict, MySQL I4 was wrongly mapped to MEDIUMINT, which is actually I3. Fixed.

Fixed mysqli MetaType() recognition. Mysqli returns numeric types unlike mysql extension. Thx Francesco Riosa.

VFP odbc driver curmode set wrongly, causing problems with memo fields. Fixed.

Odbc driver did not recognize odbc version 2 driver date types properly. Fixed. Thx Bostjan.

ChangeTableSQL() fixes to datadict-db2.inc.php by Mark Newnham.

Perf monitoring with odbc improved. Now we try in perf code to manually set the sysTimeStamp using date() if sysTimeStamp is empty.

All ADO errors are thrown as exceptions in PHP5. So we added exception handling to ado in PHP5 by creating new adodb-ado5.inc.php driver.

Added IsConnected(). Returns true if connection object connected. By Luca.Gioppo.

"Ralf Becker" RalfBecker#digitalROCK.de contributed new sapdb data-dictionary driver and a large patch that implements field and table renaming for oracle, mssql, postgresql, mysql and sapdb. See the new RenameTableSQL() and RenameColumnSQL() functions.

We now check ExecuteCursor to see if PrepareSP was initially called.

Changed oci8 datadict to use MODIFY for $dd->alterCol. Thx Mark Newnham.

4.52 10 Aug 2004

Bug found in Replace() when performance logging enabled, introduced in ADOdb 4.50. Fixed.

Replace() checks update stmt. If update stmt fails, we now return immediately. Thx to alex.

Added support for $ADODB_FORCE_TYPE in GetUpdateSQL/GetInsertSQL. Thx to niko.

Added ADODB_ASSOC_CASE support to postgres/postgres7 driver.

Support for DECLARE stmt in oci8. Thx Lochbrunner.

4.51 29 July 2004

Added adodb-xmlschema 1.0.2. Thx dan and richard.

Added new adorecordset_ext_* classes. If ADOdb extension installed for mysql, mysqlt and oci8 (but not oci8po), we use the superfast ADOdb extension code for movenext.

Added schema support to mssql and odbc_mssql MetaPrimaryKeys().

Patched MSSQL driver to support PHP NULL and Boolean values while binding the input array parameters in the _query() function. By Stephen Farmer.

Added support for clob's for mssql, UpdateBlob(). Thx to gfran#directa.com.br

Added normalize support for postgresql (true=lowercase table name, or false=case-sensitive table names) to MetaColumns($table, $normalize=true).

PHP5 variant dates in ADO not working. Fixed in adodb-ado.inc.php.

Constant ADODB_FORCE_NULLS was not working properly for many releases (for GetUpdateSQL). Fixed. Also GetUpdateSQL strips off ORDER BY now - thx Elieser Leão.

Perf Monitor for oci8 now dynamically highlights optimizer_* params if too high/low.

Added dsn support to NewADOConnection/ADONewConnection.

Fixed out of page bounds bug in _adodb_pageexecute_all_rows() Thx to "Sergio Strampelli" sergio#rir.it

Speedup of movenext for mysql and oci8 drivers.

Moved debugging code _adodb_debug_execute() to adodb-lib.inc.php.

Fixed postgresql bytea detection bug. See http://phplens.com/lens/lensforum/msgs.php?id=9849.

Fixed ibase datetimestamp typo in PHP5. Thx stefan.

Removed whitespace at end of odbtp drivers.

Added db2 metaprimarykeys fix.

Optimizations to MoveNext() for mysql and oci8. Misc speedups to Get* functions.

4.50 6 July 2004

Bumped it to 4.50 to avoid confusion with PHP 4.3.x series.

Added db2 metatables and metacolumns extensions.

Added alpha PDO driver. Very buggy, only works with odbc.

Tested mysqli. Set poorAffectedRows = true. Cleaned up movenext() and _fetch().

PageExecute does not work properly with php5 (return val not a variable). Reported Dmytro Sychevsky sych#php.com.ua. Fixed.

MetaTables() for mysql, $showschema parameter was not backward compatible with older versions of adodb. Fixed.

Changed mysql GetOne() to work with mysql 3.23 when using with non-select stmts (e.g. SHOW TABLES).

Changed TRIG_ prefix to a variable in datadict-oci8.inc.php. Thx to Luca.Gioppo#csi.it.

New to adodb-time code. We allow you to define your own daylights savings function, adodb_daylight_sv for pre-1970 dates. If the function is defined (somewhere in an include), then you can correct for daylights savings. See http://phplens.com/phpeverywhere/node/view/16#daylightsavings for more info.

New sqlitepo driver. This is because assoc mode does not work like other drivers in sqlite. Namely, when selecting (joining) multiple tables, in assoc mode the table names are included in the assoc keys in the "sqlite" driver. In "sqlitepo" driver, the table names are stripped from the returned column names. When this results in a conflict, the first field get preference. Contributed by Herman Kuiper herman#ozuzo.net

Added $forcenull parameter to GetInsertSQL/GetUpdateSQL. Idea by Marco Aurelio Silva.

More XHTML changes for GetMenu. By Jeremy Evans.

Fixes some ibase date issues. Thx to stefan bogdan.

Improvements to mysqli driver to support $ADODB_COUNTRECS.

Fixed adodb-csvlib.inc.php problem when reading stream from socket. We need to poll stream continiously.

4.23 16 June 2004

New interbase/firebird fixes thx to Lester Caine. Driver fixes a problem with getting field names in the result array, and corrects a couple of data conversions. Also we default to dialect3 for firebird. Also ibase sysDate property was wrong. Changed to cast as timestamp.

The datadict driver is set up to give quoted tables and fields as this was the only way round reserved words being used as field names in TikiWiki. TikiPro is tidying that up, and I hope to be able to produce a build of THAT which uses what I consider proper UPPERCASE field and table names. The conversion of TikiWiki to ADOdb helped in that, but until the database is completely tidied up in TikiPro ...

Modified _gencachename() to include fetchmode in name hash. This means you should clear your cache directory after installing this release as the cache name algorithm has changed.

Now Cache* functions work in safe mode, because we do not create sub-directories in the $ADODB_CACHE_DIR in safe mode. In non-safe mode we still create sub-directories. Done by modifying _gencachename().

Added $gmt parameter (true/false) to UserDate and UserTimeStamp in connection class, to force conversion of input (in local time) to be converted to UTC/GMT.

Mssql datadict did not support INT types properly (no size param allowed). Added _GetSize() to datadict-mssql.inc.php.

For borland_ibase, BeginTrans(), changed:

   $this->_transactionID = $this->_connectionID;
to
   $this->_transactionID = ibase_trans($this->ibasetrans, $this->_connectionID);

Fixed typo in mysqi_field_seek(). Thx to Sh4dow (sh4dow#php.pl).

LogSQL did not work with Firebird/Interbase. Fixed.

Postgres: made errorno() handling more consistent. Thx to Michael Jahn, Michael.Jahn#mailbox.tu-dresden.de.

Added informix patch to better support metatables, metacolumns by "Cecilio Albero" c-albero#eos-i.com

Cyril Malevanov contributed patch to oci8 to support passing of LOB parameters:

    $text = 'test test test';
    $sql = "declare rs clob; begin :rs := lobinout(:sa0); end;";
    $stmt = $conn -> PrepareSP($sql);
    $conn -> InParameter($stmt,$text,'sa0', -1, OCI_B_CLOB);
    $rs = '';
    $conn -> OutParameter($stmt,$rs,'rs', -1, OCI_B_CLOB);
    $conn -> Execute($stmt);
    echo "return = ".$rs."<br>";
As he says, the LOBs limitations are:
 - use OCINewDescriptor before binding
 - if Param is IN, uses save() before each execute. This is done automatically for you.
 - if Param is OUT, uses load() after each execute. This is done automatically for you.
 - when we bind $var as LOB, we create new descriptor and return it as a
   Bind Result, so if we want to use OUT parameters, we have to store
   somewhere &$var to load() data from LOB to it.
 - IN OUT params are not working now (should not be a big problem to fix it)
 - now mass binding not working too (I've wrote about it before)

Simplified Connect() and PConnect() error handling.

When extension not loaded, Connect() and PConnect() will return null. On connect error, the fns will return false.

CacheGetArray() added to code.

Added Init() to adorecordset_empty().

Changed postgres64 driver, MetaColumns() to not strip off quotes in default value if :: detected (type-casting of default).

Added test: if (!defined('ADODB_DIR')) die(). Useful to prevent hackers from detecting file paths.

Changed metaTablesSQL to ignore Postgres 7.4 information schemas (sql_*).

New polish language file by Grzegorz Pacan

Added support for UNION in _adodb_getcount().

Added security check for ADODB_DIR to limit path disclosure issues. Requested by postnuke team.

Added better error message support to oracle driver. Thx to Gaetano Giunta.

Added showSchema support to mysql.

Bind in oci8 did not handle $name=false properly. Fixed.

If extension not loaded, Connect(), PConnect(), NConnect() will return null.

4.22 15 Apr 2004

Moved docs to own adodb/docs folder.

Fixed session bug when quoting compressed/encrypted data in Replace().

Netezza Driver and LDAP drivers contributed by Josh Eldridge.

GetMenu now uses rtrim() on values instead of trim().

Changed MetaColumnNames to return an associative array, keys being the field names in uppercase.

Suggested fix to adodb-ado.inc.php affected_rows to support PHP5 variants. Thx to Alexios Fakos.

Contributed bulgarian language file by Valentin Sheiretsky valio#valio.eu.org.

Contributed romanian language file by stefan bogdan.

GetInsertSQL now checks for table name (string) in $rs, and will create a recordset for that table automatically. Contributed by Walt Boring. Also added OCI_B_BLOB in bind on Walt's request - hope it doesn't break anything :-)

Some minor postgres speedups in _initrs().

ChangeTableSQL checks now if MetaColumns returns empty. Thx Jason Judge.

Added ADOConnection::Time(), returns current database time in unix timestamp format, or false.

4.21 20 Mar 2004

We no longer in SelectLimit for VFP driver add SELECT TOP X unless an ORDER BY exists.

Pim Koeman contributed dutch language file adodb-nl.inc.php.

Rick Hickerson added CLOB support to db2 datadict.

Added odbtp driver. Thx to "stefan bogdan" sbogdan#rsb.ro.

Changed PrepareSP() 2nd parameter, $cursor, to default to true (formerly false). Fixes oci8 backward compat problems with OUT params.

Fixed month calculation error in adodb-time.inc.php. 2102-June-01 appeared as 2102-May-32.

Updated PHP5 RC1 iterator support. API changed, hasMore() renamed to valid().

Changed internal format of serialized cache recordsets. As we store a version number, this should be backward compatible.

Error handling when driver file not found was flawed in ADOLoadCode(). Fixed.

4.20 27 Feb 2004

Updated to AXMLS 1.01.

MetaForeignKeys for postgres7 modified by Edward Jaramilla, works on pg 7.4.

Now numbers accepts function calls or sequences for GetInsertSQL/GetUpdateSQL numeric fields.

Changed quotes of 'delete from $perf_table' to "". Thx Kehui (webmaster#kehui.net)

Added ServerInfo() for ifx, and putenv trim fix. Thx Fernando Ortiz.

Added addq(), which is analogous to addslashes().

Tested with php5b4. Fix some php5 compat problems with exceptions and sybase.

Carl-Christian Salvesen added patch to mssql _query to support binds greater than 4000 chars.

Mike suggested patch to PHP5 exception handler. $errno must be numeric.

Added double quotes (") to ADODB_TABLE_REGEX.

For oci8, Prepare(...,$cursor), $cursor's meaning was accidentally inverted in 4.11. This causes problems with ExecuteCursor() too, which calls Prepare() internally. Thx to William Lovaton.

Now dateHasTime property in connection object renamed to datetime for consistency. This could break bc.

Csongor Halmai reports that db2 SelectLimit with input array is not working. Fixed..

4.11 27 Jan 2004

Csongor Halmai reports db2 binding not working. Reverted back to emulated binding.

Dan Cech modifies datadict code. Adds support for DropIndex. Minor cleanups.

Table misspelt in perf-oci8.inc.php. Changed v$conn_cache_advice to v$db_cache_advice. Reported by Steve W.

UserTimeStamp and DBTimeStamp did not handle YYYYMMDDHHMMSS format properly. Reported by Mike Muir. Fixed.

Changed oci8 Prepare(). Does not auto-allocate OCINewCursor automatically, unless 2nd param is set to true. This will break backward compat, if Prepare/Execute is used instead of ExecuteCursor. Reported by Chris Jones.

Added InParameter() and OutParameter(). Wrapper functions to Parameter(), but nicer because they are self-documenting.

Added 'R' handling in ActualType() to datadict-mysql.inc.php

Added ADOConnection::SerializableRS($rs). Returns a recordset that can be serialized in a session.

Added "Run SQL" to performance UI().

Misc spelling corrections in adodb-mysqli.inc.php, adodb-oci8.inc.php and datadict-oci8.inc.php, from Heinz Hombergs.

MetaIndexes() for ibase contributed by Heinz Hombergs.

4.10 12 Jan 2004

Dan Cech contributed extensive changes to data dictionary to support name quoting (with `), and drop table/index.

Informix added cursorType property. Default remains IFX_SCROLL, but you can change to 0 (non-scrollable cursor) for performance.

Added ADODB_View_PrimaryKeys() for returning view primary keys to MetaPrimaryKeys().

Simplified chinese file, adodb-cn.inc.php from cysoft.

Added check for ctype_alnum in adodb-datadict.inc.php. Thx to Jason Judge.

Added connection parameter to ibase Prepare(). Fix by Daniel Hassan.

Added nameQuote for quoting identifiers and names to connection obj. Requested by Jason Judge. Also the data dictionary parser now detects `field name` and generates column names with spaces correctly.

BOOL type not recognised correctly as L. Fixed.

Fixed paths in ADODB_DIR for session files, and back-ported it to 4.05 (15 Dec 2003)

Added Schema to postgresql MetaTables. Thx to col#gear.hu

Empty postgresql recordsets that had blob fields did not set EOF properly. Fixed.

CacheSelectLimit internal parameters to SelectLimit were wrong. Thx to Nio.

Modified adodb_pr() and adodb_backtrace() to support command-line usage (eg. no html).

Fixed some fr and it lang errors. Thx to Gaetano G.

Added contrib directory, with adodb rs to xmlrpc convertor by Gaetano G.

Fixed array recordset bugs when _skiprow1 is true. Thx to Gaetano G.

Fixed pivot table code when count is false.

4.05 13 Dec 2003

Added MetaIndexes to data-dict code - thx to Dan Cech.

Rewritten session code by Ross Smith. Moved code to adodb/session directory.

Added function exists check on connecting to most drivers, so we don't crash with the unknown function error.

Smart Transactions failed with GenID() when it no seq table has been created because the sql statement fails. Fix by Mark Newnham.

Added $db->length, which holds name of function that returns strlen.

Fixed error handling for bad driver in ADONewConnection - passed too few params to error-handler.

Datadict did not handle types like 16.0 properly in _GetSize. Fixed.

Oci8 driver SelectLimit() bug &= instead of =& used. Thx to Swen Thümmler.

Jesse Mullan suggested not flushing outp when output buffering enabled. Due to Apache 2.0 bug. Added.

MetaTables/MetaColumns return ref bug with PHP5 fixed in adodb-datadict.inc.php.

New mysqli driver contributed by Arjen de Rijke. Based on adodb 3.40 driver. Then jlim added BeginTrans, CommitTrans, RollbackTrans, IfNull, SQLDate. Also fixed return ref bug.

$ADODB_FLUSH added, if true then force flush in debugging outp. Default is false. In earlier versions, outp defaulted to flush, which is not compat with apache 2.0.

Mysql driver's GenID() function did not work when when sql logging is on. Fixed.

$ADODB_SESSION_TBL not declared as global var. Not available if adodb-session.inc.php included in function. Fixed.

The input array not passed to Execute() in _adodb_getcount(). Fixed.

4.04 13 Nov 2003

Switched back to foreach - faster than list-each.

Fixed bug in ado driver - wiping out $this->fields with date fields.

Performance Monitor, View SQL, Explain Plan did not work if strlen($SQL)>max($_GET length). Fixed.

Performance monitor, oci8 driver added memory sort ratio.

Added random property, returns SQL to generate a floating point number between 0 and 1;

4.03 6 Nov 2003

The path to adodb-php4.inc.php and adodb-iterators.inc.php was not setup properly.

Patched SQLDate in interbase to support hours/mins/secs. Thx to ari kuorikoski.

Force autorollback for pgsql persistent connections - apparently pgsql did not autorollback properly before 4.3.4. See http://bugs.php.net/bug.php?id=25404

4.02 5 Nov 2003

Some errors in adodb_error_pg() fixed. Thx to Styve.

Spurious Insert_ID() error was generated by LogSQL(). Fixed.

Insert_ID was interfering with Affected_Rows() and Replace() when LogSQL() enabled. Fixed.

More foreach loops optimized with list/each.

Null dates not handled properly in ADO driver (it becomes 31 Dec 1969!).

Heinz Hombergs contributed patches for mysql MetaColumns - adding scale, made interbase MetaColumns work with firebird/interbase, and added lang/adodb-de.inc.php.

Added INFORMIXSERVER environment variable.

Added $ADODB_ANSI_PADDING_OFF for interbase/firebird.

PHP 5 beta 2 compat check. Foreach (Iterator) support. Exceptions support.

4.01 23 Oct 2003

Fixed bug in rs2html(), tohtml.inc.php, that generated blank table cells.

Fixed insert_id() incorrectly generated when logsql() enabled.

Modified PostgreSQL _fixblobs to use list/each instead of foreach.

Informix ErrorNo() implemented correctly.

Modified several places to use list/each, including GetRowAssoc().

Added UserTimeStamp() to connection class.

Added $ADODB_ANSI_PADDING_OFF for oci8po.

4.00 20 Oct 2003

Upgraded adodb-xmlschema to 1 Oct 2003 snapshot.

Fix to rs2html warning message. Thx to Filo.

Fix for odbc_mssql/mssql SQLDate(), hours was wrong.

Added MetaColumns and MetaPrimaryKeys for sybase. Thx to Chris Phillipson.

Added autoquoting to datadict for MySQL and PostgreSQL. Suggestion by Karsten Dambekalns

3.94 11 Oct 2003

Create trigger in datadict-oci8.inc.php did not work, because all cr/lf's must be removed.

ErrorMsg()/ErrorNo() did not work for many databases when logging enabled. Fixed.

Removed global variable $ADODB_LOGSQL as it does not work properly with multiple connections.

Added SQLDate support for sybase. Thx to Chris Phillipson

Postgresql checking of pgsql resultset resource was incorrect. Fix by Bharat Mediratta bharat#menalto.com. Same patch applied to _insertid and _affectedrows for adodb-postgres64.inc.php.

Added support for NConnect for postgresql.

Added Sybase data dict support. Thx to Chris Phillipson

Extensive improvements in $perf->UI(), eg. Explain now opens in new window, we show scripts which call sql, etc.

Perf Monitor UI works with magic quotes enabled.

rsPrefix was declared twice. Removed.

Oci8 stored procedure support, eg. "begin func(); end;" was incorrect in _query. Fixed.

Tiraboschi Massimiliano contributed italian language file.

Fernando Ortiz, fortiz#lacorona.com.mx, contributed informix performance monitor.

Added _varchar (varchar arrays) support for postgresql. Reported by PREVOT Stéphane.

0.10 Sept 9 2000 First release

Old change log history moved to old-changelog.htm.


ADODB Old Session Management Manual

ADODB Session Management Manual

V4.91 2 Aug 2006 (c) 2000-2006 John Lim (jlim#natsoft.com.my)

This software is dual licensed using BSD-Style and LGPL. This means you can use it in compiled proprietary and commercial products.

Useful ADOdb links: Download Other Docs

Introduction

This documentation discusses the old adodb-session.php. Here is the new documentation on the newer adodb-session2.php.

We store state information specific to a user or web client in session variables. These session variables persist throughout a session, as the user moves from page to page.

To use session variables, call session_start() at the beginning of your web page, before your HTTP headers are sent. Then for every variable you want to keep alive for the duration of the session, call session_register($variable_name). By default, the session handler will keep track of the session by using a cookie. You can save objects or arrays in session variables also.

The default method of storing sessions is to store it in a file. However if you have special needs such as you:

  • Have multiple web servers that need to share session info
  • Need to do special processing of each session
  • Require notification when a session expires

The ADOdb session handler provides you with the above additional capabilities by storing the session information as records in a database table that can be shared across multiple servers.

These records will be garbage collected based on the php.ini [session] timeout settings. You can register a notification function to notify you when the record has expired and is about to be freed by the garbage collector.

Important Upgrade Notice: Since ADOdb 4.05, the session files have been moved to its own folder, adodb/session. This is a rewrite of the session code by Ross Smith. The old session code is in adodb/session/old.

ADOdb Session Handler Features

  • Ability to define a notification function that is called when a session expires. Typically used to detect session logout and release global resources.
  • Optimization of database writes. We crc32 the session data and only perform an update to the session data if there is a data change.
  • Support for large amounts of session data with CLOBs (see adodb-session-clob.php). Useful for Oracle.
  • Support for encrypted session data, see adodb-cryptsession.php. Enabling encryption is simply a matter of including adodb-cryptsession.php instead of adodb-session.php.

Setup

There are 3 session management files that you can use:

adodb-session.php        : The default
adodb-session-clob.php   : Use this if you are storing DATA in clobs
adodb-cryptsession.php   : Use this if you want to store encrypted session data in the database

Examples

     include('adodb/adodb.inc.php');

    $ADODB_SESSION_DRIVER='mysql';
    $ADODB_SESSION_CONNECT='localhost';
    $ADODB_SESSION_USER ='scott';
    $ADODB_SESSION_PWD ='tiger';
    $ADODB_SESSION_DB ='sessiondb';

    include('adodb/session/adodb-session.php');
    session_start();

    #
    # Test session vars, the following should increment on refresh
    #
    $_SESSION['AVAR'] += 1;
    print "<p>\$_SESSION['AVAR']={$_SESSION['AVAR']}</p>";

To force non-persistent connections, call adodb_session_open() first before session_start():

    include('adodb/adodb.inc.php');

    $ADODB_SESSION_DRIVER='mysql';
    $ADODB_SESSION_CONNECT='localhost';
    $ADODB_SESSION_USER ='scott';
    $ADODB_SESSION_PWD ='tiger';
    $ADODB_SESSION_DB ='sessiondb';

    include('adodb/session/adodb-session.php');
    adodb_sess_open(false,false,false);
    session_start();

The 3rd parameter to adodb_sess_open($path, $sessname, $connectMode) sets the connection method. You can pass in the following:

$connectMode | Connection Method
true | PConnect( )
false | Connect( )
'N' | NConnect( )
'P' | PConnect( )
'C' | Connect( )

To use a encrypted sessions, simply replace the file adodb-session.php:

    include('adodb/adodb.inc.php');

    $ADODB_SESSION_DRIVER='mysql';
    $ADODB_SESSION_CONNECT='localhost';
    $ADODB_SESSION_USER ='scott';
    $ADODB_SESSION_PWD ='tiger';
    $ADODB_SESSION_DB ='sessiondb';

    include('adodb/session/adodb-cryptsession.php');
    session_start();

And the same technique for adodb-session-clob.php:

    include('adodb/adodb.inc.php');

    $ADODB_SESSION_DRIVER='mysql';
    $ADODB_SESSION_CONNECT='localhost';
    $ADODB_SESSION_USER ='scott';
    $ADODB_SESSION_PWD ='tiger';
    $ADODB_SESSION_DB ='sessiondb';

    include('adodb/session/adodb-session-clob.php');
    session_start();

An alternative way to set persistant or non-persistent connections is to call the following function before session_start() is called.

     ADODB_Session::persist('P'); # 'C' for non-persistent connections

Installation

1. Create this table in your database (MySQL syntax):

   create table sessions (
       SESSKEY char(32) not null,
       EXPIRY int(11) unsigned not null,
       EXPIREREF varchar(64),
       DATA text not null,
       primary key (sesskey)
       );

You may want to rename the 'data' field to 'session_data' as 'data' appears to be a reserved word for one or more of the following:

  • ANSI SQL
  • IBM DB2
  • MS SQL Server
  • Postgres
  • SAP

If you do, then execute:

        ADODB_Session::dataFieldName('session_data');

For the adodb-session-clob.php version, create this:

    create table sessions (
       SESSKEY char(32) not null,
       EXPIRY int(11) unsigned not null,
       EXPIREREF varchar(64),
       DATA CLOB,
      primary key (sesskey)
  );

2. Then define the following parameters. You can either modify this file, or define them before this file is included:

    $ADODB_SESSION_DRIVER='database driver, eg. mysql or ibase';
    $ADODB_SESSION_CONNECT='server to connect to';
    $ADODB_SESSION_USER ='user';
    $ADODB_SESSION_PWD ='password';
    $ADODB_SESSION_DB ='database';
    $ADODB_SESSION_TBL = 'sessions'; # setting this is optional

When the session is created, $ADODB_SESS_CONN holds the connection object.

3. Recommended is PHP 4.0.6 or later. There are documented session bugs in earlier versions of PHP.

Notifications

You can receive notification when your session is cleaned up by the session garbage collector or when you call session_destroy().

PHP's session extension will automatically run a special garbage collection function based on your php.ini session.cookie_lifetime and session.gc_probability settings. This will in turn call adodb's garbage collection function, which can be setup to do notification.

    PHP Session --> ADOdb Session  --> Find all recs  --> Send          --> Delete queued
    GC Function     GC Function        to be deleted      notification      records
    executed at     called by                             for all recs
    random time     Session Extension                     queued for deletion

When a session is created, we need to store a value in the session record (in the EXPIREREF field), typically the userid of the session. Later when the session has expired, just before the record is deleted, we reload the EXPIREREF field and call the notification function with the value of EXPIREREF, which is the userid of the person being logged off.

ADOdb uses a global variable $ADODB_SESSION_EXPIRE_NOTIFY that you must predefine before session start to store the notification configuration. $ADODB_SESSION_EXPIRE_NOTIFY is an array with 2 elements, the first being the name of the session variable you would like to store in the EXPIREREF field, and the 2nd is the notification function's name.

For example, suppose we want to be notified when a user's session has expired, based on the userid. When the user logs in, we store the id in the global session variable $USERID. The function name is 'NotifyFn'.

So we define (before session_start() is called):

    $ADODB_SESSION_EXPIRE_NOTIFY = array('USERID','NotifyFn');
And when the NotifyFn is called (when the session expires), the $USERID is passed in as the first parameter, eg. NotifyFn($userid, $sesskey). The session key (which is the primary key of the record in the sessions table) is the 2nd parameter.

Here is an example of a Notification function that deletes some records in the database and temporary files:

    function NotifyFn($expireref, $sesskey)
    {
        global $ADODB_SESS_CONN; # the session connection object
        $user = $ADODB_SESS_CONN->qstr($expireref);

        $ADODB_SESS_CONN->Execute("delete from shopping_cart where user=$user");
        system("rm /work/tmpfiles/$expireref/*");
    }

NOTE 1: If you have register_globals disabled in php.ini, then you will have to manually set the EXPIREREF. E.g.

$GLOBALS['USERID'] = GetUserID();
$ADODB_SESSION_EXPIRE_NOTIFY = array('USERID','NotifyFn');

NOTE 2: If you want to change the EXPIREREF after the session record has been created, you will need to modify any session variable to force a database record update.

Neat Notification Tricks

ExpireRef normally holds the user id of the current session.

1. You can then write a session monitor, scanning expireref to see who is currently logged on.

2. If you delete the sessions record for a specific user, eg.

delete from sessions where expireref = '$USER'
then the user is logged out. Useful for ejecting someone from a site.

3. You can scan the sessions table to ensure no user can be logged in twice. Useful for security reasons.

Using Oracle CLOBs

Suppose you are storing the DATA field in a CLOB:

   CREATE TABLE sessions (
       SESSKEY VARCHAR(32) NOT NULL,
       EXPIRY NUMBER(16)  NOT NULL,
       EXPIREREF VARCHAR(64),
       DATA CLOB,
      PRIMARY KEY (sesskey)
  );

Then your PHP code could look like this:

    ADODB_SESSION_DRIVER='oci8';
    $ADODB_SESSION_CONNECT=$tnsname;
    $ADODB_SESSION_USER ='scott';
    $ADODB_SESSION_PWD = 'tiger';
    $ADODB_SESSION_DB ='';

    $ADODB_SESSION_USE_LOBS = 'clob';
    $ADODB_SESSION_TBL = 'sessions';

    $ADODB_SESS_DEBUG=0;

    include(ADODB_DIR.'/session/adodb-session.php');

    ADODB_Session::persist('P'); # use 'C' for non-persistent connects

    session_start();

Note that you can set persistance using ADODB_Session::persist('P').

Compression/Encryption Schemes

Since ADOdb 4.05, thanks to Ross Smith, multiple encryption and compression schemes are supported. Currently, supported are:

  MD5Crypt (crypt.inc.php)
  MCrypt
  Secure (Horde's emulation of MCrypt, if MCrypt module is not available.)
  GZip
  BZip2

These are stackable. E.g.

ADODB_Session::filter(new ADODB_Compress_Bzip2());
ADODB_Session::filter(new ADODB_Encrypt_MD5());
will compress and then encrypt the record in the database.

adodb_session_regenerate_id()

Dynamically change the current session id with a newly generated one and update database. Currently only works with cookies. Useful to improve security by reducing the risk of session-hijacking. See this article on Session Fixation for more info on the theory behind this feature. Usage:

    $ADODB_SESSION_DRIVER='mysql';
    $ADODB_SESSION_CONNECT='localhost';
    $ADODB_SESSION_USER ='root';
    $ADODB_SESSION_PWD ='abc';
    $ADODB_SESSION_DB ='phplens';

    include('path/to/adodb/session/adodb-session.php');

    session_start();
    # Every 10 page loads, reset cookie for safety.
    # This is extremely simplistic example, better
    # to regenerate only when the user logs in or changes
    # user privilege levels.
    if ((rand()%10) == 0) adodb_session_regenerate_id();

This function calls session_regenerate_id() internally or simulates it if the function does not exist.

Vacuum/Optimize Database

During session garbage collection, if postgresql is detected, ADOdb can be set to run VACUUM. If mysql is detected, then optimize database could be called.You can turn this on or off using:

$turnOn = true; # or false
ADODB_Session::optimize($turnOn);

The default for optimization is it is disabled.

More Info

Also see the core ADOdb documentation.


First Topic

This is the first topic in your project. Delete this text and replace it with your own. To add a new topic, click the New Topic button on the toolbar.

To learn more about the WYSIWYG Editor, press F1 (with your cursor in this pane) to display Help.


Old Changelog: ADOdb

Old Changelog

3.92 22 Sept 2003

Added GetAssoc and CacheGetAssoc to connection object.

Removed TextMax and CharMax functions from adodb.inc.php.

HasFailedTrans() returned false when trans failed. Fixed.

Moved perf driver classes into adodb/perf/*.php.

Misc improvements to performance monitoring, including UI().

RETVAL in mssql Parameter(), we do not append @ now.

Added Param($name) to connection class, returns '?' or ":$name", for defining bind parameters portably.

LogSQL traps affected_rows() and saves its value properly now. Also fixed oci8 _stmt and _affectedrows() bugs.

Session code timestamp check for oci8 works now. Formerly default NLS_DATE_FORMAT stripped off time portion. Thx to Tony Blair (tonanbarbarian#hotmail.com). Also added new $conn->datetime field to oci8, controls whether MetaType() returns 'D' ($this->datetime==false) or 'T' ($this->datetime == true) for DATE type.

Fixed bugs in adodb-cryptsession.inc.php and adodb-session-clob.inc.php.

Fixed misc bugs in adodb_key_exists, GetInsertSQL() and GetUpdateSQL().

Tuned include_once handling to reduce file-system checking overhead.

3.91 9 Sept 2003

Only released to InterAkt

Added LogSQL() for sql logging and $ADODB_NEWCONNECTION to override factory for driver instantiation.

Added IfNull($field,$ifNull) function, thx to johnwilk#juno.com

Added portable substr support.

Now rs2html() has new parameter, $echo. Set to false to return $html instead of echoing it.

3.90 5 Sept 2003

First beta of performance monitoring released.

MySQL supports MetaTable() masking.

Fixed key_exists() bug in adodb-lib.inc.php

Added sp_executesql Prepare() support to mssql.

Added bind support to db2.

Added swedish language file - Christian Tiberg" christian#commsoft.nu

Bug in drop index for mssql data dict fixed. Thx to Gert-Rainer Bitterlich.

Left join setting for oci8 was wrong. Thx to johnwilk#juno.com

3.80 27 Aug 2003

Patch for PHP 4.3.3 cached recordset csv2rs() fread loop incompatibility.

Added matching mask for MetaTables. Only for oci8, mssql and postgres currently.

Rewrite of "oracle" driver connection code, merging with "oci8", by Gaetano.

Added better debugging for Smart Transactions.

Postgres DBTimeStamp() was wrongly using TO_DATE. Changed to TO_TIMESTAMP.

ADODB_FETCH_CASE check pushed to ADONewConnection to allow people to define it after including adodb.inc.php.

Added portugese (brazilian) to languages. Thx to "Levi Fukumori".

Removed arg3 parameter from Execute/SelectLimit/Cache* functions.

Execute() now accepts 2-d array as $inputarray. Also changed docs of fnExecute() to note change in sql query counting with 2-d arrays.

Added MONEY to MetaType in PostgreSQL.

Added more debugging output to CacheFlush().

3.72 9 Aug 2003

Added qmagic($str), which is a qstr($str) that auto-checks for magic quotes and does the right thing...

Fixed CacheFlush() bug - Thx to martin#gmx.de

Walt Boring contributed MetaForeignKeys for postgres7.

_fetch() called _BlobDecode() wrongly in interbase. Fixed.

adodb_time bug fixed with dates after 2038 fixed by Jason Pell. http://phplens.com/lens/lensforum/msgs.php?id=6980

3.71 4 Aug 2003

The oci8 driver, MetaPrimaryKeys() did not check the owner correctly when $owner == false.

Russian language file contributed by "Cyrill Malevanov" cyrill#malevanov.spb.ru.

Spanish language file contributed by "Horacio Degiorgi" horaciod#codigophp.com.

Error handling in oci8 bugfix - if there was an error in Execute(), then when calling ErrorNo() and/or ErrorMsg(), the 1st call would return the error, but the 2nd call would return no error.

Error handling in odbc bugfix. ODBC would always return the last error, even if it happened 5 queries ago. Now we reset the errormsg to '' and errorno to 0 everytime before CacheExecute() and Execute().

3.70 29 July 2003

Added new SQLite driver. Tested on PHP 4.3 and PHP 5.

Added limited "sapdb" driver support - mainly date support.

The oci8 driver did not identify NUMBER with no defined precision correctly.

Added ADODB_FORCE_NULLS, if set, then PHP nulls are converted to SQL nulls in GetInsertSQL/GetUpdateSQL.

DBDate() and DBTimeStamp() format for postgresql had problems. Fixed.

Added tableoptions to ChangeTableSQL(). Thx to Mike Benoit.

Added charset support to postgresql. Thx to Julian Tarkhanov.

Changed OS check for MS-Windows to prevent confusion with darWIN (MacOS)

Timestamp format for db2 was wrong. Changed to yyyy-mm-dd-hh.mm.ss.nnnnnn.

adodb-cryptsession.php includes wrong. Fixed.

Added MetaForeignKeys(). Supported by mssql, odbc_mssql and oci8.

Fixed some oci8 MetaColumns/MetaPrimaryKeys bugs. Thx to Walt Boring.

adodb_getcount() did not init qryRecs to 0. Missing "WHERE" clause checking in GetUpdateSQL fixed. Thx to Sebastiaan van Stijn.

Added support for only 'VIEWS' and "TABLES" in MetaTables. From Walt Boring.

Upgraded to adodb-xmlschema.inc.php 0.0.2.

NConnect for mysql now returns value. Thx to Dennis Verspuij.

ADODB_FETCH_BOTH support added to interbase/firebird.

Czech language file contributed by Kamil Jakubovic jake#host.sk.

PostgreSQL BlobDecode did not use _connectionID properly. Thx to Juraj Chlebec.

Added some new initialization stuff for Informix. Thx to "Andrea Pinnisi" pinnisi#sysnet.it

ADODB_ASSOC_CASE constant wrong in sybase _fetch(). Fixed.

3.60 16 June 2003

We now SET CONCAT_NULL_YIELDS_NULL OFF for odbc_mssql driver to be compat with mssql driver.

The property $emptyDate missing from connection class. Also changed 1903 to constant (TIMESTAMP_FIRST_YEAR=100). Thx to Sebastiaan van Stijn.

ADOdb speedup optimization - we now return all arrays by reference.

Now DBDate() and DBTimeStamp() now accepts the string 'null' as a parameter. Suggested by vincent.

Added GetArray() to connection class.

Added not_null check in informix metacolumns().

Connection parameters for postgresql did not work correctly when port was defined.

DB2 is now a tested driver, making adodb 100% compatible. Extensive changes to odbc driver for DB2, including implementing serverinfo() and SQLDate(), switching to SQL_CUR_USE_ODBC as the cursor mode, and lastAffectedRows and SelectLimit() fixes.

The odbc driver's FetchField() field names did not obey ADODB_ASSOC_CASE. Fixed.

Some bugs in adodb_backtrace() fixed.

Added "INT IDENTITY" type to adorecordset::MetaType() to support odbc_mssql properly.

MetaColumns() for oci8, mssql, odbc revised to support scale. Also minor revisions to odbc MetaColumns() for vfp and db2 compat.

Added unsigned support to mysql datadict class. Thx to iamsure.

Infinite loop in mssql MoveNext() fixed when ADODB_FETCH_ASSOC used. Thx to Josh R, Night_Wulfe#hotmail.com.

ChangeTableSQL contributed by Florian Buzin.

The odbc_mssql driver now sets CONCAT_NULL_YIELDS_NULL OFF for compat with mssql driver.

3.50 19 May 2003

Fixed mssql compat with FreeTDS. FreeTDS does not implement mssql_fetch_assoc().

Merged back connection and recordset code into adodb.inc.php.

ADOdb sessions using oracle clobs contributed by achim.gosse#ddd.de. See adodb-session-clob.php.

Added /s modifier to preg_match everywhere, which ensures that regex does not stop at /n. Thx Pao-Hsi Huang.

Fixed error in metacolumns() for mssql.

Added time format support for SQLDate.

Image => B added to metatype.

MetaType now checks empty($this->blobSize) instead of empty($this).

Datadict has beta support for informix, sybase (mapped to mssql), db2 and generic (which is a fudge).

BlobEncode for postgresql uses pg_escape_bytea, if available. Needed for compat with 7.3.

Added $ADODB_LANG, to support multiple languages in MetaErrorMsg().

Datadict can now parse table definition as declarative text.

For DataDict, oci8 autoincrement trigger missing semi-colon. Fixed.

For DataDict, when REPLACE flag enabled, drop sequence in datadict for autoincrement field in postgres and oci8.s

Postgresql defaults to template1 database if no database defined in connect/pconnect.

We now clear _resultid in postgresql if query fails.

3.40 19 May 2003

Added insert_id for odbc_mssql.

Modified postgresql UpdateBlobFile() because it did not work in safe mode.

Now connection object is passed to raiseErrorFn as last parameter. Needed by StartTrans().

Added StartTrans() and CompleteTrans(). It is recommended that you do not modify transOff, but use the above functions.

oci8po now obeys ADODB_ASSOC_CASE settings.

Added virtualized error codes, using PEAR DB equivalents. Requires you to manually include adodb-error.inc.php yourself, with MetaError() and MetaErrorMsg($errno).

GetRowAssoc for mysql and pgsql were flawed. Fix by Ross Smith.

Added to datadict types I1, I2, I4 and I8. Changed datadict type 'T' to map to timestamp instead of datetime for postgresql.

Error handling in ExecuteSQLArray(), adodb-datadict.inc.php did not work.

We now auto-quote postgresql connection parameters when building connection string.

Added session expiry notification.

We now test with odbc mysql - made some changes to odbc recordset constructor.

MetaColumns now special cases access and other databases for odbc.

3.31 17 March 2003

Added row checking for _fetch in postgres.

Added Interval type to MetaType for postgres.

Remapped postgres driver to call postgres7 driver internally.

Adorecordset_array::getarray() did not return array when nRows >= 0.

Postgresql: at times, no error message returned by pg_result_error() but error message returned in pg_last_error(). Recoded again.

Interbase blob's now use chunking for updateblob.

Move() did not set EOF correctly. Reported by Jorma T.

We properly support mysql timestamp fields when we are creating mysql tables using the data-dict interface.

Table regex includes backticks character now.

3.30 3 March 2003

Added $ADODB_EXTENSION and $ADODB_COMPAT_FETCH constant.

Made blank1stItem configurable using syntax "value:text" in GetMenu/GetMenu2. Thx to Gabriel Birke.

Previously ADOdb differed from the Microsoft standard because it did not define what to set $this->fields when EOF was reached. Now at EOF, ADOdb sets $this->fields to false for all databases, which is consist with Microsoft's implementation. Postgresql and mysql have always worked this way (in 3.11 and earlier). If you are experiencing compatibility problems (and you are not using postgresql nor mysql) on upgrading to 3.30, try setting the global variables $ADODB_COUNTRECS = true (which is the default) and $ADODB_FETCH_COMPAT = true (this is a new global variable).

We now check both pg_result_error and pg_last_error as sometimes pg_result_error does not display anything. Iman Mayes

We no longer check for magic quotes gpc in Quote().

Misc fixes for table creation in adodb-datadict.inc.php. Thx to iamsure.

Time calculations use adodb_time library for all negative timestamps due to problems in Red Hat 7.3 or later. Formerly, only did this for Windows.

In mssqlpo, we now check if $sql in _query is a string before we change || to +. This is to support prepared stmts.

Move() and MoveLast() internals changed to support to support EOF and $this->fields change.

Added ADODB_FETCH_BOTH support to mssql. Thx to Angel Fradejas afradejas#mediafusion.es

We now check if link resource exists before we run mysql_escape_string in qstr().

Before we flock in csv code, we check that it is not a http url.

3.20 17 Feb 2003

Added new Data Dictionary classes for creating tables and indexes. Warning - this is very much alpha quality code. The API can still change. See adodb/tests/test-datadict.php for more info.

We now ignore $ADODB_COUNTRECS for mysql, because PHP truncates incomplete recordsets when mysql_unbuffered_query() is called a second time.

Now postgresql works correctly when $ADODB_COUNTRECS = false.

Changed _adodb_getcount to properly support SELECT DISTINCT.

Discovered that $ADODB_COUNTRECS=true has some problems with prepared queries - suspect PHP bug.

Now GetOne and GetRow run in $ADODB_COUNTRECS=false mode for better performance.

Added support for mysql_real_escape_string() and pg_escape_string() in qstr().

Added an intermediate variable for mysql _fetch() and MoveNext() to store fields, to prevent overwriting field array with boolean when mysql_fetch_array() returns false.

Made arrays for getinsertsql and getupdatesql case-insensitive. Suggested by Tim Uckun" tim#diligence.com

3.11 11 Feb 2003

Added check for ADODB_NEVER_PERSIST constant in PConnect(). If defined, then PConnect() will actually call non-persistent Connect().

Modified interbase to properly work with Prepare().

Added $this->ibase_timefmt to allow you to change the date and time format.

Added support for $input_array parameter in CacheFlush().

Added experimental support for dbx, which was then removed when i found that it was slower than using native calls.

Added MetaPrimaryKeys for mssql and ibase/firebird.

Added new $trim parameter to GetCol and CacheGetCol

Uses updated adodb-time.inc.php 0.06.

3.10 27 Jan 2003

Added adodb_date(), adodb_getdate(), adodb_mktime() and adodb-time.inc.php.

For interbase, added code to handle unlimited number of bind parameters. From Daniel Hasan daniel#hasan.cl.

Added BlobDecode and UpdateBlob for informix. Thx to Fernando Ortiz.

Added constant ADODB_WINDOWS. If defined, means that running on Windows.

Added constant ADODB_PHPVER which stores php version as a hex num. Removed $ADODB_PHPVER variable.

Felho Bacsi reported a minor white-space regular expression problem in GetInsertSQL.

Modified ADO to use variant to store _affectedRows

Changed ibase to use base class Replace(). Modified base class Replace() to support ibase.

Changed odbc to auto-detect when 0 records returned is wrong due to bad odbc drivers.

Changed mssql to use datetimeconvert ini setting only when 4.30 or later (does not work in 4.23).

ExecuteCursor($stmt, $cursorname, $params) now accepts a new $params array of additional bind parameters -- William Lovaton walovaton#yahoo.com.mx.

Added support for sybase_unbuffered_query if ADODB_COUNTRECS == false. Thx to chuck may.

Fixed FetchNextObj() bug. Thx to Jorma Tuomainen.

We now use SCOPE_IDENTITY() instead of @@IDENTITY for mssql - thx to marchesini#eside.it

Changed postgresql movenext logic to prevent illegal row number from being passed to pg_fetch_array().

Postgresql initrs bug found by "Bogdan RIPA" bripa#interakt.ro $f1 accidentally named $f

3.00 6 Jan 2003

Fixed adodb-pear.inc.php syntax error.

Improved _adodb_getcount() to use SELECT COUNT(*) FROM ($sql) for languages that accept it.

Fixed _adodb_getcount() caching error.

Added sql to retrive table and column info for odbc_mssql.

2.91 3 Jan 2003

Revised PHP version checking to use $ADODB_PHPVER with legal values 0x4000, 0x4050, 0x4200, 0x4300.

Added support for bytea fields and oid blobs in postgres by allowing BlobDecode() to detect and convert non-oid fields. Also added BlobEncode to postgres when you want to encode oid blobs.

Added blobEncodeType property for connections to inform phpLens what encoding method to use for blobs.

Added BlobDecode() and BlobEncode() to base ADOConnection class.

Added umask() to _gencachename() when creating directories.

Added charPage for ado drivers, so you can set the code page.

$conn->charPage = CP_UTF8;
$conn->Connect($dsn);

Modified _seek in mysql to check for num rows=0.

Added to metatypes new informix types for IDS 9.30. Thx Fernando Ortiz.

_maxrecordcount returned in CachePageExecute $rsreturn

Fixed sybase cacheselectlimit( ) problems

MetaColumns() max_length should use precision for types X and C for ms access. Fixed.

Speedup of odbc non-SELECT sql statements.

Added support in MetaColumns for Wide Char types for ODBC. We halve max_length if unicode/wide char.

Added 'B' to types handled by GetUpdateSQL/GetInsertSQL.

Fixed warning message in oci8 driver with $persist variable when using PConnect.

2.90 11 Dec 2002

Mssql and mssqlpo and oci8po now support ADODB_ASSOC_CASE.

Now MetaType() can accept a field object as the first parameter.

New $arr = $db->ServerInfo( ) function. Returns $arr['description'] which is the string description, and $arr['version'].

PostgreSQL and MSSQL speedups for insert/updates.

Implemented new SetFetchMode() that removes the need to use $ADODB_FETCH_MODE. Each connection has independant fetchMode.

ADODB_ASSOC_CASE now defaults to 2, use native defaults. This is because we would break backward compat for too many applications otherwise.

Patched encrypted sessions to use replace()

The qstr function supports quoting of nulls when escape character is \

Rewrote bits and pieces of session code to check for time synch and improve reliability.

Added property ADOConnection::hasTransactions = true/false;

Added CreateSequence and DropSequence functions

Found misplaced MoveNext() in adodb-postgres.inc.php. Fixed.

Sybase SelectLimit not reliable because 'set rowcount' not cached - fixed.

Moved ADOConnection to adodb-connection.inc.php and ADORecordSet to adodb-recordset.inc.php. This allows us to use doxygen to generate documentation. Doxygen doesn't like the classes in the main adodb.inc.php file for some mysterious reason.

2.50, 14 Nov 2002

Added transOff and transCnt properties for disabling (transOff = true) and tracking transaction status (transCnt>0).

Added inputarray handling into _adodb_pageexecute_all_rows - "Ross Smith" RossSmith#bnw.com.

Fixed postgresql inconsistencies in date handling.

Added support for mssql_fetch_assoc.

Fixed $ADODB_FETCH_MODE bug in odbc MetaTables() and MetaPrimaryKeys().

Accidentally declared UnixDate() twice, making adodb incompatible with php 4.3.0. Fixed.

Fixed pager problems with some databases that returned -1 for _currentRow on MoveLast() by switching to MoveNext() in adodb-lib.inc.php.

Also fixed uninited $discard in adodb-lib.inc.php.

2.43, 25 Oct 2002

Added ADODB_ASSOC_CASE constant to better support ibase and odbc field names.

Added support for NConnect() for oracle OCINLogin.

Fixed NumCols() bug.

Changed session handler to use Replace() on write.

Fixed oci8 SelectLimit aggregate function bug again.

Rewrote pivoting code.

2.42, 4 Oct 2002

Fixed ibase_fetch() problem with nulls. Also interbase now does automatic blob decoding, and is backward compatible. Suggested by Heinz Hombergs heinz#hhombergs.de.

Fixed postgresql MoveNext() problems when called repeatedly after EOF. Also suggested by Heinz Hombergs.

PageExecute() does not rewrite queries if SELECT DISTINCT is used. Requested by hans#velum.net

Added additional fixes to oci8 SelectLimit handling with aggregate functions - thx to Christian Bugge for reporting the problem.

2.41, 2 Oct 2002

Fixed ADODB_COUNTRECS bug in odbc. Thx to Joshua Zoshi jzoshi#hotmail.com.

Increased buffers for adodb-csvlib.inc.php for extremely long sql from 8192 to 32000.

Revised pivottable.inc.php code. Added better support for aggregate fields.

Fixed mysql text/blob types problem in MetaTypes base class - thx to horacio degiorgi.

Added SQLDate($fmt,$date) function, which allows an sql date format string to be generated - useful for group by's.

Fixed bug in oci8 SelectLimit when offset>100.

2.40 4 Sept 2002

Added new NLS_DATE_FORMAT property to oci8. Suggested by Laurent NAVARRO ln#altidev.com

Now use bind parameters in oci8 selectlimit for better performance.

Fixed interbase replaceQuote for dialect != 1. Thx to "BEGUIN Pierre-Henri - INFOCOB" phb#infocob.com.

Added white-space check to QA.

Changed unixtimestamp to support fractional seconds (we always round down/floor the seconds). Thanks to beezly#beezly.org.uk.

Now you can set the trigger_error type your own user-defined type in adodb-errorhandler.inc.php. Suggested by Claudio Bustos clbustos#entelchile.net.

Added recordset filters with rsfilter.inc.php.

$conn->_rs2rs does not create a new recordset when it detects it is of type array. Some trickery there as there seems to be a bug in Zend Engine

Added render_pagelinks to adodb-pager.inc.php. Code by "Pablo Costa" pablo#cbsp.com.br.

MetaType() speedup in adodb.inc.php by using hashing instead of switch. Best performance if constant arrays are supported, as they are in PHP5.

adodb-session.php now updates only the expiry date if the crc32 check indicates that the data has not been modified.

2.31 20 Aug 2002

Made changes to pivottable.inc.php due to daniel lucuzaeu's suggestions (we sum the pivottable column if desired).

Fixed ErrorNo() in postgres so it does not depend on _errorMsg property.

Robert Tuttle added support for oracle cursors. See ExecuteCursor().

Fixed Replace() so it works with mysql when updating record where data has not changed. Reported by Cal Evans (cal#calevans.com).

2.30 1 Aug 2002

Added pivottable.inc.php. Thanks to daniel.lucazeau#ajornet.com for the original concept.

Added ADOConnection::outp($msg,$newline) to output error and debugging messages. Now you can override this using the ADODB_OUTP constant and use your own output handler.

Changed == to === for 'null' comparison. Reported by ericquil#yahoo.com

Fixed mssql SelectLimit( ) bug when distinct used.

2.30 1 Aug 2002

New GetCol() and CacheGetCol() from ross#bnw.com that returns the first field as a 1 dim array.

We have an empty recordset, but RecordCount() could return -1. Fixed. Reported by "Jonathan Polansky" jonathan#polansky.com.

We now check for session variable changes using strlen($sessval).crc32($sessval). Formerly we only used crc32().

Informix SelectLimit() problem with $ADODB_COUNTRECS fixed.

Fixed informix SELECT FIRST x DISTINCT, and not SELECT DISTINCT FIRST x - reported by F Riosa

Now default adodb error handlers ignores error if @ used.

If you set $conn->autoRollback=true, we auto-rollback persistent connections for odbc, mysql, oci8, mssql. Default for autoRollback is false. No need to do so for postgres. As interbase requires a transaction id (what a flawed api), we don't do it for interbase.

Changed PageExecute() to use non-greedy preg_match when searching for "FROM" keyword.

2.20 9 July 2002

Added CacheGetOne($secs2cache,$sql), CacheGetRow($secs2cache,$sql), CacheGetAll($secs2cache,$sql).

Added $conn->OffsetDate($dayFraction,$date=false) to generate sql that calcs date offsets. Useful for scheduling appointments.

Added connection properties: leftOuter, rightOuter that hold left and right outer join operators.

Added connection property: ansiOuter to indicate whether ansi outer joins supported.

New driver mssqlpo, the portable mssql driver, which converts string concat operator from || to +.

Fixed ms access bug - SelectLimit() did not support ties - fixed.

Karsten Kraus (Karsten.Kraus#web.de), contributed error-handling code to ADONewConnection. Unfortunately due to backward compat problems, had to rollback most of the changes.

Added new parameter to GetAssoc() to allow returning an array of key-value pairs, ignoring any additional columns in the recordset. Off by default.

Corrected mssql $conn->sysDate to return only date using convert().

CacheExecute() improved debugging output.

Changed rs2html() so newlines are converted to BR tags. Also optimized rs2html() based on feedback by "Jerry Workman" jerry#mtncad.com.

Added support for Replace() with Interbase, using DELETE and INSERT.

Some minor optimizations (mostly removing & references when passing arrays).

Changed GenID() to allows id's larger than the size of an integer.

Added force_session property to oci8 for better updateblob() support.

Fixed PageExecute() which did not work properly with sql containing GROUP BY.

2.12 12 June 2002

Added toexport.inc.php to export recordsets in CSV and tab-delimited format.

CachePageExecute() does not work - fixed - thx John Huong.

Interbase aliases not set properly in FetchField() - fixed. Thx Stefan Goethals.

Added cache property to adodb pager class. The number of secs to cache recordsets.

SQL rewriting bug in pageexecute() due to skipping of newlines due to missing /s modifier. Fixed.

Max size of cached recordset due to a bug was 256000 bytes. Fixed.

Speedup of 1st invocation of CacheExecute() by tuning code.

We compare $rewritesql with $sql in pageexecute code in case of rewrite failure.

2.11 7 June 2002

Fixed PageExecute() rewrite sql problem - COUNT(*) and ORDER BY don't go together with mssql, access and postgres. Thx to Alexander Zhukov alex#unipack.ru

DB2 support for CHARACTER type added - thx John Huong huongch#bigfoot.com

For ado, $argProvider not properly checked. Fixed - kalimero#ngi.it

Added $conn->Replace() function for update with automatic insert if the record does not exist. Supported by all databases except interbase.

2.10 4 June 2002

Added uniqueSort property to indicate mssql ORDER BY cols must be unique.

Optimized session handler by crc32 the data. We only write if session data has changed.

adodb_sess_read in adodb-session.php now returns ''correctly - thanks to Jorma Tuomainen, webmaster#wizactive.com

Mssql driver did not throw EXECUTE errors correctly because ErrorMsg() and ErrorNo() called in wrong order. Pointed out by Alexios Fakos. Fixed.

Changed ado to use client cursors. This fixes BeginTran() problems with ado.

Added handling of timestamp type in ado.

Added to ado_mssql support for insert_id() and affected_rows().

Added support for mssql.datetimeconvert=0, available since php 4.2.0.

Made UnixDate() less strict, so that the time is ignored if present.

Changed quote() so that it checks for magic_quotes_gpc.

Changed maxblobsize for odbc to default to 64000.

2.00 13 May 2002

Added drivers informix72 for pre-7.3 versions, and oci805 for oracle 8.0.5, and postgres64 for postgresql 6.4 and earlier. The postgres and postgres7 drivers are now identical.

Interbase now partially supports ADODB_FETCH_BOTH, by defaulting to ASSOC mode.

Proper support for blobs in mssql. Also revised blob support code is base class. Now UpdateBlobFile() calls UpdateBlob() for consistency.

Added support for changed odbc_fetch_into api in php 4.2.0 with $conn->_has_stupid_odbc_fetch_api_change.

Fixed spelling of tablock locking hint in GenID( ) for mssql.

Added RowLock( ) to several databases, including oci8, informix, sybase, etc. Fixed where error in mssql RowLock().

Added sysDate and sysTimeStamp properties to most database drivers. These are the sql functions/constants for that database that return the current date and current timestamp, and are useful for portable inserts and updates.

Support for RecordCount() caused date handling in sybase and mssql to break. Fixed, thanks to Toni Tunkkari, by creating derived classes for ADORecordSet_array for both databases. Generalized using arrayClass property. Also to support RecordCount(), changed metatype handling for ado drivers. Now the type returned in FetchField is no longer a number, but the 1-char data type returned by MetaType. At the same time, fixed a lot of date handling. Now mssql support dmy and mdy date formats. Also speedups in sybase and mssql with preg_match and ^ in date/timestamp handling. Added support in sybase and mssql for 24 hour clock in timestamps (no AM/PM).

Extensive revisions to informix driver - thanks to Samuel CARRIERE samuel_carriere#hotmail.com

Added $ok parameter to CommitTrans($ok) for easy rollbacks.

Fixed odbc MetaColumns and MetaTables to save and restore $ADODB_FETCH_MODE.

Some odbc drivers did not call the base connection class constructor. Fixed.

Fixed regex for GetUpdateSQL() and GetInsertSQL() to support more legal character combinations.

1.99 21 April 2002

Added emulated RecordCount() to all database drivers if $ADODB_COUNTRECS = true (which it is by default). Inspired by Cristiano Duarte (cunha17#uol.com.br).

Unified stored procedure support for mssql and oci8. Parameter() and PrepareSP() functions implemented.

Added support for SELECT FIRST in informix, modified hasTop property to support this.

Changed csv driver to handle updates/deletes/inserts properly (when Execute() returns true). Bind params also work now, and raiseErrorFn with csv driver. Added csv driver to QA process.

Better error checking in oci8 UpdateBlob() and UpdateBlobFile().

Added TIME type to MySQL - patch by Manfred h9125297#zechine.wu-wien.ac.at

Prepare/Execute implemented for Interbase/Firebird

Changed some regular expressions to be anchored by /^ $/ for speed.

Added UnixTimeStamp() and UnixDate() to ADOConnection(). Now these functions are in both ADOConnection and ADORecordSet classes.

Empty recordsets were not cached - fixed.

Thanks to Gaetano Giunta (g.giunta#libero.it) for the oci8 code review. We didn't agree on everything, but i hoped we agreed to disagree!

1.90 6 April 2002

Now all database drivers support fetch modes ADODB_FETCH_NUM and ADODB_FETCH_ASSOC, though still not fully tested. Eg. Frontbase, Sybase, Informix.

NextRecordSet() support for mssql. Contributed by "Sven Axelsson" sven.axelsson#bokochwebb.se

Added blob support for SQL Anywhere. Contributed by Wade Johnson wade#wadejohnson.de

Fixed some security loopholes in server.php. Server.php also supports fetch mode.

Generalized GenID() to support odbc and mssql drivers. Mssql no longer generates GUID's.

Experimental RowLock($table,$where) for mssql.

Properly implemented Prepare() in oci8 and ODBC.

Added Bind() support to oci8 to support Prepare().

Improved error handler. Catches CacheExecute() and GenID() errors now.

Now if you are running php from the command line, debugging messages do not output html formating. Not 100% complete, but getting there.

1.81 22 March 2002

Restored default $ADODB_FETCH_MODE = ADODB_FETCH_DEFAULT for backward compatibility.

SelectLimit for oci8 improved - Our FIRST_ROWS optimization now does not overwrite existing hint.

New Sybase SQL Anywhere driver. Contributed by Wade Johnson wade#wadejohnson.de

1.80 15 March 2002

Redesigned directory structure of ADOdb files. Added new driver directory where all database drivers reside.

Changed caching algorithm to create subdirectories. Now we scale better.

Informix driver now supports insert_id(). Contribution by "Andrea Pinnisi" pinnisi#sysnet.it

Added experimental ISO date and FetchField support for informix.

Fixed a quoting bug in Execute() with bind parameters, causing problems with blobs.

Mssql driver speedup by 10-15%.

Now in CacheExecute($secs2cache,$sql,...), $secs2cache is optional. If missing, it will take the value defined in $connection->cacheSecs (default is 3600 seconds). Note that CacheSelectLimit(), the secs2cache is still compulsory - sigh.

Sybase SQL Anywhere driver (using ODBC) contributed by Wade Johnson wade#wadejohnson.de

1.72 8 March 2002

Added @ when returning Fields() to prevent spurious error - "Michael William Miller" mille562#pilot.msu.edu

MetaDatabases() for postgres contributed by Phil pamelant#nerim.net

Mitchell T. Young (mitch#youngfamily.org) contributed informix driver.

Fixed rs2html() problem. I cannot reproduce, so probably a problem with pre PHP 4.1.0 versions, when supporting new ADODB_FETCH_MODEs.

Mattia Rossi (mattia#technologist.com) contributed BlobDecode() and UpdateBlobFile() for postgresql using the postgres specific pg_lo_import()/pg_lo_open() - i don't use them but hopefully others will find this useful. See this posting for an example of usage.

Added UpdateBlobFile() for uploading files to a database.

Made UpdateBlob() compatible with oci8po driver.

Added noNullStrings support to oci8 driver. Oracle changes all ' ' strings to nulls, so you need to set strings to ' ' to prevent the nullifying of strings. $conn->noNullStrings = true; will do this for you automatically. This is useful when you define a char column as NOT NULL.

Fixed UnixTimeStamp() bug - wasn't setting minutes and seconds properly. Patch from Agusti Fita i Borrell agusti#anglatecnic.com.

Toni Tunkkari added patch for sybase dates. Problem with spaces in day part of date fixed.

1.71 18 Jan 2002

Sequence start id support. Now $conn->Gen_ID('seqname', 50) to start sequence from 50.

CSV driver fix for selectlimit, from Andreas - akaiser#vocote.de.

Gam3r spotted that a global variable was undefined in the session handler.

Mssql date regex had error. Fixed - reported by Minh Hoang vb_user#yahoo.com.

DBTimeStamp() and DBDate() now accept iso dates and unix timestamps. This means that the PostgreSQL handling of dates in GetInsertSQL() and GetUpdateSQL() can be removed. Also if these functions are passed '' or null or false, we return a SQL null.

GetInsertSQL() and GetUpdateSQL() now accept a new parameter, $magicq to indicate whether quotes should be inserted based on magic quote settings - suggested by dj#4ict.com.

Reformated docs slightly based on suggestions by Chris Small.

1.65 28 Dec 2001

Fixed borland_ibase class naming bug.

Now instead of using $rs->fields[0] internally, we use reset($rs->fields) so that we are compatible with ADODB_FETCH_ASSOC mode. Reported by Nico S.

Changed recordset constructor and _initrs() for oci8 so that it returns the field definitions even if no rows in the recordset. Reported by Rick Hickerson (rhickers#mv.mv.com).

Improved support for postgresql in GetInsertSQL and GetUpdateSQL by "mike" mike#partner2partner.com and "Ryan Bailey" rebel#windriders.com

1.64 20 Dec 2001

Danny Milosavljevic <danny.milo#gmx.net> added some patches for MySQL error handling and displaying default values.

Fixed some ADODB_FETCH_BOTH inconsistencies in odbc and interbase.

Added more tests to test suite to cover ADODB_FETCH_* and ADODB_ERROR_HANDLER.

Added firebird (ibase) driver

Added borland_ibase driver for interbase 6.5

1.63 13 Dec 2001

Absolute to the adodb-lib.inc.php file not set properly. Fixed.

1.62 11 Dec 2001

Major speedup of ADOdb for low-end web sites by reducing the php code loading and compiling cycle. We conditionally compile not so common functions. Moved csv code to adodb-csvlib.inc.php to reduce adodb.inc.php parsing. This file is loaded only when the csv/proxy driver is used, or CacheExecute() is run. Also moved PageExecute(), GetSelectSQL() and GetUpdateSQL() core code to adodb-lib.inc.php. This reduced the 70K main adodb.inc.php file to 55K, and since at least 20K of the file is comments, we have reduced 50K of code in adodb.inc.php to 35K. There should be 35% reduction in memory and thus 35% speedup in compiling the php code for the main adodb.inc.php file.

Highly tuned SelectLimit() for oci8 for massive speed improvements on large files. Selecting 20 rows starting from the 20,000th row of a table is now 7 times faster. Thx to Tomas V V Cox.

Allow . and # in table definitions in GetInsertSQL and GetUpdateSQL. See ADODB_TABLE_REGEX constant. Thx to Ari Kuorikoski.

Added ADODB_PREFETCH_ROWS constant, defaulting to 10. This determines the number of records to prefetch in a SELECT statement. Only used by oci8.

Added high portability Oracle class called oci8po. This uses ? for bind variables, and lower cases column names.

Now all database drivers support $ADODB_FETCH_MODE, including interbase, ado, and odbc: ADODB_FETCH_NUM and ADODB_FETCH_ASSOC. ADODB_FETCH_BOTH is not fully implemented for all database drivers.

1.61 Nov 2001

Added PO_RecordCount() and PO_Insert_ID(). PO stands for portable. Pablo Roca [pabloroca#mvps.org]

GenID now returns 0 if not available. Safer is that you should check $conn->hasGenID for availability.

M'soft ADO we now correctly close recordset in _close() peterd#telephonetics.co.uk

MSSQL now supports GenID(). It generates a 16-byte GUID from mssql newid() function.

Changed ereg_replace to preg_replace in SelectLimit. This is a fix for mssql. Ereg doesn't support t or n! Reported by marino Carlos xaplo#postnuke-espanol.org

Added $recordset->connection. This is the ADOConnection object for the recordset. Works with cached and normal recordsets. Surprisingly, this had no affect on performance!

1.54 15 Nov 2001

Fixed some more bugs in PageExecute(). I am getting sick of bug in this and will have to reconsider my QA here. The main issue is that I don't use PageExecute() and to check whether it is working requires a visual inspection of the html generated currently. It is possible to write a test script but it would be quite complicated :(

More speedups of SelectLimit() for DB2, Oci8, access, vfp, mssql.

1.53 7 Nov 2001

Added support for ADODB_FETCH_ASSOC for ado and odbc drivers.

Tuned GetRowAssoc(false) in postgresql and mysql.

Stephen Van Dyke contributed ADOdb icon, accepted with some minor mods.

Enabled Affected_Rows() for postgresql

Speedup for Concat() using implode() - Benjamin Curtis ben_curtis#yahoo.com

Fixed some more bugs in PageExecute() to prevent infinite loops

1.52 5 Nov 2001

Spelling error in CacheExecute() caused it to fail. $ql should be $sql in line 625!

Added fixes for parsing [ and ] in GetUpdateSQL().

1.51 5 Nov 2001

Oci8 SelectLimit() speedup by using OCIFetch().

Oci8 was mistakenly reporting errors when $db->debug = true.

If a connection failed with ODBC, it was not correctly reported - fixed.

_connectionID was inited to -1, changed to false.

Added $rs->FetchRow(), to simplify API, ala PEAR DB

Added PEAR DB compat mode, which is still faster than PEAR! See adodb-pear.inc.php.

Removed postgres pconnect debugging statement.

1.50 31 Oct 2001

ADOdbConnection renamed to ADOConnection, and ADOdbFieldObject to ADOFieldObject.

PageExecute() now checks for empty $rs correctly, and the errors in the docs on this subject have been fixed.

odbc_error() does not return 6 digit error correctly at times. Implemented workaround.

Added ADORecordSet_empty class. This will speedup INSERTS/DELETES/UPDATES because the return object created is much smaller.

Added Prepare() to odbc, and oci8 (but doesn't work properly for oci8 still).

Made pgsql a synonym for postgre7, and changed SELECT LIMIT to use OFFSET for compat with postgres 7.2.

Revised adodb-cryptsession.php thanks to Ari.

Set resources to false on _close, to force freeing of resources.

Added adodb-errorhandler.inc.php, adodb-errorpear.inc.php and raiseErrorFn on Freek's urging.

GetRowAssoc($toUpper=true): $toUpper added as default.

Errors when connecting to a database were not captured formerly. Now we do it correctly.

1.40 19 September 2001

PageExecute() to implement page scrolling added. Code and idea by Iván Oliva.

Some minor postgresql fixes.

Added sequence support using GenID() for postgresql, oci8, mysql, interbase.

Added UpdateBlob support for interbase (untested).

Added encrypted sessions (see adodb-cryptsession.php). By Ari Kuorikoski <kuoriari#finebyte.com>

1.31 21 August 2001

Many bug fixes thanks to "GaM3R (Cameron)" <gamr#outworld.cx>. Some session changes due to Gam3r.

Fixed qstr() to quote also.

rs2html() now pretty printed.

Jonathan Younger jyounger#unilab.com contributed the great idea GetUpdateSQL() and GetInsertSQL() which generates SQL to update and insert into a table from a recordset. Modify the recordset fields array, then can this function to generate the SQL (the SQL is not executed).

"Nicola Fankhauser" <nicola.fankhauser#couniq.com> found some bugs in date handling for mssql.

Added minimal Oracle support for LOBs. Still under development.

Added $ADODB_FETCH_MODE so you can control whether recordsets return arrays which are numeric, associative or both. This is a global variable you set. Currently only MySQL, Oci8, Postgres drivers support this.

PostgreSQL properly closes recordsets now. Reported by several people.

Added UpdateBlob() for Oracle. A hack to make it easier to save blobs.

Oracle timestamps did not display properly. Fixed.

1.20 6 June 2001

Now Oracle can connect using tnsnames.ora or server and service name

Extensive Oci8 speed optimizations. Oci8 code revised to support variable binding, and /*+ FIRST_ROWS */ hint.

Worked around some 4.0.6 bugs in odbc_fetch_into().

Paolo S. Asioli paolo.asioli#libero.it suggested GetRowAssoc().

Escape quotes for oracle wrongly set to '. Now '' is used.

Variable binding now works in ODBC also.

Jumped to version 1.20 because I don't like 13 :-)

1.12 6 June 2001

Changed $ADODB_DIR to ADODB_DIR constant to plug a security loophole.

Changed _close() to close persistent connections also. Prevents connection leaks.

Major revision of oracle and oci8 drivers. Added OCI_RETURN_NULLS and OCI_RETURN_LOBS to OCIFetchInto(). BLOB, CLOB and VARCHAR2 recognition in MetaType() improved. MetaColumns() returns columns in correct sort order.

Interbase timestamp input format was wrong. Fixed.

1.11 20 May 2001

Improved file locking for Windows.

Probabilistic flushing of cache to avoid avalanche updates when cache timeouts.

Cached recordset timestamp not saved in some scenarios. Fixed.

1.10 19 May 2001

Added caching. CacheExecute() and CacheSelectLimit().

Added csv driver. See http://php.weblogs.com/ADODB_csv.

Fixed SelectLimit(), SELECT TOP not working under certain circumstances.

Added better Frontbase support of MetaTypes() by Frank M. Kromann.

1.01 24 April 2001

Fixed SelectLimit bug. not quoted properly.

SelectLimit: SELECT TOP -1 * FROM TABLE not support by Microsoft. Fixed.

GetMenu improved by glen.davies#cce.ac.nz to support multiple hilited items

FetchNextObject() did not work with only 1 record returned. Fixed bug reported by $tim#orotech.net

Fixed mysql field max_length problem. Fix suggested by Jim Nicholson (jnich#att.com)

1.00 16 April 2001

Given some brilliant suggestions on how to simplify ADOdb by akul. You no longer need to setup $ADODB_DIR yourself, and ADOLoadCode() is automatically called by ADONewConnection(), simplifying the startup code.

FetchNextObject() added. Suggested by Jakub Marecek. This makes FetchObject() obsolete, as this is more flexible and powerful.

Misc fixes to SelectLimit() to support Access (top must follow distinct) and Fields() in the array recordset. From Reinhard Balling.

0.96 27 Mar 2001

ADOConnection Close() did not return a value correctly. Thanks to akul#otamedia.com.

When the horrible magic_quotes is enabled, back-slash () is changed to double-backslash (\). This doesn't make sense for Microsoft/Sybase databases. We fix this in qstr().

Fixed Sybase date problem in UnixDate() thanks to Toni Tunkkari. Also fixed MSSQL problem in UnixDate() - thanks to milhouse31#hotmail.com.

MoveNext() moved to leaf classes for speed in MySQL/PostgreSQL. 10-15% speedup.

Added null handling in bindInputArray in Execute() -- Ron Baldwin suggestion.

Fixed some option tags. Thanks to john#jrmstudios.com.

0.95 13 Mar 2001

Added postgres7 database driver which supports LIMIT and other version 7 stuff in the future.

Added SelectLimit to ADOConnection to simulate PostgreSQL's "select * from table limit 10 offset 3". Added helper function GetArrayLimit() to ADORecordSet.

Fixed mysql metacolumns bug. Thanks to Freek Dijkstra (phpeverywhere#macfreek.com).

Also many PostgreSQL changes by Freek. He almost rewrote the whole PostgreSQL driver!

Added fix to input parameters in Execute for non-strings by Ron Baldwin.

Added new metatype, X for TeXt. Formerly, metatype B for Blob also included text fields. Now 'B' is for binary/image data. 'X' for textual data.

Fixed $this->GetArray() in GetRows().

Oracle and OCI8: 1st parameter is always blank -- now warns if it is filled.

Now hasLimit and hasTop added to indicate whether SELECT * FROM TABLE LIMIT 10 or SELECT TOP 10 * FROM TABLE are supported.

0.94 04 Feb 2001

Added ADORecordSet::GetRows() for compatibility with Microsoft ADO. Synonym for GetArray().

Added new metatype 'R' to represent autoincrement numbers.

Added ADORecordSet.FetchObject() to return a row as an object.

Finally got a Linux box to test PostgreSql. Many fixes.

Fixed copyright misspellings in 0.93.

Fixed mssql MetaColumns type bug.

Worked around odbc bug in PHP4 for sessions.

Fixed many documentation bugs (affected_rows, metadatabases, qstr).

Fixed MySQL timestamp format (removed comma).

Interbase driver did not call ibase_pconnect(). Fixed.

0.93 18 Jan 2002

Fixed GetMenu bug.

Simplified Interbase commit and rollback.

Default behaviour on closing a connection is now to rollback all active transactions.

Added field object handling for array recordset for future XML compatibility.

Added arr2html() to convert array to html table.

0.92 2 Jan 2002

Interbase Commit and Rollback should be working again.

Changed initialisation of ADORecordSet. This is internal and should not affect users. We are doing this to support cached recordsets in the future.

Implemented ADORecordSet_array class. This allows you to simulate a database recordset with an array.

Added UnixDate() and UnixTimeStamp() to ADORecordSet.

0.91 21 Dec 2000

Fixed ODBC so ErrorMsg() is working.

Worked around ADO unrecognised null (0x1) value problem in COM.

Added Sybase support for FetchField() type

Removed debugging code and unneeded html from various files

Changed to javadoc style comments to adodb.inc.php.

Added maxsql as synonym for mysqlt

Now ODBC downloads first 8K of blob by default

0.90 15 Nov 2000

Lots of testing of Microsoft ADO. Should be more stable now.

Added $ADODB_COUNTREC. Set to false for high speed selects.

Added Sybase support. Contributed by Toni Tunkkari (toni.tunkkari#finebyte.com). Bug in Sybase API: GetFields is unable to determine date types.

Changed behaviour of RecordSet.GetMenu() to support size parameter (listbox) properly.

Added emptyDate and emptyTimeStamp to RecordSet class that defines how to represent empty dates.

Added MetaColumns($table) that returns an array of ADOFieldObject's listing the columns of a table.

Added transaction support for PostgresSQL -- thanks to "Eric G. Werk" egw#netguide.dk.

Added adodb-session.php for session support.

0.80 30 Nov 2000

Added support for charSet for interbase. Implemented MetaTables for most databases. PostgreSQL more extensively tested.

0.71 22 Nov 2000

Switched from using require_once to include/include_once for backward compatability with PHP 4.02 and earlier.

0.70 15 Nov 2000

Calls by reference have been removed (call_time_pass_reference=Off) to ensure compatibility with future versions of PHP, except in Oracle 7 driver due to a bug in php_oracle.dll.

PostgreSQL database driver contributed by Alberto Cerezal (acerezalp#dbnet.es).

Oci8 driver for Oracle 8 contributed by George Fourlanos (fou#infomap.gr).

Added mysqlt database driver to support MySQL 3.23 which has transaction support.

Oracle default date format (DD-MON-YY) did not match ADOdb default date format (which is YYYY-MM-DD). Use ALTER SESSION to force the default date.

Error message checking is now included in test suite.

MoveNext() did not check EOF properly -- fixed.

0.60 Nov 8 2000

Fixed some constructor bugs in ODBC and ADO. Added ErrorNo function to ADOConnection class.

0.51 Oct 18 2000

Fixed some interbase bugs.

0.50 Oct 16 2000

Interbase commit/rollback changed to be compatible with PHP 4.03.

CommitTrans( ) will now return true if transactions not supported.

Conversely RollbackTrans( ) will return false if transactions not supported.

0.46 Oct 12

Many Oracle compatibility issues fixed.

0.40 Sept 26

Many bug fixes

Now Code for BeginTrans, CommitTrans and RollbackTrans is working. So is the Affected_Rows and Insert_ID. Added above functions to test.php.

ADO type handling was busted in 0.30. Fixed.

Generalised Move( ) so it works will all databases, including ODBC.

0.30 Sept 18

Renamed ADOLoadDB to ADOLoadCode. This is clearer.

Added BeginTrans, CommitTrans and RollbackTrans functions.

Added Affected_Rows() and Insert_ID(), _affectedrows() and _insertID(), ListTables(), ListDatabases(), ListColumns().

Need to add New_ID() and hasInsertID and hasAffectedRows, autoCommit

0.20 Sept 12

Added support for Microsoft's ADO.

Added new field to ADORecordSet -- canSeek

Added new parameter to _fetch($ignore_fields = false). Setting to true will not update fields array for faster performance.

Added new field to ADORecordSet/ADOConnection -- dataProvider to indicate whether a class is derived from odbc or ado.

Changed class ODBCFieldObject to ADOFieldObject -- not documented currently.

Added benchmark.php and testdatabases.inc.php to the test suite.

Added to ADORecordSet FastForward( ) for future high speed scrolling. Not documented.

Realised that ADO's Move( ) uses relative positioning. ADOdb uses absolute.

0.10 Sept 9 2000

First release